Pixelige und schlecht lesbare Schriftendarstellung - KDE

Alles rund um die möglichen Desktopumgebungen wie KDE, Gnome, XFCE usw. die es unter Linux gibt

Moderator: Moderatoren

Arnie_75
Newbie
Newbie
Beiträge: 25
Registriert: 24. Jun 2004, 22:00

Beitrag von Arnie_75 » 12. Jan 2005, 03:00

So,
hab auf meiner X86_64-Installation jetzt auch neu kompilliert, bekomme am Ende aber folgenden Fehler:

Preparing... ########################################### [100%]
package freetype2-2.1.9-3 is already installed
file /usr/lib64/libfreetype.so.6.3.7 from install of freetype2-2.1.9-3 conflicts with file from package freetype2-2.1.9-3
linux:/home #



Kann mir das jemand erklären??

Werbung:
Grothesk
Ultimate Guru
Ultimate Guru
Beiträge: 14662
Registriert: 26. Okt 2003, 11:52
Wohnort: Köln

Beitrag von Grothesk » 12. Jan 2005, 09:52

Kann mir das jemand erklären??
Das scheint ein Fall für das apt-Forum zu sein. Vielleicht kann dir der Apt-Gott o2pus da weiterhelfen.

Grothesk

Arnie_75
Newbie
Newbie
Beiträge: 25
Registriert: 24. Jun 2004, 22:00

Beitrag von Arnie_75 » 15. Jan 2005, 02:30

So,

habs jetzt hinbekommen. Bin mir allerdings nicht sicher, ob ich überhaupt das Richtige gmeacht habe. Ich habe die neueste freetype2.scr.rpm, die ich für Suse im Netz finden konnte, entsprechend modifiziert und dann wieder installiert.

Nur seh ich eigentlich keinen Unterschied... :(
Kann mir jemand sagen, ob das Problem mit der sehr hässlichen Schrift unterSUSE eigentlich immer bestehen wird, oder ist das ein mehr oder weniger verbreitetes Problem besonders in Bezug auf TFT-Bildschirme, dass in der nächsten Suse-Version behoben sein wird?

torkoss
Newbie
Newbie
Beiträge: 1
Registriert: 2. Mär 2005, 22:57

Beitrag von torkoss » 2. Mär 2005, 23:38

Hallo,

hab ds gleiche Problem - vor 3 Wochen Suse 9.2 installiert und alle Schriften werden unscharf dargestellt.
Bin Neuling in Sachen Linux und komme nicht weiter!!
Nach der Installation von freetype2 befindet sich die Datei freetype2.spec nicht in dem Ordner /usr/src/packages/SPECS. Weiter kann ich auch nicht bei Yast den Quellcode installieren (wie hier weiter oben beschrieben.

Kann mir bitte jemand helfen, das ich trotz meiner beschränkten Linuxkenntnisse in den Genuss klarer Schriften komme.

Meine e-Mail torkoss@versanet.de

Joerk
Newbie
Newbie
Beiträge: 2
Registriert: 9. Mär 2005, 23:21

Suse 9.2 und das gleiche Problem :(

Beitrag von Joerk » 9. Mär 2005, 23:28

Beschäftige mich seit 3 Tagen mit Linux - Suse 9.2. Hab das OS problemlos auf mein Compaq EVO N600c Notebook installieren können, sogar meine WLAN-Karte Netgear MA401 wurde auf Anhieb erkannt. Per Internetverbindungsfreigabe surfe ich mit Suse drahtlos über meinem Windows PC im Netz, klappt alles hervorragend!

Aber: Die Schrift bzw. die Fontsdarstellung ist im Vergleich zu Windows eine Katastrophe. Freefonts 2.19.3 ist installiert, ich komme aber wie obige Poster nicht an die Source-Quellen und kann demnach den bytecode interpreter nicht aktivieren. :(

Ist irgendwie extrem frustrierend.

Gibts denn für Suse 9.2 wirklich keine Lösung :?: :?: :?:

Gruß,
Joerk

GLehnhoff
Newbie
Newbie
Beiträge: 25
Registriert: 12. Apr 2004, 16:56
Wohnort: Wächtersbach / Germany
Kontaktdaten:

Schriften

Beitrag von GLehnhoff » 10. Mär 2005, 09:18

Hallo,

ich muss auch nochmal meinen Senf loslassen, da ich vor über einem Jahr auch als Anfänger mit den beschissenen Schriften konfrontiert war.

Vorne weg, heute geht's. Und das alles mit Bordmitteln (oder ich habe mich daran gewöhnt)

Ich besitze Suse 9.2 (ging auch bereits mit 9.1) auf einem Labbi. Wichtig ist erst mal zu wissen, dass der Bildschirm des Labbis nur bei seiner größt-möglichen Auflösung klar ist. Das trifft für Windows, wie für Linux zu (dieses Problem gibt es bei einem Röhrenmonitor nicht).

Also, 1. Schritt: Raus kriegen, was die maximale Bildschirmauflösung ist und mit YAST diese einstellen (wie gesagt, gilt nicht für Röhrenmonitore).

Dann scheint es eine große Rolle zu spielen, welche Schrift man benutzt, welche Schriftgröße, welche Farbe. Meine Erfahrung ist z. B. dass auf dem Desktop eine weiße Schriftfarbe vor dunklem Hintergrund deutlich klarer ist als umgekehrt. Auch die Schriftgröße spielt eine entscheidende Rolle. Diese steht bei mir auf 8 px. Meine Erfahrung, um so kleiner, um so besser. Als Schrift benutze ich Suse Sans. Aber auch andere zeigen ein gutes Ergebnis.

Also, 2. Schritt: Mit Schriftfarbe, -größe und -art experimentieren. Ganz wichtig: Schattierungen abstellen. Mit Schattierungen wird's auf alle Fälle undeutlich.

Für Konqueror etc. nutze ich weiterhin schwarze Schriftfarbe.

Wichtig zu wissen: nicht alle Applikationen halten sich an diese Voreinstellungen. OpenOffice z. B. hat seine eigenen Einstellungen. Hier habe ich gute Ergebnisse erzielt, wenn ich die Schriftgröße auf 90% gesetzt habe. Das gleiche gilt für mozillabasierende Applikationen. Hier muss man aber wo ganz anders rum fummeln, was an anderer Stelle dieses Forums beschrieben ist.

Alle diese Angaben gelten für KDE 3.1 + 3.2, sowie Suse Linux 9.1 und 9.2 und einem Asus Labbi mit 1400x1050 Bildschirmauflösung. Mit Gnome sieht die Welt, und damit einige Applikationen, wieder ganz anders aus.

mfg gl

Arnie_75
Newbie
Newbie
Beiträge: 25
Registriert: 24. Jun 2004, 22:00

Beitrag von Arnie_75 » 20. Mai 2005, 13:44

Jetzt hab ich mir die 9.3 als DVDs gekauft und gleich mal die Schriften wie beschrieben neu kompilliert.

Von den 3 neuen Dateien
freetype2-2.1.9-4.x86_64.rpm
freetype2-debuginfo-2.1.9-4.x86_64.rpm
freetype2-devel-2.1.9-4.x86_64.rpm

kann ich allerdings nur die debuginfo installieren, und das auch nur über die Konsole.
Wenn ich die 'devel' über die Konsole installiere, erhalte ich z.B. diese Fehlermeldung:

package freetype2-devel-2.1.9-4 is already installed
file /usr/include/freetype2/freetype/config/ftoption.h from install of f reetype2-devel-2.1.9-4 conflicts with file from package freetype2-devel-2.1.9-4
file /usr/lib64/libfreetype.a from install of freetype2-devel-2.1.9-4 co nflicts with file from package freetype2-devel-2.1.9-4

Wenn ich die Dateien per Mausklick über Yast installieren will, fragt er immer nach der CD, und ich habe das Gefühl, dass er freetype2 dann auch nur von der DVD installiert...

Gamic
Member
Member
Beiträge: 109
Registriert: 26. Jun 2004, 15:16

Beitrag von Gamic » 20. Mai 2005, 18:40

GLehnhoff hat geschrieben: Mozilla/KDE:
Alles Schrecklich! Schriften (Menuleisten) viel zu groß! Schrecklich im Aussehen. Aufgerufene Webseiten genauso beschissen wie unter Gnome.
Die Größe der Schriften kann man global sehr einfach durch den Eintrag "Xft.dpi: 96" in der Datei "/etc/X11/Xresources" einstellen (Wert entsprechend anpassen).

Dadurch entfällt auch die Notwendigkeit Schriftgrößen kleiner als 8 Pixel einzustellen.

Arnie_75
Newbie
Newbie
Beiträge: 25
Registriert: 24. Jun 2004, 22:00

Beitrag von Arnie_75 » 23. Mai 2005, 15:13

So, habs jetzt endlich geschafft, die neu kompillierten Schriften zu installieren.
Ich musste die alten freetype2 erst über YAST deinstallieren, damit ich sie danach per Kommandozeile neuinstallieren konnte. Die Schriften sind jetzt endlich wieder so gut wie unter Windows :)

ABER... die Schriften in OpenOffice und FireFox sind nach wie vor ******.... :x
Kann man die Schriften im FireFox nicht aus KDE übernehmen, damit sie auch scharf sind?

BTW: Ich finde, man sollte diesen Thread sticky machen, da das Problem der schlechten Schriften vermutlich alle Nutzer mit TFT-Bildschirmen betrifft.

Für alle, die nicht wissen, worum es geht:
Konqueror mit neu kompillierten Schriften:
Bild

FireFox ohne AntiAliasing:
Bild

FireFox mit AntiAliasing und AutoHinting und Sub-Pixel Hinting:
Bild

In den Screenshots sieht das letzte Bild besser aus, als es in Wirklichkeit ist. Real hat man das Gefühl, die falsche Brille aufgesetzt zu haben ;)

EDIT: Um die Schriften auf den Screenshots zu beurteilen, muss man das Bild auf die reale Größe vergrößern. bei mir muss ich dafür einmal ins Bild klciekn, sonst werden die Screenshots auf die Browsergröße angepasst.

Schafsviech
Newbie
Newbie
Beiträge: 5
Registriert: 20. Mai 2005, 23:38

Beitrag von Schafsviech » 4. Jun 2005, 17:49

Habe trotz freetype2 version 2.1.9- immernoch unsaubere Schriften, habe nach der installation kurz an den schriften getestet und BOOM war alles unsauber und krakelig, hab die freetype2 version dann nochmal per CD aktualisiert... kein effekt! "Voreinstellungen"... kein effekt! Was zum geier ist das!?!? Sitz schon ne ganze woche an dem problem!
Aber im Yast-Kontrollzentrum sehn die schriften perfekt aus!

PS: Ja hab schon sämtliche threads durchsucht, nichts geholfen!

Please HELP!

Marco de Majo Gonzales
Newbie
Newbie
Beiträge: 20
Registriert: 8. Apr 2005, 14:35

Beitrag von Marco de Majo Gonzales » 8. Jun 2005, 01:44

Hab das selbe Problem mit CRT-Monitor und das schon seit Suse 9.1 (jetzt hab ich 9.2 hier).
Es hat sich nichts verbessert! Habe alles mögliche ausprobiert. Das Neukompilieren von freetype2 hat allerdings auch bei mir nicht funktioniert, da ich die Sourcen nicht installieren konnte.
Besonders beschissen ist die Schrift auf Webseiten mit Firefox oder Konqueror.
Bin jetzt nicht der Suse-Auskenner, aber ich hab mich durch etliche Seiten gelesen um nicht weiter zu kommen. :wink:
Ist es denn mit 9.3 nun endlich besser?
Ich halte mich aus diesem Grund zum größten Teil an Windows, welches ich eigendlich irgendwann nur noch zur Film- und Audiobearbeitung nutzen wollte - so war meine Überlegung voriges Jahr als ich mir Suse (9.1) kaufte (ist aber nichts draus geworden).
Es kann doch nicht so schwer sein dieses Problem herstellerseitig zu lösen und mal ein BS mit vernünftigen Default-Einstellungen hinzukriegen an dem ein Neuling nicht noch etliche Stunden herumbasteln muß (das meine ich jetzt nicht allgemein, sondern auf dieses Problem mit der Lesbarkeit der Schriften bezogen).
Hilft 'ne Aktualisierung von Suse (KDE 3.4 hats auch nicht gebracht)?

Marco

PS: Nee, meine ich nicht nur auf dieses Schriftproblem bezogen (vorl.Satz), sondern auch auf die Einrichtung eines Internetzugangs (ich erinnere mich gerade daran wie ich Wochen damit zubrachte, nach etlichen Neuinstallationen, zu versuchen mit meiner Fritz-Karte ins Internet zu kommen). Aber das ist ja eigentlich ein Treiber-Problem, in Windows hätte ich den Karten-Treiber install., eingerichtet und gut is.
Aber warum kann Novell nicht schon Treiber mitliefern die zumindest in den Grundfunktionen immer funktionieren?

Joerk
Newbie
Newbie
Beiträge: 2
Registriert: 9. Mär 2005, 23:21

Suse 9.2 und 9.3 - es geht wirklich!

Beitrag von Joerk » 12. Jun 2005, 22:58

So, nachdem ich die Schrift mit beiden Versionen scharf bekommen habe, möchte ich hier kurz meine Vorgehensweise erläutern:


1. TrueType Schriftarten von Windows installieren
(muss man denke ich nicht groß erklären)


2. Freetype2 downloaden und installieren

Suse 9.2
ftp://ftp.gwdg.de/pub/linux/suse/ftp.su ... -3.src.rpm

Suse 9.3
ftp://ftp.gwdg.de/pub/linux/suse/ftp.su ... -4.src.rpm

Mittels Konsole wird das Paket installiert
Suse 9.2: rpm -ivh freetype2-2.1.9-3.src.rpm
Suse 9.3: rpm -ivh freetype2-2.1.9-4.src.rpm

Bei mir wurde die Software mit diesem Befehl nicht installiert, da die Version von Freetype bereits auf der Platte war. Allerdings hat dieser Befehl dazu geführt, dass ich im Ordner

/usr/src/packages/SPECS/

endlich die Datei "freetype2.spec" gefunden habe, d.h. die Sourcen wurden aus der RPM extrahiert.


3. Sourcen Update

Danach habe ich die Datei "freetype2.spec" wie bereits mehrfach beschrieben geändert:

Folgende Zeile suchen

# %%patch100 -p 1 -b .bytecode

und das "#" Zeichen entfernen.

Ich habe NUR das#-Zeichen entfernt!


4. Paket bauen und installieren

rpmbuild -bb /usr/src/packages/SPEC/freetype2.spec

Wenn eine Fehlermeldung ala "error: Failed build dependencies:" erscheint, müssen noch zusätzlich Pakete installiert werden.

Diese kann man mittels "Yast -> Software installieren" einfach nachinstallieren.

Zuvor sollte man jedoch eine neue Installationsquelle anlegen.

Beispielsweise:
ftp://ftp.gwdg.de/pub/linux/suse/ftp.su ... /i386/9.2/

Besonderheit Suse 9.3 c´t-Version:
=========================
Da ich die c´t Suse 9.3 Personale Edition installiert habe, musste ich sämtliche fehlenden Pakete per DVD installieren, da die Pakete noch nicht öffentlich per FTP verfügbar sind. Leider konnte ich 2 Pakete (zlib-devel / ncurses-devel) nicht auf der DVD finden, sodass ich gezwungen war, die Pakete aus der 9.2 er Version zu installieren, was jedoch problemlos funktionierte:

Yast > Installationsquelle ändern

von 9.3 auf 9.2

ftp://ftp.gwdg.de/pub/linux/suse/ftp.su ... /i386/9.3/
ftp://ftp.gwdg.de/pub/linux/suse/ftp.su ... /i386/9.2/

Und dann per "Yast > Software installieren" einfach die 2 fehlenden Pakete installieren. Da es 2 Konflikte gab, musste ich 2 andere Pakete (zlib / ncurses) downgraden.
==========================

Nach dem RPM-Build wird das neue Paket im Ordner

/usr/src/packages/RPMS/i586

installiert (Klick auf die Datei und per Yast installieren).


5. Schrifteinstellungen

Per Kontrollzentrum habe ich dann noch die Schriften eingestellt:

1. Tahoma 7px
2. Kantenglättung: aktiv
3. Bereich von 7-15 px ausgeschlossen
4. Subpixel-Hinting: aktiv
5. Hinting: Vollständig


6. KDE neu starten

Abmelden und neu Anmelden

Die Schriften sollten nun extrem scharf sein, analog Windows.


Bei mir hat es einwandfrei funktioniert. Einzig Firefox und OpenOffice muss ich noch irgendwie konfigurieren, dazu bin ich noch nicht gekommen. Alles andere ist aber nun richtig schön scharf.


Fraglich ist nur, warum Suse die Distribution in so einem Zustand bzw. mit so einer Konfiguration ausliefert. Hier werden für Einsteiger fast unüberwindbare Hürden aufgestellt.

Gruß,
Jürgen

PS: Bei Fragen - PN schreiben

Marco de Majo Gonzales
Newbie
Newbie
Beiträge: 20
Registriert: 8. Apr 2005, 14:35

Beitrag von Marco de Majo Gonzales » 13. Jun 2005, 21:15

Na das ist doch mal was.
Werde ich auch noch mal ausprobieren.
Liest sich so, daß auch ich es verstehen kann:) Danke!
Warum das so ausgeliefert wird frage ich mich auch.

Hoffentlich klappt es auch bei Firefox.
Danke nochmal, Joerk!

Gruß Marco

FBear
Newbie
Newbie
Beiträge: 1
Registriert: 30. Jun 2005, 23:19

Beitrag von FBear » 30. Jun 2005, 23:27

Bei mir hat das in der c't-Edition nicht funktioniert. Ohne Kantenglättung sind die Fonts einfach nur pixelig. Ich habe ab Schritt 3 alles exakt so gemacht, wie du es beschrieben hast, allerdings habe ich Tahoma 8pt eingestellt, wiel mir 7 pt auf meinem 17" LCD zu klein ist.

Die Sourcen habe ich direkt über yast2 geladen und installiert, sollte aber ja keinen Unterschied machen.

Allerdings bilde ich mir ein, dass die Schriften selbst mit Kantenglättung besser sind, auch in Firefox.

borgg
Newbie
Newbie
Beiträge: 45
Registriert: 31. Mai 2004, 15:46
Kontaktdaten:

Beitrag von borgg » 7. Jul 2005, 10:56

Woraus bezieht OpenOffice seie Schriften? Eventuell muss man das ja nur neu bauen nachdem man freetype umgebaut hat? Ist das dagegen statisch gelinkt? Weiß da wer was?

Benutzeravatar
hypnotoad
Newbie
Newbie
Beiträge: 41
Registriert: 8. Okt 2004, 18:08

Beitrag von hypnotoad » 15. Jul 2005, 15:03

Von mir auch vielen Dank für die exzellente Anleitung, bei mir auf meinem TFT habe ich jetzt endlich die richtige, gewünscht scharfe Darstellung!

Kann man das nicht Sticky-pinnen? Denke mal, dass es jedem hilft!

js2002
Newbie
Newbie
Beiträge: 5
Registriert: 26. Nov 2005, 15:53
Kontaktdaten:

Beitrag von js2002 » 26. Nov 2005, 15:58

hmmmm,

ich habe das Problem auch allerdings mit einem CRT Monitor.
Unter Windows konnte ich einfach TuneUp Utilities installieren und dort keine Glättung einstellen und es ging.

Was muss ich tun, damit die schrift von readmes und in Browsern vernünftig aussieht. In den Konsolenfenster ist alles ok.

Konnte mir mal jemand genauer sagen wie ich zB MS Types installiere. In diesem Thread stand nur "muss dazu ja hoffentlich nichts sagen".
Kann jemand mit mir das Schritt für Schritt durchgehen? Ich kriege hier gleich nen Nervenzusammenbruch ;-)

...oder wie schalte ich auf gnome um um mal zu sehen wie es da ist.

Grothesk
Ultimate Guru
Ultimate Guru
Beiträge: 14662
Registriert: 26. Okt 2003, 11:52
Wohnort: Köln

Beitrag von Grothesk » 26. Nov 2005, 16:18

MS TrueType Schriften installierst du am bequemsten über yast/you. Dort kann man das auswählen. Ganz unten in der Liste der Patches.
"Die Rechtschreibung ist Freeware, du darfst sie kostenlos nutzen. Allerdings ist sie nicht OpenSource, d.h. du sollst sie nicht verändern oder in veränderter Form veröffentlichen."

js2002
Newbie
Newbie
Beiträge: 5
Registriert: 26. Nov 2005, 15:53
Kontaktdaten:

Beitrag von js2002 » 26. Nov 2005, 19:09

...eben nicht, der bricht bei 50% ab und ich weiss nicht warum.

Grothesk
Ultimate Guru
Ultimate Guru
Beiträge: 14662
Registriert: 26. Okt 2003, 11:52
Wohnort: Köln

Beitrag von Grothesk » 26. Nov 2005, 19:12

Laufen lassen. Das skript braucht je nachdem schon mal was länger.
Oder schau dir im skript an welcher Server angesprochen wird und lad die von Hand runter.
"Die Rechtschreibung ist Freeware, du darfst sie kostenlos nutzen. Allerdings ist sie nicht OpenSource, d.h. du sollst sie nicht verändern oder in veränderter Form veröffentlichen."

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast