Programme unter KDE auf Arbeitsfläche X starten

Alles rund um die möglichen Desktopumgebungen wie KDE, Gnome, XFCE usw. die es unter Linux gibt

Moderator: Moderatoren

Antworten
Benutzeravatar
ViktorII
Member
Member
Beiträge: 97
Registriert: 26. Aug 2004, 14:06

Programme unter KDE auf Arbeitsfläche X starten

Beitrag von ViktorII » 14. Sep 2004, 17:30

Hallo zusammen

Gibt es eine Moeglichkeit, Programme, die mittels einer Verknüpfung gestartet werden, auf einer gewünschte Arbeitsfläche starten zu lassen? Normalerweise starten ein Programm ja auf der Arbeitsfläche auf der man sich gerade befindet.

Vielen Dank
Viktor

Werbung:
towo
Moderator
Moderator
Beiträge: 3704
Registriert: 15. Feb 2004, 16:42
Wohnort: Nimritz
Kontaktdaten:

Beitrag von towo » 14. Sep 2004, 17:39

kstart --help

ist Dein Stichwort.
Signatur nach Diktat spazieren gegangen

Bild

Benutzeravatar
ViktorII
Member
Member
Beiträge: 97
Registriert: 26. Aug 2004, 14:06

Beitrag von ViktorII » 15. Sep 2004, 15:41

Interessant.

Funktioniert aber nur bedingt:

Code: Alles auswählen

kstart -desktop 4 xawtv
funktioniert.

Code: Alles auswählen

kstart -desktop 3 /home/user1/eDonkey/edonkey2000
allerdings nicht. Startet immer auf dem aktuellen Dektop. Sollte doch eigentlich nicht!?

Dann habe ich noch was getestet

Code: Alles auswählen

kstart -alldesktops -skiptaskbar -skippager gkrellm -m2 -geometry +1192
Trotz -geometry +1192 startet gkrellm am linken Desktoprand. Genauer gesagt: Für den Bruchteil einer Sekunde ist es rechts zu sehen, erscheint dann aber links.
Die Optionen -alldesktops -skiptaskbar scheinen -geometry aufzuheben. Nur mit -alldesktops gehts.

Wer weiss Rat?
Viktor

HaukeW
Member
Member
Beiträge: 189
Registriert: 30. Jan 2005, 14:39
Wohnort: Hamburg
Kontaktdaten:

Beitrag von HaukeW » 23. Apr 2006, 17:32

ich habe ein ähnliches Problem: Wenn ich kstart benutze, um z.B.

Code: Alles auswählen

kstart --desktop 4 nvu
zu starten, erscheint nvu immer auf dem aktuellen Desktop - warum?

[edit] Ok, es scheint daran zu liegen, dass kstart nur dann funktioniert, wenn es über ALT-F2 im KDE aufgerufen wird. Ich hatte mir ein kleines script geschrieben, mit dem 4 Fenster auf 4 Arbeitsflächen geöffnet werden (gimp auf 3, Firefox auf 2, nvu auf 4, konqueror auf 1), und jeder Befehl, für sich eingegeben im "Befehl ausführen" Menü geht - aber wenn ich sie in ein script reinsetze und ausführe, wird die --desktop x Option ignoriert...
System: SuSE 11.3
AMD Athlon 3500+
Asus Mainboard
Soundblaster audigy2
Nvidia GeForce 8600
Festplatte+DVD-Brenner
----
eingetragener Linux-User #391592
http://counter.li.org

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste