KDE-Absturz bei Fehlern in KDE-Programmen

Alles rund um die möglichen Desktopumgebungen wie KDE, Gnome, XFCE usw. die es unter Linux gibt

Moderator: Moderatoren

Antworten
Markus Wagner
Member
Member
Beiträge: 61
Registriert: 27. Jul 2004, 11:14
Wohnort: Österreich
Kontaktdaten:

KDE-Absturz bei Fehlern in KDE-Programmen

Beitrag von Markus Wagner » 14. Sep 2004, 10:12

Hallo Leute!

Ich habe ein ganz merkwürdiges Problem, das ich gestern noch nicht hatte als ich meinen Lappi schlafen gelegt habe, heute spinnt er aber komplett (habe kein Update gemacht gestern und die hdparm-Einstellungen von gestern auch wieder zurückgestellt)

Sobald ich ein KDE-eigenes Programm start und damit arbeite und es kommt ein Fehler, friert KDE und das System komplett ein, ich kann dann nur noch den Stecker ziehen.

Im /var/log/messages steht immer folgendes bevor ich den Stecker ziehe:

Sep 14 09:55:55 linux gconfd (markus-4729): (Version 2.4.0.1) wird gestartet, Prozesskennung 4729, Benutzer »markus«
Sep 14 09:55:55 linux gconfd (markus-4731): (Version 2.4.0.1) wird gestartet, Prozesskennung 4731, Benutzer »markus«
Sep 14 09:55:55 linux gconfd (markus-4731): Die Sperre für den Dämon konnte nicht erzeugt werden. Dieser wird daher beendet: »/tmp/gconfd-markus/lock/ior« konnte nicht gesperrt werden: möglicherweise hat ein anderer Prozess die Sperre bereits erzeugt oder die Konfiguration der NFS-Dateisperren Ihres Betriebssystems ist fehlerhaft (Die Ressource ist zur Zeit nicht verfügbar)
Sep 14 09:55:56 linux gconfd (markus-4729): Die Adresse »xml:readonly:/etc/opt/gnome/gconf/gconf.xml.mandatory« wurde an der Position 0 zu einer nur lesbaren Konfigurationsquelle aufgelöst
Sep 14 09:55:56 linux gconfd (markus-4729): Die Adresse »xml:readwrite:/home/markus/.gconf« wurde an der Position 1 zu einer schreibbaren Konfigurationsquelle aufgelöst
Sep 14 09:55:56 linux gconfd (markus-4729): Die Adresse »xml:readonly:/etc/opt/gnome/gconf/gconf.xml.defaults« wurde an der Position 2 zu einer nur lesbaren Konfigurationsquelle aufgelöst

Ok, das hilft ja schon bisschen weiter, weil man weiß, dass es ein Problem gibt. Leider hab ich nur keine Ahnung, was gconfd ist und wie ich da bei der Fehlersuche anfange, vielleicht könnt ihr mir da ja helfen ...

Danke
Markus

Werbung:
Gast

Beitrag von Gast » 14. Sep 2004, 12:50

Etwas naiv würde ich jetzt sagen: Lösch doch mal das Verzeichnis /tmp/gconfd-markus .

Hab aber sonst keine Idee/Ahnung :cry:

Markus Wagner
Member
Member
Beiträge: 61
Registriert: 27. Jul 2004, 11:14
Wohnort: Österreich
Kontaktdaten:

Beitrag von Markus Wagner » 15. Sep 2004, 21:47

Nein, das hat auch nix gebracht. Interessant ist, dass das nur beim normalen User, nicht bei root auftritt. Außerdem funktionieren die Signalsounds von KDE nicht mehr, obwohl sie richtig eingestellt sind und ich sonst ganz normalen Sound habe. Absturz passiert immer nur bei Fehlern in KDE-eigenen Programmen, zum Beispiel wenn ich den Mixer abdrehen will (da kommt ja so eine Fehlerbestätigung), wenn ich im KWrite bei einer Wortsuche nix finde, wenn ich in der Systemüberwachung einen Task beenden will, usw. usf.

Sonst kann ich interessanterweise ganz normal arbeiten. Ein Komplett-Upgrade mit APT hat mir auch nichts gebracht. Verwende aber noch KDE 3.2.1, habe aber vor bald auf 3.3 umzusteigen.

Hat noch jemand eine Idee?

Gast

Beitrag von Gast » 15. Sep 2004, 21:53

Ich vermute dennoch, dass es was mit einer vermurksten Konfiguration in deinem Homeverzeichnis, oder sonstwo zu tun hat. Ansonsten hätte das Update geholfen.

Hast du auch gconfd aktualisiert?

Vielleicht hilft dir eine Update auf KDE3.3, aber das wäre mit Kanonen auf Spatzen geschossen. Nur wenn du das sowieso vor hast... dumm ist nur, wenn dann die defekte config dein KDE3.3 auch lahmlegt.

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 15. Sep 2004, 22:33

Markus Wagner hat geschrieben:Nein, das hat auch nix gebracht. Interessant ist, dass das nur beim normalen User, nicht bei root auftritt. Außerdem funktionieren die Signalsounds von KDE nicht mehr, obwohl sie richtig eingestellt sind und ich sonst ganz normalen Sound habe. Absturz passiert immer nur bei Fehlern in KDE-eigenen Programmen, zum Beispiel wenn ich den Mixer abdrehen will (da kommt ja so eine Fehlerbestätigung), wenn ich im KWrite bei einer Wortsuche nix finde, wenn ich in der Systemüberwachung einen Task beenden will, usw. usf.

Sonst kann ich interessanterweise ganz normal arbeiten. Ein Komplett-Upgrade mit APT hat mir auch nichts gebracht. Verwende aber noch KDE 3.2.1, habe aber vor bald auf 3.3 umzusteigen.

Hat noch jemand eine Idee?
ad sounds:
die *.wav wurden zu *.oggs

hast du jetzt evtl einen Mix aus kde-3.2 und kde-3.3?
rpm -qa | grep kde

in einer use-group have ich folgendes gefunden
mv $HOME/.kde $HOME/xxx
die Konfig wird beim nächsten Start wieder hergestellt

und rm $HOME/.Xauthority

ein Versuch wäre es wert ;)
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Markus Wagner
Member
Member
Beiträge: 61
Registriert: 27. Jul 2004, 11:14
Wohnort: Österreich
Kontaktdaten:

Beitrag von Markus Wagner » 15. Sep 2004, 23:08

Oh Mann Jungs, wenns nicht so traurig wär, wäre es ja schon fast wieder lustig. :(

Hab mich nämlich daran erinnert, dass ich vor ein paar Tagen im KDE-Kontrollzentrum die Lautstärke der Kontrollsounds auf etwa 60% zurückgestellt habe. Nachdem es jetzt wieder auf 100% ist, funktioniert alles wieder einwandfrei.

Scheinbar scheint KDE damit nicht zurechtgekommen zu sen, deswegen gabs auch immer die Probleme dann wenn ein KDE-Programm einen Fehler oder Hinweis gab bzw. wurde deshalb auch der Systemstartsound nicht abgespielt.

Danke trotzdem für eure Tipps!

Das ganze bestärkt mich nur noch mehr nun endlich auf 3.3 umzusteigen, denn das 3.2.1 scheint dermaßen verbugged zu sein, dass es nicht mehr schön ist. :roll:

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast