downgrade von kde3.3 auf kde3.2.3 aber wie?

Alles rund um die möglichen Desktopumgebungen wie KDE, Gnome, XFCE usw. die es unter Linux gibt

Moderator: Moderatoren

Antworten
Benutzeravatar
scuddi
Newbie
Newbie
Beiträge: 27
Registriert: 28. Apr 2004, 18:53
Kontaktdaten:

downgrade von kde3.3 auf kde3.2.3 aber wie?

Beitrag von scuddi » 11. Sep 2004, 23:17

hi liebe forum user
nachdem ich jetzt kde3.3 etwa 3 wochen genutzt habe möchte ich wieder zurück zu kde3.2.3. kde3.3 hat mir einfach zu viele bugs und bereitet mir nur probleme. ich habe mir die benötigten kde3.2.3 pakete besorgt aber ich weiß nicht wie ich das mit dem downgraden anstellen soll. in yast2 finde ich keine möglichkeit die alten kde pakete zu installieren :( . ganz praktisch wäre auch eine installation per stapelverarbeitung, damit ich nicht jedes einzelne paket manuell installieren muss. ich bin für jede hilfe dankbar die mich wegbringt von dieser besch...eidenen :x kde3.3 version
AMD Athlon XP 1800+
ASUS A7V8X-X
ASUS Geforce4 Ti 4400
768 MB DDR RAM PC2700
SuSE 10.0|Kernel 2.6.13-15.10-default
|KDE 3.5.5 "release 19.1"

Werbung:
Gast

Beitrag von Gast » 11. Sep 2004, 23:28

hi
wie hast du das geupdated? über apt - dann wäre es einfach....
Sonst mach mal rpm -qa | grep kde dann deinstalliere alle aufgelisteten pakete und installiere das alte kde
Ich weiß nicht ob es so funzt :wink: Musst du ausprobieren.
Ich übernehme keine garantie !!!

Gruß }-Tux-{

Benutzeravatar
scuddi
Newbie
Newbie
Beiträge: 27
Registriert: 28. Apr 2004, 18:53
Kontaktdaten:

Beitrag von scuddi » 11. Sep 2004, 23:32

habe das update mit apt und synaptic gemacht habe aber bei synaptic irgendwie auch keine möglichkeit gefunden downzugraden. habe die version 0.53 von synaptic...
AMD Athlon XP 1800+
ASUS A7V8X-X
ASUS Geforce4 Ti 4400
768 MB DDR RAM PC2700
SuSE 10.0|Kernel 2.6.13-15.10-default
|KDE 3.5.5 "release 19.1"

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 11. Sep 2004, 23:41

das geht wunderbar mit apt.
erstelle eine Datei /etc/apt/preferences

dort schreibst du für jedes kde-Paket rein:
Package: kdebase3
Pin: Version 3.2*
Pin-Priority: 1001
...
die Liste der Pakete erhälst du mit rpm -qa | sort | grep kde

dann apt-get update
apt-get upgrade

evtl musst du noch in der sources.list das Verzeichnis mit den KDE3.3 Paketen rausnehmen.
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Benutzeravatar
scuddi
Newbie
Newbie
Beiträge: 27
Registriert: 28. Apr 2004, 18:53
Kontaktdaten:

Beitrag von scuddi » 12. Sep 2004, 12:19

@oc2pus danke für deinen tipp. ich habe alles so gemacht wie du gesagt hast aber wenn ich apt-get upgrade eingebe kommt

Code: Alles auswählen

Lese Paketlisten... Fertig
E: Ungültiger Eintrag in preferences Datei, kein Paketkopf
:?
AMD Athlon XP 1800+
ASUS A7V8X-X
ASUS Geforce4 Ti 4400
768 MB DDR RAM PC2700
SuSE 10.0|Kernel 2.6.13-15.10-default
|KDE 3.5.5 "release 19.1"

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 12. Sep 2004, 12:24

meine Glaskugel ist gerade verliehen ....

dann zeige mir mal die /etc/apt/preferences :)
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Benutzeravatar
scuddi
Newbie
Newbie
Beiträge: 27
Registriert: 28. Apr 2004, 18:53
Kontaktdaten:

Beitrag von scuddi » 12. Sep 2004, 12:26

Code: Alles auswählen

Package: kde3-i18n-de
Pin: Version 3.2*
Pin-Priority: 1001
Package: kdeaddons3-kate
Pin: Version 3.2*
Pin-Priority: 1001
Package: kdeaddons3-kicker
Pin: Version 3.2*
Pin-Priority: 1001
Package: kdeaddons3-konqueror
Pin: Version 3.2*
Pin-Priority: 1001
Package: kdeartwork3-sound
Pin: Version 3.2*
Pin-Priority: 1001
Package: kdeartwork3-xscreensaver
Pin: Version 3.2*
Pin-Priority: 1001
Package: kdebase3
Pin: Version 3.2*
Pin-Priority: 1001
Package: kdebase3-devel
Pin: Version 3.2*
Pin-Priority: 1001
Package: kdebase3-kdm
Pin: Version 3.2*
Pin-Priority: 1001
Package: kdebase3-ksysguardd
Pin: Version 3.2*
Pin-Priority: 1001
Package: kdebase3-nsplugin
Pin: Version 3.2*
Pin-Priority: 1001
Package: kdebase3-samba
Pin: Version 3.2*
Pin-Priority: 1001
Package: kdegames3
Pin: Version 3.2*
Pin-Priority: 1001
Package: kdegames3-card
Pin: Version 3.2*
Pin-Priority: 1001
Package: kdegraphics3
Pin: Version 3.2*
Pin-Priority: 1001
Package: kdegraphics3-fax
Pin: Version 3.2*
Pin-Priority: 1001
Package: kdegraphics3-kamera
Pin: Version 3.2*
Pin-Priority: 1001
Package: kdegraphics3-postscript
Pin: Version 3.2*
Pin-Priority: 1001
Package: kdelibs3
Pin: Version 3.2*
Pin-Priority: 1001
Package: kdelibs3-devel
Pin: Version 3.2*
Pin-Priority: 1001
Package: kdelibs3-doc
Pin: Version 3.2*
Pin-Priority: 1001
Package: kdemultimedia3
Pin: Version 3.2*
Pin-Priority: 1001
Package: kdemultimedia3-CD
Pin: Version 3.2*
Pin-Priority: 1001
Package: kdemultimedia3-jukebox
Pin: Version 3.2*
Pin-Priority: 1001
Package: kdemultimedia3-sound
Pin: Version 3.2*
Pin-Priority: 1001
Package: kdemultimedia3-video
Pin: Version 3.2*
Pin-Priority: 1001
Package: kdemultimedia3-video-xine
Pin: Version 3.2*
Pin-Priority: 1001
Package: kdenetwork3
Pin: Version 3.2*
Pin-Priority: 1001
Package: kdenetwork3-InstantMessenger
Pin: Version 3.2*
Pin-Priority: 1001
Package: kdenetwork3-news
Pin: Version 3.2*
Pin-Priority: 1001
Package: kdenetwork3-vnc
Pin: Version 3.2*
Pin-Priority: 1001
Package: kdepim3
Pin: Version 3.2*
Pin-Priority: 1001
Package: kdepim3-kpilot
Pin: Version 3.2*
Pin-Priority: 1001
Package: kdepim3-organizer
Pin: Version 3.2*
Pin-Priority: 1001
Package: kdeutils3
Pin: Version 3.2*
Pin-Priority: 1001
Package: kdeutils3-devel
Pin: Version 3.2*
Pin-Priority: 1001
Package: kdeutils3-laptop
Pin: Version 3.2*
Pin-Priority: 1001
AMD Athlon XP 1800+
ASUS A7V8X-X
ASUS Geforce4 Ti 4400
768 MB DDR RAM PC2700
SuSE 10.0|Kernel 2.6.13-15.10-default
|KDE 3.5.5 "release 19.1"

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 12. Sep 2004, 12:28

hm sieht korrekt aus ... evtl fehlt ein Zeilenabschluss am Ende?

P.S bin grade im IRC-channel: http://hotspace.de/irc
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste