Evolution, Probleme beim starten

Alles rund um die möglichen Desktopumgebungen wie KDE, Gnome, XFCE usw. die es unter Linux gibt

Moderator: Moderatoren

Antworten
Benutzeravatar
michael_33
Member
Member
Beiträge: 70
Registriert: 20. Jul 2004, 09:58

Evolution, Probleme beim starten

Beitrag von michael_33 » 11. Aug 2004, 08:18

Hallo,

passt zwar auch nach >>Groupware<<, aber ich denke hier sitzen mehr Experten. :)

Habe hier ne SuSE9.0, die per apt-get immer mal erneuert wird. So hab ich mir jetzt Evolution 1.4.5 installiert, nur leider startet das Ding nicht:

michael@thor:~> evolution
(Killing old version of Wombat...)
evolution: relocation error: /opt/gnome/lib/evolution/1.4/libeshell.so.0: undefined symbol: ORBit_skel_class_register

Hmm, lt. dieser Seite hier:
http://forum.gnome-de.org/index.php?for ... opic&id=66

scheint es einen Konflikt zwischen zwei Paketen zu geben, den ich leider mit apt-get nicht wegbekomme!? Soll heissen, sobald ich eines der Pakete entfernen will, killt er auch evolution mit.

Liegts jetzt wircklich an dem Konflikt oder ist das was anderes?

michael
.| 2.6.15-gentoo-r1 | .. fluxbox 0.9.14 ..|.
.| AMD Athlon(tm) XP 2400+ | GSA-4040B | Elitegroup K7S5A | Matrox Millennium G400 |.

Werbung:
Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 11. Aug 2004, 11:13

apt-get remove evolution <== erst mal weg damit

apt-get install evolution
falls es jetzt Fehlermeldungen gibt, hier posten ;)
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Benutzeravatar
michael_33
Member
Member
Beiträge: 70
Registriert: 20. Jul 2004, 09:58

Beitrag von michael_33 » 11. Aug 2004, 11:59

Nix erstmal weg damit; evolution 1.4.5-48 kann ich ohne Fehlermeldung installieren, per apt-get, wenn ich usr-local-bin rausnehme.
Der Hit ist, wenn ich usr-local-bin in meine sources.list reinnehme bekomme ich angeboten:

thor:~ # apt-get install evolution
Lese Paketlisten... Fertig
Erzeuge Abhängigkeitsbaum... Fertig
Einige Pakete konnten nicht installiert werden. Dies könnte bedeuten,
dass Sie eine unmögliche Situation angefordert haben oder, falls Sie die
instabile Distribution verwenden, dass einige benötigte Pakete noch nicht
erzeugt oder aus 'Incoming' verschoben worden sind.

Da Sie nur eine einzelne Operation angefordert haben, ist es extrem
wahrscheinlich, dass das Paket schlichtweg nicht installierbar ist und
ein Bugreport über dieses Paket eingereicht werden sollte.
Die folgende Information könnte helfen die Sitation zu beheben:

Die folgenden Pakete besitzen unerfülte Abhängigkeiten:
evolution: Hängt ab von: libgal-2.0.so.6
Hängt ab von: libgal-a11y-2.0.so.6
Hängt ab von: libgtkhtml-3.0.so.4
E: Fehlerhafte Pakete

das Teil was hier installiert werden soll ist von ulb und nennt sich 1.4.6-100.SuSE.ulb.1

Hmm, und was nun?
.| 2.6.15-gentoo-r1 | .. fluxbox 0.9.14 ..|.
.| AMD Athlon(tm) XP 2400+ | GSA-4040B | Elitegroup K7S5A | Matrox Millennium G400 |.

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 11. Aug 2004, 12:08

nimm die usr-local-bin aus deiner sources.list raus ;)

und nochmal: deinstalliere das vorhandene evolution und installiere es neu - OHNE usr-local-bin

apt-get update nicht vergessen bei Änderung an sources.list !

Nachtrag:
falls du schon mehrer ulb Pakete installiert hast, die solltest du auch entfernen und durch SuSE-konforme Pakete ersetzen ;)
Ist dir klar warum die usr-local-bin heissen ?
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Benutzeravatar
michael_33
Member
Member
Beiträge: 70
Registriert: 20. Jul 2004, 09:58

Beitrag von michael_33 » 11. Aug 2004, 22:48

ulb ist raus, apt-get update gemacht, auf pakete geprüft, die nach ulb aussehen -> nix gefunden. evolution 1.4.5-58 installiert, ohne fehlermeldungen:

michael@thor:~> evolution
(Killing old version of Wombat...)
evolution: relocation error: /opt/gnome/lib/evolution/1.4/libeshell.so.0: undefined symbol: ORBit_skel_class_register


??? Hmm?
.| 2.6.15-gentoo-r1 | .. fluxbox 0.9.14 ..|.
.| AMD Athlon(tm) XP 2400+ | GSA-4040B | Elitegroup K7S5A | Matrox Millennium G400 |.

Benutzeravatar
michael_33
Member
Member
Beiträge: 70
Registriert: 20. Jul 2004, 09:58

Beitrag von michael_33 » 13. Aug 2004, 07:40

So, habe gestern mal alles was nach Gnome aussah gekillt:
"apt-get groupremove Gnome", HUCH, was da so alles dazugehört.....schlagartig kein XFree, samba, cups, etc. mehr.... naja

hab ne Flat, also alles neu installiert.

Code: Alles auswählen

thor:~ # apt-get install evolution
Lese Paketlisten... Fertig
Erzeuge Abhängigkeitsbaum... Fertig
Einige Pakete konnten nicht installiert werden. Dies könnte bedeuten,
dass Sie eine unmögliche Situation angefordert haben oder, falls Sie die
instabile Distribution verwenden, dass einige benötigte Pakete noch nicht
erzeugt oder aus 'Incoming' verschoben worden sind.

Da Sie nur eine einzelne Operation angefordert haben, ist es extrem
wahrscheinlich, dass das Paket schlichtweg nicht installierbar ist und
ein Bugreport über dieses Paket eingereicht werden sollte.
Die folgende Information könnte helfen die Sitation zu beheben:

Die folgenden Pakete besitzen unerfülte Abhängigkeiten:
  evolution: Hängt ab von: libgal-2.0.so.5
             Hängt ab von: libgtkhtml-3.0.so.2
             Hängt ab von: libgtkhtml-a11y-3.0.so.2
E: Fehlerhafte Pakete
und der HIT ist:

Code: Alles auswählen

thor:~ # locate libgal
/opt/gnome/lib/libgal-2.2.so.0
/opt/gnome/lib/libgal-2.2.so.0.0.1
/opt/gnome/lib/libgal-a11y-2.2.so.0
/opt/gnome/lib/libgal-a11y-2.2.so.0.0.1
bevor fragen kommen, ldconfig ist ausgeführt und /opt/gnome/lib ist in der ld.so.conf drinnen.

So, Frage, wer hat hier Mist gebaut, mit den Abhängigkleiten, apt-get oder der Paketbauer?
.| 2.6.15-gentoo-r1 | .. fluxbox 0.9.14 ..|.
.| AMD Athlon(tm) XP 2400+ | GSA-4040B | Elitegroup K7S5A | Matrox Millennium G400 |.

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 13. Aug 2004, 07:50

Hängt ab von: libgal-2.0.so.5
und
/opt/gnome/lib/libgal-2.2.so.0
sind NICHT das gleiche ;)
also richtiges Paket finden ...

ich könnte wetten ein apt-get -f install wirkt wahre Wunder ...
es gibt offenstichlich Pakete welche von libgal-2.2* abhängen, deshalb wird evolution nicht installiert. Das Paket evolution will aber libgal-2.0*.

Prüfe mit apt-cache show evolution, welche Versionen von evolution dein apt sieht. Installiere dann eines dieser Pakete mit
apt-get install evolution=<Versionsnummer>

Hier liegt mit ziemlicher Sicherheit ein Problem in der sources.list.
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Benutzeravatar
michael_33
Member
Member
Beiträge: 70
Registriert: 20. Jul 2004, 09:58

Beitrag von michael_33 » 13. Aug 2004, 10:39

Hi,
oc2pus hat geschrieben:
ich könnte wetten ein apt-get -f install wirkt wahre Wunder ...

Code: Alles auswählen

thor:~ # apt-get -f install
Lese Paketlisten... Fertig
Erzeuge Abhängigkeitsbaum... Fertig
0 upgraded, 0 newly installed, 0 entfernt und 248 nicht upgegradet.
offensichtlich nicht.

apt-cache show sieht zwei Versionen:
1.4.5-48 und
1.4.4-86

Hmm, schlägt aber fehl:

Code: Alles auswählen

thor:~ # apt-get install evolution-1.4.4
Lese Paketlisten... Fertig
Erzeuge Abhängigkeitsbaum... Fertig
E: Konnte Paket evolution-1.4.4 nicht finden

thor:~ # apt-get install evolution-1.4.4-86
Lese Paketlisten... Fertig
Erzeuge Abhängigkeitsbaum... Fertig
E: Konnte Paket evolution-1.4.4-86 nicht finden

thor:~ # apt-get install evolution-1.4.5-48
Lese Paketlisten... Fertig
Erzeuge Abhängigkeitsbaum... Fertig
E: Konnte Paket evolution-1.4.5-48 nicht finden
Was mache ich bloss falsch?
.| 2.6.15-gentoo-r1 | .. fluxbox 0.9.14 ..|.
.| AMD Athlon(tm) XP 2400+ | GSA-4040B | Elitegroup K7S5A | Matrox Millennium G400 |.

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 13. Aug 2004, 10:44

Code: Alles auswählen

thor:~ # apt-get -f install
Lese Paketlisten... Fertig
Erzeuge Abhängigkeitsbaum... Fertig
0 upgraded, 0 newly installed, 0 entfernt und 248 nicht upgegradet.
248 ungeklärte Pakete .....
und du willst jetzt nur partiell etwas updaten, das wird nicht funktionieren.
apt-cache show sieht zwei Versionen:
1.4.5-48 und
1.4.4-86

thor:~ # apt-get install evolution-1.4.4
Lese Paketlisten... Fertig
Erzeuge Abhängigkeitsbaum... Fertig
E: Konnte Paket evolution-1.4.4 nicht finden
apt-get install evolution=1.4.4-86

ich habe geschrieben:
apt-get install evolution=<Versionsnummer>
wer lesen kann ist klar im Vorteil .... ;)
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Benutzeravatar
michael_33
Member
Member
Beiträge: 70
Registriert: 20. Jul 2004, 09:58

Beitrag von michael_33 » 13. Aug 2004, 14:15

Okay, first:

Code: Alles auswählen

thor:~ # apt-get -f install
Lese Paketlisten... Fertig
Erzeuge Abhängigkeitsbaum... Fertig
0 upgraded, 0 newly installed, 0 entfernt und 2 nicht upgegradet.
Und jetzt:

Code: Alles auswählen

thor:~ # apt-get install evolution=1.4.4-86
Lese Paketlisten... Fertig
Erzeuge Abhängigkeitsbaum... Fertig
Einige Pakete konnten nicht installiert werden. Dies könnte bedeuten,
dass Sie eine unmögliche Situation angefordert haben oder, falls Sie die
instabile Distribution verwenden, dass einige benötigte Pakete noch nicht
erzeugt oder aus 'Incoming' verschoben worden sind.

Da Sie nur eine einzelne Operation angefordert haben, ist es extrem
wahrscheinlich, dass das Paket schlichtweg nicht installierbar ist und
ein Bugreport über dieses Paket eingereicht werden sollte.
Die folgende Information könnte helfen die Sitation zu beheben:

Die folgenden Pakete besitzen unerfülte Abhängigkeiten:
  evolution: Hängt ab von: libgal-2.0.so.5
             Hängt ab von: libgtkhtml-3.0.so.2
             Hängt ab von: libgtkhtml-a11y-3.0.so.2
E: Fehlerhafte Pakete

und 

thor:~ # apt-get install evolution=1.4.5-48
Lese Paketlisten... Fertig
Erzeuge Abhängigkeitsbaum... Fertig
Einige Pakete konnten nicht installiert werden. Dies könnte bedeuten,
dass Sie eine unmögliche Situation angefordert haben oder, falls Sie die
instabile Distribution verwenden, dass einige benötigte Pakete noch nicht
erzeugt oder aus 'Incoming' verschoben worden sind.

Da Sie nur eine einzelne Operation angefordert haben, ist es extrem
wahrscheinlich, dass das Paket schlichtweg nicht installierbar ist und
ein Bugreport über dieses Paket eingereicht werden sollte.
Die folgende Information könnte helfen die Sitation zu beheben:

Die folgenden Pakete besitzen unerfülte Abhängigkeiten:
  evolution: Hängt ab von: libgal-2.0.so.5
             Hängt ab von: libgtkhtml-3.0.so.2
             Hängt ab von: libgtkhtml-a11y-3.0.so.2
E: Fehlerhafte Pakete
:?: :?: :?:
.| 2.6.15-gentoo-r1 | .. fluxbox 0.9.14 ..|.
.| AMD Athlon(tm) XP 2400+ | GSA-4040B | Elitegroup K7S5A | Matrox Millennium G400 |.

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 13. Aug 2004, 14:36

evolution: Hängt ab von: libgal-2.0.so.5
Hängt ab von: libgtkhtml-3.0.so.2
Hängt ab von: libgtkhtml-a11y-3.0.so.2
jetzt musst du noch
gal2 (libgal-2.0...)
libgtkhtml2 installieren.

apt-cache search libgal ==> welche Pakete haben diese Datei
apt-cache show gal2 ... Bingo ;)

==> apt-get install evolution gal2 libgtkhtml2
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste