Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Ausdruck von Mails unter KMail - Sonderzeichen=Buchstabensalat

Alles rund um die möglichen Desktopumgebungen wie KDE, Gnome, XFCE usw. die es unter Linux gibt

Moderator: Moderatoren

Antworten
perkuni
Newbie
Newbie
Beiträge: 3
Registriert: 28. Jun 2017, 21:52

Ausdruck von Mails unter KMail - Sonderzeichen=Buchstabensalat

Beitrag von perkuni » 28. Jun 2017, 22:12

Hallo allerseits,

ich nutze OpenSuse 42.2 mit KDE-Desktop und bin damit soweit auch zufrieden. Seit einige Zeit habe ich jedoch ein Problem, für das ich bisher keine Lösung gefunden habe: in der aktuellen Version von KMail erfolgt der Ausdruck von Mails über den Webbrowser (--> Die Druck-Unterstützung in WebEngine ist derzeit eingeschränkt. Für das Drucken wird ein externer Webbrowser verwendet.). Soweit, so gut. Die QtWebEnginde kann zurzeit also nicht drucken. KMail öffnet dann Konqueror (obwohl mein Standardbrowser Firefox ist) aber auch damit könnte ich leben. Leider ist es jedoch so, dass oftmals die Sonderzeichen und Umlaute nicht korrekt dargestellt werden. Ich vermute, dass das mit dem Zeichensatz der jeweiligen Mail zu tun hat, mir ist allerdings nicht klar, wie ich das überprüfen oder beeinflussen kann. Da ich viele Vorgänge dokumentiere und immer wieder auch Mails ausdrucke, die dann teilweise sehr schlecht verständlich sind, wäre ich für Hinweise zur Problemlösung sehr dankbar. Und: nein, ich möchte nicht auf Thunderbird umsteigen. Damit werde ich einfach nicht warm, egal wie oft ich es versuche...

Viele Grüße

Ingo

Werbung:
Sauerland
Guru
Guru
Beiträge: 3230
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: Ausdruck von Mails unter KMail - Sonderzeichen=Buchstabensalat

Beitrag von Sauerland » 29. Jun 2017, 06:50

Stell die Kodierung im konqueror um.
Oder nimm Firefox für Text/html.
Dort natürlich auch auf Unicode.
Desktop: OpenSUSE Leap 15.0, Nvidia-Grafik Kernel 4.x
Laptop: OpenSUSE Leap 15.0, Intel-Skylake, Kernel 4.12

perkuni
Newbie
Newbie
Beiträge: 3
Registriert: 28. Jun 2017, 21:52

Re: Ausdruck von Mails unter KMail - Sonderzeichen=Buchstabensalat

Beitrag von perkuni » 29. Jun 2017, 09:03

Hallo,

Danke für den Tipp. Seitdem ich gestern die QtWebEngine aktualisiert habe (irgendetwas funktionierte wohl nicht mit dem automatischen Update), scheint das Kodierungsproblem gelöst zu sein. Firefox bietet leider nicht die Möglichkeit, "Unicode" einzustellen. Ich finde dort nur "Mitteleuropäisch"... Wie auch immer, ich behalte das im Auge. Kommt ja bald Leap 42.3. Und für den Druck der Mails kann ich auch bei Konqueror bleiben.

Gruß

Ingo

Sauerland
Guru
Guru
Beiträge: 3230
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: Ausdruck von Mails unter KMail - Sonderzeichen=Buchstabensalat

Beitrag von Sauerland » 29. Jun 2017, 17:29

Firefox bietet leider nicht die Möglichkeit, "Unicode" einzustellen. Ich finde dort nur "Mitteleuropäisch"...
Bild
Seitdem ich gestern die QtWebEngine aktualisiert habe (irgendetwas funktionierte wohl nicht mit dem automatischen Update), scheint das Kodierungsproblem gelöst zu sein.
Naja, dann hast du aber nicht nur die offiziellen Repos eingebunden....

Code: Alles auswählen

grep -i qtwebengine /var/log/zypp/history 
2017-01-01 09:16:11|install|libqt5-qtwebengine|5.6.1-2.5|x86_64||openSUSE-42.2-0|9ced66454d313b101d19f822fcb5f1cf76ba988b|
2017-01-01 10:00:56|install|libqt5-qtwebengine|5.6.1-4.2|x86_64|root@linux-549c|repo-update|cae41c5fdf7bfcb86b89db21cae9b335c1e7a36d8a2b6683bda9c62c2aa9089e|
2017-01-19 07:59:24|install|libqt5-qtwebengine-devel|5.6.1-4.2|x86_64|root@linux64|repo-update|37dddef6aa4b9414545fd892f8985dfe09c88ec8f6e5a8db0583895f9017a808|

OT:
@josef-wien:
Besser so?????
Desktop: OpenSUSE Leap 15.0, Nvidia-Grafik Kernel 4.x
Laptop: OpenSUSE Leap 15.0, Intel-Skylake, Kernel 4.12

perkuni
Newbie
Newbie
Beiträge: 3
Registriert: 28. Jun 2017, 21:52

Re: Ausdruck von Mails unter KMail - Sonderzeichen=Buchstabensalat

Beitrag von perkuni » 2. Jul 2017, 18:35

Hallo,

ich stelle eben fest, dass das tatsächlich auch gar nicht der Fall war. Keine Ahnung was ich da gesehen habe... Das Problem besteht also weiterhin. Ich habe jetzt aber auch herausgefunden, die ich bei Firefox an die Textkodierung komme. Das wurde mir bisher nicht angezeigt. Diese Schaltfläche habe ich nun hinzugefügt. Wenn ich eine E-Mail öffne, wird sie zwar weiterhin ggf. falsch dekodiert, wenn ich dann auf "Unicode" stelle, geht es aber. Nur merken will Firefox sich das nicht dauerhaft... Aber eine Schritt weiter bin ich jetzt schon! Vielen Dank soweit.

Gruß

Ingo

Antworten