KDE Sitzung unter openSUSE 42.2 in Virtualbox unbrauchbar

Alles rund um die möglichen Desktopumgebungen wie KDE, Gnome, XFCE usw. die es unter Linux gibt

Moderator: Moderatoren

Antworten
Benutzeravatar
f.gruber
Hacker
Hacker
Beiträge: 367
Registriert: 24. Jun 2006, 19:40
Wohnort: Bad Schallerbach

KDE Sitzung unter openSUSE 42.2 in Virtualbox unbrauchbar

Beitrag von f.gruber » 16. Jan 2017, 13:28

Hallo,
ich habe ein Upgrade meiner Virtualbox VM openSUSE von Leap 42.1 auf 42.2 gemacht.

Nach dem Start der VM kann eine Plasma5 Sitzung im Gastsystem starten. Sobald ich aber die Maus über die Kontrolleiste der VM bewege, verschwindet die Kontrolleiste. Wenn ich die Maus an der (nicht mehr sichtbaren) Kontrolleiste bewege, erscheint das entsprechende Tooltip für das nicht sichtbare Icon, das sich dort befinden sollte. Klicke ich anschließend an der Stelle, passiert nichts. :roll:

Ich kann also in der VM keine Programme starten, jedenfalls nicht mit Mausklick.

Ich bin umgestiegen von der OSS Version von Virtualbox, die von Suse mitgeliefert wird, auf die proprietäre Virtualbox Version von Oracle.
Mein Host System ist openSUSE 42.2.

Ja, ich habe wirklich eine openSUSE Version als VM unter openSUSE. Diese VM habe ich mit Hilfe von Suse Studio gemacht, weil ich gewisse Dinge probieren wollte. Als Leap 42.1 VM hat sie funktioniert.

Im Gastsystem habe ich mittels YAST alles deinstalliert, was da von virtualbox drinnen stand:

Code: Alles auswählen

virtualbox-guest-kmp-default
virtualbox-guest-tools
Dann habe ich die aktuelle GuestAdditions ISO eingebunden und installiert (Version 5.1.12).

Ich kann die VM in den Runlevel 2 booten, also somit habe ich jedenfalls Zugriff auf das Gastsystem.
Eine LxQt Sitzung kann ich übrigens auch starten und auch damit arbeiten.

Es kommt aber - schon beim Displaymanager (also vor dem Login) vor, dass plötzlich der VM Bildschirm zu flackern anfängt. Er blinkt dann regelmäßig im 1/2 Sekunden Takt. Ich kann dann nur mehr die VM ausschalten. Beim nächsten Boot komme ich zumindest wieder zum Login Screen.

Liegt es an den Gasterweiterungen?
Oder liegt es doch am HostSystem, da erscheint manchmal in der Kontrolleiste der rote Käfer und sagt irgendwas von einem KWin Absturz (KWin wurde unerwartet beendet). Aber ich kann dann meist doch wieder normal weiterarbeiten ...

Also alles zusammen ziemlich unerfreulich.
Hat jemand Tipps für mich parat?

Tja, vor dem Abschicken dieses Postings habe ich noch schnell in der Virtualbox GUI unter "Anzeige" die 3D-Beschleunigung für diese VM ausgeschaltet und siehe da, das war die Lösung.

Die VM bootet etwas länger jetzt aber es scheint sonst alles zu funktionieren. Plasma5 arbeitet normal sogar mit eingeschaltetem Compositing.

Ich schicke das Posting trotzdem weg, vielleicht hilft es jemand anderem und außerdem wäre ja die Hardwarebeschleunigung durchaus wünschenswert :???:
Gruß
Ferdinand

Werbung:
Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste