andere Oberflächen auswählen

Alles rund um die möglichen Desktopumgebungen wie KDE, Gnome, XFCE usw. die es unter Linux gibt

Moderator: Moderatoren

Antworten
Herr Heimlich
Newbie
Newbie
Beiträge: 6
Registriert: 25. Jul 2004, 11:20

andere Oberflächen auswählen

Beitrag von Herr Heimlich » 25. Jul 2004, 11:26

Hallo,

ich verwende SuSE 9.1 personal (das zum Downloaden) und habe mir mit Yast den xfc-WM geholt.

Leider habe ich bei der grafischen Linux-Anmeldung keine Wahl, welchen WM ich starten will.

Ich habe schon in /etc/sysconfig/windowmanager den eintrag SUSEWM_WM="all" hinzugefügt, was aber auch nichts gebracht hat. Andere passende Einstellungen in Yast habe ich leider auch nicht gefunden.

Bei anderen Linux-Versionen besteht die Möglichkeit, bei der Anmeldung den WM zu wählen. WIe kann ich das bei SuSE einstellen?

Werbung:
Benutzeravatar
BirgerS
Member
Member
Beiträge: 163
Registriert: 21. Jun 2004, 23:06
Wohnort: Mülheim/Ruhr

Beitrag von BirgerS » 25. Jul 2004, 17:27

Ich VERMUTE mal, daß bei dieser "1-CD-Version" keine weiteren WMs dabei sind, oder daß Du nicht alle installiert hast. Schau mal in Yast, ob Du da mehr Möglichkeiten hast - oder such da mal nach anderen WMs.
Suse Linux 10.0 / KDE 3.5.1
Intel P4 2,53 GHz / 1024 MB DDR-RAM / ATI X700 256 MB

littlepaul
Newbie
Newbie
Beiträge: 4
Registriert: 19. Jul 2004, 08:16

Beitrag von littlepaul » 25. Jul 2004, 18:16


Herr Heimlich
Newbie
Newbie
Beiträge: 6
Registriert: 25. Jul 2004, 11:20

Beitrag von Herr Heimlich » 27. Jul 2004, 22:28

Danke für die Tipps, aber leider funktioniert das bei mir so nicht :-(

Ich wollte es so machen, wie's in dem anderen Forum beschrieben ist.
Dumm nur, dass es in meiner /etc/opt/kde3/share/config/kdm/kdmrc keinen Eintrag
"HideMenu=True" gibt, den ich dann auf False setzen könnte.
Naja macht ja nichts, hab ich den halt einfach an die entsprechende Stelle hinzugefügt.

Und die /usr/X11R6/lib/X11/xdm/Xsession sieht bei mir auch ein wenig anders aus als dort beschrieben.
Ich hab z.B. einen "*)" - Eintrag. Soll ich den dann rausmachen, so dass an der Stelle nur noch "kde)" und "xfc)" dortsteht?

Schade, dass man das Verhalten von diesem kdm nicht einfach im Kontrollzentrum einstellen kann :-(

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 27. Jul 2004, 22:40

aus /etc/sysconfig/windowmanager
## Type: string
## Default: all
#
# This is the (space separated) list of window managers for which you
# want to generate the config file. Valid values are:
# "kde", "gnome", "windowmaker", "blackbox", "fvwm", "fvwm2",
# "fvwm95", "bowman", "mwm", "ctwm", "all".
# Default setting is "all" which is for generating files for all wms.
#
SUSEWM_WM="all"
dort trage alle deine WM ein die du haben willst

xfce wird von SuSE etwas stiefmütterlich behandelt und deshalb ist der so nicht integrierbar.
Xfce4 starten
Benutzen Sie startxfce4 um eine Xfce Sitzung zu starten; das beinhaltet das Panel, den Fenstermanager und die Desktophintergrund-Verwaltung. Alle Programme, oder symbolische Links zu Programmen, die sich in ~/Desktop/Autostart/ befinden, werden automatisch von startxfce4 mitgestartet.

Um startxfce4 anzupassen, kopieren Sie ${sysconfdir}/xfce4/xinitrc in Ihren eigenen ~/.xfce4/ Ordner und passen diese Datei an. Wenn Sie aus dem Quellcode installieren, zeigt ${sysconfdir} auf /usr/local/etc, bei binären Paketen ist es oft /etc.

Alternativ können Sie auch Ihr eigene ~/.xinitrc bzw. ~/.xsession Datei erstellen, wenn Sie einen grafischen Loginmanager nutzen.
d.h du kannst in deiner ~/.xinitrc den xfce eintragen (schau dir die anderen Einträge an) WINDOWMANAGER=xfce ==> startxfce wird aufgerufen ;)
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Benutzeravatar
Yogibär
Member
Member
Beiträge: 121
Registriert: 2. Mär 2005, 13:00
Wohnort: Berlin

Beitrag von Yogibär » 1. Apr 2005, 21:53

Habe ein ähnliches Problem wie Herr Heimlich Nachdem ich den KDE
auf 3.4 geupdated habe, erschien beim Anmeldebildschirm nicht mehr Gnome zur Auswahl. Gnome war aber vorhanden, denn nach - startx gnome - konnte ich Gnome auch starten, es fehlte aber wie gesagt der Eintrag des Login-Managers.
Ich kann mich erinnern, dass ich bei SuSE 8.xx über Yast auch andere Windowmanager komfortabel eintragen konnte,bei SUSE 9.2 habe ich aber bisher nichts gefunden. Vielleicht sehe ich aber den Wald vor lauter Bäumen nicht.
Kann übrigens die nächsten 14 Tage wegen Urlaubs nicht antworten!

Gruß an alle Linuxer!

Pentium 4 3,0 GHz - 1024 MB RAM - Asus Geforce 6600 GT - SuSE 9.2

IhmSelbst
Member
Member
Beiträge: 53
Registriert: 28. Okt 2003, 01:03
Wohnort: 26349 Jade, nds, adw
Kontaktdaten:

Beitrag von IhmSelbst » 19. Apr 2005, 18:15


Yehudi
Guru
Guru
Beiträge: 2152
Registriert: 21. Jan 2004, 13:51
Wohnort: Hamburg
Kontaktdaten:

Beitrag von Yehudi » 25. Apr 2005, 12:14

Hallo beim Benutzerwechsel, wird Gnome und KDE nicht mehr aufgeführt.
Es werden folgende Möglichkeiten angeboten: Standard, Benutzerdefiniert (vorherige), MWM,TWM.
Das war es. IhmSelbst seinen Befehl habe ich schon ausgeführt, oc2pus seine oben aufgeführte Zeile kann ich jedoch nicht finden. (MC)


Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste