Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

KDE-Start - udisks2.service macht Pause

Alles rund um die möglichen Desktopumgebungen wie KDE, Gnome, XFCE usw. die es unter Linux gibt

Moderator: Moderatoren

Antworten
Benutzeravatar
heinerf
Newbie
Newbie
Beiträge: 42
Registriert: 20. Nov 2008, 19:51
Wohnort: Hochsauerland, UTM 32U451833 5671342

KDE-Start - udisks2.service macht Pause

Beitrag von heinerf » 20. Jan 2014, 19:22

Hallo,

das Problem tritt sporadisch auf, unregelmäßig und für mich nicht reproduzierbar:
Beim Start des KDE-Desktop gibt es hin und wieder eine längere Pause, und zwar nach dem 3. Symbol (Erdkugel - Netzwerk?). Als Ursache konnte ich udisks2.service ausmachen, welches im besten Fall 6-7 sec braucht, manchmal aber eben auch über 30 sec. Maximum war heute 38.449ms.

Wie gesagt, ich habe keine Erklärung dafür, mal tritt der Effekt auf, mal nicht. Irgendeine Systematik konnte ich bisher nicht feststellen.

Vielleicht hat jemand eine Idee oder einen Tip zur Abhilfe?

Grüße
Hein
openSUSE Leap 15.1 / KDE Plasma 5.12.8
----------------------------------------------------------------------------
Habt ihr etwas gegen sie? - Nein.
Aber ihr bekämpft sie trotzdem? - Das ist unser Job.
Komische Einstellung!

Werbung:
Benutzeravatar
SUSEDJAlex
Advanced Hacker
Advanced Hacker
Beiträge: 863
Registriert: 18. Apr 2008, 22:09
Wohnort: Heimatplanet Abydos

Re: KDE-Start - udisks2.service macht Pause

Beitrag von SUSEDJAlex » 23. Jan 2014, 08:59

warum postest du die Meldungen nicht ?

Poste bitte das hier:

Code: Alles auswählen

cat /etc/os-release
systemctl status udisks2.service
df -h
LG SUSEDJAlex
openSUSE LEAP 15.0 mit Plasma 5.13 / arch linux mit Kernel 4.14.67-1-lts und XFCE4

Benutzeravatar
heinerf
Newbie
Newbie
Beiträge: 42
Registriert: 20. Nov 2008, 19:51
Wohnort: Hochsauerland, UTM 32U451833 5671342

Re: KDE-Start - udisks2.service macht Pause

Beitrag von heinerf » 23. Jan 2014, 17:00

SUSEDJAlex hat geschrieben:warum postest du die Meldungen nicht ?
Meinst du sowas?

Code: Alles auswählen

hein@novalis:~> systemd-analyze blame
          7.589s network.service
          6.847s network@enp2s0.service
          2.604s SuSEfirewall2_init.service
          1.847s cycle.service
          1.810s systemd-udev-root-symlink.service
          1.672s kmod-static-nodes.service
          1.448s SuSEfirewall2.service
          1.154s home.mount
          1.026s systemd-vconsole-setup.service
           889ms systemd-modules-load.service
           889ms systemd-remount-fs.service
           879ms udisks2.service
           ...
Heute mal ausgesprochen schnell! (Vorführeffekt)
Poste bitte das hier:

Code: Alles auswählen

hein@novalis:~> cat /etc/os-release
NAME=openSUSE
VERSION="13.1 (Bottle)"
VERSION_ID="13.1"
PRETTY_NAME="openSUSE 13.1 (Bottle) (x86_64)"
ID=opensuse
ANSI_COLOR="0;32"
CPE_NAME="cpe:/o:opensuse:opensuse:13.1"
BUG_REPORT_URL="https://bugs.opensuse.org"
HOME_URL="https://opensuse.org/"
ID_LIKE="suse"

Code: Alles auswählen

hein@novalis:~> systemctl status udisks2.service
udisks2.service - Disk Manager
   Loaded: loaded (/usr/lib/systemd/system/udisks2.service; static)
   Active: active (running) since Do 2014-01-23 16:42:28 CET; 9min ago
     Docs: man:udisks(8)
 Main PID: 2588 (udisksd)
   CGroup: /system.slice/udisks2.service
           └─2588 /usr/lib/udisks2/udisksd --no-debug

Code: Alles auswählen

hein@novalis:~> df -h
Dateisystem    Größe Benutzt Verf. Verw% Eingehängt auf
/dev/sda11       20G    5,7G   13G   31% /
devtmpfs        1,9G     40K  1,9G    1% /dev
tmpfs           2,0G       0  2,0G    0% /dev/shm
tmpfs           2,0G    3,6M  2,0G    1% /run
tmpfs           2,0G       0  2,0G    0% /sys/fs/cgroup
tmpfs           2,0G    3,6M  2,0G    1% /var/run
tmpfs           2,0G    3,6M  2,0G    1% /var/lock
/dev/sda12      186G     11G  175G    6% /home
Irgendeine Idee? Ich nicht.

Grüße
Hein
openSUSE Leap 15.1 / KDE Plasma 5.12.8
----------------------------------------------------------------------------
Habt ihr etwas gegen sie? - Nein.
Aber ihr bekämpft sie trotzdem? - Das ist unser Job.
Komische Einstellung!

Benutzeravatar
SUSEDJAlex
Advanced Hacker
Advanced Hacker
Beiträge: 863
Registriert: 18. Apr 2008, 22:09
Wohnort: Heimatplanet Abydos

Re: KDE-Start - udisks2.service macht Pause

Beitrag von SUSEDJAlex » 24. Jan 2014, 09:20

ich zeig mal meine Ausgabe von udisks2.service:

Code: Alles auswählen

systemctl status udisks2.service
udisks2.service - Disk Manager
   Loaded: loaded (/usr/lib/systemd/system/udisks2.service; static)
   Active: active (running) since Fr 2014-01-24 08:10:36 CET; 1h 3min ago
     Docs: man:udisks(8)
 Main PID: 1449 (udisksd)
   CGroup: /system.slice/udisks2.service
           └─1449 /usr/lib/udisks2/udisksd --no-debug

Jan 24 08:10:35 linux-n610.site udisksd[1449]: udisks daemon version 2.1.1 starting
Jan 24 08:10:36 linux-n610.site systemd[1]: Started Disk Manager.
Jan 24 08:10:36 linux-n610.site udisksd[1449]: Acquired the name org.freedesktop.UDisks2 on the system message bus
und systemd analyze blame:

Code: Alles auswählen

systemd-analyze blame
          4.494s hddtemp.service
          2.044s postfix.service
          2.041s SuSEfirewall2.service
          1.835s NetworkManager.service
          1.756s xdm.service
          1.609s cycle.service
          1.595s systemd-udev-root-symlink.service
          1.541s vboxdrv.service
          1.525s kmod-static-nodes.service
          1.134s lvm2-activation.service
          1.058s dev-mqueue.mount
          1.057s dev-hugepages.mount
          1.057s sys-kernel-debug.mount
           770ms systemd-fsck-root.service
           770ms systemd-readahead-collect.service
           770ms systemd-readahead-replay.service
           756ms systemd-vconsole-setup.service
           694ms polkit.service
           559ms ntp.service
           545ms systemd-fsck@dev-disk-by\x2did-ata\x2dHitachi_HDS721010DLE630_MSK523Y205GJDB\x2dpart4.service
           528ms systemd-sysctl.service
           506ms wpa_supplicant.service
           506ms systemd-logind.service
           503ms avahi-daemon.service
           437ms lvm2-activation-early.service
           363ms plymouth-start.service
           290ms boot-efi.mount
           219ms SuSEfirewall2_init.service
           206ms home.mount
           197ms systemd-udev-settle.service
           191ms systemd-udevd.service
           191ms systemd-random-seed.service
           188ms var-run.mount
           167ms apparmor.service
           165ms lm_sensors.service
           136ms systemd-modules-load.service
            95ms systemd-tmpfiles-clean.service
            94ms user@1000.service
            94ms sys-fs-fuse-connections.mount
            94ms systemd-tmpfiles-setup-dev.service
            81ms tmp.mount
            75ms udisks2.service
            56ms plymouth-read-write.service
            52ms systemd-tmpfiles-setup.service
            34ms user@0.service
            29ms rtkit-daemon.service
            14ms rsyslog.service
            14ms alsa-restore.service
            12ms systemd-udev-trigger.service
            12ms vboxweb-service.service
            10ms vboxballoonctrl-service.service
             8ms vboxautostart-service.service
             6ms rc-local.service
             6ms systemd-remount-fs.service
             5ms systemd-update-utmp-runlevel.service
             5ms systemd-user-sessions.service
             3ms upower.service
             3ms systemd-update-utmp.service
             3ms dev-disk-by\x2did-ata\x2dHitachi_HDS721010DLE630_MSK523Y205GJDB\x2dpart2.swap
             3ms systemd-journal-flush.service
             1ms bluetooth.service
             1ms var-lock.mount
           678us systemd-readahead-done.service
LG SUSEDJAlex
openSUSE LEAP 15.0 mit Plasma 5.13 / arch linux mit Kernel 4.14.67-1-lts und XFCE4

Benutzeravatar
heinerf
Newbie
Newbie
Beiträge: 42
Registriert: 20. Nov 2008, 19:51
Wohnort: Hochsauerland, UTM 32U451833 5671342

Re: KDE-Start - udisks2.service macht Pause

Beitrag von heinerf » 24. Jan 2014, 15:28

SUSEDJAlex hat geschrieben:Ich zeig mal meine Ausgabe von ...
und systemd analyze blame:

Code: Alles auswählen

systemd-analyze blame
          4.494s hddtemp.service
          2.044s postfix.service
          2.041s SuSEfirewall2.service
          ...
            75ms udisks2.service
 
Ich beneide dich!
Das war soeben:

Code: Alles auswählen

systemd-analyze blame
          6.926s network.service
          6.238s udisks2.service
          6.186s network@enp2s0.service
          1.912s cycle.service
          ...
Mal ganz konkret meine Frage: Warum braucht udisks2.service (bei mir) mal 38 sec und mal nur 0.8 sec?

Grüße Hein
openSUSE Leap 15.1 / KDE Plasma 5.12.8
----------------------------------------------------------------------------
Habt ihr etwas gegen sie? - Nein.
Aber ihr bekämpft sie trotzdem? - Das ist unser Job.
Komische Einstellung!

Benutzeravatar
heinerf
Newbie
Newbie
Beiträge: 42
Registriert: 20. Nov 2008, 19:51
Wohnort: Hochsauerland, UTM 32U451833 5671342

Re: KDE-Start - udisks2.service macht Pause

Beitrag von heinerf » 31. Jan 2014, 17:26

Seltsam: seit meinem letzten Post keine Verzögerungen mehr gehabt. Dachte schon an wunderbare Selbstheilung.
Heute steckt wieder der Wurm drin: einmal 34.210s, einmal 21.766s :-(

Also nochmal meine Frage: Warum braucht udisks2.service (bei mir) mal über 30 sec und mal nur 0.8 sec?

Grüße Hein
openSUSE Leap 15.1 / KDE Plasma 5.12.8
----------------------------------------------------------------------------
Habt ihr etwas gegen sie? - Nein.
Aber ihr bekämpft sie trotzdem? - Das ist unser Job.
Komische Einstellung!

Benutzeravatar
Jägerschlürfer
Moderator
Moderator
Beiträge: 4494
Registriert: 1. Jul 2005, 12:22
Wohnort: nahe Würzburg

Re: KDE-Start - udisks2.service macht Pause

Beitrag von Jägerschlürfer » 31. Jan 2014, 17:56

prüfe deine Festplatte doch bitte mal auf Fehler,...
>Linux-Club Foren FAQ< >LC-Wiki<

Know your enemy and know yourself Sun Tzu

Benutzeravatar
heinerf
Newbie
Newbie
Beiträge: 42
Registriert: 20. Nov 2008, 19:51
Wohnort: Hochsauerland, UTM 32U451833 5671342

Re: KDE-Start - udisks2.service macht Pause

Beitrag von heinerf » 1. Feb 2014, 17:08

Jägerschlürfer hat geschrieben:prüfe deine Festplatte doch bitte mal auf Fehler,...
zuerst mal, so sieht sie aus:

Code: Alles auswählen

Disk /dev/sda: 1000.2 GB, 1000204886016 bytes, 1953525168 sectors
Units = Sektoren of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk label type: dos
Disk identifier: 0x2bd2c32a

   Gerät  boot.     Anfang        Ende     Blöcke   Id  System
/dev/sda1            2048      206847      102400    7  HPFS/NTFS/exFAT
/dev/sda2          206848   409806847   204800000    7  HPFS/NTFS/exFAT
/dev/sda3   *   409806848  1951424511   770808832    5  Extended
/dev/sda4      1951424512  1953523119     1049304   12  Compaq diagnostics
/dev/sda5       409808896   475779071    32985088    7  HPFS/NTFS/exFAT
/dev/sda6       475781120   685496319   104857600    b  W95 FAT32
/dev/sda7       685498368   689719295     2110464   82  Linux swap / Solaris
/dev/sda8       689721344   815556607    62917632   83  Linux
/dev/sda9       815558656  1094981631   139711488   83  Linux
/dev/sda10     1094983680  1514414079   209715200   83  Linux
/dev/sda11     1514416128  1556361215    20972544   83  Linux
/dev/sda12     1556363264  1951424511   197530624   83  Linux
und fsck.ext4 sagt zu sda8...sda12: sauber
openSUSE Leap 15.1 / KDE Plasma 5.12.8
----------------------------------------------------------------------------
Habt ihr etwas gegen sie? - Nein.
Aber ihr bekämpft sie trotzdem? - Das ist unser Job.
Komische Einstellung!

Benutzeravatar
misiu
Moderator
Moderator
Beiträge: 3995
Registriert: 8. Mär 2004, 11:27
Wohnort: bei Schweinfurt

Re: KDE-Start - udisks2.service macht Pause

Beitrag von misiu » 1. Mär 2014, 20:14

Ich glaube, du solltest die Festplatte mit

Code: Alles auswählen

smartctl -a /dev/sda
testen (wahrscheinlich, als root).
Vorausgesetzt , die Smartmontools sind installiert.

MfG
misiu

Benutzeravatar
heinerf
Newbie
Newbie
Beiträge: 42
Registriert: 20. Nov 2008, 19:51
Wohnort: Hochsauerland, UTM 32U451833 5671342

Re: KDE-Start - udisks2.service macht Pause

Beitrag von heinerf » 7. Mär 2014, 12:14

misiu hat geschrieben:Ich glaube, du solltest die Festplatte mit

Code: Alles auswählen

smartctl -a /dev/sda
testen (wahrscheinlich, als root).
hab ich inzwischen auch gemacht. Alles ist im (äußerst) grünen Bereich.
Hab die Ausgaben nicht mehr parat, aber es waren alle Werte nahe an 100% der Sollwerte.

Im Übrigen hat sich am Verhalten von udisks2.service nichts geändert. Normalerweise <1s, aber hin und wieder auch mal >30s.
Noch irgendwelche Vorstellungen?

Grüße
Hein
openSUSE Leap 15.1 / KDE Plasma 5.12.8
----------------------------------------------------------------------------
Habt ihr etwas gegen sie? - Nein.
Aber ihr bekämpft sie trotzdem? - Das ist unser Job.
Komische Einstellung!

Antworten