Suse 9.1: Update auf Gnome 2.6 gründlich daneben

Alles rund um die möglichen Desktopumgebungen wie KDE, Gnome, XFCE usw. die es unter Linux gibt

Moderator: Moderatoren

Antworten
Tommy_taifun
Newbie
Newbie
Beiträge: 24
Registriert: 8. Apr 2004, 13:12

Suse 9.1: Update auf Gnome 2.6 gründlich daneben

Beitrag von Tommy_taifun » 8. Jul 2004, 15:51

Hallo,

ich habe mir gerade mit yast die Gnome 2.6 rpms vom suse-ftp-server installiert. Das hat aber das ganze System versaut. Kann mir wer sagen, wie ich den Mist wieder loswerde? ich habs schon aus yast heraus versucht, aber einige Dinge wollen sich absolut nicht downgraden lassen (zum Beispiel atk). Auch nicht, wenn ich per Hand und mit --force die alten rpm wieder einspielen möchte. Dann kommen etliche Bildschirme voller Fehlermeldungen. Wer kann mir helfen?
Gruß,
TommyT

Werbung:
Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 8. Jul 2004, 16:09

rpm --force UND --nodeps probieren.

Damit "hängt" dein System kurzzeituig schief aber wenn du die downgrade Pakete wieder installiert ist alles roger.

P.S.
bitte auch immer die Fehlermeldung posten ;)

Tommy_taifun
Newbie
Newbie
Beiträge: 24
Registriert: 8. Apr 2004, 13:12

Beitrag von Tommy_taifun » 8. Jul 2004, 16:19

Danke, werds gleich ausprobieren. Aber die Fehlermeldungen habe ich nicht gepostet, weil diese länger sind, als der Buffer der shell.

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 8. Jul 2004, 16:26

nicht die ganze Ausgabe, ein kleines Stück reicht meist schon.

ansonsten <befehl> | tee <datei> ==> wird auf Bildschirm und in Datei ausgegeben ;)

rpm -Uhv xyz | tee meinUpdate.txt

Tommy_taifun
Newbie
Newbie
Beiträge: 24
Registriert: 8. Apr 2004, 13:12

Beitrag von Tommy_taifun » 8. Jul 2004, 16:36

So, jetzt hab ich ne schöne Fehlermeldung.

Code: Alles auswählen

# rpm -Uhv --force gnome-vfs*.rpm
Preparing...                ########################################### [100%]
   1:gnome-vfs2-32bit       ########################################### [ 14%]
   2:gnome-vfs2             warning: /etc/opt/gnome/gnome-vfs-2.0/modules/cdda-module.conf saved as /etc/opt/gnome/gnome-vfs-2.0/modules/cdda-module.conf.rpmorig
warning: /etc/opt/gnome/gnome-vfs-2.0/modules/default-modules.conf saved as /etc/opt/gnome/gnome-vfs-2.0/modules/default-modules.conf.rpmorig
warning: /etc/opt/gnome/gnome-vfs-2.0/modules/ssl-modules.conf saved as /etc/opt/gnome/gnome-vfs-2.0/modules/ssl-modules.conf.rpmorig
warning: /etc/opt/gnome/gnome-vfs-2.0/vfolders/applications-all-users.vfolder-info saved as /etc/opt/gnome/gnome-vfs-2.0/vfolders/applications-all-users.vfolder-info.rpmorig
warning: /etc/opt/gnome/gnome-vfs-2.0/vfolders/drives.vfolder-info saved as /etc/opt/gnome/gnome-vfs-2.0/vfolders/drives.vfolder-info.rpmorig
warning: /etc/opt/gnome/gnome-vfs-2.0/vfolders/favorites.vfolder-info saved as /etc/opt/gnome/gnome-vfs-2.0/vfolders/favorites.vfolder-info.rpmorig
warning: /etc/opt/gnome/gnome-vfs-2.0/vfolders/network.vfolder-info saved as /etc/opt/gnome/gnome-vfs-2.0/vfolders/network.vfolder-info.rpmorig
warning: /etc/opt/gnome/gnome-vfs-2.0/vfolders/preferences-all-users.vfolder-info saved as /etc/opt/gnome/gnome-vfs-2.0/vfolders/preferences-all-users.vfolder-info.rpmorig
warning: /etc/opt/gnome/gnome-vfs-2.0/vfolders/server-settings.vfolder-info saved as /etc/opt/gnome/gnome-vfs-2.0/vfolders/server-settings.vfolder-info.rpmorig
warning: /etc/opt/gnome/gnome-vfs-2.0/vfolders/start-here.vfolder-info saved as /etc/opt/gnome/gnome-vfs-2.0/vfolders/start-here.vfolder-info.rpmorig
warning: /etc/opt/gnome/gnome-vfs-2.0/vfolders/system-settings.vfolder-info saved as /etc/opt/gnome/gnome-vfs-2.0/vfolders/system-settings.vfolder-info.rpmorig
########################################### [ 29%]
rpmdb: PANIC: Das Argument ist ungültig
rpmdb: fatal region error detected; run recovery
rpmdb: fatal region error detected; run recovery
rpmdb: fatal region error detected; run recovery
rpmdb: fatal region error detected; run recovery
rpmdb: fatal region error detected; run recovery
rpmdb: fatal region error detected; run recovery
error: db4 error(-30982) from dbcursor->c_put: DB_RUNRECOVERY: Fatal error, run database recovery
error: error(-30982) storing record LC_MESSAGES into Basenames
rpmdb: fatal region error detected; run recovery
error: db4 error(-30982) from dbcursor->c_get: DB_RUNRECOVERY: Fatal error, run database recovery
error: error(-30982) getting "gnome-vfs-2.0.mo" records from Basenames index
rpmdb: fatal region error detected; run recovery
Das geht dann ewig so weiter...

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Beitrag von oc2pus » 8. Jul 2004, 16:38

oh, das sieht so aus als ob die rpm-Datenbank einen Schaden hat.

gib mal ein rpm --rebuilddb (als root)

und probier dann nochmal

Tommy_taifun
Newbie
Newbie
Beiträge: 24
Registriert: 8. Apr 2004, 13:12

Beitrag von Tommy_taifun » 8. Jul 2004, 16:45

Ahh, cool, danke tausend mal. Jetzt geht's. Mal sehen, ob das Update von Gnome jetzt auch läuft.

Schönen Tag und Dank,
TommyT

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste