Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[gelöst] Alternative zu Kshutdown

Alles rund um die möglichen Desktopumgebungen wie KDE, Gnome, XFCE usw. die es unter Linux gibt

Moderator: Moderatoren

Antworten
PowerPaul
Hacker
Hacker
Beiträge: 611
Registriert: 18. Aug 2006, 11:44
Wohnort: SATA Platte hinten rechts

[gelöst] Alternative zu Kshutdown

Beitrag von PowerPaul » 21. Feb 2009, 09:57

Hallo Leute!

Ich habe mein geliebtes Kshutdown aus dem Packman Repro hier, auf Suse 11.1 installiert.
Leider funktioniert Rechner ausschalten, Rechner neu starten usw nicht.

Wie muss ich Kshutdown konfigurieren (halt, shutdown, rebboot)
Kshutdown meckert immer das KDM nicht läuft...

War schon praktisch, die Kist2 nachts um 2 Uhr automatisch runterzufahren...

Wie krieg ich das hin, oder hat jemand eine vergleichbare Alternative?

Es funktionieren übrigens beider Versionen (KDE 3 & KDE 4) nicht...
Welches andere Programm könnt ihr mir empfehlen...oder
es gibt doch bestimmt einen Befehl, das ich die Kiste in
z.B. 3 Stunden runterfahren kann??
Zuletzt geändert von PowerPaul am 27. Feb 2009, 10:23, insgesamt 2-mal geändert.
Desktop : openSuse 12.2 x32 / Abit KN9 (nForce 4) / 2 GB RAM / AMD x2 4600 Mhz / Aver DVB-T 771 / Radeon HD 5400 1 GM RAM
Notebook: openSuse 12.1 x64 / Aspire 7750G / 8 GB RAM / Core i7 Quad / 120 GB SSD / 750 GB SATA-HD / Radeon HD 6850M 1 GB VRAM

Werbung:
Stefan Staeglich
Advanced Hacker
Advanced Hacker
Beiträge: 960
Registriert: 11. Mai 2004, 10:37

Re: Kshutdown Rechner runterfahren funktioniert nicht mehr!

Beitrag von Stefan Staeglich » 21. Feb 2009, 23:18

Ja, gibt es für die Konsole. Müßtest du dann aber als root ausführen.

Code: Alles auswählen

shutdown -h Uhrzeit
Gruß Stefan

Benutzeravatar
longman
Advanced Hacker
Advanced Hacker
Beiträge: 866
Registriert: 22. Apr 2004, 19:01
Wohnort: zuhause

Re: Kshutdown Rechner runterfahren funktioniert nicht mehr!

Beitrag von longman » 21. Feb 2009, 23:35

Moin,
der Befehl shutdown in einer Konsole (su) kann das machen.
Du könntest die Zeilen unten in eine Datei kopieren und diese
mit chmod +x name.sh ausführbar machen.
Anschliessend kannst Du ein Programmsymbol von name.sh erzeugen und
den shutdown durch Doppelklick starten und jeweils die Uhrzeit angeben.

Schau am besten mal in einer Konsole die Parameter an.
Dort gibt es weitere Möglichkeiten.

Code: Alles auswählen

#!/bin/bash

echo "Bitte eine Uhrzeit für den shutdown angeben"
echo "z.B. 23:00"

read  SHDOWNTIME 

echo "Das system wird um "$SHDOWNTIME" runtergefahren."
/sbin/shutdown $SHDOWNTIME -h -t 30
Tschüss bis neulich,
Gruss Burkhard aka longman
- This System is MS free and works fine -


Linupedia - Wiki des Linux Club | NICHT LESEN! AUF GAR KEINEN FALL! NIEMALS NICHT!

PowerPaul
Hacker
Hacker
Beiträge: 611
Registriert: 18. Aug 2006, 11:44
Wohnort: SATA Platte hinten rechts

Re: Kshutdown Rechner runterfahren funktioniert nicht mehr!

Beitrag von PowerPaul » 22. Feb 2009, 10:21

Vielen Dank!
...Das mit "shutdown" habe ich schon herausgefunden!
Aber das ich gleich ein kleines Script bekomme --- Super!

...habe noch mit dem Knüppel shutdown für user erlaubt:

Code: Alles auswählen

chmod +s /sbin/shutdown
Desktop : openSuse 12.2 x32 / Abit KN9 (nForce 4) / 2 GB RAM / AMD x2 4600 Mhz / Aver DVB-T 771 / Radeon HD 5400 1 GM RAM
Notebook: openSuse 12.1 x64 / Aspire 7750G / 8 GB RAM / Core i7 Quad / 120 GB SSD / 750 GB SATA-HD / Radeon HD 6850M 1 GB VRAM

Antworten