Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

2 Soundkarten. Die eine (extern) wird nur manchmal...

Alles rund um Hardware, die unter Linux läuft oder zum Laufen gebracht werden soll

Moderator: Moderatoren

Antworten
SquirrelFrank
Newbie
Newbie
Beiträge: 44
Registriert: 25. Mai 2006, 12:13

2 Soundkarten. Die eine (extern) wird nur manchmal...

Beitrag von SquirrelFrank » 23. Mär 2007, 20:23

hi!

ich habe 2 Soundkarten (1x Onboard, und einmal das Sonica Theater -> 5.1 Extern USB)

mein Problem:

Ich habe alsa installiert. danach habe ich bei den Audioeinstellungen herumgespielt, und wenn ich (ich benütze Suse 10.2) bei Desktop - Konfiguration die Soundeinstellung auf automatisch, und bei amaroK auf OSS mit dem gerät dev/dsp stelle, dann kann ich über meine externe Soundkarte hören.

Wenn ich jetzt das ganze jedoch in amaroK auf, sagen wir ALSA stelle, und dann wieder zurück, dann geht das bis zum Neustart nicht mehr.

So, oder so höre ich extern auch nur 2.1, statt 5.1

Ich will, dass ich egal von welchem Programm, UND die Systemsounds über meine Externe Soundkarte hören, und nicht 2.1 sondern 5.1

weiß wer, was ich tun kann?

lg. Squirrel

Werbung:
Benutzeravatar
whois
Administrator
Administrator
Beiträge: 16606
Registriert: 11. Okt 2004, 08:50
Wohnort: Aachen
Kontaktdaten:

Beitrag von whois » 24. Mär 2007, 17:42

Hi

Disable im Bios deinen Chip und lösch beide Karten anschliessend in Yast.
Danach neu einlesen und du dürftest kein Problem mehr haben.

Linux übernimmt die Bios Einstellungen.

cu

SquirrelFrank
Newbie
Newbie
Beiträge: 44
Registriert: 25. Mai 2006, 12:13

Beitrag von SquirrelFrank » 24. Mär 2007, 19:21

magst du das genauer erklären, weil ich will mir mein BIOS nicht schrotten...

also cool währe ne genaue liste, oder so, was ich machen muss.

vielen dank!
Squirrel
Bild

Grothesk
Ultimate Guru
Ultimate Guru
Beiträge: 14662
Registriert: 26. Okt 2003, 11:52
Wohnort: Köln

Beitrag von Grothesk » 24. Mär 2007, 19:23

Jedes BIOS ist anders. Du wirst dich da vermutlich auf eigene Faust durchkämpfen müssen. Heißer Tip: Oftmals steht was von Audio und/oder AC97 daneben.
"Die Rechtschreibung ist Freeware, du darfst sie kostenlos nutzen. Allerdings ist sie nicht OpenSource, d.h. du sollst sie nicht verändern oder in veränderter Form veröffentlichen."

SquirrelFrank
Newbie
Newbie
Beiträge: 44
Registriert: 25. Mai 2006, 12:13

Beitrag von SquirrelFrank » 24. Mär 2007, 20:01

asso.. das "disablen" bekomme ich wahrscheinlich schon hin... mein Problem ist eher das neu einlesen, dass ja in Linux geschehen soll, oder?

lg. Squirrel
Bild

carsten
Guru
Guru
Beiträge: 1632
Registriert: 27. Jan 2004, 13:27
Wohnort: Mittelhessen

Beitrag von carsten » 24. Mär 2007, 20:13

nee, anders gemeint:
Disablen im BIOS und der interne Chip ist weg. Nun beide Karten in YAST löschen und dann neu erkennen lassen. Nun sollte nurnoch die Karte erkannt werden.

Grüße
Intel DB65ALB3, Chipsatz B65, Celeron G540, 4GB, 1x1TB System, 2x 2TB SATA RAID1, SuSE 13.2 (noch)

SquirrelFrank
Newbie
Newbie
Beiträge: 44
Registriert: 25. Mai 2006, 12:13

Beitrag von SquirrelFrank » 25. Mär 2007, 19:29

aber, wenn das geht, möchte ich das so wie bei Windows haben, dass die USB Soundkarte meine Standard Karte ist, und die interne dann angesprochen wird, wenn die USB Soundkarte nicht angeschlossen ist.

Wenn das gar nicht geht, wird mir aber nix anderes übrig bleiben, als den Chip zu löschen.

lg. Squirrel
Bild

Antworten