Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Intel 915GM Chipsatzfrage

Alles rund um Hardware, die unter Linux läuft oder zum Laufen gebracht werden soll

Moderator: Moderatoren

Antworten
Benutzeravatar
mikrosaft
Member
Member
Beiträge: 62
Registriert: 6. Jun 2004, 17:35

Intel 915GM Chipsatzfrage

Beitrag von mikrosaft » 9. Nov 2005, 18:06

Hallo Leute,

ich möchte mir in naher Zukunft ein neues Notebook zulegen. Ins Auge gefasst habe ich verschiedene Modelle von Toshiba oder IBM.
Allerdings bin ich ein wenig verwirrt wegen dem, was ich über den Chipsatz i915GM bisher in unterschiedlichen Foren gelesen habe.
Deshalb ein paar Fragen dazu:
Funktioniert 3D mit dem Grafikkern, oder nicht? Intel stellt doch Linux-Treiber zur Verfügung. Hat also jemand das ganze erfolgreich am laufen?
Mit welcher Grafikleistung kann ich hierbei rechnen? Reicht das, um mal RTCW bzw. ET/TCE zu zocken (ist schon was älter) oder zum Video schaun (wo steht die Grafikleistung im Vergleich mit einer Desktop GForce FX 5200)?
Hmm, wenn jemand auf diese Fragen Antworten hat - immer her damit... ;)

Gruss
ms

Werbung:
Benutzeravatar
onkelchentobi
Guru
Guru
Beiträge: 1899
Registriert: 11. Feb 2005, 15:54
Wohnort: BW - Stuttgart
Kontaktdaten:

Re: Intel 915GM Chipsatzfrage

Beitrag von onkelchentobi » 9. Nov 2005, 19:38

i915GM selbst sollte unter Linux funktionieren.

http://www.tuxhardware.de/category124/p ... _info.html

Wie es aber mit 3D ausschaut kann ich dir nicht sagen.
GNU/Debian Linux - Testing 32 Bit / Kernel 2.6.30.2 Vanilla / Ion3 - 20090110 / i2p

*** NO E-PATENTS ***

Benutzeravatar
mikrosaft
Member
Member
Beiträge: 62
Registriert: 6. Jun 2004, 17:35

Beitrag von mikrosaft » 9. Nov 2005, 20:07

hmmm... hab mir Deinen Link mal angesehen.
Wenn in der xorg.conf die Module dri und glx geladen werden so deutet das doch auf 3D-Unterstützung hin, oder?
Am besten wäre vllt. wirklich noch, wenn mir jemand mit diesem Chip eine Rückmeldung geben könnte.

Gruss
ms

Benutzeravatar
mikrosaft
Member
Member
Beiträge: 62
Registriert: 6. Jun 2004, 17:35

[gelöst]

Beitrag von mikrosaft » 13. Nov 2005, 17:17

Nun, ich kann jetzt bestätigen: der Chipsatz unerstützt auc bei meiner SUSE 10.0 3D... ;)

Matt.Shure
Newbie
Newbie
Beiträge: 29
Registriert: 21. Aug 2005, 20:41

Beitrag von Matt.Shure » 17. Nov 2005, 10:27

Hi,

unter der aktuellen Kubuntu Version habe ich den Chip nicht dazu überreden können die 3D Beschleunigung zu nutzen, klappt das bei Suse Out-of-the-box?

Habs sowohl mit dem 2.6.12er Kernel der bei Kubuntu 5.10 dabei ist als auch mit einem 2.6.14er aus den Debian Repositories probiert. Dri wird angeblich geladen, glxinfo sagt aber " DRI : no ".

Welchen Treiber verwendest du? i810 oder i915?
Wenn ich den i915 auswähle kommt der X-Server nicht mehr hoch, obwohl die Module im gleichen Verzeichnis liegen wie die des i810, mit dem es geht :?:

Wäre für nen Tpp dankbar!

Gruß,
Matt Shure

Benutzeravatar
mikrosaft
Member
Member
Beiträge: 62
Registriert: 6. Jun 2004, 17:35

Beitrag von mikrosaft » 17. Nov 2005, 18:41

Hallöle,

@out-of-the-Box: Ja, muss man nur per YAST aktivieren, die 3D-Beschleunigung.
Xorg nutzt das Modul i810, war bei der SUSE dabei.
Es handelt sich hier übrigens um ein Toshiba Satellite L20-101, einen ausfühlichen Bericht kann man in ein paar Tagen bei http://www.tuxmobil.de/toshiba.html nachlesen (derzeit ist nur eine vorläufige Bestandsaufnahme online).

Ich habe hier mal ein par System-Infos zusammengesammelt:

Code: Alles auswählen

mario@chubaka:~> glxgears
4870 frames in 5.0 seconds = 974.000 FPS
5581 frames in 5.0 seconds = 1116.200 FPS
5477 frames in 5.0 seconds = 1095.400 FPS
5579 frames in 5.0 seconds = 1115.800 FPS
5558 frames in 5.0 seconds = 1111.600 FPS
mario@chubaka:~> 3Ddiag
3Ddiag version 0.728
Verifying 3D configuration:
Using 3dinfo
************************************************************

Verifying 3D configuration for 3D board "Intel Corporation 915 GM (8086@2592)":


Tests for X.Org configuration:
  Config File /etc/X11/xorg.conf ... done.
  Driver ... done.
  Extensions ... done.
  Options ... done.


Checking GL/GLU/glut runtime configuration:
  GL/GLU  ... done (package xorg-x11-Mesa)
  glut ... done (package freeglut)
mario@chubaka:~> glxinfo
name of display: :0.0
display: :0  screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
    GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
    GLX_EXT_import_context, GLX_OML_swap_method, GLX_SGI_make_current_read,
    GLX_SGIS_multisample, GLX_SGIX_fbconfig
client glx vendor string: SGI
client glx version string: 1.4
client glx extensions:
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_allocate_memory,
    GLX_MESA_swap_control, GLX_MESA_swap_frame_usage, GLX_OML_swap_method,
    GLX_OML_sync_control, GLX_SGI_make_current_read, GLX_SGI_swap_control,
    GLX_SGI_video_sync, GLX_SGIS_multisample, GLX_SGIX_fbconfig,
    GLX_SGIX_pbuffer, GLX_SGIX_visual_select_group
GLX extensions:
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_allocate_memory,
    GLX_OML_swap_method, GLX_SGI_make_current_read, GLX_SGIS_multisample,
    GLX_SGIX_fbconfig, GLX_SGIX_visual_select_group
OpenGL vendor string: Tungsten Graphics, Inc
OpenGL renderer string: Mesa DRI Intel(R) 915GM 20050225 x86/MMX/SSE2
OpenGL version string: 1.3 Mesa 6.2.1
OpenGL extensions:
    GL_ARB_depth_texture, GL_ARB_fragment_program, GL_ARB_imaging,
    GL_ARB_multisample, GL_ARB_multitexture, GL_ARB_point_parameters,
    GL_ARB_shadow, GL_ARB_texture_border_clamp, GL_ARB_texture_compression,
    GL_ARB_texture_cube_map, GL_ARB_texture_env_add,
    GL_ARB_texture_env_combine, GL_ARB_texture_env_dot3,
    GL_ARB_texture_mirrored_repeat, GL_ARB_texture_rectangle,
    GL_ARB_transpose_matrix, GL_ARB_vertex_buffer_object,
    GL_ARB_vertex_program, GL_ARB_window_pos, GL_EXT_abgr, GL_EXT_bgra,
    GL_EXT_blend_color, GL_EXT_blend_equation_separate,
    GL_EXT_blend_func_separate, GL_EXT_blend_minmax, GL_EXT_blend_subtract,
    GL_EXT_clip_volume_hint, GL_EXT_cull_vertex, GL_EXT_compiled_vertex_array,
    GL_EXT_convolution, GL_EXT_copy_texture, GL_EXT_draw_range_elements,
    GL_EXT_fog_coord, GL_EXT_histogram, GL_EXT_multi_draw_arrays,
    GL_EXT_packed_pixels, GL_EXT_point_parameters, GL_EXT_polygon_offset,
    GL_EXT_rescale_normal, GL_EXT_secondary_color,
    GL_EXT_separate_specular_color, GL_EXT_shadow_funcs, GL_EXT_stencil_wrap,
    GL_EXT_subtexture, GL_EXT_texture, GL_EXT_texture3D,
    GL_EXT_texture_edge_clamp, GL_EXT_texture_env_add,
    GL_EXT_texture_env_combine, GL_EXT_texture_env_dot3,
    GL_EXT_texture_filter_anisotropic, GL_EXT_texture_lod_bias,
    GL_EXT_texture_object, GL_EXT_texture_rectangle, GL_EXT_vertex_array,
    GL_3DFX_texture_compression_FXT1, GL_APPLE_client_storage,
    GL_APPLE_packed_pixels, GL_ATI_blend_equation_separate,
    GL_IBM_rasterpos_clip, GL_IBM_texture_mirrored_repeat,
    GL_INGR_blend_func_separate, GL_MESA_pack_invert, GL_MESA_ycbcr_texture,
    GL_MESA_window_pos, GL_NV_blend_square, GL_NV_light_max_exponent,
    GL_NV_texture_rectangle, GL_NV_texgen_reflection, GL_NV_vertex_program,
    GL_NV_vertex_program1_1, GL_SGI_color_matrix, GL_SGI_color_table,
    GL_SGIS_generate_mipmap, GL_SGIS_texture_border_clamp,
    GL_SGIS_texture_edge_clamp, GL_SGIS_texture_lod, GL_SGIX_depth_texture,
    GL_SUN_multi_draw_arrays
glu version: 1.3
glu extensions:
    GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

   visual  x  bf lv rg d st colorbuffer ax dp st accumbuffer  ms  cav
 id dep cl sp sz l  ci b ro  r  g  b  a bf th cl  r  g  b  a ns b eat
----------------------------------------------------------------------
0x23 24 tc  0 32  0 r  y  .  8  8  8  8  0  0  0  0  0  0  0  0 0 None
0x24 24 tc  0 32  0 r  .  .  8  8  8  8  0  0  0  0  0  0  0  0 0 None
0x25 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  8  0  0  0  0  0 0 None
0x26 24 tc  0 32  0 r  .  .  8  8  8  8  0 24  8  0  0  0  0  0 0 None
0x27 24 tc  0 32  0 r  y  .  8  8  8  8  0  0  0 16 16 16 16  0 0 Slow
0x28 24 tc  0 32  0 r  .  .  8  8  8  8  0  0  0 16 16 16 16  0 0 Slow
0x29 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  8 16 16 16 16  0 0 Slow
0x2a 24 tc  0 32  0 r  .  .  8  8  8  8  0 24  8 16 16 16 16  0 0 Slow
0x2b 24 dc  0 32  0 r  y  .  8  8  8  8  0  0  0  0  0  0  0  0 0 None
0x2c 24 dc  0 32  0 r  .  .  8  8  8  8  0  0  0  0  0  0  0  0 0 None
0x2d 24 dc  0 32  0 r  y  .  8  8  8  8  0 24  8  0  0  0  0  0 0 None
0x2e 24 dc  0 32  0 r  .  .  8  8  8  8  0 24  8  0  0  0  0  0 0 None
0x2f 24 dc  0 32  0 r  y  .  8  8  8  8  0  0  0 16 16 16 16  0 0 Slow
0x30 24 dc  0 32  0 r  .  .  8  8  8  8  0  0  0 16 16 16 16  0 0 Slow
0x31 24 dc  0 32  0 r  y  .  8  8  8  8  0 24  8 16 16 16 16  0 0 Slow
0x32 24 dc  0 32  0 r  .  .  8  8  8  8  0 24  8 16 16 16 16  0 0 Slow
mario@chubaka:~> uname -r
2.6.13-15-default
Meine Xorg.conf:
# /.../
# SaX generated X11 config file
# Created on: 2005-11-12T17:30:45+0100.
#
# Version: 7.1
# Contact: Marcus Schaefer <sax@suse.de>, 2002
#
# Automatically generated by [ISaX] (7.1)
# PLEASE DO NOT EDIT THIS FILE!
#

Section "Files"
FontPath "/usr/X11R6/lib/X11/fonts/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/local"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/URW"
FontPath "/usr/X11R6/lib/X11/fonts/Speedo"
FontPath "/usr/X11R6/lib/X11/fonts/PEX"
FontPath "/usr/X11R6/lib/X11/fonts/cyrillic"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/latin7/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/baekmuk:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/japanese:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/kwintv"
FontPath "/usr/X11R6/lib/X11/fonts/truetype"
FontPath "/usr/X11R6/lib/X11/fonts/uni:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/CID"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/misc/sgi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/xtest"
FontPath "/opt/kde3/share/fonts"
InputDevices "/dev/ttyS0"
InputDevices "/dev/ttyS1"
InputDevices "/dev/ttyS2"
InputDevices "/dev/ttyS3"
InputDevices "/dev/ttyS4"
InputDevices "/dev/ttyS5"
InputDevices "/dev/ttyS6"
InputDevices "/dev/ttyS7"
InputDevices "/dev/ttyS8"
InputDevices "/dev/psaux"
InputDevices "/dev/logibm"
InputDevices "/dev/sunmouse"
InputDevices "/dev/atibm"
InputDevices "/dev/amigamouse"
InputDevices "/dev/atarimouse"
InputDevices "/dev/inportbm"
InputDevices "/dev/gpmdata"
InputDevices "/dev/mouse"
InputDevices "/dev/usbmouse"
InputDevices "/dev/adbmouse"
InputDevices "/dev/input/mice"
InputDevices "/dev/input/event0"
InputDevices "/dev/pointer0"
InputDevices "/dev/pointer1"
InputDevices "/dev/pointer2"
InputDevices "/dev/pointer3"
EndSection

Section "ServerFlags"
Option "AllowMouseOpenFail"
EndSection

Section "Module"
Load "freetype"
Load "type1"
Load "dbe"
Load "glx"
Load "extmod"
Load "v4l"
Load "dri"
EndSection

Section "InputDevice"
Driver "kbd"
Identifier "Keyboard[0]"
Option "Protocol" "Standard"
Option "XkbLayout" "de"
Option "XkbModel" "pc105"
Option "XkbRules" "xfree86"
Option "XkbVariant" "nodeadkeys"
EndSection


Section "InputDevice"
Driver "mouse"
Identifier "Mouse[1]"
Option "Buttons" "5"
Option "Device" "/dev/input/mice"
Option "Name" "USB Mouse"
Option "Protocol" "explorerps/2"
Option "Vendor" "Sysp"

Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
Driver "synaptics"
Identifier "Mouse[3]"
Option "Device" "/dev/input/mice"
Option "Emulate3Buttons" "on"
Option "InputFashion" "Mouse"
Option "Name" "Synaptics;Touchpad"
Option "Protocol" "explorerps/2"
Option "SHMConfig" "on"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"
EndSection


Section "Monitor"
Option "CalcAlgorithm" "XServerPool"
DisplaySize 300 220
HorizSync 30-40
Identifier "Monitor[0]"
ModelName "LGPHILIPSLCD MONITOR"
Option "DPMS"
VendorName "LPL"
VertRefresh 43-75
UseModes "Modes[0]"
EndSection


Section "Modes"
Identifier "Modes[0]"
EndSection


Section "Screen"
DefaultDepth 24
SubSection "Display"
Depth 15
Modes "1024x768" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 32
Modes "1024x768" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768" "800x600" "768x576" "640x480"
EndSubSection
Device "Device[0]"
Identifier "Screen[0]"
Monitor "Monitor[0]"
EndSection


Section "Device"
BoardName "915 GM"
BusID "0:2:0"
Driver "i810"
Identifier "Device[0]"
Option "DRI"
Screen 0
VendorName "Intel"
EndSection


Section "ServerLayout"
Identifier "Layout[all]"
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
InputDevice "Mouse[3]" "SendCoreEvents"
Option "Clone" "off"
Option "Xinerama" "off"
Screen "Screen[0]"
EndSection

Section "DRI"
Group "video"
Mode 0660
EndSection

Section "Extensions"
EndSection
Falls Du noch Fragen hast stehe ich gerne zur Verfügung.

Grüsse
ms

Matt.Shure
Newbie
Newbie
Beiträge: 29
Registriert: 21. Aug 2005, 20:41

Beitrag von Matt.Shure » 18. Nov 2005, 00:57

Hab meine Module Section und die DRI Section mal an deine angepasst, und nach wie vor unter Device den i810 gewählt.

Aber glxinfo sagt immer noch

Code: Alles auswählen

mattshure@L613:~$ glxinfo
name of display: :0.0
display: :0  screen: 0
direct rendering: No

Benutzeravatar
mikrosaft
Member
Member
Beiträge: 62
Registriert: 6. Jun 2004, 17:35

Beitrag von mikrosaft » 18. Nov 2005, 08:56

Ich habe gerade eine Merkwürdigkeit festgestellt: Obwohl in meiner xorg.conf einwandfrei das Modul i810 eingetragen ist, listet mir lsmod überaschenderweise das Modul i915... :?: :shock:
Da blick ich jetzt nicht wirklich durch.

Ich boot bei nächster Gelegenheit mal Kanotix mit dem Schleppi und schau mir mal an, ob und wie ich das Problem nachstellen kann.
Um was für ein Notebook handelt es sich denn bei Dir?

Gruss
ms

[edit]
Wer lesen kann ist klar im Vorteil: Hab gerade Kanotix gebootet und mich gewundert, dass da kein xorg läuft... Jetzt hab ich dann doch festgestellt, dass Du von Kubuntu und nicht von Kanotix geredet hast...
Zuletzt geändert von mikrosaft am 18. Nov 2005, 18:33, insgesamt 1-mal geändert.

Matt.Shure
Newbie
Newbie
Beiträge: 29
Registriert: 21. Aug 2005, 20:41

Beitrag von Matt.Shure » 18. Nov 2005, 10:59

Hi,

Ich habe ein Samsung X 20 1600V mit eben diesem nervigem i915 Chipsatz.

Danke für deine Mühe,
Matt

thomaskrause
Newbie
Newbie
Beiträge: 2
Registriert: 9. Aug 2004, 13:58
Wohnort: Kiefersfelden
Kontaktdaten:

Beitrag von thomaskrause » 26. Dez 2005, 17:14

hi

hab ein IBM R52 mit dem i915 chipsatz und bekomm den unter Aurox einfach nicht zum laufen. Habs schon mit dem HOWTO von thinkwiki.org probiert aber es läuft einfach ned. Immer wenn der X-Server mit der neuen Config startet bleibt mein Bildschirm schwarz, egal ob ich i915 oder i810 in der Xorg.conf verwende

Ich hoffe ihr könnt mir irgenwie helfen


Thomas

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast