Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

SUSE 9.2 Drucker druckt nicht mehr

Alles rund um Hardware, die unter Linux läuft oder zum Laufen gebracht werden soll

Moderator: Moderatoren

Benutzeravatar
crazyrolf
Advanced Hacker
Advanced Hacker
Beiträge: 964
Registriert: 7. Apr 2004, 09:05
Wohnort: Odenthal

SUSE 9.2 Drucker druckt nicht mehr

Beitrag von crazyrolf »

Nach dem update auf 9.2 druckt mein drucker nicht mehr.

erkannt wird er ohne probleme aber drucken will er nicht, keinen mux.

drucker canon s330 lief unter 9.1 mit turboprint ohne probleme.

jetzt unter 9.2 weder mit turboprint noch mit einem linux-suse treiber. steht da als aktiv OK wartet auf aufträge.

aber wenn ich was abschicke tut sich nix, auftrag steht da im druckermanager aber es passiert nix. weder direkt am usb noch über einen kleinen printserver.

was ist das?

gruß crazy
Gruß crazyrolf
-EX-Moderator-Mail-
Benutzeravatar
misiu
Moderator
Moderator
Beiträge: 4016
Registriert: 8. Mär 2004, 11:27
Wohnort: bei Schweinfurt

Beitrag von misiu »

Wird wohl was ähnliches wie bei dem Update der SuSE 9.1
mit YOU. Da wird CUPS ausser gefecht gesetzt. Versuche auch mit CUPS deinstallieren/installieren oder warte auf Update
vom Turboprint. Ich tippe auf CUPS.

MfG
misiu
Benutzeravatar
crazyrolf
Advanced Hacker
Advanced Hacker
Beiträge: 964
Registriert: 7. Apr 2004, 09:05
Wohnort: Odenthal

Beitrag von crazyrolf »

sieht fast so aus.

ich habe es auch ohne turboprint versucht geht auch nicht.

hast du cubs schon mal neu installiert?

erfolg?

crazy
Gruß crazyrolf
-EX-Moderator-Mail-
Benutzeravatar
misiu
Moderator
Moderator
Beiträge: 4016
Registriert: 8. Mär 2004, 11:27
Wohnort: bei Schweinfurt

Beitrag von misiu »

Kann ich leider nicht sagen, hab keine SuSE9.2. Nur da ich das
Druckerforum betreue, ist mir gleich aufgefallen die
Ähnlichkeit des Fehlers mit den anderen Beiträgen, die mit
Problemen nach Update klagen. Es war immer CUPS und
ich hab keine Ahnung bis jetzt, wieso die Druckaufträge
nicht weitergereicht werden. Die einfachste Lösung:
CUPS neu drauf:
http://portal.suse.com/sdb/de/2004/07/p ... stall.html

müsste eigentlich genauso funktionieren.

MfG
misiu
Benutzeravatar
crazyrolf
Advanced Hacker
Advanced Hacker
Beiträge: 964
Registriert: 7. Apr 2004, 09:05
Wohnort: Odenthal

Beitrag von crazyrolf »

tia hab cups runter und wieder drauf!

leider nix.

das komische ist, ich habe den drucker an einem printserver, so ein kleiner usb, und der sagt doch glatt er wäre im druckbetrieb nachdem ich den auftrag gesendet habe aber es kommt nix.

unter Windows geht das teil.

hat ja auch unter 9.1 geklappt!

der drucker geht aber auch nicht direkt am usb-port.

muxst sich einfach nicht mehr.

hoffe da kommt ein update und das bald!

crazy
Gruß crazyrolf
-EX-Moderator-Mail-
Benutzeravatar
misiu
Moderator
Moderator
Beiträge: 4016
Registriert: 8. Mär 2004, 11:27
Wohnort: bei Schweinfurt

Beitrag von misiu »

und andere USB-Geräte laufen?

MfG
misiu
Benutzeravatar
crazyrolf
Advanced Hacker
Advanced Hacker
Beiträge: 964
Registriert: 7. Apr 2004, 09:05
Wohnort: Odenthal

Beitrag von crazyrolf »

ja zumindest die maus und meine usb-platte!

drucker wird ja auch erkannt wenn ich ihn direkt an den usb vom rechner klemme, druckt nur nicht.

crazy
Gruß crazyrolf
-EX-Moderator-Mail-
Benutzeravatar
misiu
Moderator
Moderator
Beiträge: 4016
Registriert: 8. Mär 2004, 11:27
Wohnort: bei Schweinfurt

Beitrag von misiu »

Ok usb ist es nicht, weiter:
was sagt :

Code: Alles auswählen

lpc status
was steht bei Druckjob in:
/var/log/cups/error_log

hast du schon von der Kommandozeile gedruckt?

Code: Alles auswählen

lpr -PDruckername Datei
sind alle Module geladen?

Code: Alles auswählen

lsmod | grep lp
lsmod | grep usb
Mal gucken, vielleicht finden wir was......

misiu
Benutzeravatar
crazyrolf
Advanced Hacker
Advanced Hacker
Beiträge: 964
Registriert: 7. Apr 2004, 09:05
Wohnort: Odenthal

Beitrag von crazyrolf »

rolf:/home/rolf # lpc status
canonS330:
printer is on device 'socket' speed -1
queuing is enabled
printing is enabled
no entries
daemon present


I [29/Oct/2004:20:00:30 +0200] Listening to 0:631
E [29/Oct/2004:20:00:30 +0200] Unknown Location directive # on line 811.
I [29/Oct/2004:20:00:30 +0200] Loaded configuration file "/etc/cups/cupsd.conf"
I [29/Oct/2004:20:00:30 +0200] Configured for up to 100 clients.
I [29/Oct/2004:20:00:30 +0200] Allowing up to 100 client connections per host.
I [29/Oct/2004:20:00:30 +0200] Full reload is required.
I [29/Oct/2004:20:00:35 +0200] LoadPPDs: Read "/etc/cups/ppds.dat", 3984 PPDs...
I [29/Oct/2004:20:00:39 +0200] LoadPPDs: No new or changed PPDs...
I [29/Oct/2004:20:00:39 +0200] Full reload complete.
I [29/Oct/2004:20:24:54 +0200] Scheduler shutting down normally.
I [29/Oct/2004:20:27:46 +0200] Listening to 0:631
I [29/Oct/2004:20:27:46 +0200] Loaded configuration file "/etc/cups/cupsd.conf"
I [29/Oct/2004:20:27:46 +0200] Configured for up to 100 clients.
I [29/Oct/2004:20:27:46 +0200] Allowing up to 100 client connections per host.
I [29/Oct/2004:20:27:46 +0200] Full reload is required.
I [29/Oct/2004:20:27:46 +0200] LoadPPDs: Read "/etc/cups/ppds.dat", 3470 PPDs...
I [29/Oct/2004:20:27:49 +0200] LoadPPDs: Wrote "/etc/cups/ppds.dat", 3984 PPDs...
E [29/Oct/2004:20:27:49 +0200] LoadAllJobs: Unable to queue job for destination "http://rolf:631/printers/canons330"!
I [29/Oct/2004:20:27:49 +0200] Full reload complete.
I [29/Oct/2004:20:28:40 +0200] Scheduler shutting down normally.
I [29/Oct/2004:20:28:40 +0200] Listening to 0:631
I [29/Oct/2004:20:28:40 +0200] Loaded configuration file "/etc/cups/cupsd.conf"
I [29/Oct/2004:20:28:40 +0200] Configured for up to 100 clients.
I [29/Oct/2004:20:28:40 +0200] Allowing up to 100 client connections per host.
I [29/Oct/2004:20:28:40 +0200] Full reload is required.
I [29/Oct/2004:20:28:40 +0200] LoadPPDs: Read "/etc/cups/ppds.dat", 3984 PPDs...
I [29/Oct/2004:20:28:40 +0200] LoadPPDs: No new or changed PPDs...
I [29/Oct/2004:20:28:40 +0200] Full reload complete.
I [29/Oct/2004:20:28:41 +0200] Setting y2test device-uri to "socket://192.168.2.5:9100" (was "file:/dev/null".)
I [29/Oct/2004:20:28:41 +0200] Setting y2test printer-is-accepting-jobs to 1 (was 0.)
I [29/Oct/2004:20:28:41 +0200] Setting y2test printer-state to 3 (was 5.)
I [29/Oct/2004:20:28:41 +0200] Saving printers.conf...
I [29/Oct/2004:20:28:41 +0200] New printer 'y2test' added by 'root'.
I [29/Oct/2004:20:28:41 +0200] Adding start banner page "none" to job 1.
I [29/Oct/2004:20:28:41 +0200] Adding end banner page "none" to job 1.
I [29/Oct/2004:20:28:41 +0200] Job 1 queued on 'y2test' by 'root'.
I [29/Oct/2004:20:28:41 +0200] Started filter /usr/lib/cups/filter/pstops (PID 7717) for job 1.
I [29/Oct/2004:20:28:41 +0200] Started filter /usr/lib/cups/filter/pstoturboprint (PID 7718) for job 1.
I [29/Oct/2004:20:28:41 +0200] Started backend /usr/lib/cups/backend/socket (PID 7719) for job 1.
E [29/Oct/2004:20:30:37 +0200] Unable to open /etc/cups/passwd.md5 - Datei oder Verzeichnis nicht gefunden
E [29/Oct/2004:20:30:37 +0200] cancel_job: "rolf" not authorized to delete job id 1 owned by "root"!
I [29/Oct/2004:20:30:45 +0200] Printer 'y2test' deleted by 'root'.
I [29/Oct/2004:20:30:45 +0200] Saving printers.conf...
I [29/Oct/2004:20:30:49 +0200] Scheduler shutting down normally.
I [29/Oct/2004:20:30:49 +0200] Listening to 0:631
E [29/Oct/2004:20:30:49 +0200] Unknown Location directive # on line 834.
I [29/Oct/2004:20:30:49 +0200] Loaded configuration file "/etc/cups/cupsd.conf"
I [29/Oct/2004:20:30:49 +0200] Configured for up to 100 clients.
I [29/Oct/2004:20:30:49 +0200] Allowing up to 100 client connections per host.
I [29/Oct/2004:20:30:49 +0200] Full reload is required.
I [29/Oct/2004:20:30:49 +0200] LoadPPDs: Read "/etc/cups/ppds.dat", 3984 PPDs...
I [29/Oct/2004:20:30:49 +0200] LoadPPDs: No new or changed PPDs...
I [29/Oct/2004:20:30:49 +0200] Full reload complete.
I [29/Oct/2004:20:30:51 +0200] Setting canonS330 device-uri to "socket://192.168.2.5:9100" (was "file:/dev/null".)
I [29/Oct/2004:20:30:51 +0200] Setting canonS330 printer-is-accepting-jobs to 1 (was 0.)
I [29/Oct/2004:20:30:51 +0200] Setting canonS330 printer-state to 3 (was 5.)
I [29/Oct/2004:20:30:51 +0200] Saving printers.conf...
I [29/Oct/2004:20:30:51 +0200] New printer 'canonS330' added by 'root'.
I [29/Oct/2004:20:30:51 +0200] Saving printers.conf...
I [29/Oct/2004:20:30:51 +0200] Saving classes.conf...
I [29/Oct/2004:20:30:51 +0200] Default destination set to 'canonS330' by 'root'.
I [29/Oct/2004:20:30:51 +0200] Scheduler shutting down normally.
I [29/Oct/2004:20:30:51 +0200] Listening to 0:631
E [29/Oct/2004:20:30:51 +0200] Unknown Location directive # on line 834.
I [29/Oct/2004:20:30:51 +0200] Loaded configuration file "/etc/cups/cupsd.conf"
I [29/Oct/2004:20:30:51 +0200] Configured for up to 100 clients.
I [29/Oct/2004:20:30:51 +0200] Allowing up to 100 client connections per host.
I [29/Oct/2004:20:30:51 +0200] Full reload is required.
I [29/Oct/2004:20:30:52 +0200] LoadPPDs: Read "/etc/cups/ppds.dat", 3984 PPDs...
I [29/Oct/2004:20:30:52 +0200] LoadPPDs: No new or changed PPDs...
I [29/Oct/2004:20:30:52 +0200] Full reload complete.


Druck aus komandozeile = NIX (das selbe) printserver sagt printing aber kommt nix!


rolf:/home/rolf/Documents # lsmod | grep lp
rolf:/home/rolf/Documents # lsmod | grep usb
usbserial 26856 0
usbhid 40132 0
usbcore 106724 7 usbserial,usbhid,microtek,ehci_hcd,ohci_hcd
rolf:/home/rolf/Documents #

ENDE
Gruß crazyrolf
-EX-Moderator-Mail-
Benutzeravatar
crazyrolf
Advanced Hacker
Advanced Hacker
Beiträge: 964
Registriert: 7. Apr 2004, 09:05
Wohnort: Odenthal

Beitrag von crazyrolf »

was ist das ?

E [29/Oct/2004:22:37:35 +0200] Unable to open /etc/cups/passwd.md5 - Datei oder Verzeichnis nicht gefunden

datei ist nicht da?!

crazy


PS:
ich denke weil ich versucht habe als user den auftrag von root zu löschen gelle.
Zuletzt geändert von crazyrolf am 29. Okt 2004, 23:21, insgesamt 1-mal geändert.
Gruß crazyrolf
-EX-Moderator-Mail-
Benutzeravatar
crazyrolf
Advanced Hacker
Advanced Hacker
Beiträge: 964
Registriert: 7. Apr 2004, 09:05
Wohnort: Odenthal

Beitrag von crazyrolf »

auszug aus turboprint_cups.log

----------- Start of print job -----------
ESP Ghostscript 7.07 (2003-07-12)
Copyright 2003 artofcode LLC and Easy Software Products, all rights reserved.
This software comes with NO WARRANTY: see the file COPYING for details.
Unrecoverable error: syntaxerror in token
Operand stack:
--nostringval-- --nostringval-- --nostringval-- --nostringval-- Bazooka --nostringval--
------------ End of print job ------------

was sagt das?
Unrecoverable error: syntaxerror in token
Gruß crazyrolf
-EX-Moderator-Mail-
Benutzeravatar
misiu
Moderator
Moderator
Beiträge: 4016
Registriert: 8. Mär 2004, 11:27
Wohnort: bei Schweinfurt

Beitrag von misiu »

turboprintfehler-> keine Ahnung, kann sein, das die
es mit der neuen Turboprintversion beseitigen. War
bei 9.1 auch so. Hast du nach dem Update überhaupt
die xtpconfig/xtpsetup neu eingerichtet?

Unable to open /etc/cups/passwd.md5 - Datei oder Verzeichnis nicht gefunden : dürfte normal sein
weil bei SuSE kein CUPS-Passwort gesetzt ist.

Ist das Modul "printer" geladen?

müsste nämlich bei usbcore dabei sein.
Wenn nicht versuche

Code: Alles auswählen

modprobe printer
und dann drucken.
Benutzeravatar
crazyrolf
Advanced Hacker
Advanced Hacker
Beiträge: 964
Registriert: 7. Apr 2004, 09:05
Wohnort: Odenthal

Beitrag von crazyrolf »

bei 9.1 auch so. Hast du nach dem Update überhaupt
die xtpconfig/xtpsetup neu eingerichtet?

Was ist das???

Wie wo und warum?

Crazy
Gruß crazyrolf
-EX-Moderator-Mail-
Benutzeravatar
misiu
Moderator
Moderator
Beiträge: 4016
Registriert: 8. Mär 2004, 11:27
Wohnort: bei Schweinfurt

Beitrag von misiu »

Erst schau, ob das Modul "printer" geladen ist! (lsmod)

Turboprint:
http://www.turboprint.de/german/index.html

Da steht alles.

du kannst von der Textkonsole
xtpconfig oder xtpsetup direkt aufrufen.
Es sind Programme, um den Turboprinttreiber
einzurichten.
Benutzeravatar
crazyrolf
Advanced Hacker
Advanced Hacker
Beiträge: 964
Registriert: 7. Apr 2004, 09:05
Wohnort: Odenthal

Beitrag von crazyrolf »

es liegt nicht an turboprint geht auch nicht ohne, also mit suse treiber.

rolf:/home/rolf # lsmod
Module Size Used by
thinkpad 6020 0
udf 84612 0
snd_seq 53008 2
nvram 8328 0
nfsd 106824 5
exportfs 5632 1 nfsd
nvidia 4815052 22
usbserial 26856 0
parport_pc 37824 1
lp 10536 0
parport 37960 2 parport_pc,lp
speedstep_lib 4228 0
freq_table 4356 0
thermal 17928 0
processor 25640 1 thermal
fan 5380 0
button 8464 0
edd 10012 0
battery 11396 0
ac 6404 0
snd_pcm_oss 57896 0
snd_mixer_oss 19200 1 snd_pcm_oss
snd_cmipci 29860 8
snd_pcm 96776 2 snd_pcm_oss,snd_cmipci
snd_page_alloc 10248 1 snd_pcm
snd_opl3_lib 10624 1 snd_cmipci
snd_timer 24708 3 snd_seq,snd_pcm,snd_opl3_lib
snd_hwdep 9220 1 snd_opl3_lib
gameport 4608 1 snd_cmipci
snd_mpu401_uart 7552 1 snd_cmipci
snd_rawmidi 24356 1 snd_mpu401_uart
snd_seq_device 8716 3 snd_seq,snd_opl3_lib,snd_rawmidi
snd 60164 29 snd_seq,snd_pcm_oss,snd_mixer_oss,snd_cmipci,snd_pcm,snd_opl3_lib,snd_timer,snd_hwdep,snd_mpu401_uart,snd_rawmidi,snd_seq_device
soundcore 9056 1 snd
ipv6 237312 21
microtek 7552 0
usbhid 40132 0
usb_storage 62400 0
evdev 8960 0
joydev 9664 0
sg 35872 0
st 37404 0
sd_mod 16912 0
sr_mod 16292 0
scsi_mod 111308 6 microtek,usb_storage,sg,st,sd_mod,sr_mod
ide_cd 38176 0
cdrom 36508 2 sr_mod,ide_cd
8139too 24064 0
mii 4992 1 8139too
ehci_hcd 29188 0
ohci_hcd 20228 0
nvidia_agp 7580 1
agpgart 32168 2 nvidia_agp
subfs 7552 5
nls_cp437 5888 1
vfat 13056 1
fat 43168 1 vfat
nls_utf8 2176 2
ntfs 91888 1
dm_mod 54524 0
usbcore 106724 8 usbserial,microtek,usbhid,usb_storage,ehci_hcd,ohci_hcd
forcedeth 16384 0
reiserfs 242000 1

crazy
Gruß crazyrolf
-EX-Moderator-Mail-
Benutzeravatar
misiu
Moderator
Moderator
Beiträge: 4016
Registriert: 8. Mär 2004, 11:27
Wohnort: bei Schweinfurt

Beitrag von misiu »

Also, da fehlt das Modul "printer"!
füre aus:

Code: Alles auswählen

modprobe printer
und schau , was passiert, sollten keine
Fehlermeldungen kommen, versuche zu drucken,

hast du einen Scanner (Microtek) am USB/Parport?

MfG
misiu
Benutzeravatar
crazyrolf
Advanced Hacker
Advanced Hacker
Beiträge: 964
Registriert: 7. Apr 2004, 09:05
Wohnort: Odenthal

Beitrag von crazyrolf »

ups

rolf:/home/rolf # modprobe printer
FATAL: Module printer not found.
rolf:/home/rolf #


was jetzt?

ja hab einen scanner microtec der läuft auch.

crazy
Gruß crazyrolf
-EX-Moderator-Mail-
Benutzeravatar
misiu
Moderator
Moderator
Beiträge: 4016
Registriert: 8. Mär 2004, 11:27
Wohnort: bei Schweinfurt

Beitrag von misiu »

Da ist was faul, möglicherweise bei Kernelwechsel sind
die Module nicht richtig eingetragen. Auf jeden Fall
dass durfte die Ursache sein....
Bitte um Verzeihung, aber ich bin heute schon seit 4:30
auf den Beinen, mein Bett wartet ;-)
Morgen ist auch noch ein Tag.

MfG
misiu
Benutzeravatar
crazyrolf
Advanced Hacker
Advanced Hacker
Beiträge: 964
Registriert: 7. Apr 2004, 09:05
Wohnort: Odenthal

Beitrag von crazyrolf »

na kasse!

das dumme ist aber, das ist nicht nur bei dem rechner so den ich upgedatet habe, auch bei dem wo ich die platte geputzt habe und direkt 9.2 neu aufgespielt habe.

gute Nacht

crazy
Gruß crazyrolf
-EX-Moderator-Mail-
Benutzeravatar
misiu
Moderator
Moderator
Beiträge: 4016
Registriert: 8. Mär 2004, 11:27
Wohnort: bei Schweinfurt

Beitrag von misiu »

Guten Morgen Deutschland! :D
Endlich ausgeschlafen.

So , also gehen wir der Sache auf den Grund:
Textkonsole + su + rootpasswort, dann

Code: Alles auswählen

modinfo printer
Müsste so was ausgegeben werden:
misiu1:/home/misiu # modinfo printer
filename: /lib/modules/2.4.21-243-athlon/kernel/drivers/usb/printer.o
description: "USB Printer Device Class driver"
author: "Michael Gee, Pavel Machek, Vojtech Pavlik, Randy Dunlap, Pete Zaitcev, David Paschal"
license: "GPL"
parm: proto_bias int, description "Favourite protocol number"

Bei dir wird natürlich andere Kernel angezeigt.

Wenn da nichts kommt, dann schau im:

/lib/modules/2.X.X/kernel/drivers/usb/
ob eine Datei , wie:

printer.o

vorhanden ist. Es ist nämlich, das fehlende Kernel-Druckmodul.

Es kann sein, dass in dem Verzeichnis:
/lib/modules/ mehrere Kernel vorhanden sind ( nach Update mit Sicherheit).

Also schau und schreibe .

Mit ausgeschlaffenem Gruss ;-)
misiu
Antworten