Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[Gelöst] hplip spinnt

Alles rund um Hardware, die unter Linux läuft oder zum Laufen gebracht werden soll

Moderator: Moderatoren

klaus-dieter
Hacker
Hacker
Beiträge: 444
Registriert: 10. Jun 2004, 04:50

[Gelöst] hplip spinnt

Beitrag von klaus-dieter »

Hi,

habe einen HP M1212nf MFP Drucker der seit Jahren unter openSuse läuft (mit hplip). Habe jetzt auf leap 15.2 upgedatet und wollte hplip neu installlieren und den Drucker wieder neu konfigurieren.

Als root habe ich hp-setup ausgeführt

Code: Alles auswählen

@linux-zd3t:/etc/sane.d> hp-setup

HP Linux Imaging and Printing System (ver. 3.19.12)
Printer/Fax Setup Utility ver. 9.0

Copyright (c) 2001-18 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Searching... (bus=net, timeout=5, ttl=4, search=(None) desc=0, method=slp)
 
HP Linux Imaging and Printing System (ver. 3.19.12)
Plugin Download and Install Utility ver. 2.1

Copyright (c) 2001-18 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.


HP Linux Imaging and Printing System (ver. 3.19.12)
Plugin Download and Install Utility ver. 2.1

Copyright (c) 2001-18 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Checking for network connection...
Downloading plug-in from: 
Receiving digital keys: /usr/bin/gpg --homedir /home/karla/.hplip/.gnupg --no-permission-warning --keyserver pool.sks-keyservers.net --recv-keys 0x4ABA2F66DBD5A95894910E0673D770CDA59047B9
Creating directory plugin_tmp
Verifying archive integrity... All good.
Uncompressing HPLIP 3.19.12 Plugin Self Extracting Archive..............................................................

HP Linux Imaging and Printing System (ver. 3.19.12)
Plugin Installer ver. 3.0

Copyright (c) 2001-18 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Plug-in version: 3.19.12
Installed HPLIP version: 3.19.12
Number of files to install: 64

note: Using PyQt5
 
Done.
 Plug-in installation successful 

Done.
error:  The device you are trying to setup requires a binary plug-in. Some functionalities may not work as expected without plug-ins.  Please run 'hp-plugin' as normal user to install plug-ins.   Visit  http://hplipopensource.com  for more infomation. 

Man bemerke "Plug-in Installation successful" und danach error dass das plug-in nicht installiert ist. Widerspricht sich ein wenig...

hp-plugin habe ich auch als normaler User laufen gelassen, hat aber nichts geholfen. hplip.state zeigt dass das plug-in installiert ist:

Code: Alles auswählen

linux-zd3t:/var/lib/hp # more hplip.state 
[plugin]
installed = 1
eula = 1
version = 3.19.12

Hat jemand eine Idee wie ich da weiter kommen kann?

Danke!
Zuletzt geändert von klaus-dieter am 16. Okt 2020, 13:13, insgesamt 2-mal geändert.
Benutzeravatar
misiu
Moderator
Moderator
Beiträge: 4012
Registriert: 8. Mär 2004, 11:27
Wohnort: bei Schweinfurt

Re: hplip spinnt

Beitrag von misiu »

Normalerweise ist es bei Opensuse besser die Pakete aus den Repos zu benutzen. Danach besteht die
Möglichkeit den Drucker über Yast einzurichten, was in dem Sinne besser ist, dass Yast bei der Einrichtung
auch die Firewall-Regeln richtigstellt.

MfG
misiu
klaus-dieter
Hacker
Hacker
Beiträge: 444
Registriert: 10. Jun 2004, 04:50

Re: hplip spinnt

Beitrag von klaus-dieter »

Habe inzwischen herausgefunden dass 15.2 bisher nicht supported ist. Heute kam eine neue Version die aber auch nicht richtig tut. Die Version im repro von Suse ist schon etwas alt.
Benutzeravatar
misiu
Moderator
Moderator
Beiträge: 4012
Registriert: 8. Mär 2004, 11:27
Wohnort: bei Schweinfurt

Re: hplip spinnt

Beitrag von misiu »

Das die alt ist , heißt nicht, dass der Drucker nicht geht.

MfG
misiu
Benutzeravatar
misiu
Moderator
Moderator
Beiträge: 4012
Registriert: 8. Mär 2004, 11:27
Wohnort: bei Schweinfurt

Re: hplip spinnt

Beitrag von misiu »

Oder die "Printing" -Repo anbinden:
https://download.opensuse.org/repositor ... Leap_15.2/

(aktuelle hplip 3.20.6)
klaus-dieter
Hacker
Hacker
Beiträge: 444
Registriert: 10. Jun 2004, 04:50

Re: hplip spinnt

Beitrag von klaus-dieter »

Hi,

alles schon probiert. Er erkennt einen Drucker aber er druckt nichts. Im Repro liegt 3.20.6, aktuell ist aber 3.20.9 und lt. HP ist erst ab dieser Version openSuse 15.2 unterstützt. Klar kann auch vorher funktionieren, funktioniert aber nicht. In den letzten Jahren hat hplip am zuverlässigsten funktioniert.

Momentan bekomme ich folgenden Fehler bei der manuellen Installation gemäß HP Anleitung

Code: Alles auswählen

Run "hp-plugin" to installa plugin libraries if you are not automatically prompted

Traceback (most recent call last):
  File "/usr/share/hplip/ui4/setupdialog.py", line 1307, in NextButton_clicked
    self.showAddPrinterPage()
  File "/usr/share/hplip/ui4/setupdialog.py", line 731, in showAddPrinterPage
    self.readwriteFaxInformation()
  File "/usr/share/hplip/ui4/setupdialog.py", line 1102, in readwriteFaxInformation
    d = fax.getFaxDevice(self.fax_uri, disable_dbus=True)
  File "/usr/share/hplip/fax/fax.py", line 534, in getFaxDevice
    return MarvellFaxDevice(device_uri, printer_name, callback, fax_type, disable_dbus)
  File "/usr/share/hplip/fax/marvellfax.py", line 109, in __init__
    self.service.SendEvent(device_uri, printer_name, EVENT_FAX_FAILED_MISSING_PLUGIN, os.getenv('USER'), job_id, "Plugin is not installed")
AttributeError: 'NoneType' object has no attribute 'SendEvent'

Done.
Fax will ich eigentlich nicht, konnte aber nichts sehen wo ich die Option weg nehmen konnte.
Zuletzt geändert von gehrke am 30. Sep 2020, 14:00, insgesamt 1-mal geändert.
Grund: Bitte zukünftig <code>-Tags verwenden - https://linux-club.de/forum/viewtopic.php?f=92&t=105750
Sauerland
Guru
Guru
Beiträge: 3840
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: hplip spinnt

Beitrag von Sauerland »

Er erkennt einen Drucker aber er druckt nichts. Im Repro liegt 3.20.6, aktuell ist aber 3.20.9
Nachdem ich heute morgen diesen Beitrag gelesen hab, hab ich nachgeschaut, da gab es nur die Version 3.20.6 bei hplip.
Die neue Version muss danach veröffentlicht worden sein....

Hast du mit:

Code: Alles auswählen

hp-check
als root mal die fehlenden Pakete anzeigen lassen und nachinstalliert?
Desktop: OpenSUSE Leap 15.2, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.2, Intel-Skylake, Kernel 5.3
klaus-dieter
Hacker
Hacker
Beiträge: 444
Registriert: 10. Jun 2004, 04:50

Re: hplip spinnt

Beitrag von klaus-dieter »

Da ist alles installiert lt hp-check. Allerdings dumpt hp-check am Ende, da könnte also noch was fehlen.
-------------------------
| External Dependencies |
-------------------------

cups CUPS - Common Unix Printing System REQUIRED 1.1 2.2.7 OK 'CUPS Scheduler is running'
gs GhostScript - PostScript and PDF language interpreter and previewer REQUIRED 7.05 9.52 OK -
xsane xsane - Graphical scanner frontend for SANE OPTIONAL 0.9 0.999 OK -
scanimage scanimage - Shell scanning program OPTIONAL 1.0 1.0.27 OK -
dbus DBus - Message bus system REQUIRED - 1.12.2 OK -
policykit PolicyKit - Administrative policy framework OPTIONAL - 0.116 OK -
network network -wget OPTIONAL - 1.20.3 OK -
avahi-utils avahi-utils OPTIONAL - 0.7 OK -

------------------------
| General Dependencies |
------------------------

libjpeg libjpeg - JPEG library REQUIRED - - OK -
cups-devel CUPS devel- Common Unix Printing System development files REQUIRED - 2.2.7 OK -
cups-image CUPS image - CUPS image development files REQUIRED - 2.2.7 OK -
libpthread libpthread - POSIX threads library REQUIRED - b'2.26' OK -
libusb libusb - USB library REQUIRED - 1.0 OK -
sane SANE - Scanning library REQUIRED - 1.0.27 OK -
sane-devel SANE - Scanning library development files REQUIRED - 1.0.27 OK -
libnetsnmp-devel libnetsnmp-devel - SNMP networking library development files REQUIRED 5.0.9 5.7.3 OK -
libcrypto libcrypto - OpenSSL cryptographic library REQUIRED - 1.1.1 OK -
python3X Python 2.2 or greater - Python programming language REQUIRED 2.2 3.6.10 OK -
python3-notify2 Python libnotify - Python bindings for the libnotify Desktop notifications OPTIONAL - - OK -
Traceback (most recent call last):
File "/usr/bin/hp-check", line 862, in <module>
num_errors, num_warns = dep.validate(time_flag, is_quiet_mode)
File "/usr/bin/hp-check", line 368, in validate
self.core.dependencies[dep])
File "/usr/bin/hp-check", line 210, in __update_deps_info
installed_ver = self.core.version_func[deps_info[6]]()
File "/usr/share/hplip/installer/dcheck.py", line 303, in get_pyQt4_version
from PyQt4 import QtCore
ImportError: cannot import name 'QtCore'
Sauerland
Guru
Guru
Beiträge: 3840
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: hplip spinnt

Beitrag von Sauerland »

Kannst du es mal mit der Installation der 4 Pakete von hier versuchen:
https://download.opensuse.org/repositor ... Leap_15.2/

Und bitte Konsolenausgaben nicht als Zitat, dann ist die Formatierung futsch.
Besser als Code, ist der </> Knopf.

Bitte auch alles posten, incl. der kompletten Eingabezeile.
Wenn es zu lang ist, in eine Textdatei kopieren und hier anfügen.
Desktop: OpenSUSE Leap 15.2, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.2, Intel-Skylake, Kernel 5.3
Sauerland
Guru
Guru
Beiträge: 3840
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: hplip spinnt

Beitrag von Sauerland »

Installier auch mal python3-qt4.

Hab ich jetzt in meine Pakete als Requires eingebaut.
Dann sollte der Fehler verschwinden.
Desktop: OpenSUSE Leap 15.2, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.2, Intel-Skylake, Kernel 5.3
klaus-dieter
Hacker
Hacker
Beiträge: 444
Registriert: 10. Jun 2004, 04:50

Re: hplip spinnt

Beitrag von klaus-dieter »

Habe jetzt das Repro von Saulerland mit 3.20.9 verwendet, komme aber nicht wirklich weiter. hp-check zeigt keinen Fehler:

Code: Alles auswählen

 hp-check 
Saving output in log file: /etc/sane.d/hp-check.log

HP Linux Imaging and Printing System (ver. 3.20.9)
Dependency/Version Check Utility ver. 15.1

Copyright (c) 2001-18 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Note: hp-check can be run in three modes:
1. Compile-time check mode (-c or --compile): Use this mode before compiling the HPLIP supplied tarball (.tar.gz or .run) to determine if the proper dependencies are installed to successfully compile      
HPLIP.                                                                                                                                                                                                       
2. Run-time check mode (-r or --run): Use this mode to determine if a distro supplied package (.deb, .rpm, etc) or an already built HPLIP supplied tarball has the proper dependencies installed to          
successfully run.                                                                                                                                                                                            
3. Both compile- and run-time check mode (-b or --both) (Default): This mode will check both of the above cases (both compile- and run-time dependencies).                                                   

Check types:                                                                                                                                                                                                 
a. EXTERNALDEP - External Dependencies                                                                                                                                                                       
b. GENERALDEP - General Dependencies (required both at compile and run time)                                                                                                                                 
c. COMPILEDEP - Compile time Dependencies                                                                                                                                                                    
d. [All are run-time checks]                                                                                                                                                                                 
PYEXT SCANCONF QUEUES PERMISSION                                                                                                                                                                             

Status Types:
    OK
    MISSING       - Missing Dependency or Permission or Plug-in
    INCOMPAT      - Incompatible dependency-version or Plugin-version

 
---------------
| SYSTEM INFO |
---------------

 Kernel: 5.3.18-lp152.41-default #1 SMP Thu Sep 3 23:02:59 UTC 2020 (a4d139b) GNU/Linux
 Host: linux-zd3t
 Proc: 5.3.18-lp152.41-default #1 SMP Thu Sep 3 23:02:59 UTC 2020 (a4d139b) GNU/Linux
 Distribution: 3 15.2
 Bitness: 64 bit


-----------------------
| HPLIP CONFIGURATION |
-----------------------

HPLIP-Version: HPLIP 3.20.9
HPLIP-Home: /usr/share/hplip
HPLIP-Installation: Auto installation is supported for suse distro  15.2 version 

Current contents of '/etc/hp/hplip.conf' file:
# hplip.conf.  Generated from hplip.conf.in by configure.

[hplip]
version=3.20.9

[dirs]
home=/usr/share/hplip
run=/var/run
ppd=/usr/share/cups/model/manufacturer-PPDs/hplip
ppdbase=/usr/share/cups/model/manufacturer-PPDs
doc=/usr/share/doc/packages/hplip
html=/usr/share/doc/packages/hplip
icon=/usr/share/applications
cupsbackend=/usr/lib/cups/backend
cupsfilter=/usr/lib/cups/filter
drv=/usr/lib/cups/driver
bin=/usr/bin
apparmor=/etc/apparmor.d
# Following values are determined at configure time and cannot be changed.
[configure]
network-build=yes
libusb01-build=no
pp-build=yes
gui-build=yes
scanner-build=yes
fax-build=yes
dbus-build=yes
cups11-build=no
doc-build=yes
shadow-build=no
hpijs-install=yes
foomatic-drv-install=no
foomatic-ppd-install=yes
foomatic-rip-hplip-install=no
hpcups-install=yes
cups-drv-install=no
cups-ppd-install=yes
internal-tag=3.20.9
restricted-build=no
ui-toolkit=qt5
qt3=no
qt4=no
qt5=yes
policy-kit=no
lite-build=no
udev_sysfs_rules=no
hpcups-only-build=no
hpijs-only-build=no
apparmor_build=no
class-driver=no


Current contents of '/var/lib/hp/hplip.state' file:
[plugin]
installed = 1
eula = 1
version = 3.20.9



Current contents of '~/.hplip/hplip.conf' file:
[commands]
scan=/usr/bin/xsane -V %SANE_URI%

[fax]
email_address=
voice_phone=

[last_used]
device_uri=
printer_name=HP_LaserJet_Professional_M1212nf_MFP
working_dir=.

[polling]
device_list=
enable=false
interval=5

[refresh]
enable=false
rate=30
type=1

[settings]
systray_messages=0
systray_visible=0

[upgrade]
last_upgraded_time=1580929525
notify_upgrade=false
pending_upgrade_time=0

 <Package-name>        <Package-Desc>      <Required/Optional> <Min-Version> <Installed-Version> <Status>   <Comment>

-------------------------
| External Dependencies |
-------------------------

 cups                 CUPS - Common Unix Printing System                           REQUIRED        1.1             2.2.7           OK         'CUPS Scheduler is running'
 gs                   GhostScript - PostScript and PDF language interpreter and previewer REQUIRED        7.05            9.52            OK         -
 xsane                xsane - Graphical scanner frontend for SANE                  OPTIONAL        0.9             0.999           OK         -
 scanimage            scanimage - Shell scanning program                           OPTIONAL        1.0             1.0.27          OK         -
 dbus                 DBus - Message bus system                                    REQUIRED        -               1.12.2          OK         -
 policykit            PolicyKit - Administrative policy framework                  OPTIONAL        -               0.116           OK         -
 network              network -wget                                                OPTIONAL        -               1.20.3          OK         -
 avahi-utils          avahi-utils                                                  OPTIONAL        -               0.7             OK         -

------------------------
| General Dependencies |
------------------------

 libjpeg              libjpeg - JPEG library                                       REQUIRED        -               -               OK         -
 cups-devel           CUPS devel- Common Unix Printing System development files    REQUIRED        -               2.2.7           OK         -
 cups-image           CUPS image - CUPS image development files                    REQUIRED        -               2.2.7           OK         -
 libpthread           libpthread - POSIX threads library                           REQUIRED        -               b'2.26'         OK         -
 libusb               libusb - USB library                                         REQUIRED        -               1.0             OK         -
 sane                 SANE - Scanning library                                      REQUIRED        -               1.0.27          OK         -
 sane-devel           SANE - Scanning library development files                    REQUIRED        -               1.0.27          OK         -
 libavahi-dev         libavahi-dev                                                 REQUIRED        -               -               OK         -
 libnetsnmp-devel     libnetsnmp-devel - SNMP networking library development files REQUIRED        5.0.9           5.7.3           OK         -
 libcrypto            libcrypto - OpenSSL cryptographic library                    REQUIRED        -               1.1.1           OK         -
 python3X             Python 2.2 or greater - Python programming language          REQUIRED        2.2             3.6.10          OK         -
 python3-notify2      Python libnotify - Python bindings for the libnotify Desktop notifications OPTIONAL        -               -               OK         -
 python3-pyqt4-dbus   PyQt 4 DBus - DBus Support for PyQt4                         OPTIONAL        4.0             4.12.3          OK         -
 python3-pyqt4        PyQt 4- Qt interface for Python (for Qt version 4.x)         REQUIRED        4.0             4.12.3          OK         -
 python3-dbus         Python DBus - Python bindings for DBus                       REQUIRED        0.80.0          1.2.4           OK         -
 python3-xml          Python XML libraries                                         REQUIRED        -               2.2.5           OK         -
 python3-devel        Python devel - Python development files                      REQUIRED        2.2             3.6.10          OK         -
 python3-pil          PIL - Python Imaging Library (required for commandline scanning with hp-scan) OPTIONAL        -               5.0.0           OK         -
 python3-reportlab    Reportlab - PDF library for Python                           OPTIONAL        2.0             3.4.0           OK         -

--------------
| COMPILEDEP |
--------------

 libtool              libtool - Library building support services                  REQUIRED        -               2.4.6           OK         -
 gcc                  gcc - GNU Project C and C++ Compiler                         REQUIRED        -               7.5.0           OK         -
 make                 make - GNU make utility to maintain groups of programs       REQUIRED        3.0             4.2.1           OK         -

---------------------
| Python Extentions |
---------------------

 cupsext              CUPS-Extension                                               REQUIRED        -               3.20.9          OK         -
 hpmudext             IO-Extension                                                 REQUIRED        -               3.20.9          OK         -

----------------------
| Scan Configuration |
----------------------

 hpaio                HPLIP-SANE-Backend                                           REQUIRED        -               3.20.9          OK         'hpaio found in /etc/sane.d/dll.conf'
 scanext              Scan-SANE-Extension                                          REQUIRED        -               3.20.9          OK         -

------------------------------
| DISCOVERED SCANNER DEVICES |
------------------------------

No Scanner found.

--------------------------
| DISCOVERED USB DEVICES |
--------------------------

No devices found.

---------------------------------
| INSTALLED CUPS PRINTER QUEUES |
---------------------------------

 
lpstat
------
Type: Unknown
Device URI: No destinations added.


--------------
| PERMISSION |
--------------

No errors or warnings.

Done.
Wenn ich als root hp-setup laufen lassen erkennt er meinen Drucker und beim nächsten "Next" crashed der GUI und in der Konsole sehe ich:

Code: Alles auswählen

# hp-setup 

HP Linux Imaging and Printing System (ver. 3.20.9)
Printer/Fax Setup Utility ver. 9.0

Copyright (c) 2001-18 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-root'
Searching... (bus=net, timeout=5, ttl=4, search=(None) desc=0, method=slp)
error: Loading /usr/share/hplip/fax/plugins/fax_marvell.so failed. Try after installing plugin libraries

Run "hp-plugin" to installa plugin libraries if you are not automatically prompted

Traceback (most recent call last):
  File "/usr/share/hplip/ui5/setupdialog.py", line 1305, in NextButton_clicked
    self.showAddPrinterPage()
  File "/usr/share/hplip/ui5/setupdialog.py", line 729, in showAddPrinterPage
    self.readwriteFaxInformation()
  File "/usr/share/hplip/ui5/setupdialog.py", line 1100, in readwriteFaxInformation
    d = fax.getFaxDevice(self.fax_uri, disable_dbus=True)
  File "/usr/share/hplip/fax/fax.py", line 534, in getFaxDevice
    return MarvellFaxDevice(device_uri, printer_name, callback, fax_type, disable_dbus)
  File "/usr/share/hplip/fax/marvellfax.py", line 109, in __init__
    self.service.SendEvent(device_uri, printer_name, EVENT_FAX_FAILED_MISSING_PLUGIN, os.getenv('USER'), job_id, "Plugin is not installed")
AttributeError: 'NoneType' object has no attribute 'SendEvent'
Aborted (core dumped)
Fax will ich gar nicht.

Wenn ich hp-plugin als normalen User laufen lasse bekomme ich folgenden Fehler (obwohl hp-check gesagt hat dass plugin ist installiert)

Code: Alles auswählen

hp-plugin 

HP Linux Imaging and Printing System (ver. 3.20.9)
Plugin Download and Install Utility ver. 2.1

Copyright (c) 2001-18 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.


HP Linux Imaging and Printing System (ver. 3.20.9)
Plugin Download and Install Utility ver. 2.1

Copyright (c) 2001-18 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Checking for network connection...
Downloading plug-in from: 
Plugin is not accessible. Trying to download it from fallback location: [https://developers.hp.com/sites/default/files/hplip-3.20.9-plugin.run]
Receiving digital keys: /usr/bin/gpg --homedir /home/xxxx/.hplip/.gnupg --no-permission-warning --keyserver pool.sks-keyservers.net --recv-keys 0x4ABA2F66DBD5A95894910E0673D770CDA59047B9
Creating directory plugin_tmp
Verifying archive integrity... All good.
Uncompressing HPLIP 3.20.9 Plugin Self Extracting Archive.Extraction failed.
error: Python gobject/dbus may be not installed
|
gzip: stdout: Broken pipe
error: Plug-in install failed.
qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 1097, resource id: 37768585, major code: 40 (TranslateCoords), minor code: 0

Done.
Sauerland
Guru
Guru
Beiträge: 3840
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: hplip spinnt

Beitrag von Sauerland »

Läuft apparmor?
Wenn ja, installier mal apparmor-utils.
Dann als root:

Code: Alles auswählen

aa-disable /usr/share/hplip/plugin.py
Danach noch einmal als User:

Code: Alles auswählen

hp-plugin
Desktop: OpenSUSE Leap 15.2, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.2, Intel-Skylake, Kernel 5.3
klaus-dieter
Hacker
Hacker
Beiträge: 444
Registriert: 10. Jun 2004, 04:50

Re: hplip spinnt

Beitrag von klaus-dieter »

Habe appamor jetzt mal disabled. Nach einem reboot hat die plugin Installation success angezeigt. hp-setup als root dumpt immer noch genauso wie zuvor.
Sauerland
Guru
Guru
Beiträge: 3840
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: hplip spinnt

Beitrag von Sauerland »

Kopier dir mal die beiden Dateien nach /usr/share/hplip/fax/plugins/:
https://www.krauttranslate.de/~sauerlan ... -x86_64.so
https://www.krauttranslate.de/~sauerlan ... marvell.so

Falls das Verzeichnis nicht besteht, bitte melden.
Desktop: OpenSUSE Leap 15.2, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.2, Intel-Skylake, Kernel 5.3
Sauerland
Guru
Guru
Beiträge: 3840
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: hplip spinnt

Beitrag von Sauerland »

Desktop: OpenSUSE Leap 15.2, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.2, Intel-Skylake, Kernel 5.3
klaus-dieter
Hacker
Hacker
Beiträge: 444
Registriert: 10. Jun 2004, 04:50

Re: hplip spinnt

Beitrag von klaus-dieter »

Habe alle Dateien ausgetauscht, sie waren alle schon vorhanden. Der Fehler ist der gleiche geblieben, ich habe dann wieder zurück zu meinen Originaldateien gewechselt.
Sauerland
Guru
Guru
Beiträge: 3840
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: hplip spinnt

Beitrag von Sauerland »

Sauerland hat geschrieben: 30. Sep 2020, 19:00 Installier auch mal python3-qt4.

Hab ich jetzt in meine Pakete als Requires eingebaut.
Dann sollte der Fehler verschwinden.
Hast du das auch schon gemacht?
Desktop: OpenSUSE Leap 15.2, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.2, Intel-Skylake, Kernel 5.3
klaus-dieter
Hacker
Hacker
Beiträge: 444
Registriert: 10. Jun 2004, 04:50

Re: hplip spinnt

Beitrag von klaus-dieter »

Ja hatte ich schon vorher gemacht.
Sauerland
Guru
Guru
Beiträge: 3840
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: hplip spinnt

Beitrag von Sauerland »

Kannst du den Drucker in Yast--Hardware---Drucker einrichten?
Desktop: OpenSUSE Leap 15.2, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.2, Intel-Skylake, Kernel 5.3
Antworten