Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Keine Funktion der Tastatur im Grafikmodus

Alles rund um Hardware, die unter Linux läuft oder zum Laufen gebracht werden soll

Moderator: Moderatoren

Antworten
Lino1
Newbie
Newbie
Beiträge: 13
Registriert: 24. Nov 2013, 09:03

Keine Funktion der Tastatur im Grafikmodus

Beitrag von Lino1 »

Hallo zusammen,

nach einem Update per zypper dup (neuer kernel 5.8.0-1) reagiert die Tastatur nicht mehr. Nach "Abmeldung" zurück auf den Anmeldebildschirm ebenfalls keine Funktion. Mit der Virtual-Tastatur "Strg+Alt+F1" auf der Konsole ist die Funktion gegeben! Starte ich das System im Boot-menu erweitertes menu mit den kernel 5.7.9-1.2 ist alles in Ordnung. Eine Woche später wieder ein Update, in der Hoffnung, der Fehler ist behoben (neuer kernel 5.8.4-1). Leider das gleiche Problem.
Nun kann ich auch nicht mehr den kernel 5.7.9-1.2 nutzen, der ist im erweiterten menu durch kernel 5.8.0-1 ersetzt worden.
Was kann ich noch versuchen, um das Problem zu lösen und wo finde ich im Internet ein repo mit dem kernel 5.7.9-1.2 ?


Mein System.
Notebook ASUS UX3410U
Tumbleweed 64 Bit
HD Grafics 620 Mesa DRI Intel
KDE-Plasma 5.19.4
Benutzeravatar
Heinz-Peter
Guru
Guru
Beiträge: 2344
Registriert: 24. Okt 2005, 14:04

Re: Keine Funktion der Tastatur im Grafikmodus

Beitrag von Heinz-Peter »

Wenn die Tastatur am USB Buchse eingesteckt ist dann kannst versuchen das USB Kabel ziehen und wieder einstecken. Wenn die Tastatur aber nicht am USB Anschluss hängt, sondern an PS/2 Buchse dann kannst Du das nicht machen. Es besteht dann die Gefahr den Anschluss zu zerstören.

Grüße
Man sollte viel häufiger einen Mutausbruch haben.
BS: Suse13.2/Ubuntu16.04LTS/Ubuntu18.04LTS/Leap15.2/Win, Prozessor: Pentium 4 550 (3,40 GHz, FSB800, Hyper-Threading) & Intel i3-7100U 2,4GHz, Grafikkarte: Nvidia Geforce 6610XL & Intel HD 620.
Lino1
Newbie
Newbie
Beiträge: 13
Registriert: 24. Nov 2013, 09:03

Re: Keine Funktion der Tastatur im Grafikmodus

Beitrag von Lino1 »

Hallo Heinz-Peter,

es handelt sich hier um die Notebooktastatur. Das macht die Sache so kompliziert. Meine Vermutung ist, es liegt an der Kernel-Version.

Gruss lino1
josef-wien
Ultimate Guru
Ultimate Guru
Beiträge: 5503
Registriert: 23. Sep 2008, 17:09

Re: Keine Funktion der Tastatur im Grafikmodus

Beitrag von josef-wien »

Ich denke eher an eine Inkompatibilität mit dem Grafiksystem. Wenn Du Xorg verwendest, schau Dir die Datei /var/log/Xorg.0.log an. Zu Wayland kann ich nichts sagen.
Benutzeravatar
Heinz-Peter
Guru
Guru
Beiträge: 2344
Registriert: 24. Okt 2005, 14:04

Re: Keine Funktion der Tastatur im Grafikmodus

Beitrag von Heinz-Peter »

Den alten Kernel kannst Du suchen unter: Yast -- Software -- Suche nach kernel-default
oder an der Konsole mit

Code: Alles auswählen

zypper se kernel-default
Man sollte viel häufiger einen Mutausbruch haben.
BS: Suse13.2/Ubuntu16.04LTS/Ubuntu18.04LTS/Leap15.2/Win, Prozessor: Pentium 4 550 (3,40 GHz, FSB800, Hyper-Threading) & Intel i3-7100U 2,4GHz, Grafikkarte: Nvidia Geforce 6610XL & Intel HD 620.
Sauerland
Guru
Guru
Beiträge: 3894
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: Keine Funktion der Tastatur im Grafikmodus

Beitrag von Sauerland »

Heinz-Peter hat geschrieben: 5. Sep 2020, 22:11 Den alten Kernel kannst Du suchen unter: Yast -- Software -- Suche nach kernel-default
oder an der Konsole mit

Code: Alles auswählen

zypper se kernel-default
Aber nicht bei Tumbleweed wenn der deinstalliert war.....
Desktop: OpenSUSE Leap 15.2, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.2, Intel-Skylake, Kernel 5.3
Lino1
Newbie
Newbie
Beiträge: 13
Registriert: 24. Nov 2013, 09:03

Re: Keine Funktion der Tastatur im Grafikmodus

Beitrag von Lino1 »

YAST stellt nur den aktuellen und den zuvor installierten kernel zu Verfügung.
Mit zypper erhalte ich folgendes Ergebnis:

Code: Alles auswählen

# zypper se kernel-default
Repository-Daten werden geladen...
Installierte Pakete werden gelesen...

S  | Name                        | Zusammenfassung                                               | Typ
---+-----------------------------+---------------------------------------------------------------+------
i+ | kernel-default              | The Standard Kernel                                           | Paket
   | kernel-default-base         | The Standard Kernel - base modules                            | Paket
   | kernel-default-base-rebuild | Empty package to ensure rebuilding kernel-default-base in OBS | Paket
   | kernel-default-devel        | Development files necessary for building kernel modules       | Paket
 
/var/log/Xorg.0.log hat eine Fehlermeldung die ich aber nicht verstehe.

Code: Alles auswählen

[    12.790] (**) Option "Device" "/dev/input/event0"
[    12.790] (**) Option "_source" "server/udev"
[    12.794] (II) event0  - AT Translated Set 2 keyboard: is tagged by udev as: Keyboard
[    12.794] (II) event0  - AT Translated Set 2 keyboard: device is a keyboard
[    12.812] (II) event0  - AT Translated Set 2 keyboard: device removed
[    12.813] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio0/input/input0/event0"
[    12.813] (II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD, id 16)
[    12.813] (**) Option "xkb_model" "pc105"
[    12.813] (**) Option "xkb_layout" "de"
[    12.813] (**) Option "xkb_variant" "nodeadkeys"
[    12.813] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
[    12.817] (II) event0  - AT Translated Set 2 keyboard: is tagged by udev as: Keyboard
[    12.817] (II) event0  - AT Translated Set 2 keyboard: device is a keyboard
[    12.842] (II) config/udev: Adding input device PC Speaker (/dev/input/event8)
[    12.842] (II) No input driver specified, ignoring this device.
[    12.842] (II) This device may have been added with another device file.
[    12.916] (EE) Failed to open authorization file "/run/sddm/{1ac0c72f-7d59-412b-b60d-24f8874fd740}": No such file or directory
[    14.085] (II) modeset(0): EDID vendor "CMN", prod id 5330
Benutzeravatar
Heinz-Peter
Guru
Guru
Beiträge: 2344
Registriert: 24. Okt 2005, 14:04

Re: Keine Funktion der Tastatur im Grafikmodus

Beitrag von Heinz-Peter »

Sauerland hat geschrieben: 5. Sep 2020, 22:32 Aber nicht bei Tumbleweed wenn der deinstalliert war.....
OK, das wusste ich nicht. Wenn man aber nicht zurück rudern kann dann vielleicht wäre besser Snapshots zu installieren, so wie hier beschrieben -->https://www.opensuse-forum.de/thread/63 ... post279314

Grüße und Danke für die Korrektur.

Heinz-Peter
Man sollte viel häufiger einen Mutausbruch haben.
BS: Suse13.2/Ubuntu16.04LTS/Ubuntu18.04LTS/Leap15.2/Win, Prozessor: Pentium 4 550 (3,40 GHz, FSB800, Hyper-Threading) & Intel i3-7100U 2,4GHz, Grafikkarte: Nvidia Geforce 6610XL & Intel HD 620.
Benutzeravatar
susejunky
Advanced Hacker
Advanced Hacker
Beiträge: 807
Registriert: 19. Sep 2014, 18:22

Re: Keine Funktion der Tastatur im Grafikmodus

Beitrag von susejunky »

Hallo Lino1,
Lino1 hat geschrieben: 5. Sep 2020, 17:19... nach einem Update per zypper dup (neuer kernel 5.8.0-1) reagiert die Tastatur nicht mehr. Nach "Abmeldung" zurück auf den Anmeldebildschirm ebenfalls keine Funktion. Mit der Virtual-Tastatur "Strg+Alt+F1" auf der Konsole ist die Funktion gegeben!
funktioniert die Eingabe über eine externe, an USB angeschlossene Tastatur?
Lino1 hat geschrieben: 5. Sep 2020, 17:19... wo finde ich im Internet ein repo mit dem kernel 5.7.9-1.2 ?
Hier https://download.opensuse.org/history/2 ... /repo/oss/ kannst Du noch kernel 5.7.11-1.2 für Tumbleweed finden. Nutzung auf eigene Gefahr!

Bei meinen Systemen tritt das von Dir geschilderte Problem zwar nicht auf, aber es wurden bereits ähnliche Fehler in Bugzilla gemeldet, bei denen Du Dich beteiligen könntest:

https://bugzilla.suse.com/show_bug.cgi?id=1175581
https://bugzilla.opensuse.org/show_bug.cgi?id=1175599

Zu letzterem gibt es auch einen Beitrag auf dem englischsprachigen openSUSE-Forum: https://forums.opensuse.org/showthread. ... o-keyboard

Viele Grüße

susejunky
josef-wien
Ultimate Guru
Ultimate Guru
Beiträge: 5503
Registriert: 23. Sep 2008, 17:09

Re: Keine Funktion der Tastatur im Grafikmodus

Beitrag von josef-wien »

Lino1 hat geschrieben:[ 12.916] (EE) Failed to open authorization file "/run/sddm/{1ac0c72f-7d59-412b-b60d-24f8874fd740}": No such file or directory
Zu sddm kann ich nichts sagen, aber zur Fehlereingrenzung könntest Du einen anderen display manager versuchen (aber frage nicht mich, welche openSUSE anbietet). Weiters könntest Du bei der Anmeldung icewm oder einen anderen window manager probieren.

P. S. Ich will ja nicht in offenen Wunden bohren, aber warum hast Du in dieser Situation nicht in /etc/zypp/zypp.conf das Löschen des funktionierenden Kernel verhindert?
Benutzeravatar
susejunky
Advanced Hacker
Advanced Hacker
Beiträge: 807
Registriert: 19. Sep 2014, 18:22

Re: Keine Funktion der Tastatur im Grafikmodus

Beitrag von susejunky »

josef-wien hat geschrieben: 6. Sep 2020, 11:47... aber zur Fehlereingrenzung könntest Du einen anderen display manager versuchen (aber frage nicht mich, welche openSUSE anbietet).
z.B. lightdm
josef-wien hat geschrieben: 6. Sep 2020, 11:47... Weiters könntest Du bei der Anmeldung icewm oder einen anderen window manager probieren.
In einer der genannten Fehlermeldungen hat das aber nicht zum Erfolg geführt ...
josef-wien hat geschrieben: 6. Sep 2020, 11:47... P. S. Ich will ja nicht in offenen Wunden bohren, aber warum hast Du in dieser Situation nicht in /etc/zypp/zypp.conf das Löschen des funktionierenden Kernel verhindert?
Vielleicht ist Lino1 (ebenso wie ich ;) ) Opfer dieses Fehlers https://bugzilla.opensuse.org/show_bug.cgi?id=1176192 / https://forums.opensuse.org/showthread. ... -zypp-conf geworden?

Viele Grüße

susejunky
Lino1
Newbie
Newbie
Beiträge: 13
Registriert: 24. Nov 2013, 09:03

Re: [gelöst] Keine Funktion der Tastatur im Grafikmodus

Beitrag von Lino1 »

Habe hier https://bbs.archlinux.org/viewtopic.php ... #p1922517 die Lösung gefunden. Nachdem ich folgenden Code in die Datei xorg.conf.d eingefügt habe, läuft alles wie vorher!

Code: Alles auswählen

Section "InputClass"
        Identifier "Asus WMI hotkeys"
        MatchProduct "Asus WMI hotkeys"
        Option "Ignore" "on"
EndSection      [code]

Auf die Frage "warum hast Du in dieser Situation nicht in /etc/zypp/zypp.conf das Löschen des funktionierenden Kernel verhindert?" 
1. weil ich nicht wusste das es möglich ist
2. bin ich davon ausgegangen, das es kein Problem ist, wieder einen älteren kernel zu installieren
Hinterher ist man dann schlauer und hat mal wieder aus Fehlern gelernt!

Vielen Dank für die Beiträge und Eure Bemühungen

Gruß Lino1
Benutzeravatar
Heinz-Peter
Guru
Guru
Beiträge: 2344
Registriert: 24. Okt 2005, 14:04

Re: Keine Funktion der Tastatur im Grafikmodus

Beitrag von Heinz-Peter »

Hallo @Lino1,

Danke für die Rückmeldung. Und schon wieder hat @josef-wien den richtigen Riecher gehabt :) mit dem Hinweis auf die Xorg.

Grüße
Man sollte viel häufiger einen Mutausbruch haben.
BS: Suse13.2/Ubuntu16.04LTS/Ubuntu18.04LTS/Leap15.2/Win, Prozessor: Pentium 4 550 (3,40 GHz, FSB800, Hyper-Threading) & Intel i3-7100U 2,4GHz, Grafikkarte: Nvidia Geforce 6610XL & Intel HD 620.
Antworten