Seite 1 von 1

[Gelöst] Fedora 32: Intel VT wird nicht erkannt

Verfasst: 8. Mai 2020, 07:39
von gehrke
Moin *

Ich möchte eine virtuelle Maschine aufbauen mit KVM, der Host läuft mit Fedora 32. Installation wie hier beschrieben verlief scheinbar auch problemlos:
https://docs.fedoraproject.org/en-US/qu ... alization/

Ich habe eine reale Maschine aus Altersgründen konvertiert mit einer Dual-Boot-Config für CentOS und Win7. Diese VM kann ich starten, GRUB lässt mich auswählen, aber beide Systeme booten scheinbar nicht. Oder besser: Es ist unglaublich langsam und erzeugt massive Load auf dem Host.
Also möglicherweise 'nur' ein Performance-Problem.

Allerdings bin ich verwundert, dass ich nicht die erwarteten Virtualisierungs-Eigenschaften der CPU auf dem Host finden kann, was meiner Recherche nach die Ursache für das beobachtete Verhalten sein kann.
KVM requires a CPU with virtualization extensions, found on most consumer CPUs. These extensions are called Intel VT or AMD-V.
Auf dem Host:

Code: Alles auswählen

# egrep '^flags.*(vmx|svm)' /proc/cpuinfo
<nix>
Vollständiger:

Code: Alles auswählen

# cat /proc/cpuinfo 
processor	: 0
vendor_id	: GenuineIntel
cpu family	: 6
model		: 58
model name	: Intel(R) Core(TM) i5-3470 CPU @ 3.20GHz
stepping	: 9
microcode	: 0x21
cpu MHz		: 1596.460
cache size	: 6144 KB
physical id	: 0
siblings	: 4
core id		: 0
cpu cores	: 4
apicid		: 0
initial apicid	: 0
fpu		: yes
fpu_exception	: yes
cpuid level	: 13
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc cpuid aperfmperf pni pclmulqdq dtes64 monitor ds_cpl smx est tm2 ssse3 cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer aes xsave avx f16c rdrand lahf_lm cpuid_fault epb pti ssbd ibrs ibpb stibp fsgsbase smep erms xsaveopt dtherm ida arat pln pts md_clear flush_l1d
bugs		: cpu_meltdown spectre_v1 spectre_v2 spec_store_bypass l1tf mds swapgs itlb_multihit
bogomips	: 6385.70
clflush size	: 64
cache_alignment	: 64
address sizes	: 36 bits physical, 48 bits virtual
power management:
[... 3 weitere ...]
Die Flags scheinen zu fehlen.

Ein Blick ins BIOS/UEFI zeigt, dass es zumindest die richtige CPU ist:

Code: Alles auswählen

Intel Core(TM) i5-3470 CPU @ 3.20GHz
Laut Intel sollte die aber die notwendigen Eigenschaften besitzen:
Advanced Technologies

Intel® Turbo Boost Technology ‡ 2.0
Intel® vPro™ Platform Eligibility ‡ Yes
Intel® Hyper-Threading Technology ‡ No
Intel® Virtualization Technology (VT-x) ‡ Yes
Intel® Virtualization Technology for Directed I/O (VT-d) ‡ Yes
Intel® VT-x with Extended Page Tables (EPT) ‡ Yes
https://ark.intel.com/content/www/us/en ... 0-ghz.html

Es gibt im BIOS/UEFI keine Option, diese Eigenschaft an-/abzuschalten.

Code: Alles auswählen

HP Compaq Elite 8300 MT
Hinweis: Der Host ist 'historisch gewachsen'. Die Installation von Fedora vor Jahren erfolgte noch auf einer anderen Hardware. Das System wurde bei Hardwarewechsel nicht neu installiert, sondern nur die Disks in die neue Hardware geschoben und lief. Könnte eine mögliche Ursache sein, aber die CPU wird ja richtig erkannt.

Warum werden diese Eigenschaften nicht korrekt erkannt?
TNX

Glückauf,
gehrke

Re: Fedora 32: Intel VT wird nicht erkannt

Verfasst: 8. Mai 2020, 08:34
von marce
Wo im BIOS hast Du denn geschaut? Google meint, es wäre unter System -> Security zu finden (hab' gerade leider kein HP hier, die stehen alle im Büro und ich bin im Homeoffice... - AFAIR sollte aber alles mit den Dingern gehen, ich erinnere mich auch, daß mehr oder weniger durch's komplette BIOS turnen musste...)

https://superuser.com/questions/802496/ ... 8300-elite

Re: Fedora 32: Intel VT wird nicht erkannt

Verfasst: 8. Mai 2020, 08:40
von gehrke
OK, ich schau nachher noch ein zweites mal nach. Partielle Erblindung wäre ja tatsächlich eine plausible Erklärung.
TNX

Re: Fedora 32: Intel VT wird nicht erkannt

Verfasst: 8. Mai 2020, 09:04
von gehrke
Alter, muss dringend beim Optiker! :ops:

Ja, genau an der genannten Stelle waren die Optionen zu finden und alle 'disabled'.

Nachdem ich das eingeschaltet habe, sind die erwarteten Flags da:

Code: Alles auswählen

# egrep '^flags.*(vmx|svm)' /proc/cpuinfo
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc cpuid aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer aes xsave avx f16c rdrand lahf_lm cpuid_fault epb pti ssbd ibrs ibpb stibp tpr_shadow vnmi flexpriority ept vpid fsgsbase smep erms xsaveopt dtherm ida arat pln pts md_clear flush_l1d

Code: Alles auswählen

# lsmod | grep kvm
kvm_intel             327680  0
kvm                   806912  1 kvm_intel
irqbypass              16384  1 kvm
Danke vielmals für den schnellen Support.