Seite 1 von 1

[gelöst] Laserdrucker OS Leap 15.1-kompatibel

Verfasst: 8. Jul 2019, 20:36
von Eckart Spindler
Hallo. Ich möchte mir einen Laserdrucker kaufen (kein Multifunktionsgerät), welcher leicht und zuverlässig ist, möglichst lange hält und mit OpenSuse Leap 15.1 kompatibel ist. Schwarz-weiss würde schon reichen. Hat jemand einen Tipp für mich, welcher Drucker da in Frage käme? Ich verwende zur Zeit einen Tintenstrahldrucker Canon Pixma IP 7052, welcher kaputt ist (es ist schon der 2. Canon Pixma IP 7052).

Re: Laserdrucker OS Leap 15.1-kompatibel

Verfasst: 9. Jul 2019, 16:48
von Sauerland
Ich hab hier nen Brother HL2140 am laufen, der druckt schon jahrelang ohne Probleme, Treiber (32 bit) von Brother....

Re: Laserdrucker OS Leap 15.1-kompatibel

Verfasst: 9. Jul 2019, 18:06
von Benutzer 56433 gelöscht
Bei mir läuft seit Jahren ein Samsung SL-M2835DW.

Re: Laserdrucker OS Leap 15.1-kompatibel

Verfasst: 9. Jul 2019, 20:57
von Eckart Spindler
Sauerland hat geschrieben:
9. Jul 2019, 16:48
Ich hab hier nen Brother HL2140 am laufen....
Danke für den Hinweis. Ich habe gerade auf der Webseite von Brother nachgesehen. Der Drucker ist zur Zeit ausverkauft (was sicherlich für den Drucker spricht).

Re: Laserdrucker OS Leap 15.1-kompatibel

Verfasst: 9. Jul 2019, 20:58
von Eckart Spindler
rolandb hat geschrieben:
9. Jul 2019, 18:06
Bei mir läuft seit Jahren ein Samsung SL-M2835DW.
Danke für den Hinweis.

Re: Laserdrucker OS Leap 15.1-kompatibel

Verfasst: 10. Jul 2019, 10:26
von Uwe.Lü
Hallo, wir haben hier im Büro seit Jahren folgende Drucker ohne Probleme am Laufen:
HP LaserJet 1606 DN
Brother MFC - L2700DN und
Samsung X3280NR

Für die ersten beiden Drucker findet man die Treiber im CUPS, der Treiber für den Samsung auf der Samsung Website.

Re: Laserdrucker OS Leap 15.1-kompatibel

Verfasst: 10. Jul 2019, 16:53
von Sauerland
Meines war nur als Beispiel zu sehen, der Drucker hat auch schon ein paar Jährchen auf dem Rücken........

Problemlos sollten Brother- und HP-Drucker eigentlich funktionieren.

Re: Laserdrucker OS Leap 15.1-kompatibel

Verfasst: 11. Jul 2019, 10:14
von mkossmann
Uwe.Lü hat geschrieben:
10. Jul 2019, 10:26

Samsung X3280NR

der Treiber für den Samsung auf der Samsung Website.
Da die Druckersparte von Samsung von HP übernommen wurde, findet man auch den Treiber inzwischen bei HP https://support.hp.com/de-de/drivers/se ... l/16449672.

Re: Laserdrucker OS Leap 15.1-kompatibel

Verfasst: 23. Sep 2019, 11:56
von Eckart Spindler
Entschuldigt meine verspätete Antwort. Aber mein Rechner war monatelang mit Linux nicht arbeitsfähig wegen Festplattenproblemen. Das Problem ist jetzt gelöst und ich kann wieder unter Linux arbeiten.
Aber nun zum Drucker: Ich habe mir einen HP LaserJet Pro M15w gekauft. Laut Installationsanleitung habe ich

Code: Alles auswählen

hplip-3.19.8.run
mit

Code: Alles auswählen

chmode +x hplip-3.19.8.run
und

Code: Alles auswählen

./hplip-3.19.8.run
installiert. Aber der Drucker ist nicht in meinem Druckerverzeichnis enthalten und ich kann unter OS Leap 15.1 nicht mit dem Drucker drucken.
Ich habe parallel noch Windows10. Da funktioniert der Drucker einwandfrei.
Was muss ich noch tun, damit der Drucker unter OS Leap 15.1 druckt?

Re: Laserdrucker OS Leap 15.1-kompatibel

Verfasst: 23. Sep 2019, 13:09
von Sauerland
1. Warum installierst du hplip am Paketmanager vorbei? Ist unnötig, es gibt auch aktuelle rpms:

Code: Alles auswählen

zypper se -s hplip
S  | Name        | Type       | Version          | Arch   | Repository         
---+-------------+------------+------------------+--------+--------------------
i+ | hplip       | package    | 3.19.8-lp151.1.2 | x86_64 | Sauerland-Leap-15.1
v  | hplip       | package    | 3.18.6-lp151.1.1 | x86_64 | OSS         
2. Warum nimmst du nicht das von openSUSE bereitgestellte?
siehe Ausgabe zu 1
denn:

Code: Alles auswählen

HPLIP 3.18.4 adds support for following new devices:
.
.
.
.

        HP LaserJet Pro M15w 
Ich würde jetzt als root mal das hplip deinstallieren:

Code: Alles auswählen

hp-uninstall
danach hplip mit dem Paketmanager installieren:

Code: Alles auswählen

zypper in hplip
danach mal das setup bei angeschlossenem Drucker aufrufen:

Code: Alles auswählen

hp-setup
Alles wie schon gesagt als root.

Re: Laserdrucker OS Leap 15.1-kompatibel

Verfasst: 23. Sep 2019, 16:14
von Eckart Spindler
Das mit der Deinstallation hat nicht geklappt. Da kam eine Fehlermeldung
Cannot find ...
oder so ähnlich. Aber die Installation hat funktioniert. Der Drucker druckt jetzt.
Ist das ein Problem, wenn die Deinstallation nicht funktioniert hat?

Re: Laserdrucker OS Leap 15.1-kompatibel

Verfasst: 23. Sep 2019, 18:27
von Sauerland
Aber die Installation hat funktioniert. Der Drucker druckt jetzt.
Never change a...........

Lass es so wie es ist.

Re: Laserdrucker OS Leap 15.1-kompatibel

Verfasst: 23. Sep 2019, 21:46
von Eckart Spindler
o.k. Vielen Dank.