Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[gelöst] USB-WLAN TP-LINK wird nicht sauber erkannt

Alles rund um Hardware, die unter Linux läuft oder zum Laufen gebracht werden soll

Moderator: Moderatoren

Antworten
warpi
Hacker
Hacker
Beiträge: 446
Registriert: 17. Mär 2005, 12:04
Wohnort: augsburg

[gelöst] USB-WLAN TP-LINK wird nicht sauber erkannt

Beitrag von warpi » 12. Feb 2019, 11:15

Hallo liebe Linuxhelfer,
was bisher geschah:
TP-Link USB-Adapter AC1300 Archer T4U erstanden.
Auf der Verpackung wird die Unterstützung von Kernel 2.6.18 - 4.4 erwähnt.
Damit dachte ich, super wird dann ja wohl mit einem neueren Kernel funktionieren.
Tuts aber nicht.
Hier ein paar Infos:

Code: Alles auswählen

uname -a
Linux Warpi 4.12.14-lp150.12.45-default #1 SMP Mon Jan 14 20:29:59 UTC 2019 (7a62739) x86_64 x86_64 x86_64 GNU/Linux

Code: Alles auswählen

lsusb
Bus 006 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 046d:c50d Logitech, Inc. Cordless Mouse
Bus 001 Device 003: ID 05e3:0608 Genesys Logic, Inc. Hub
Bus 001 Device 005: ID 046a:0023 Cherry GmbH CyMotion Master Linux Keyboard G230
Bus 001 Device 002: ID 2357:0115  
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Kein Ergebnis bei:

Code: Alles auswählen

hwinfo --wlan
Bei der Hardware-Erkennung unter Yast dann folgender Eintrag bei USB:
USB 00.0: 0000 Unclassified device
[Created at usb.122]
Unique ID: ADDn.p4pjJFdLEgF
Parent ID: k4bc.2DFUsyrieMD
SysFS ID: /devices/pci0000:00/0000:00:14.0/usb1/1-1/1-1:1.0
SysFS BusID: 1-1:1.0
Hardware Class: unknown
Model: "TP-Link 802.11ac NIC"
Hotplug: USB
Vendor: usb 0x2357 "TP-Link"
Device: usb 0x0115 "802.11ac NIC"
Revision: "2.10"
Serial ID: "123456"
Speed: 480 Mbps
Module Alias: "usb:v2357p0115d0210dc00dsc00dp00icFFiscFFipFFin00"
Config Status: cfg=no, avail=yes, need=no, active=unknown
Attached to: #52 (Hub)
Somit hab ich keinen Plan mehr, wie der USB-Wlan-Adapter ans Leben kommen soll.
Wenn noch Infos fehlen, werd ich die gerne liefern.
Zuletzt geändert von warpi am 12. Feb 2019, 13:18, insgesamt 1-mal geändert.
Zufriedener 64bit Intel-i7 8-Kern Benutzer, der darauf nur Linux & sonst nix ran läßt.

Werbung:
josef-wien
Ultimate Guru
Ultimate Guru
Beiträge: 5281
Registriert: 23. Sep 2008, 17:09

Re: USB-WLAN TP-LINK wird nicht sauber erkannt

Beitrag von josef-wien » 12. Feb 2019, 12:00

https://wikidevi.com/wiki/TP-LINK_Archer_T4U_v3 hat geschrieben:USB ID not yet observed in any mainline kernel / this list
Der verwendete Chip ist ziemlich neu. Nachdem
warpi hat geschrieben:Auf der Verpackung wird die Unterstützung von Kernel 2.6.18 - 4.4 erwähnt.
nicht stimmt, würde ich das Ding zurückgeben. Ansonsten bleibt Dir nur, abzuwarten oder zu versuchen, das Kernel-Modul selbst zu bauen (den Quellcode gibt es unter "Support page", allerdings steht dort "For Linux (kernel 2.6.18 ~ 4.11)", d. h. es könnten durchaus noch Anpassungen notwendig sein).

warpi
Hacker
Hacker
Beiträge: 446
Registriert: 17. Mär 2005, 12:04
Wohnort: augsburg

Re: USB-WLAN TP-LINK wird nicht sauber erkannt

Beitrag von warpi » 12. Feb 2019, 12:10

Danke josef-wien für den Hinweis.
Werde versuchen, den Adapter zurückzugeben. Wenn man sich nicht mal mehr auf die Verpackungsbeschreibung verlassen kann, auf was denn dann?
Zufriedener 64bit Intel-i7 8-Kern Benutzer, der darauf nur Linux & sonst nix ran läßt.

josef-wien
Ultimate Guru
Ultimate Guru
Beiträge: 5281
Registriert: 23. Sep 2008, 17:09

Re: USB-WLAN TP-LINK wird nicht sauber erkannt

Beitrag von josef-wien » 12. Feb 2019, 12:18

Realistisch gesehen auf gar nichts, solange Hersteller der Unsitte huldigen, kommentarlos den verwendeten Chip auszutauschen, weil sie ohnehin einen passenden Windows-Treiber beilegen.


warpi
Hacker
Hacker
Beiträge: 446
Registriert: 17. Mär 2005, 12:04
Wohnort: augsburg

[gelöst] USB-WLAN TP-LINK wird nicht sauber erkannt

Beitrag von warpi » 12. Feb 2019, 13:15

Danke nochmal für die schnelle Hilfe. Werde mal den Umtausch versuchen. Hab bereits auf der TP-Link Webseite mich zu dem Thema geäußert.
Zufriedener 64bit Intel-i7 8-Kern Benutzer, der darauf nur Linux & sonst nix ran läßt.

Sauerland
Guru
Guru
Beiträge: 3454
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: [gelöst] USB-WLAN TP-LINK wird nicht sauber erkannt

Beitrag von Sauerland » 12. Feb 2019, 16:58

Desktop: OpenSUSE Leap 15.0, Nvidia-Grafik Kernel 4.x
Laptop: OpenSUSE Leap 15.0, Intel-Skylake, Kernel 4.12

warpi
Hacker
Hacker
Beiträge: 446
Registriert: 17. Mär 2005, 12:04
Wohnort: augsburg

Re: [gelöst] USB-WLAN TP-LINK wird nicht sauber erkannt

Beitrag von warpi » 12. Feb 2019, 18:07

Hallo Sauerland,
danke für die rpm-Adresse, leider etwas zu spät.
Hab mir den WLAN-Stick N von Fritz! besorgt.
Angesteckt-erkannt-konfiguriert-verbunden.
Der Link zum rpm wird sicherlich anderen helfen.
Nochmals danke.
Zufriedener 64bit Intel-i7 8-Kern Benutzer, der darauf nur Linux & sonst nix ran läßt.

Antworten