Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

SSD reagiert nicht mehr

Alles rund um Hardware, die unter Linux läuft oder zum Laufen gebracht werden soll

Moderator: Moderatoren

Antworten
Benutzeravatar
Mueck
Newbie
Newbie
Beiträge: 32
Registriert: 25. Jun 2010, 10:37
Wohnort: Karlsruhe

SSD reagiert nicht mehr

Beitrag von Mueck » 20. Jan 2019, 15:21

Moin

Bei meinem relativ neuen Rechner hat letzte Nacht ein laufendes Programm, das gerade auf der SSD liegende Bilder verarbeiten sollte, abgebrochen wegen Lesefehler. In der Hoffnung, es möge sich nur was verklemmt haben, Rechner versucht neu zu starten, was aber nicht wirklich gelang, weder mit dem vorinstallierten, aber nicht lizenzierten Win10, das auf der SSD liegt, noch mit dem Opensuse, das eigentlich auf der anderen klassischen Platte liegt. Im Moment läuft ein Kubuntu 18.04 Live-System von DVD. Das findet die SSD, m.E.n. eigentlich auf /dev/sda liegend, nicht, sondern verkauft mir die andere Platte als /dev/sda ...
Kann man vom Kubuntu aus irgendwas diagnostisches starten, um rauszufinden, was da los ist?

Werbung:
Benutzeravatar
Mueck
Newbie
Newbie
Beiträge: 32
Registriert: 25. Jun 2010, 10:37
Wohnort: Karlsruhe

Re: SSD reagiert nicht mehr

Beitrag von Mueck » 20. Jan 2019, 16:00

Im anscheinend auch lahmenden BIOS, bis es mal endlich da ist, ist von der SSD auch nix zu sehen.

Mit etwas mehr Geduld, als ich es anfangs hatte, kommt OpenSuse doch noch, wenn auch nur per Admin-PW im Modus "zu Wartungszwecken". Frage nach Diagnostik kann also auch darauf erweitert werden ... :roll:

josef-wien
Ultimate Guru
Ultimate Guru
Beiträge: 5339
Registriert: 23. Sep 2008, 17:09

Re: SSD reagiert nicht mehr

Beitrag von josef-wien » 20. Jan 2019, 16:16

Wenn nicht einmal das BIOS die SSD erkennt, wird bei Kubuntu die Ausgabe von

Code: Alles auswählen

dmesg | grep ata[1-9]
wohl auch keine Erkenntnisse bringen. Bei einem Desktop-PC würde ich Strom- und Datenkabel tauschen und andere Anschlüsse probieren.

Vermutlich sprichst Du bei openSUSE die SSD über die Datei /etc/fstab oder die Boot-Optionen an, und dann versucht das System natürlich auch, darauf zuzugreifen.

Benutzeravatar
Mueck
Newbie
Newbie
Beiträge: 32
Registriert: 25. Jun 2010, 10:37
Wohnort: Karlsruhe

Re: SSD reagiert nicht mehr

Beitrag von Mueck » 20. Jan 2019, 16:40

Vom OpenSuse aus bringt greppen nach ata1

Code: Alles auswählen

SATA max UDMA/133 abar m131072@0xfc80000 port 0xfc80100 irq 37
softreset failed (device not ready)     (insg. 4x)
link is slow to respond, please be patient (ready=0)
limiting SATA link speed to 3.0 Gbps
reset failed, giving up
ata2 ist die andere Platte, ata5 DVD

in der /etc/fstab soll sie gemounted werden, da ist sie per UUID=... drin

mkossmann
Member
Member
Beiträge: 175
Registriert: 3. Aug 2009, 19:07

Re: SSD reagiert nicht mehr

Beitrag von mkossmann » 22. Jan 2019, 16:09

Die Fehlerbeschreibung riecht sehr nach Hardware. Wenn also Wechseln von Kabeln und SATA-Port keine Besserung bringt, bleibt nur die SSD übrig. In diesen Fall ist die SSD aber vermutlich schon soweit defekt, das auch Diagnosetools wie smartctl die Platte nicht mehr ansprechen können.

Benutzeravatar
Jägerschlürfer
Moderator
Moderator
Beiträge: 4495
Registriert: 1. Jul 2005, 12:22
Wohnort: nahe Würzburg

Re: SSD reagiert nicht mehr

Beitrag von Jägerschlürfer » 23. Jan 2019, 08:19

ich würde auch sagen, dass die Platte das zeitliche gesegnet hat. Wenn die Kabel getauscht wurden, und das BIOS die SSD nicht mehr anzeigt, kannst du wohl nicht mehr viel machen,..
Einzig was du einmal noch machen kannst, wenn noch nicht getan, mal die Platte an einen anderen Port auf dem Mainboard anschließen. Nicht dass dieser einen defekt aufweist.

Ansonsten, nachdem es ein noch relativ neuer Rechner ist, könnte ja noch Garantie auf die Platte sein. Wenn dann noch ein Backup vorhanden ist, damit wenigstens keine Daten verloren gingen, ist die Sache doch nur halb so schlimm, oder?
>Linux-Club Foren FAQ< >LC-Wiki<

Know your enemy and know yourself Sun Tzu

Benutzeravatar
Mueck
Newbie
Newbie
Beiträge: 32
Registriert: 25. Jun 2010, 10:37
Wohnort: Karlsruhe

Re: SSD reagiert nicht mehr

Beitrag von Mueck » 8. Feb 2019, 17:23

Anderen Port habe ich noch probiert, nix. Anderes Kabel hatte ich nicht rumliegen, also zum Händler zurück und auf Garantie tauschen lassen.

Auf der Platte waren neben dem nicht bestellten und unlizenziertem Windows noch frisch gescannte Dias, von denen bisher nur 4/5 auf die andere Platte kopiert waren ... Einen Kasten also nochmal demnext ...

Benutzeravatar
Mueck
Newbie
Newbie
Beiträge: 32
Registriert: 25. Jun 2010, 10:37
Wohnort: Karlsruhe

Re: SSD reagiert nicht mehr

Beitrag von Mueck » 10. Feb 2019, 16:24

Eine Frage ist noch offen.
Mit der Ersatzplatte bootet er noch nicht wieder richtig.
Zuerst gedacht, dass er wohl noch über das nun fehlende Win10-Fragment stolpert, aber nach noch mal Bootloader auffrischen unverändert.
Die sichtbaren Meldungen kommen mir aus meinem Monitorfragenfaden bekannt vor, das damalige Problem hatte ich aber gelöst.

Code: Alles auswählen

[0.250192] ACPI BIOS Error (bug): Failure creating [\_SB.SMIC], AE_ALREADY_EXISTS (20180810/dswload2-16)
[0.250212] ACPI Error: AE_ALREADY_EXISTS, During name lookup/catalog (20180810/psobject-221)
[0.250220] ACPI BIOS Error (bug): Failure creating [\_SB.SMIB], AE_ALREADY_EXISTS (20180810/dsfield-626)
[1.077094] ACPI BIOS Error (bug): AMD-Vi: Unable to write to IOMMU perf counter.
 
- Dann:

Code: Alles auswählen

Administratorpaswort für Wartungszwecke eingeben (oder Strg+D, um fortzufahren):
Das mit IOMMU habe ich mit "amd_iommu=off" weggekriegt, hilft aber nix. Der Rest klingt irrelevant und hat alles bisher auch nicht am Booten gehindert.
Nach Strg+D scheint er zu hängen, aber nach Passworteingabe kann ich mit startx relativ normal als root weiter machen.
Ersatzplatte ist gemounted und ansprechbar.
Kernel ist 4.19.11-1.g096f733-default

Im Moment springt mir mit dmesg nix ins Auge, woran das normale booten scheitern könnte ...

josef-wien
Ultimate Guru
Ultimate Guru
Beiträge: 5339
Registriert: 23. Sep 2008, 17:09

Re: SSD reagiert nicht mehr

Beitrag von josef-wien » 10. Feb 2019, 17:21

Unaktuelle Eintragungen in /etc/fstab? Eventuell auch bei den Boot-Optionen?

Benutzeravatar
Mueck
Newbie
Newbie
Beiträge: 32
Registriert: 25. Jun 2010, 10:37
Wohnort: Karlsruhe

Re: SSD reagiert nicht mehr

Beitrag von Mueck » 10. Feb 2019, 19:43

josef-wien hat geschrieben:
10. Feb 2019, 17:21
Unaktuelle Eintragungen in /etc/fstab?
Das scheint's gewesen zu sein, da war die alte noch drin ...
Muss ich noch mal nachvollziehen, warum mir das nirgends auffiel ...

Antworten