Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Problem mit Hardwarebeschleunigung

Alles rund um Hardware, die unter Linux läuft oder zum Laufen gebracht werden soll

Moderator: Moderatoren

Antworten
Schweineschwarte
Member
Member
Beiträge: 85
Registriert: 13. Jan 2006, 16:41
Wohnort: Berlin
Kontaktdaten:

Problem mit Hardwarebeschleunigung

Beitrag von Schweineschwarte » 26. Okt 2017, 16:13

Hallo in die Runde,
ich hatte mit meinem Rechner das Problem, dass bspw. HD-Videos auf YouTube (manchmal aber auch Spiele), entweder den Browser (egal ob Firefox oder Chromium) zum Absturz brachten, X abstürzte oder der ganze Rechner sich verabschiedete. Zum Testen hatte ich dann die Hardwarebeschleunigung bei Firefox deaktiviert und seitdem scheint es keine Probleme (bei Firefox) in dieser Richtung mehr zu geben. Bei anderen Browsern bzw. Spielen treten sie aber dennoch auf.
Nun wollte ich fragen wie man die Ursache weiter orten/eingrenzen kann, um es zu beheben bzw. ggf. einen Fehlerbericht zu erstellen?
Ich weiß nicht ob es damit zu tun hat, aber scheinbar erkennen Programme eine andere Mesa-Version als ich installiert habe.
Wenn ich bspw. glmark2 starte steht dort:

Code: Alles auswählen

=======================================================
    glmark2 2014.03
=======================================================                                                                                                                           
    OpenGL Information                                                                                                                                                            
    GL_VENDOR:     X.Org                                                                                                                                                          
    GL_RENDERER:   Gallium 0.4 on AMD POLARIS12 (DRM 3.18.0 / 4.13.9-13-default, LLVM 3.8.0)
    GL_VERSION:    3.0 Mesa 17.1.8
=======================================================
Installiert ist jedoch:

Code: Alles auswählen

zypper se -si mesa
Repository-Daten werden geladen...
Installierte Pakete werden gelesen...

S  | Name                 | Typ   | Version      | Arch   | Repository
---+----------------------+-------+--------------+--------+-----------
i+ | Mesa                 | Paket | 17.1.6-720.1 | x86_64 | X11:XOrg  
i+ | Mesa-32bit           | Paket | 17.1.6-720.1 | x86_64 | X11:XOrg  
i+ | Mesa-demo-x          | Paket | 8.3.0-55.2   | x86_64 | X11:XOrg  
i+ | Mesa-libEGL1         | Paket | 17.1.6-720.1 | x86_64 | X11:XOrg  
i+ | Mesa-libEGL1-32bit   | Paket | 17.1.6-720.1 | x86_64 | X11:XOrg  
i+ | Mesa-libGL1          | Paket | 17.1.6-720.1 | x86_64 | X11:XOrg  
i+ | Mesa-libGL1-32bit    | Paket | 17.1.6-720.1 | x86_64 | X11:XOrg  
i+ | Mesa-libGLESv2-2     | Paket | 17.1.6-720.1 | x86_64 | X11:XOrg  
i+ | Mesa-libglapi0       | Paket | 17.1.6-720.1 | x86_64 | X11:XOrg  
i+ | Mesa-libglapi0-32bit | Paket | 17.1.6-720.1 | x86_64 | X11:XOrg  
i+ | Mesa-libva           | Paket | 17.1.6-720.1 | x86_64 | X11:XOrg  
i+ | libOSMesa8           | Paket | 17.1.6-720.1 | x86_64 | X11:XOrg  
i+ | libOSMesa8-32bit     | Paket | 17.1.6-720.1 | x86_64 | X11:XOrg 
Mein System:
openSUSE 42.3 64 Bit mit KDE/Plasma und Kernel 4.13
Grafikkarte:

Code: Alles auswählen

hwinfo --gfxcard
33: PCI 100.0: 0300 VGA compatible controller (VGA)             
  [Created at pci.378]
  Unique ID: VCu0.P_htqVJZrTF
  Parent ID: ruGf.18GO5eD4sl1
  SysFS ID: /devices/pci0000:00/0000:00:02.1/0000:01:00.0
  SysFS BusID: 0000:01:00.0
  Hardware Class: graphics card
  Model: "ATI Lexa PRO [Radeon RX 550]"
  Vendor: pci 0x1002 "ATI Technologies Inc"
  Device: pci 0x699f "Lexa PRO [Radeon RX 550]"
  SubVendor: pci 0x1da2 
  SubDevice: pci 0xe367 
  Revision: 0xc7
  Driver: "amdgpu"
  Driver Modules: "amdgpu"
  Memory Range: 0xc0000000-0xcfffffff (ro,non-prefetchable)
  Memory Range: 0xd0000000-0xd01fffff (ro,non-prefetchable)
  I/O Ports: 0xe000-0xefff (rw)
  Memory Range: 0xfea00000-0xfea3ffff (rw,non-prefetchable)
  Memory Range: 0x000c0000-0x000dffff (rw,non-prefetchable,disabled)
  IRQ: 38 (1127974 events)
  I/O Ports: 0x3c0-0x3df (rw)
  Module Alias: "pci:v00001002d0000699Fsv00001DA2sd0000E367bc03sc00i00"
  Driver Info #0:
    Driver Status: amdgpu is active
    Driver Activation Cmd: "modprobe amdgpu"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #32 (PCI bridge)

Primary display adapter: #33
Kernel:

Code: Alles auswählen

zypper se -si kernel
Repository-Daten werden geladen...
Installierte Pakete werden gelesen...

S  | Name                 | Typ   | Version      | Arch   | Repository            
---+----------------------+-------+--------------+--------+-----------------------
i+ | kernel-default       | Paket | 4.13.9-12.1  | x86_64 | (Systempakete)        
i+ | kernel-default       | Paket | 4.13.9-13.1  | x86_64 | home:ithod:kernel     
i+ | kernel-default-devel | Paket | 4.13.9-12.1  | x86_64 | (Systempakete)        
i+ | kernel-default-devel | Paket | 4.13.9-13.1  | x86_64 | home:ithod:kernel     
i+ | kernel-devel         | Paket | 4.13.9-12.1  | noarch | (Systempakete)        
i+ | kernel-devel         | Paket | 4.13.9-13.1  | noarch | home:ithod:kernel     
i+ | kernel-firmware      | Paket | 20170530-9.1 | noarch | openSUSE-Leap-42.3-Oss
i+ | kernel-firmware      | Paket | 20170530-9.1 | noarch | openSUSE-Leap-42.3-0  
i+ | kernel-macros        | Paket | 4.13.9-13.1  | noarch | home:ithod:kernel  
Vielen Dank für eure Hilfe! :)

Werbung:
spoensche
Moderator
Moderator
Beiträge: 7338
Registriert: 30. Okt 2004, 23:53
Wohnort: Siegen

Re: Problem mit Hardwarebeschleunigung

Beitrag von spoensche » 29. Okt 2017, 00:25

Wenn der Browser bei Spielen abstürzt, dann kannst du in 90% der Fälle davon ausgehen, dass es mit dem Flash- Plugin zusammen hängt. Der Browser ist dann nicht der Schuldige.
Ob ein Spiel das Flash-Plugin verwendet kannst du mit einem Rechtsklick auf das Spiel herausfinden.

Videos von Youtube verwenden HTML5 für die Video Controlls. Da könnte es evtl. mit DRM zusammen hängen.

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 4 Gäste