[gelöst] Leap 42.2 kennt Scanner CANON Lide 25 nicht

Alles rund um Hardware, die unter Linux läuft oder zum Laufen gebracht werden soll

Moderator: Moderatoren

bayernherz
Hacker
Hacker
Beiträge: 441
Registriert: 5. Nov 2011, 20:27
Wohnort: in Oberbayern

Re: Leap 42.2 kennt Scanner CANON Lide 25 nicht

Beitrag von bayernherz » 17. Mär 2017, 18:17

hallo community,

root Terminal

Code: Alles auswählen

yast2 scanner
nach den beide Fehlermeldungen, siehe nachfolgenden Link
http://susepaste.org/82367754
http://susepaste.org/42294425
habe ich über den Button Edit den Canon Lide 25 ausgewählt.
Nach anschliessender Bestätigung war der Scanner Type nicht eingetragen, siehe folgenden Link
http://susepaste.org/84658156
/etc/sane.d/dll.conf

Code: Alles auswählen

#lexmark
#ma1509
#magicolor
#matsushita
#microtek
#microtek2
#mustek
#mustek_pp
#mustek_usb
#mustek_usb2
#nec
#niash
#p5
#pie
#pint
#pixma
plustek
#plustek_pp
#pnm
#qcam
#ricoh
#rts8891
#s9036
#sceptre
#sharp
#sm3600
#sm3840
#snapscan
#sp15c
#st400
#stv680
#tamarack
#teco1
#teco2
#teco3
#test
#u12
#umax
#umax_pp
#umax1220u
#v4l
#xerox_mfp
hpaio
Auffällig ist, das nach jeder Konfig mit YAST2 scanner wieder die letzte Zeile hpaio in der Datei
eingetragen wird, Selbst, wenn ich diese vor der Konfiguration auskommentiert habe.

Hat das ganze etwar doch mit HPLIP zu tun, welches in der Taskleiste steht ?

Bei Aufruf von xsane wird der Scanner ewige Zeit gesucht und dann abegbrochen. :igitt:

gruss
bayernherz :thumbs:

Werbung:
Sauerland
Guru
Guru
Beiträge: 2671
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: Leap 42.2 kennt Scanner CANON Lide 25 nicht

Beitrag von Sauerland » 17. Mär 2017, 18:39

So lange der Scanner nicht eingerichtet ist, kannst du mit irgendeinem Scanprogramm gar nichts machen.

Du hast also den Canon Scanner in Yast markiert und dann auf edit gedrückt?
Wenn ja, was passiert?
Es sollte eigentlich so etwas wie "anlegen der Scanner Datenbank" erscheinen.
Desktop: OpenSUSE Leap 42.2, Nvidia-Grafik Kernel 4.4
Laptop: OpenSUSE Leap 42.1, ATI-Grafik (Radeon-Treiber)
Laptop: OpenSUSE Leap 42.2, Intel-Skylake, Kernel 4.x

Benutzeravatar
Heinz-Peter
Guru
Guru
Beiträge: 1853
Registriert: 24. Okt 2005, 14:04

Re: Leap 42.2 kennt Scanner CANON Lide 25 nicht

Beitrag von Heinz-Peter » 17. Mär 2017, 18:43

habe ich über den Button Edit den Canon Lide 25 ausgewählt.
Nach anschliessender Bestätigung war der Scanner Type nicht eingetragen,
Hier kannst jetzt die Treiber auswählen und installieren. Eine einfache Bestätigung bringt gar nichts.

Edit: Ich bin langsamer geworden, oder der @Sauerland ist für mich zu schnell ;)
Mein Betriebssystem: Suse 13.2/13.1, Prozessor: Pentium 4 550 (3,40 GHz, FSB800, Hyper-Threading), Grafikkarte: Nvidia Geforce 6610XL (PCIe)/128MByte.
Wir müssen lernen, entweder als Brüder miteinander zu leben oder als Narren unterzugehen.

bayernherz
Hacker
Hacker
Beiträge: 441
Registriert: 5. Nov 2011, 20:27
Wohnort: in Oberbayern

Re: Leap 42.2 kennt Scanner CANON Lide 25 nicht

Beitrag von bayernherz » 17. Mär 2017, 19:28

hallo community,
Sauerland hat geschrieben:
Du hast also den Canon Scanner in Yast markiert und dann auf edit gedrückt?
Wenn ja, was passiert?
Anzeige von:
Scanner Modul and Driver Selection
1. Auswahl von:
Canon CanonScan LIDE25: (Package sane-backends) Driver pulstek sould provide good functionality (USB-ID 0x4a9-0x2220)
2. Betätigung von Button: Next

Statusanzeige:
Determine active scanners -> bleibt sehr lange stehen

keine weiteren Meldung

Anzeige von Seite: Initializing Scanner Configuration
Markierter Driver: not configured Canon canonScan USB scanner ...


Betätigung von Button: ok

kurze Anzeige: save activ driver

gruss
bayernherz :thumbs:

bayernherz
Hacker
Hacker
Beiträge: 441
Registriert: 5. Nov 2011, 20:27
Wohnort: in Oberbayern

Re: Leap 42.2 kennt Scanner CANON Lide 25 nicht

Beitrag von bayernherz » 18. Mär 2017, 10:44

hallo community,

bin gerade wieder mit meinem PCLinuxOS 2017 mit KDE 5.8.6 unterwegs, um Referenztests bezüglich Scanner durchzuführen.
PCLinuxOS verwendet den Kernel 4.9.13-pclos1
Habe den Scanner mit dem Tool Configure your Computer, Hardware, Setup Scanner manuell eingerichtet,
da die automatische Erkennung ebenfalls hin. Der Scanner lief auf Anhieb. :-P
Allerdings konnte ich das Tool xsane zum Scannen auch nicht benutzen, da es den Scanner nicht gefunden hat.
Allerdings Skanlite funktioniert bestens.
Wenn Ihr zur Diagnose was aus den System braucht, bitte melden, da ich es sonst wieder umbaue auf Leap 42.3
(Dazu muss ich immer den halben Laptop zerlegen, um die HDD zu tauschen)

viele grüsse aus dem morgendliche Oberbayern
vom bayernherz :thumbs:

Benutzeravatar
Alero
Member
Member
Beiträge: 208
Registriert: 28. Nov 2016, 16:20
Wohnort: Gera, Ost-Thüringen

Re: Leap 42.2 kennt Scanner CANON Lide 25 nicht

Beitrag von Alero » 18. Mär 2017, 14:49

42.3 ??

Gesendet von meinem SM-T530


bayernherz
Hacker
Hacker
Beiträge: 441
Registriert: 5. Nov 2011, 20:27
Wohnort: in Oberbayern

Re: Leap 42.2 kennt Scanner CANON Lide 25 nicht

Beitrag von bayernherz » 18. Mär 2017, 17:41

hallo community,

habe vielleicht eine wertvolle Erkenntnis mit PCLinuxOS erworben.
Bei Aufruf vom Scannprogramm Skanlite nach einem Neustart erscheint nachfolgende Meldung in einem Popup-Fenster:

Code: Alles auswählen

The following scanners

  -  Noname HD WebCam virtual device
  -  Canon CanoScan LiDE25 flatbed scanner

are available on your system. 
Die WebCam kann auch einwandfrei von Skanlite bedient werden.
Nur findet das Programm nach einem weiteren Start weder WebCam noch Scanner.
Dieses ist erst wieder nach einem erneutetem Setup Scanners mit Config my computer möglich.

Warscheinlich spukt uns dieses virtual device: HD WebCan auch in unser YAST2 scanner hinein.
So jetzt ist die Frage: Was tut sprach Zeus, die Götter sind besoffen und der Olymp der kotzt
Neuinstallation wegen totaler verkonfiguration oder weiterdebuggen?
Gerne warte ich auf euere Tipps und Vorschläge. :roll:

viele grüsse aus dem spatnachmittaglichen Oberbayern
vom bayernherz :thumbs:

bayernherz
Hacker
Hacker
Beiträge: 441
Registriert: 5. Nov 2011, 20:27
Wohnort: in Oberbayern

Re: Leap 42.2 kennt Scanner CANON Lide 25 nicht

Beitrag von bayernherz » 19. Mär 2017, 17:27

Hallo community,
mit dem Test PCLinuxOS habe ich jetzt aber nachgewiesen, das der ACER - Notebook mit meinem CANON Scanner LIDE 25 zusammen funktionieren kann.

Fazit:
Das Problem kann jetzt eigentlich nur noch meiner Meinung an den nachfolgenden 2 Punkten liegen:
1. Das openSuse Leap 42.2 OS ist kaputt konfiguriert worden.

2. Es ist ein openSuSe Leap 42.2 Problem.

Lösungen zu Pkt.
1. Neuinstallation
2. ???

Würde mich über Euere Unterstützung sehr freuen.
PCLinuxOS ist für mich nicht so das Thema, da es nur sehr schwer bis garnicht möglich ist, darauf das Qt-Entwicklungssystem zum Laufen zu bringen. Und das ist für mich ein nogo.

viele grüsse aus den sonntaglichen Oberbaye
vom bayernherz :thumbs:

Benutzeravatar
susejunky
Hacker
Hacker
Beiträge: 355
Registriert: 19. Sep 2014, 18:22

Re: Leap 42.2 kennt Scanner CANON Lide 25 nicht

Beitrag von susejunky » 20. Mär 2017, 16:09

Hallo bayernherz,
bayernherz hat geschrieben:
19. Mär 2017, 17:27
... Das openSuse Leap 42.2 OS ist kaputt konfiguriert worden. ... Lösungen Neuinstallation ???
das sollte meines Erachtens nicht notwendig sein. Ein Löschen der fehlerhaften Scanner-Konfiguration sollte ausreichen.

Wenn Dein Scanner (unter openSUSE 42.2) korrekt eingerichtet ist, dann sollten auf Deinem System die folgenden Dateien vorhanden sein:
  • /etc/sane.d/dll.conf
    In dieser Datei sollte nur der Eintrag "plustek" NICHT auskommentiert (d.h. kein vorangestelltes "#") sein (in Deinem Beitrag vom 17.03.2017, 18:17 war das auch so).
  • /etc/sane.d/plustek.conf
    Diese Datei sollte vorhanden sein. Ob und ggf. wie Du deren Inhalt noch anpassen musst, kann ich Dir allerdings nicht sagen (da ich einen anderen Scanner nutze).
  • /etc/udev/rules.d/55-libsane.rules
    In dieser Datei sollte folgender Eintrag zu finden sein:

    Code: Alles auswählen

    # Canon CanoScan LiDE25
    ATTR{idVendor}=="04a9", ATTR{idProduct}=="2220", MODE="0664", GROUP="lp", ENV{libsane_matched}="yes"
  • /etc/udev/rules.d/56-sane-backends-autoconfig.rules
    In dieser Datei sollte folgender Eintrag zu finden sein:

    Code: Alles auswählen

    ATTR{idVendor}=="04a9", ATTR{idProduct}=="2220", ENV{sane_backend_plustek}="yes"
Sind diese Dateien und die genannten Inhalte bei Dir vorhanden?

Ich kenne zwar PCLinuxOS nicht, aber eventuell wird die Scanner-Konfiguration dort auch mit diesen Dateien durchgeführt; d.h. Du könntest die Datei-Inhalte zwischen PCLinuxOS und openSUSE ggf.abgleichen.

Viele Grüße

susejunky

josef-wien
Guru
Guru
Beiträge: 4765
Registriert: 23. Sep 2008, 17:09

Re: Leap 42.2 kennt Scanner CANON Lide 25 nicht

Beitrag von josef-wien » 20. Mär 2017, 17:24

bayernherz hat geschrieben:
19. Mär 2017, 17:27
2. Es ist ein openSuSe Leap 42.2 Problem.
Daß diese Möglichkeit nicht zutrifft, hast Du in Deinem Eröffnungsbeitrag geschrieben.

Wenn ich eine Möglichkeit an den Haaren herbeiziehe, fällt mir ein Interrupt-Konflikt ein. Was ergeben:

Code: Alles auswählen

cat /proc/interrupts

Code: Alles auswählen

/sbin/udevadm info --export-db | grep -C30 libsane_matched
Scheint
bayernherz hat geschrieben:
18. Mär 2017, 17:41
Noname HD WebCam virtual device
unter lspci oder unter lsusb auf?

P. S. Die openSUSE-Datei /etc/udev/rules.d/55-libsane.rules entspricht bei PCLinuxOS /lib/udev/rules.d/60-libsane.rules, so etwas wie /etc/udev/rules.d/56-sane-backends-autoconfig.rules gibt es nicht (und solange mir nicht jemand deren sed-Befehl erklärt, zweifle ich an der Notwendigkeit dieser Datei).

bayernherz
Hacker
Hacker
Beiträge: 441
Registriert: 5. Nov 2011, 20:27
Wohnort: in Oberbayern

Re: Leap 42.2 kennt Scanner CANON Lide 25 nicht

Beitrag von bayernherz » 22. Mär 2017, 12:50

hallo community,

Entschuldigung, das ich mich erst jetzt wieder melde, aber ich habe einige Tage nicht ins Forum geschaut.
josef-wien hat geschrieben:
bayernherz hat geschrieben: ↑
9. Mär 2017, 17:27
2. Es ist ein openSuSe Leap 42.2 Problem.
Daß diese Möglichkeit nicht zutrifft, hast Du in Deinem Eröffnungsbeitrag geschrieben.
Ich muss mich hier leider korregieren:
Ich verwende auf meinem Desktop das openSuSE Leap 42.1
Entschuldigung.
Der Scanner läuft hier mit xsane, aber mitunter auch etwas stoperich. D.h. Der Scanner wird im gray-modus
immer gefunden u. im color-modus kommt es auch zu Problemen. Aber mitunter kommt es auch im gray-modus zu scan Abbrüchen.
Das war nicht immer so, hat sich im Laufe der Zeit mit den Update so eingeschlichen. Kann man aber sooo mit leben.
susejunky hat geschrieben:
Wenn Dein Scanner (unter openSUSE 42.2) korrekt eingerichtet ist, dann sollten auf Deinem System die folgenden Dateien vorhanden sein:

/etc/sane.d/dll.conf
In dieser Datei sollte nur der Eintrag "plustek" NICHT auskommentiert (d.h. kein vorangestelltes "#") sein (in Deinem Beitrag vom 17.03.2017, 18:17 war das auch so).
Es sind zwei Einträge auskommentiert:

Code: Alles auswählen

plustek
hpaio
susejunky hat geschrieben:
/etc/udev/rules.d/55-libsane.rules
In dieser Datei sollte folgender Eintrag zu finden sein:

Code: Alles auswählen

# Canon CanoScan LiDE25
ATTR{idVendor}=="04a9", ATTR{idProduct}=="2220", MODE="0664", GROUP="lp", ENV{libsane_matched}="yes
Inhalt von meiner etc/udev/rules.d/55-libsane.rules

Code: Alles auswählen

# Canon CanoScan LiDE25
ATTR{idVendor}=="04a9", ATTR{idProduct}=="2220", MODE="0664", GROUP="lp", ENV{libsane_matched}="yes"
susejunky hat geschrieben:
/etc/udev/rules.d/56-sane-backends-autoconfig.rules
In dieser Datei sollte folgender Eintrag zu finden sein:

Code: Alles auswählen

ATTR{idVendor}=="04a9", ATTR{idProduct}=="2220", ENV{sane_backend_plustek}="yes"
Inhalt von meiner /etc/udev/rules.d/56-sane-backends-autoconfig.rules

Code: Alles auswählen

ATTR{idVendor}=="04a9", ATTR{idProduct}=="2220", ENV{sane_backend_plustek}="yes"
Fazit: Die Einträge beider Dateien sind identisch.
Anmerkung:

Code: Alles auswählen

yast2 scanner
wird nicht korrekt beendet.
Ich bin ja der Meinung, das die Ursache der lauferende HP Device Manager ist, der auch in der KDE Taskleiste steht.
Und dieser HP Device Manager lief unter PCLinuxOS nicht.
Weiterhin funktionierte unter PCLinuxOS xsane ebenfalls nicht. Ich habe dort Skanlite verwendet.

Nachfolgend noch einige Diagnose, die josef-wien gern gesehen hätte:
Alle Diagnose wurden im root Termianl durchgeführt.

Code: Alles auswählen

lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 0bda:57f2 Realtek Semiconductor Corp. 
Bus 001 Device 003: ID 0489:e0a3 Foxconn / Hon Hai 
Bus 001 Device 007: ID 04a9:2220 Canon, Inc. CanoScan LIDE 25
Bus 001 Device 006: ID 046d:c404 Logitech, Inc. TrackMan Wheel
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Code: Alles auswählen

lspci
00:00.0 Host bridge: Intel Corporation Skylake Host Bridge/DRAM Registers (rev 09)
00:02.0 VGA compatible controller: Intel Corporation Device 1927 (rev 0a)
00:14.0 USB controller: Intel Corporation Sunrise Point-LP USB 3.0 xHCI Controller (rev 21)
00:14.2 Signal processing controller: Intel Corporation Sunrise Point-LP Thermal subsystem (rev 21)
00:15.0 Signal processing controller: Intel Corporation Sunrise Point-LP Serial IO I2C Controller #0 (rev 21)
00:16.0 Communication controller: Intel Corporation Sunrise Point-LP CSME HECI #1 (rev 21)
00:17.0 SATA controller: Intel Corporation Sunrise Point-LP SATA Controller [AHCI mode] (rev 21)
00:1d.0 PCI bridge: Intel Corporation Device 9d18 (rev f1)
00:1d.2 PCI bridge: Intel Corporation Device 9d1a (rev f1)
00:1d.3 PCI bridge: Intel Corporation Device 9d1b (rev f1)
00:1f.0 ISA bridge: Intel Corporation Sunrise Point-LP LPC Controller (rev 21)
00:1f.2 Memory controller: Intel Corporation Sunrise Point-LP PMC (rev 21)
00:1f.3 Audio device: Intel Corporation Sunrise Point-LP HD Audio (rev 21)
00:1f.4 SMBus: Intel Corporation Sunrise Point-LP SMBus (rev 21)
02:00.0 Network controller: Qualcomm Atheros Device 0042 (rev 31)
03:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. Device 5287 (rev 01)
03:00.1 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 12)

Code: Alles auswählen

cat /proc/interrupts
            CPU0       CPU1       CPU2       CPU3       
   0:         23          0          0          0  IR-IO-APIC    2-edge      timer
   1:          4          2        106          2  IR-IO-APIC    1-edge      i8042
   8:          0          0          1          0  IR-IO-APIC    8-edge      rtc0
   9:          4          0          0         13  IR-IO-APIC    9-fasteoi   acpi
  12:        494        401      11545        262  IR-IO-APIC   12-edge      i8042
  16:          0          0          0          0  IR-IO-APIC   16-fasteoi   idma64.0, i801_smbus, i2c_designware.0
 120:          0          0          0          0  DMAR-MSI    0-edge      dmar0
 121:          0          0          0          0  DMAR-MSI    1-edge      dmar1
 122:          0          0          0          0  IR-PCI-MSI 475136-edge      PCIe PME
 123:          7          0          0          0  IR-PCI-MSI 479232-edge      aerdrv, PCIe PME
 124:          0          0          0          0  IR-PCI-MSI 481280-edge      aerdrv, PCIe PME
 125:       5317      13547       4307       2600  IR-PCI-MSI 376832-edge      ahci[0000:00:17.0]
 126:       1173          1       8434          0  IR-PCI-MSI 327680-edge      xhci_hcd
 127:         14          0          0          0  IR-PCI-MSI 1572864-edge      rtsx_pci
 128:        103         17         65      20287  IR-PCI-MSI 32768-edge      i915
 129:         34          0          0          0  IR-PCI-MSI 360448-edge      mei_me
 130:          7          3        361          3  IR-PCI-MSI 1574912-edge      eth0
 131:         11          0          6          0  IR-PCI-MSI 1048576-edge      ath10k_pci
 132:       1267          8          3          0  IR-PCI-MSI 514048-edge      snd_hda_intel:card0
 NMI:          1          0          0          0   Non-maskable interrupts
 LOC:      13218      12853      12441      12942   Local timer interrupts
 SPU:          0          0          0          0   Spurious interrupts
 PMI:          1          0          0          0   Performance monitoring interrupts
 IWI:          0          0          0          0   IRQ work interrupts
 RTR:          3          0          0          0   APIC ICR read retries
 RES:       3097       2675       1915       2304   Rescheduling interrupts
 CAL:       1280       1218       1849       1597   Function call interrupts
 TLB:        151         97        199        123   TLB shootdowns
 TRM:          0          0          0          0   Thermal event interrupts
 THR:          0          0          0          0   Threshold APIC interrupts
 DFR:          0          0          0          0   Deferred Error APIC interrupts
 MCE:          0          0          0          0   Machine check exceptions
 MCP:          3          3          3          3   Machine check polls
 ERR:          0
 MIS:          0
 PIN:          0          0          0          0   Posted-interrupt notification event
 PIW:          0          0          0          0   Posted-interrupt wakeup event

Code: Alles auswählen

/sbin/udevadm info --export-db | grep -C30 libsane_matched
P: /devices/pci0000:00/0000:00:14.0/usb1/1-4
N: bus/usb/001/007
E: BUSNUM=001
E: DEVNAME=/dev/bus/usb/001/007
E: DEVNUM=007
E: DEVPATH=/devices/pci0000:00/0000:00:14.0/usb1/1-4
E: DEVTYPE=usb_device
E: DRIVER=usb
E: ID_BUS=usb
E: ID_FOR_SEAT=usb-pci-0000_00_14_0-usb-0_4
E: ID_MODEL=CanoScan
E: ID_MODEL_ENC=CanoScan
E: ID_MODEL_FROM_DATABASE=CanoScan LIDE 25
E: ID_MODEL_ID=2220
E: ID_PATH=pci-0000:00:14.0-usb-0:4
E: ID_PATH_TAG=pci-0000_00_14_0-usb-0_4
E: ID_REVISION=0100
E: ID_SERIAL=Canon_CanoScan
E: ID_USB_INTERFACES=:ff00ff:
E: ID_VENDOR=Canon
E: ID_VENDOR_ENC=Canon
E: ID_VENDOR_FROM_DATABASE=Canon, Inc.
E: ID_VENDOR_ID=04a9
E: MAJOR=189
E: MINOR=6
E: PRODUCT=4a9/2220/100
E: SUBSYSTEM=usb
E: TAGS=:seat:uaccess:
E: TYPE=255/0/255
E: USEC_INITIALIZED=289840377
E: libsane_matched=yes
E: sane_backend_plustek=yes

P: /devices/pci0000:00/0000:00:14.0/usb1/1-4/1-4:1.0
E: DEVPATH=/devices/pci0000:00/0000:00:14.0/usb1/1-4/1-4:1.0
E: DEVTYPE=usb_interface
E: ID_MODEL_FROM_DATABASE=CanoScan LIDE 25
E: ID_USB_CLASS_FROM_DATABASE=Vendor Specific Class
E: ID_VENDOR_FROM_DATABASE=Canon, Inc.
E: INTERFACE=255/0/255
E: MODALIAS=usb:v04A9p2220d0100dcFFdsc00dpFFicFFisc00ipFFin00
E: PRODUCT=4a9/2220/100
E: SUBSYSTEM=usb
E: TYPE=255/0/255
E: USEC_INITIALIZED=289848653

P: /devices/pci0000:00/0000:00:14.0/usb1/1-5
N: bus/usb/001/003
E: BUSNUM=001
E: DEVNAME=/dev/bus/usb/001/003
E: DEVNUM=003
E: DEVPATH=/devices/pci0000:00/0000:00:14.0/usb1/1-5
E: DEVTYPE=usb_device
E: DRIVER=usb
E: ID_BUS=usb
E: ID_FOR_SEAT=usb-pci-0000_00_14_0-usb-0_5
E: ID_MODEL=e0a3
E: ID_MODEL_ENC=e0a3
E: ID_MODEL_ID=e0a3
E: ID_PATH=pci-0000:00:14.0-usb-0:5
E: ID_PATH_TAG=pci-0000_00_14_0-usb-0_5
Gespannt warte ich auf Eure Anworten.

viele grüsse aus dem mittaglichen Oberbayern
vom bayernherz :thumbs:

Nachtrag: 22.032017 15:00
Habe nochmals eine Konfiguration mit

Code: Alles auswählen

yast2 scanner
durchgeführt, allerdings habe ich jetzt den Scanner an einer USB3 Buchse angesteckt.
Und die Konfiguration ist durchgelaufen.
Die USB3 - Buchse habe ich bislang nicht benutzt, weil bei meinem Desktop mit openSuSE grundsätzlich nur eine USB2-Buchse funktioniert hat. Allerdings ist mir dann bei meinem PCLinuxOs-20117 aufgefallen, das auch die USB3 - Buchse funktioniert.

Das Scannen mit Leap 42.2 funktioniert bislang auch mit Skanlite nicht.
In der /etc/scane.d/dll.conf wird immer wieder der Eintrag: hpaio hinzugefügt, auch wenn ich ihn manuell entferne.
Ich bin immer noch der Meinung das ist dem HP Device Manager zu verdanken, der deaktiviert werden müsste.

Benutzeravatar
susejunky
Hacker
Hacker
Beiträge: 355
Registriert: 19. Sep 2014, 18:22

Re: Leap 42.2 kennt Scanner CANON Lide 25 nicht

Beitrag von susejunky » 22. Mär 2017, 16:18

Hallo bayernherz,

vorab erst ein "disclaimer" meinerseits: Ich nutze einen CanoScan 700 LiDE (sane-backend: "genesys") unter openSUSE 42.2 (Kernel 4.10.4, sane-backends 1.0.24-4.40) und verwende xsane (0.998-26.5) zum Scannen. Meine Konfiguration ist also nur bedingt mit der Deinen vergleichbar und ich kann die von Dir geschilderten Probleme bei mir nicht nachstellen.

Der HP-Devicemanager (hplip 3.16.5-1.5) ist bei mir ebenfalls aktiv, da ich einen in meinem Netzwerk verfügbaren HP-Drucker (nur Drucker, kein Drucker-Scanner-Kombigerät!) verwende. Der Eintrag "hpaio" in "/etc/sane.d/dll.conf" hat bei mir keinerlei Einfluss auf die Funktion meines Scanners. Nur um nicht bei jedem xsane-Aufruf die Fehlermeldung http://susepaste.org/82367754 zu erhalten, habe ich den Eintrag auskommentiert.

Leider konnte ich Deiner letzten Antwort nicht entnehmen, ob bei Dir die Konfigurationsdatei "/etc/sane.d/plustek.conf" vorhanden ist. Ohne die wird Dein Scanner sehr wahrscheinlich nicht genutzt werden können. Eventuell muss auch deren Inhalt noch angepasst werden.

Auch ich hatte in der Vergangenheit wiederholt (nahezu bei jedem Releasewechsel) Probleme mit der Inbetriebnahme bzw. dem Betrieb meines Scanners. Hier meine Erfahrungen (die bei Deiner Konfiguration ggf. nur bedingt verwertbar sind):
  • Dokumentation & Co.
    In der openSUSE-Supportdatenbank gibt es einen Beitrag zu dem Thema Scanner: https://en.opensuse.org/SDB:Configuring_Scanners
    Gezielte Unterstützung zu SANE erhält man in der sane-devel-mailingliste
    Anmeldung: http://lists.alioth.debian.org/cgi-bin/ ... sane-devel
    Archiv (auch ohne Anmeldung einsehbar): http://lists.alioth.debian.org/pipermail/sane-devel/
  • USB 2.0/3.0
    Mein Scanner verfügt über eine USB 2.0 Schnittstelle. Verbinde ich ihn mit einer USB 3.0-Buchse meines Rechners, so kommt es zu Problemen. Daher betreibe ich meinen Scanner nur direkt (ohne Hub) an einer USB 2.0-Buchse meines Rechners. Ich kann mich wage erinnern, dass es Probleme mit SANE an USB 3.0 inkl. eines workarounds gibt/gab. Da kann Dir ggf. die Suchmaschine Deines Vertrauens weiterhelfen.
  • Fehlermeldungen beim Scannen
    Wie bereits gesagt, verwende ich xsane zum Scannen. Es kommt des öfteren vor, dass der Scan-Vorgang nicht startet und statt dessen eine Fehlermeldung ("... ungültiger Parameter ..." o.ä.) angezeigt wird. Verändere ich daraufhin einen der Scan-Parameter (z.B. erhöhe die Helligkeit und stelle sie wieder auf den ursprünglichen Wert zurück) funktioniert der nächste Scan-Vorgang wieder problemlos.
  • Lange Verzögerung beim Starten eines Scan-Vorgangs
    In seltenen Fällen dauert es bis zu ca. 30 sec. nach drücken des Scan-Buttons, bis der Scan-Vorgang beginnt.
Vielleicht kannst Du Dein Problem lösen, indem Du eine aktuellere SANE-Version verwendest. Dazu kannst Du wie folgt vorgehen:
  1. in YaST konfigurierte Scanner löschen
  2. in YaST alle sane-xxx-Pakete deinstallieren
  3. alle Dateien im Verzeichnis /etc/sane.d/ löschen
  4. die Datei /etc/udev/rules.d/55-libsane.rules löschen
  5. die Datei /etc/udev/rules.d/56-sane-backends-autoconfig.rules löschen
  6. in YaST das Repository http://download.opensuse.org/repositori ... Leap_42.2/ einbinden und SANE aus diesem Repository installieren
Sollte das auch noch nicht weiterhelfen, dann kannst Du auch die aktuellste Version von hier "git://anonscm.debian.org/git/sane/sane-backends.git" selbst kompilieren und installieren.

Viele Grüße

susejunky

bayernherz
Hacker
Hacker
Beiträge: 441
Registriert: 5. Nov 2011, 20:27
Wohnort: in Oberbayern

Re: Leap 42.2 kennt Scanner CANON Lide 25 nicht

Beitrag von bayernherz » 22. Mär 2017, 16:54

hallo community,

erstmal vielen Dank für Deine ausführliche Antwort susejunky. :-P :-P :-P
Arbeiten wir die Punkte der Reihe nach ab.
susejunky hat geschrieben:
Leider konnte ich Deiner letzten Antwort nicht entnehmen, ob bei Dir die Konfigurationsdatei "/etc/sane.d/plustek.conf"
Entschuldigung habe ich übersehen. Aber ich denke die wurde erst erzeugt.
pulstek.conf

Code: Alles auswählen

# Plustek-SANE Backend configuration file
# For use with LM9831/2/3 based USB scanners
#

# each device needs at least two lines:
# - [usb] vendor-ID and product-ID
# - device devicename
# i.e. for Plustek (0x07B3) UT12/16/24 (0x0017)
# [usb] 0x07B3 0x0017
# device /dev/usbscanner
# or
# device libusb:bbb:ddd
# where bbb is the busnumber and ddd the device number
# make sure that your user has access to /proc/bus/usb/bbb/ddd
#
# additionally you can specify some options
# warmup, lOffOnEnd, lampOff
#
# For autodetection use
# [usb]
# device /dev/usbscanner
#
# or simply
# [usb]
#
# or if you want a specific device but you have no idea about the
# device node or you use libusb, simply set vendor- and product-ID
# [usb] 0x07B3 0x0017
# device auto
#
# NOTE: autodetection is safe, as it uses the info it got
#       from the USB subsystem. If you're not using the
#       autodetection, you MUST have attached that device
#       at your USB-port, that you have specified...
#

[usb]

#
# options for the previous USB entry
#
# switch lamp off after xxx secs, 0 disables the feature
# (can also be set via frontend)
option lampOff 300

# warmup period in seconds, 0 means no warmup, -1 means auto-warmup
# (can also be set via frontend)
option warmup -1

# 0 means leave lamp-status untouched, not 0 means switch off
# on sane_close
# (can also be set via frontend)
option lOffOnEnd 1

#
# options to tweak the image start-position
# (WARNING: there's no internal range check!!!)
#
# for the normal scan area
#
option posOffX 0
option posOffY 0

# for transparencies
option tpaOffX 0
option tpaOffY 0

# for negatives
option negOffX 0
option negOffY 0

#
# for setting the calibration strip position
# (WARNING: there's no internal range check!!!)
# -1 means use built in
# (can also be set via frontend)
option posShadingY -1
option tpaShadingY -1
option negShadingY -1

#
# to invert the negatives, 0 disables the feature
#
option invertNegatives 0

#
# to disable the internal sensor speedup function, 
# 1 disables the feature
#
option disableSpeedup 0

#
# to save/restore coarse calibration data
# (can also be set via frontend)
option cacheCalData 0

#
# use alternate calibration routines
#
option altCalibration 0

#
# for skipping whole calibration step
#
option skipCalibration 0

#
# for skipping entire fine calibration step
# coarse calibration is done
#
option skipFine 0

#
# discard the result of the fine white calibration
#
option skipFineWhite 0

#
# some scanners have a dark calibration strip, in
# general this one should be used for calibration.
# As this could cause some trouble, this option
# overrides that and the dark calibration will be
# done by switching the lamp off
#
option skipDarkStrip 0

# for replacing the gain values found during coarse
# calibration
# (can also be set via frontend)
option red_gain   -1
option green_gain -1
option blue_gain  -1

# for replacing the offset values found during coarse
# calibration
# (can also be set via frontend)
option red_offset   -1
option green_offset -1
option blue_offset  -1

#
# for replacing the default lampoff settings, this
# works only for CIS devices like CanoScan LiDE20
# (can also be set via frontend)
option red_lampoff   -1
option green_lampoff -1
option blue_lampoff  -1

#
# for adjusting the default gamma values
# (can also be set via frontend)
option redGamma         1.0
option greenGamma       1.0
option blueGamma        1.0
option grayGamma        1.0

#
# to enable TPA (EPSON or UMAX, if autodetection fails)
# 0 means default behaviour as specified in the internal tables
# 1 means enable (needed for UMAX 3450)
option enableTPA 0

#
# model override functionality, currently only available for
# Mustek devices, using NSCs' vendor ID: 0x0400 and
# also their product ID: 0x1000 (LM9831) 0x1001 (LM9832)
#
# mov/PID    |    0x1000   |   0x1001
# ---------------------------------------
# 0 (default)| BearPaw1200 | BearPaw 2400
# 1          |   ignored   | BearPaw 1200
#
option mov 0

#
# and of course the device-name
#
# device /dev/usbscanner
device auto

#
# to define a new device, start with a new section:
# [usb] 
#
Wie gesagt Skanlite sucht unendlich lange und startet erst, wenn mann den USB-Stecker wieder abzieht
und meldet dann beim Scann-Start irgendetwas mit I/O-Error. Ist aber klar, da der Scanner ja wieder abgesteckt wurde.
Und wie gesagt, eine Konfiguration mit

Code: Alles auswählen

YAST2 scanner
hat nur mit USB3 funktioniert.
Auch gegen meine Erfahrungen in der Vergangenheit.
Würde ja gern den HP device Manager deaktivieren.
Habe aber einen HP-Laserdruck an einem PrintServer laufen, der mit
CUPS (HP LaserJet 1200 - CUPS+Gutenprint v5.2.10) kofiguriert ist.
Wie wird der HP Device Manager deaktiviert ?

viele grüsse aus dem nachmittaglichen Oberbyern
vom bayernherz :thumbs:

Sauerland
Guru
Guru
Beiträge: 2671
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: Leap 42.2 kennt Scanner CANON Lide 25 nicht

Beitrag von Sauerland » 22. Mär 2017, 17:14

Lass den HP-Manager doch einfach da wo er ist, unten rechts.
Der sollte normalerweise nicht stören.

Denn HP hat eigentlich ein vorbildliche Linuxunterstützung, was man von Canon nicht gerade sagen kann.........

Du kannst natürlich den HP-Manager deinstallieren, einfach hplip komplett deinstallieren.
Wenn dein HP-Drucker natürlich mit dem originalen HP Treiber läuft, ist der HP-Treiber natürlich auch nicht mehr vorhanden.....
Wenn dein HP-Drucker mit einem freien Treiber läuft, ist das egal.

PS
Hier arbeitet ein Brother-, Hp- und Epson-Drucker, sowie ein HP- und Epson-Scanner ohne Probleme nebeneinander.
Trotz dem HP-Manager.
Desktop: OpenSUSE Leap 42.2, Nvidia-Grafik Kernel 4.4
Laptop: OpenSUSE Leap 42.1, ATI-Grafik (Radeon-Treiber)
Laptop: OpenSUSE Leap 42.2, Intel-Skylake, Kernel 4.x

Benutzeravatar
susejunky
Hacker
Hacker
Beiträge: 355
Registriert: 19. Sep 2014, 18:22

Re: Leap 42.2 kennt Scanner CANON Lide 25 nicht

Beitrag von susejunky » 22. Mär 2017, 17:30

Hallo bayernherz,
bayernherz hat geschrieben:
22. Mär 2017, 16:54
... Würde ja gern den HP device Manager deaktivieren.
Habe aber einen HP-Laserdruck an einem PrintServer laufen, der mit
CUPS (HP LaserJet 1200 - CUPS+Gutenprint v5.2.10) kofiguriert ist.
Wie wird der HP Device Manager deaktiviert ? ...
wie bereits gesagt, bei mir verursacht der HP-Devicemanager keine Probleme.

Wenn Du ihn unbedingt loswerden willst, kannst Du ihn mit YaST2 deinstallieren, was aber ggf. auch dazu führt, dass Du Deinen Drucker nicht mehr nutzen kannst, da die HP-spezifischen PPD-Dateien gelöscht werden.

Du kannst auch in "/etc/xdg/autostart/" die Datei "hplip-systray.desktop" in "hplip-systray.desktop.xxx" umbenennen. Dann sollte der HP-Devicemanager beim nächsten Start nicht mehr automatisch gestartet werden.

Hast Du schon einmal ausprobiert, ob die aktuellere Version von SANE (1.0.25) Dein Problem löst?

Viele Grüße

susejunky

josef-wien
Guru
Guru
Beiträge: 4765
Registriert: 23. Sep 2008, 17:09

Re: Leap 42.2 kennt Scanner CANON Lide 25 nicht

Beitrag von josef-wien » 22. Mär 2017, 18:09

bayernherz hat geschrieben:
22. Mär 2017, 12:50
die josef-wien gern gesehen hätte
Meine Frage war:
josef-wien hat geschrieben:
20. Mär 2017, 17:24
Scheint
bayernherz hat geschrieben:
18. Mär 2017, 17:41
Noname HD WebCam virtual device
unter lspci oder unter lsusb auf?
Welche Eintragung dem Gerät entspricht, könnte ich nur raten, und das wird wenig bringen. Aber ich denke, das ist jetzt belanglos. libsane_matched=yes wird nur beim Canon-Scanner gesetzt, und von der vagen Möglichkeit eines Interrupt-Konflikts sehe ich auch nichts. Somit überlasse ich das Feld wieder den anderen Helfern.

bayernherz
Hacker
Hacker
Beiträge: 441
Registriert: 5. Nov 2011, 20:27
Wohnort: in Oberbayern

Re: Leap 42.2 kennt Scanner CANON Lide 25 nicht

Beitrag von bayernherz » 22. Mär 2017, 18:23

hallo community,
susejunky hat geschrieben:
Du kannst auch in "/etc/xdg/autostart/" die Datei "hplip-systray.desktop" in "hplip-systray.desktop.xxx" umbenennen. Dann sollte der HP-Devicemanager beim nächsten Start nicht mehr automatisch gestartet werden.
Habe ich mal gemacht, bringt garnichts, der Eintrag in der Datei /etc/sane.d/dll.conf mit hpaio ist nach einem Neustart trotzdem wieder da. Momentan habe ich folgende sane versionen
http://susepaste.org/63987760
susejunky hat geschrieben:
Hast Du schon einmal ausprobiert, ob die aktuellere Version von SANE (1.0.25) Dein Problem löst?
Das werde ich jetzt nach Deiner Liste, die die Vorgehensweise ja sehr gut darstellt tun.
1. in YaST konfigurierte Scanner löschen
2. in YaST alle sane-xxx-Pakete deinstallieren
3. alle Dateien im Verzeichnis /etc/sane.d/ löschen
4. die Datei /etc/udev/rules.d/55-libsane.rules löschen
5. die Datei /etc/udev/rules.d/56-sane-backends-autoconfig.rules löschen
6. in YaST das Repository http://download.opensuse.org/repositori ... eap_42.2/ einbinden und SANE aus diesem Repository installieren.

Ich melde mich dann wieder.

viele grüsse aus dem abendliche Oberbayer
vom bayernherz :thumbs:

Benutzeravatar
susejunky
Hacker
Hacker
Beiträge: 355
Registriert: 19. Sep 2014, 18:22

Re: Leap 42.2 kennt Scanner CANON Lide 25 nicht

Beitrag von susejunky » 22. Mär 2017, 18:32

Hallo bayernherz,

Gibt es unter PCLinuxOS auch eine Datei "/etc/sane.d/plustek.conf"?

Wenn ja, stimmt deren Inhalt mit der Datei "/etc/sane.d/plustek.conf" von openSUSE 42.2 überein?

Wenn die Inhalte nicht übereinstimmen, hast Du schon einmal ausprobiert, ob die PCLinuxOS-Variante von "/etc/sane.d/plustek.conf" unter openSUSE 42.2 funktioniert?

Hast Du unter openSUSE 42.2 schon einmal probiert in der Datei "/etc/sane.d/plustek.conf" die USB-Konfiguration Deines Scanners direkt einzutragen?

Viele Grüße

susejunky

josef-wien
Guru
Guru
Beiträge: 4765
Registriert: 23. Sep 2008, 17:09

Re: Leap 42.2 kennt Scanner CANON Lide 25 nicht

Beitrag von josef-wien » 22. Mär 2017, 18:42

bayernherz hat geschrieben:
22. Mär 2017, 18:23
hplip-systray.desktop
Datei entfernen, oder hinten ein
~
anhängen.


susejunky hat geschrieben:
22. Mär 2017, 18:32
stimmt deren Inhalt mit der Datei "/etc/sane.d/plustek.conf" von openSUSE 42.2 überein?
Ich habe mir das Paket sane-backends-1.0.24-4.40.x86_64.rpm heruntergeladen, darin ist 1:1 diesselbe Datei wie bei PCLinuxOS (das die Version 1.0.25 verwendet).

bayernherz
Hacker
Hacker
Beiträge: 441
Registriert: 5. Nov 2011, 20:27
Wohnort: in Oberbayern

Re: Leap 42.2 kennt Scanner CANON Lide 25 nicht

Beitrag von bayernherz » 22. Mär 2017, 19:08

hallo community,
sane package habe ich jetzt noch nicht ausgetauscht, so schnell bin ich nicht.
susejunky hat gechrieben:
Hast Du unter openSUSE 42.2 schon einmal probiert in der Datei "/etc/sane.d/plustek.conf" die USB-Konfiguration Deines Scanners direkt einzutragen?
Nein, aber möchte ich als nächstes gern mal probieren, bevor ich den Vergleich der Konfigdateien pulstek.conf von PCLOS und Leap 42.2 durchführe. aber wie ?
Konsole mit user Rechten:

Code: Alles auswählen

lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 0bda:57f2 Realtek Semiconductor Corp. 
Bus 001 Device 003: ID 0489:e0a3 Foxconn / Hon Hai 
Bus 001 Device 002: ID 046d:c404 Logitech, Inc. TrackMan Wheel
Bus 001 Device 005: ID 04a9:2220 Canon, Inc. CanoScan LIDE 25
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
gruss bayernherz :thumbs:

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 5 Gäste