Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Radeon Probleme mit Font-Darstellung

Alles rund um Hardware, die unter Linux läuft oder zum Laufen gebracht werden soll

Moderator: Moderatoren

Antworten
edgarkls
Hacker
Hacker
Beiträge: 535
Registriert: 27. Jan 2005, 15:59
Wohnort: manchester
Kontaktdaten:

Radeon Probleme mit Font-Darstellung

Beitrag von edgarkls » 20. Nov 2014, 23:00

Ich habe eine Radeon R7 240 Karte. Seit dem upgrade auf Opensuse 13.2 (Neuinstallation) habe ich eine Problem mit der Darstellung von Schriften in Firefox, Thunderbird und Evolution. Einzelne Buchstaben werden entweder nur als farbisges Quadrat angezeigt oder - besonders irritierend - im gesamten Text durch einen anderen ersetzt (g durch y zum Beispiel). Andere Browser wie Chromium und alle anderen Programme sind nicht betroffen. Im Firefox habe ich die Hardware-Beschleunigung an - und ausgeschaltet, das hat aber nichts wesentliches verändert.

Mein System: Opensuse 13.2, Gnome, quelloffener Radeon-Treiber. Ich hatte anfangs Gnome in Verdacht, aber das Problem tritt auch unter E17 und Awesome auf. Der Versuch, auf den FGLRX-Treiber von Sebastian Siebert umzusteigen, ist leider fehlgeschlagen.

Hat irgendwer eine Ahnung, was das Problem sein könnte? Tante Google hat mir leider auch nicht weitergeholfen. Allerdings scheinen Windows-User das Problem in den vergangenen Jahren auch gehabt zu haben. Die von denen vorgeschlagenen Lösungen funktionieren mit der aktuellen Firefox-Version jedoch auch nicht.

Werbung:
josef-wien
Ultimate Guru
Ultimate Guru
Beiträge: 5286
Registriert: 23. Sep 2008, 17:09

Re: Radeon Probleme mit Font-Darstellung

Beitrag von josef-wien » 20. Nov 2014, 23:47

Hast Du makerpm-amd-14.9-os13.2-refurbished.sh verwendet. Wenn ja, was bedeutet:
edgarkls hat geschrieben:ist leider fehlgeschlagen
P. S. Zwei Beiträge sind einer zuviel.

edgarkls
Hacker
Hacker
Beiträge: 535
Registriert: 27. Jan 2005, 15:59
Wohnort: manchester
Kontaktdaten:

Re: Radeon Probleme mit Font-Darstellung

Beitrag von edgarkls » 20. Nov 2014, 23:53

Danke, habe auch gerade gemerkt, dass der Beitrag zweimal rausgegangen ist. Ja, ich habe die refurbished-Version verwendet. Die Installation ist auch glatt gelaufen, nur bin ich dann nach dem Neustart auf einem Textbildschirm gelandet. Weder Xorg.0.log noch dmesg gaben irgendwelche brauchbaren Hinweise auf was eventuell schiefgelaufen war. Ich bin dann zunächst mal zurück zum offenen Treiber und warte auf die erste aktuelle fglrx-Version, die auf den neuen Xorg zugeschnitten ist.

josef-wien
Ultimate Guru
Ultimate Guru
Beiträge: 5286
Registriert: 23. Sep 2008, 17:09

Re: Radeon Probleme mit Font-Darstellung

Beitrag von josef-wien » 21. Nov 2014, 00:04

Mangels 13.2 eine theoretische Idee: Nachdem die initrd jetzt anders erzeugt wird, könnte dabei etwas falsch gelaufen sein, und radeon war dort immer noch drinnen und somit aktiv.

edgarkls
Hacker
Hacker
Beiträge: 535
Registriert: 27. Jan 2005, 15:59
Wohnort: manchester
Kontaktdaten:

Re: Radeon Probleme mit Font-Darstellung

Beitrag von edgarkls » 21. Nov 2014, 00:09

Ah, das könnte eine Möglichkeit sein. Da müsste ich mich mal schlau machen, was sich eigentlich geändert hat und welche Konsequenzen die Änderungen haben.

edgarkls
Hacker
Hacker
Beiträge: 535
Registriert: 27. Jan 2005, 15:59
Wohnort: manchester
Kontaktdaten:

Re: Radeon Probleme mit Font-Darstellung

Beitrag von edgarkls » 24. Nov 2014, 01:16

Anscheinend ist das ein Bug im radeon-Treiber, oder vielmehr in Glamour. Auf Bugzilla und in den Arch-Foren gibt's bereits eine längere Diskussion darüber. Hmmm....

Antworten