Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Treiber Backport? Terratec Cinergy 2400i DT DVB-T

Alles rund um Hardware, die unter Linux läuft oder zum Laufen gebracht werden soll

Moderator: Moderatoren

Antworten
schnurzelat
Member
Member
Beiträge: 169
Registriert: 30. Jun 2008, 20:17

Treiber Backport? Terratec Cinergy 2400i DT DVB-T

Beitrag von schnurzelat »

Hallo,

ich habe eine Terratec Cinergy 2400i DT PCIe DVB-T Karte und kann leider keinen funktionierenden Treiber finden.

Ab Kernel 3.7 soll der Treiber nun im Kernel integriert sein. Kann ich den Treiber irgendwie unter 3.4.11 zum Laufen bringen?

Ich habe einige Treiber (http://wiki.ubuntuusers.de/Terratec_Cinergy_2400i_DT, https://github.com/wurststulle/ngene_2400i) gefunden, die mit der 2400i funktionieren sollen, jedoch lies sich keiner kompilieren.

Hat jemand einen Tip?

Gruß schnurzelat
Derzeitiger Server: OpenSuse Leap 15.1 auf einem Dell T20 mit einem Xeon E3-1225 v3 und 16 GB RAM
Wichtige Anwendungen: Apache2, MySQL, Samba, Squid, SquidGuard, x11vnc
Sauerland
Guru
Guru
Beiträge: 3738
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: Treiber Backport? Terratec Cinergy 2400i DT DVB-T

Beitrag von Sauerland »

jedoch lies sich keiner kompilieren.
Fehlermeldung?

Sowie:

Code: Alles auswählen

/sbin/lspci -vvvnn
Hier nur der Teil zur Karte.
Desktop: OpenSUSE Leap 15.2, Nvidia-Grafik Kernel 5.x
Laptop: OpenSUSE Leap 15.2, Intel-Skylake, Kernel 5.3
josef-wien
Ultimate Guru
Ultimate Guru
Beiträge: 5453
Registriert: 23. Sep 2008, 17:09

Re: Treiber Backport? Terratec Cinergy 2400i DT DVB-T

Beitrag von josef-wien »

schnurzelat hat geschrieben:Ab Kernel 3.7 soll der Treiber nun im Kernel integriert sein.
Und was hindert Dich daran, den aktuellen Kernel (vorerst einmal zusätzlich) zu installieren?
schnurzelat
Member
Member
Beiträge: 169
Registriert: 30. Jun 2008, 20:17

Re: Treiber Backport? Terratec Cinergy 2400i DT DVB-T

Beitrag von schnurzelat »

@ Sauerland

Code: Alles auswählen

01:00.0 Multimedia video controller [0400]: Micronas Semiconductor Holding AG nGene PCI-Express Multimedia Controller [18c3:0720]
Subsystem: TERRATEC Electronic GmbH Device [153b:1167]
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 0, Cache Line Size: 64 bytes
Interrupt: pin A routed to IRQ 11
Region 0: Memory at f7c10000 (32-bit, non-prefetchable) [size=64K]
Region 1: Memory at f7c00000 (64-bit, non-prefetchable) [size=64K]
Capabilities: [40] Power Management version 2
Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
Capabilities: [48] MSI: Enable- Count=1/1 Maskable- 64bit+
Address: 0000000000000000 Data: 0000
Capabilities: [58] Express (v1) Endpoint, MSI 00
DevCap: MaxPayload 128 bytes, PhantFunc 0, Latency L0s <64ns, L1 <1us
ExtTag- AttnBtn- AttnInd- PwrInd- RBE- FLReset-
DevCtl: Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
RlxdOrd- ExtTag- PhantFunc- AuxPwr+ NoSnoop+
MaxPayload 128 bytes, MaxReadReq 512 bytes
DevSta: CorrErr- UncorrErr- FatalErr- UnsuppReq- AuxPwr- TransPend-
LnkCap: Port #0, Speed 2.5GT/s, Width x1, ASPM L0s, Latency L0 unlimited, L1 unlimited
ClockPM- Surprise- LLActRep- BwNot-
LnkCtl: ASPM Disabled; RCB 64 bytes Disabled- Retrain- CommClk+
ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
LnkSta: Speed 2.5GT/s, Width x1, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
Capabilities: [100 v1] Device Serial Number 00-00-00-37-30-3c-31-30
Capabilities: [400 v1] Virtual Channel
Caps: LPEVC=0 RefClk=100ns PATEntryBits=1
Arb: Fixed- WRR32- WRR64- WRR128-
Ctrl: ArbSelect=Fixed
Status: InProgress-
VC0: Caps: PATOffset=00 MaxTimeSlots=1 RejSnoopTrans-
Arb: Fixed- WRR32- WRR64- WRR128- TWRR128- WRR256-
Ctrl: Enable+ ID=0 ArbSelect=Fixed TC/VC=01
Status: NegoPending- InProgress-
Die Karte wird im dmesg als

Code: Alles auswählen

nGene PCIE bridge driver, Copyright (C) 2005-2007 Micronas
saa7146: register extension 'av7110'
erkannt. Leider gibt es kein dvb device.

lsmod |grep dvb

Code: Alles auswählen

dvb_pll 18747 0
dvb_ttpci 121120 0
dvb_core 114208 10 ngene,stv0299,or51211,or51132,lgdt330x,lgdt3305,dib8000,dib7000p,cxd2820r,dvb_ttpci
saa7146_vv 74749 1 dvb_ttpci
saa7146 29689 2 dvb_ttpci,saa7146_vv
ttpci_eeprom 12780 1 dvb_ttpci
Kompilierfehler:

Code: Alles auswählen

make
make -C /lib/modules/3.4.11-2.16-desktop/build SUBDIRS=/root/ngene_p11 CONFIG_DVB_NGENE=m CONFIG_DVB_DRXD=m modules
make[1]: Entering directory `/usr/src/linux-3.4.11-2.16-obj/x86_64/desktop'
  CC [M]  /root/ngene_p11/drxd_hard.o
/root/ngene_p11/drxd_hard.c:123:33: error: field \u2018param\u2019 has incomplete type
/root/ngene_p11/drxd_hard.c: In function \u2018CorrectSysClockDeviation\u2019:
/root/ngene_p11/drxd_hard.c:1521:8: error: \u2018BANDWIDTH_8_MHZ\u2019 undeclared (first use in this function)
/root/ngene_p11/drxd_hard.c:1521:8: note: each undeclared identifier is reported only once for each function it appears in
/root/ngene_p11/drxd_hard.c:1524:8: error: \u2018BANDWIDTH_7_MHZ\u2019 undeclared (first use in this function)
/root/ngene_p11/drxd_hard.c:1527:8: error: \u2018BANDWIDTH_6_MHZ\u2019 undeclared (first use in this function)
/root/ngene_p11/drxd_hard.c: In function \u2018StartDiversity\u2019:
/root/ngene_p11/drxd_hard.c:1698:8: error: \u2018BANDWIDTH_8_MHZ\u2019 undeclared (first use in this function)
/root/ngene_p11/drxd_hard.c: In function \u2018DRX_Start\u2019:
/root/ngene_p11/drxd_hard.c:1853:12: error: dereferencing pointer to incomplete type
/root/ngene_p11/drxd_hard.c:1883:12: error: dereferencing pointer to incomplete type
/root/ngene_p11/drxd_hard.c:1904:12: error: dereferencing pointer to incomplete type
/root/ngene_p11/drxd_hard.c:2021:12: error: dereferencing pointer to incomplete type
/root/ngene_p11/drxd_hard.c:2138:12: error: dereferencing pointer to incomplete type
/root/ngene_p11/drxd_hard.c:2197:12: error: dereferencing pointer to incomplete type
/root/ngene_p11/drxd_hard.c:2199:8: error: \u2018BANDWIDTH_AUTO\u2019 undeclared (first use in this function)
/root/ngene_p11/drxd_hard.c:2200:8: error: \u2018BANDWIDTH_8_MHZ\u2019 undeclared (first use in this function)
/root/ngene_p11/drxd_hard.c:2208:8: error: \u2018BANDWIDTH_7_MHZ\u2019 undeclared (first use in this function)
/root/ngene_p11/drxd_hard.c:2215:8: error: \u2018BANDWIDTH_6_MHZ\u2019 undeclared (first use in this function)
/root/ngene_p11/drxd_hard.c:2235:11: error: dereferencing pointer to incomplete type
/root/ngene_p11/drxd_hard.c:2236:11: error: dereferencing pointer to incomplete type
/root/ngene_p11/drxd_hard.c: In function \u2018drxd_set_frontend\u2019:
/root/ngene_p11/drxd_hard.c:2721:15: error: dereferencing pointer to incomplete type
/root/ngene_p11/drxd_hard.c:2725:3: error: too many arguments to function \u2018fe->ops.tuner_ops.set_params\u2019
/root/ngene_p11/drxd_hard.c: At top level:
/root/ngene_p11/drxd_hard.c:2783:2: warning: initialization from incompatible pointer type [enabled by default]
/root/ngene_p11/drxd_hard.c:2783:2: warning: (near initialization for \u2018drxd_ops.set_frontend\u2019) [enabled by default]
/root/ngene_p11/drxd_hard.c:2784:2: warning: initialization from incompatible pointer type [enabled by default]
/root/ngene_p11/drxd_hard.c:2784:2: warning: (near initialization for \u2018drxd_ops.get_frontend\u2019) [enabled by default]
make[4]: *** [/root/ngene_p11/drxd_hard.o] Error 1
make[3]: *** [_module_/root/ngene_p11] Error 2
make[2]: *** [sub-make] Error 2
make[1]: *** [all] Error 2
make[1]: Leaving directory `/usr/src/linux-3.4.11-2.16-obj/x86_64/desktop'
make: *** [all] Error 2
@konqui

Genau das funktioniert nicht. Diese Seite verweist auf u. a. diesen o. g. Treiber.

@josef-wien

Ein nicht zur Distribution gehörender Kernel bringt immer ein bisschen huddelei mit sich. Zur Not würde ich es machen. Leider ist der 3.7er Kernel im Factory und nicht im Tubleweed repo. Welchen Kernel (Vorkompiliert? Welches repo?) sollte ich deiner Meinung nach am Besten probieren?

Gruß schnurzelat
Derzeitiger Server: OpenSuse Leap 15.1 auf einem Dell T20 mit einem Xeon E3-1225 v3 und 16 GB RAM
Wichtige Anwendungen: Apache2, MySQL, Samba, Squid, SquidGuard, x11vnc
Freddie62
Guru
Guru
Beiträge: 1581
Registriert: 24. Jan 2006, 14:21

Re: Treiber Backport? Terratec Cinergy 2400i DT DVB-T

Beitrag von Freddie62 »

Ich nutze dieses Repo.

CU Freddie
4 X Tumbleweed, Kernel: 5.4.10-1-default, LXDE. Schleppi: Dell Latitude 5520 mit Win7 Prof./Tumbleweed-X64, Kernel: 5.4.10-1-default, LXDE
josef-wien
Ultimate Guru
Ultimate Guru
Beiträge: 5453
Registriert: 23. Sep 2008, 17:09

Re: Treiber Backport? Terratec Cinergy 2400i DT DVB-T

Beitrag von josef-wien »

schnurzelat hat geschrieben:Leider ist der 3.7er Kernel im Factory und nicht im Tubleweed repo.
Brauchst Du ein eine (schärfere) Brille? Ob Du das Tumbleweed-Repro (wird ausführlicher getestet wird, enthält daher zum Zeitpunkt dieses Beitrags noch 3.7.4) oder das von Freddie62 genannte Kernel-Repo (enthält schon 3.7.5) verwendest, ist Geschmackssache. Die bevorzugte Methode, einen Kernel zusätzlich zu installieren, habe ich in der Linupedia hinterlegt.
schnurzelat
Member
Member
Beiträge: 169
Registriert: 30. Jun 2008, 20:17

Re: Treiber Backport? Terratec Cinergy 2400i DT DVB-T

Beitrag von schnurzelat »

Bin jetzt auf Tumbleweed. Kernel 3.7.5. Die Karte wird zwar 'besser' erkannt funktioniert aber immer noch nicht.

Ich habe hier auch mein Problem gepostet, da dort evtl. mehr DVB User angemeldet sind.

Code: Alles auswählen

[78195.845297] cxd2099: module is from the staging directory, the quality is unknown, you have been warned.
[78384.193243] nGene PCIE bridge driver, Copyright (C) 2005-2007 Micronas
[78384.193278] ngene: Found Terratec Integra/Cinergy2400i Dual DVB-T
[78384.193816] ngene: Device version 1
[78384.193860] ngene: Loading firmware file ngene_15.fw.
[78384.219955] error in i2c_read_reg
[78384.219959] No CXD2099 detected at 40
[78384.220215] drxd: not found
[78384.220220] No DRXD found!
[78384.220328] drxd: not found
[78384.220330] No DRXD found!

Code: Alles auswählen

lsmod | grep drxd
drxd 27535 0
lsmod | grep ngene
ngene 37173 0
dvb_core 125515 1 ngene
cxd2099 13277 1 ngene
Kein DVB Device.


Gruß schnurzelat
Derzeitiger Server: OpenSuse Leap 15.1 auf einem Dell T20 mit einem Xeon E3-1225 v3 und 16 GB RAM
Wichtige Anwendungen: Apache2, MySQL, Samba, Squid, SquidGuard, x11vnc
Benutzeravatar
konqui
Hacker
Hacker
Beiträge: 273
Registriert: 13. Okt 2005, 11:14
Wohnort: Frankfurt/M.

Re: Treiber Backport? Terratec Cinergy 2400i DT DVB-T

Beitrag von konqui »

Nur mal so am Rande...
DVB ist installiert und läuft?
schnurzelat
Member
Member
Beiträge: 169
Registriert: 30. Jun 2008, 20:17

Re: Treiber Backport? Terratec Cinergy 2400i DT DVB-T

Beitrag von schnurzelat »

Ja, läuft. In diesem Rechner war mal eine Nova-T eingebaut, die funktioniert hat.
Derzeitiger Server: OpenSuse Leap 15.1 auf einem Dell T20 mit einem Xeon E3-1225 v3 und 16 GB RAM
Wichtige Anwendungen: Apache2, MySQL, Samba, Squid, SquidGuard, x11vnc
schnurzelat
Member
Member
Beiträge: 169
Registriert: 30. Jun 2008, 20:17

Re: Treiber Backport? Terratec Cinergy 2400i DT DVB-T

Beitrag von schnurzelat »

Nach einem reboot erschien folgendes im dmesg:

Code: Alles auswählen

[   63.340686] ngene: Found Terratec Integra/Cinergy2400i Dual DVB-T
[   63.341073] ngene: Device version 1
[   63.352593] ngene: Loading firmware file ngene_15.fw.
[   65.734678] ngene: Command timeout cmd=03 prev=04
[   65.738857] host_to_ngene (c000): 03 07 e0 32 42 00 00 02
[   65.743427] ngene_to_host (c100): 00 00 00 00 00 00 00 00
[   65.748585] dev->hosttongene (ffff88003701d000): 03 07 e0 32 42 00 00 02
[   65.752924] dev->ngenetohost (ffff88003701d100): 00 00 00 00 00 00 00 00
Könnte es sein, dass die Karte kaputt ist?

Gruß schnurzelat
Derzeitiger Server: OpenSuse Leap 15.1 auf einem Dell T20 mit einem Xeon E3-1225 v3 und 16 GB RAM
Wichtige Anwendungen: Apache2, MySQL, Samba, Squid, SquidGuard, x11vnc
schnurzelat
Member
Member
Beiträge: 169
Registriert: 30. Jun 2008, 20:17

Re: Treiber Backport? Terratec Cinergy 2400i DT DVB-T

Beitrag von schnurzelat »

Ich hab's aufgegeben und die alte Nova-T wieder eingebaut.
Derzeitiger Server: OpenSuse Leap 15.1 auf einem Dell T20 mit einem Xeon E3-1225 v3 und 16 GB RAM
Wichtige Anwendungen: Apache2, MySQL, Samba, Squid, SquidGuard, x11vnc
Antworten