Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Touchpad konfigurieren

Alles rund um Hardware, die unter Linux läuft oder zum Laufen gebracht werden soll

Moderator: Moderatoren

Antworten
Quatschkopp
Newbie
Newbie
Beiträge: 6
Registriert: 5. Apr 2010, 12:20

Touchpad konfigurieren

Beitrag von Quatschkopp » 5. Apr 2010, 12:37

Hallo,

ich verwende hier OpenSuse 11.2 in seiner ursprünglichen Konfiguration auf einen ASUS-Laptop. Alles funktioniert so weit. Nun kam in mir der Wunsch, das Touchpad so zu konfigurieren, dass es deaktiviert ist, wenn man auf der Tastatur tippt. Leider sehe ich vor lauter Anleitungen den Baum vor lauter Wald nicht mehr. Wie gehe ich vor? Man benötigt den synaptics-Treiber. Der scheint jedoch nicht installiert zu sein. Das mache ich an den fest, das touchfreeze nicht funktioniert und das bei Eingabe von

syndaemon -d

kam bisher eine Fehlermeldung, dass wohl der Synaptics-Treiber geladen wäre. Jetzt, nach dem ich in der xorg.conf bei der mouse-section von Treiber "mouse" auf "synaptics" gestellt habe, kommt bei o.g. Eingabe:

Unable to find a synaptics device.

Ich find das alles verwirrend: Man soll keine Einstellungen in der xorg.conf machen und die Einstellungen über hal machen.

Also meine Frage: Was muss ich machen, dass das Touchpad beim tippen deaktiviert ist?

Werbung:
Benutzeravatar
Ganymed
Guru
Guru
Beiträge: 1609
Registriert: 15. Mai 2006, 12:58
Wohnort: JETZT ? DIREKT HINTER DIR !!
Kontaktdaten:

Re: Touchpad konfigurieren

Beitrag von Ganymed » 5. Apr 2010, 13:18

Nicht so kompliziert denken.
Viele moderne Asus-Schleppies haben eine Doppelbelegung einiger Funktionstasten
Auf dem X72NV kann ich durch die Parallelbelegung von F9. das Touchpad umschalten.

Gruß Ganymed
julia ist gut zu vögeln --- Groß- und Kleinschreibung retten die Ehre.
komm wir essen Opa --- Satzzeichen retten sogar das Leben
:)

Quatschkopp
Newbie
Newbie
Beiträge: 6
Registriert: 5. Apr 2010, 12:20

Re: Touchpad konfigurieren

Beitrag von Quatschkopp » 5. Apr 2010, 14:22

Und das funktioniert Out-Of-The-Box? Ist den bei Deiner F9-Taste ein Symbol? Hast Du das selbst konfiguriert? Ich habe den Asus K51AC-SX077D.

Benutzeravatar
Ganymed
Guru
Guru
Beiträge: 1609
Registriert: 15. Mai 2006, 12:58
Wohnort: JETZT ? DIREKT HINTER DIR !!
Kontaktdaten:

Re: Touchpad konfigurieren

Beitrag von Ganymed » 5. Apr 2010, 16:00

Quatschkopp hat geschrieben:Und das funktioniert Out-Of-The-Box? Ist den bei Deiner F9-Taste ein Symbol?
Bei Deinem Notebook ist der Touchpad-Lock auch F+F9.

Naja, dieses Feature habe ich nicht bewusst installiert oder konfiguriert - es funktioniert einfach.
Meine Installation ist auch etwas grenzwertig oder nicht sofort nachvollziehbar.
Wegen 3DConnexion, Intuos4, etwas sensibler Mobile-Nvidia-Grafik 9400M läuft hier ein 11.2-64 mit 2.6.33-jen Kernel, zugehörigen Grafiktreiber und KDE 4.4.2, eben meine mobile Bastelbox.

Suche mal über die YAST-Paketsuche nach Asus - in den home:/-Repositorys des Buildservice werden häufig Pakete für besondere Notebook-Features angeboten. Aber Achtung das ist echte Spielwiese der Entwickler - die sich auch über etwas Feedback freuen würden.

Gruß Ganymed
julia ist gut zu vögeln --- Groß- und Kleinschreibung retten die Ehre.
komm wir essen Opa --- Satzzeichen retten sogar das Leben
:)

Quatschkopp
Newbie
Newbie
Beiträge: 6
Registriert: 5. Apr 2010, 12:20

Re: Touchpad konfigurieren

Beitrag von Quatschkopp » 5. Apr 2010, 16:31

Leider funktioniert FN+F9 nicht. Und interessante Pakete fand ich auch nicht. Wie sieht den Deine grenzwertige Config aus insb. in Bezug auf die xorg.conf oder auch HAL?

Benutzeravatar
Ganymed
Guru
Guru
Beiträge: 1609
Registriert: 15. Mai 2006, 12:58
Wohnort: JETZT ? DIREKT HINTER DIR !!
Kontaktdaten:

Re: Touchpad konfigurieren

Beitrag von Ganymed » 5. Apr 2010, 17:51

Morgen Abend kann ich Dir genaueres sagen, aber ich bin mir ziehmlich sicher keine xorg.conf zu haben, denn wegen der Hardwareabstraction habe ich mir das Gefrickle mit dem Grafiktablet angetan - mit der xorg.conf konnte ich das Intuos nicht zur Laufzeit einstöpseln.

Gruß Ganymed
julia ist gut zu vögeln --- Groß- und Kleinschreibung retten die Ehre.
komm wir essen Opa --- Satzzeichen retten sogar das Leben
:)

Quatschkopp
Newbie
Newbie
Beiträge: 6
Registriert: 5. Apr 2010, 12:20

Re: Touchpad konfigurieren

Beitrag von Quatschkopp » 5. Apr 2010, 18:13

Das klingt ja mal interessant. Den überall steht ja, man soll über HAL einrichten und nicht über die xorg.conf.

Benutzeravatar
oc2pus
Ultimate Guru
Ultimate Guru
Beiträge: 6506
Registriert: 21. Jun 2004, 13:01

Re: Touchpad konfigurieren

Beitrag von oc2pus » 5. Apr 2010, 18:44

a) libsynaptics und das Fronten ksynaptics installieren
Pakete bei SuSE bzw mit webpin suchen

ODER

b) keytouch und keytouch-editor
http://keytouch.sourceforge.net/

Code: Alles auswählen

KeyTouch is a program which allows you to easily configure the extra function keys of your keyboard. This means that you can define, for every individual function key, what to do if it is pressed. When you buy a new keyboard a CD-ROM will probably included. This CD-ROM contains software to configure the extra function keys (the image above shows an example of extra function keys) of your keyboard with. The problem however is that most of the times the software is not available for Linux. KeyTouch is the solution to this problem. It allows you to easily configure the extra funtion keys of your keyboard. 
Pakete bei packman

ODER

c) touchfreeze
http://qsynaptics.sourceforge.net/index.html

Code: Alles auswählen

A facility for disabling touchpad tap-to-click function. Touchfreeze docks in your system tray and disables your touchpad while typing. It re-enables your touchpad when typing stops, using a configurable delay time. NOTE: * needs /usr/bin/synclient * needs synaptics driver shm access enabled 
Pakete bei packman
tell people what you want to do, and they'll probably help you to do it.
PackMan
LinWiki : Das Wiki für Linux User

Benutzeravatar
blacklips
Hacker
Hacker
Beiträge: 448
Registriert: 28. Nov 2006, 19:33
Wohnort: gießen, frankfurt

Re: Touchpad konfigurieren

Beitrag von blacklips » 5. Apr 2010, 19:23

Ich denke, dass du Einstellungen für das Touchpad in einer fdi Datei in /etc/hal/fdi/policy festlegen kannst. Ich hoffe, dass diese Information noch stimmt, da es im Moment wohl wieder abgeschafft werden soll.

Code: Alles auswählen

<?xml version="1.0" encoding="ISO-8859-1"?>
<deviceinfo version="0.2">
 <device>
   <match key="info.capabilities" contains="input.touchpad">
     <match key="info.product" contains="Synaptics TouchPad">
       <merge key="input.x11_driver" type="string">synaptics</merge>
       
       <merge key="input.x11_options.LeftEdge" type="string">1700</merge>
       <merge key="input.x11_options.RightEdge" type="string">5300</merge>
       <merge key="input.x11_options.TopEdge" type="string">1700</merge>
       <merge key="input.x11_options.BottomEdge" type="string">4200</merge>
       <merge key="input.x11_options.HorizEdgeScroll" type="string">1</merge>
       <merge key="input.x11_options.VertEdgeScroll" type="string">1</merge>
       <merge key="input.x11_options.VertTwoFingerScroll" type="string">0</merge>
       <merge key="input.x11_options.HorizTwoFingerScroll" type="string">0</merge>
       <merge key="input.x11_options.HorizScrollDelta" type="string">0</merge>
       <merge key="input.x11_options.VertScrollDelta" type="string">100</merge>
       <merge key="input.x11_options.PressureMotionMinZ" type="string">10</merge>
       <merge key="input.x11_options.FingerLow" type="string">25</merge>
       <merge key="input.x11_options.FingerHigh" type="string">30</merge>
       <merge key="input.x11_options.FingerPress" type="string">256</merge>
       <merge key="input.x11_options.PalmDetect" type="string">0</merge>
       <merge key="input.x11_options.PalmMinWidth" type="string">10</merge>
       <merge key="input.x11_options.PalmMinZ" type="string">200</merge>
       <merge key="input.x11_options.MinSpeed" type="string">0.25</merge>
       <merge key="input.x11_options.MaxSpeed" type="string">0.5</merge>
       <merge key="input.x11_options.AccelFactor" type="string">0.005</merge>
       <merge key="input.x11_options.MaxTapMove" type="string">220</merge>
       <merge key="input.x11_options.MaxTapTime" type="string">180</merge>
       <merge key="input.x11_options.MaxDoubleTapTime" type="string">200</merge>
       <merge key="input.x11_options.TapButton1" type="string">1</merge>
       <merge key="input.x11_options.TapButton2" type="string">2</merge>
       <merge key="input.x11_options.TapButton3" type="string">3</merge>
       <merge key="input.x11_options.RTCornerButton" type="string">0</merge>
       <merge key="input.x11_options.RBCornerButton" type="string">0</merge>
       <merge key="input.x11_options.LTCornerButton" type="string">0</merge>
	<merge key="input.x11_options.TouchpadOff" type="string">0</merge>
   <merge key="input.x11_options.LBCornerButton" type="string">0</merge>
     </match>
     <match key="info.product" contains="AlpsPS/2 ALPS">
       <merge key="input.x11_driver" type="string">synaptics</merge>
     </match>
     <match key="info.product" contains="appletouch">
       <merge key="input.x11_driver" type="string">synaptics</merge>
     </match>
     <match key="info.product" contains="bcm5974">
       <merge key="input.x11_driver" type="string">synaptics</merge>
     </match>
   </match>
 </device>
</deviceinfo>
Das ist meine synaptics.fdi, die du dir eventuell kopieren kannst.
Linux: Xfce 4.6

Quatschkopp
Newbie
Newbie
Beiträge: 6
Registriert: 5. Apr 2010, 12:20

Re: Touchpad konfigurieren

Beitrag von Quatschkopp » 5. Apr 2010, 20:15

Vielen Dank für die Antworten. Ich habe alle Vorschläge probiert. Es hat leider noch nichts funktioniert. Ich habe die Pakete

touchfreeze
libsynaptics
ksynaptics

installiert und außerdem habe ich die synaptics.fdi angelegt. Ich hab das nacheinander gemacht und immer wieder den Laptop neu gebootet. Wenn ich bei Touchfreeze das Touchpad sozusagen deaktiviert habe, brachte das keine Wirkung. ksynaptics brach mit der Fehlermeldung ab, ich müsste in der xorg.conf

Option "SHMConfig" "on"

setzen:
1. Das habe ich schon eine Weile und
2. Ist das vielleicht sogar der Fehler?

Zusätzlich habe ich noch das Paket

kcm_touchpad

installiert. Die Einstellungsmöglichkeiten sind ausgegraut.

Die ganzen Lösungen setzen doch alle synaptics voraus? Ich habe das Gefühl, dass da das Problem liegt.

Deswegen ein paar Fragen:

1. Für das Touchpad wird doch der Synaptics-Treiber benötigt?
a.) Muss dafür das Paket "libsynaptics" installiert sein?
-> das war bis dato nicht installiert. Leider brachte das aber noch keine Verbesserung. Müssen grundsätzliche noch weitere Pakete installiert sein?

b.) Obwohl das Ganze ja über dieses HAL konfiguriert wird, müssen dennoch neben der

/etc/hal/fdi/policy/synaptics.fdi

noch andere wie die xorg.conf konfiguriert werden?

c.) in der Standard-xorg.conf gibt es eine Section für die Maus mit dem Treiber "mouse". Gilt die Section auch für das Touchpad oder müsste man für das Touchpad eine weitere Section anlegen?

Quatschkopp
Newbie
Newbie
Beiträge: 6
Registriert: 5. Apr 2010, 12:20

Re: Touchpad konfigurieren

Beitrag von Quatschkopp » 13. Jun 2010, 10:40

Hallo,

nach längerer Zeit habe ich mich diesem Problem wieder zugewandt. Inzwischen versuche ich (bisher erfolglos) mit http://bitbucket.org/lunar/synaptiks/ mein Glück. Das Tool funktioniert zwar auch nicht, aber es gibt zumindest eine Fehlermeldung aus:

"Warnung: Die Konfiguration des Touchpads wird auf Ihrem System nicht unterstützt. Der synaptics-Treiber ist entweder nicht geladen, oder zu alt. [...]"

Das Paket "libsynaptics" ist installiert. Ist das auch das Paket, in dem der Treiber enthalten ist, oder ist das dafür ein weiteres Paket notwendig? In der Wiki von OpenSuse http://en.opensuse.org/Synaptics_Touchpad wird die Verwendung von HAL empfohlen. Man soll dafür

sudo cp /usr/share/hal/fdi/policy/10osvendor/11-x11-synaptics.fdi /etc/hal/fdi/policy/11-x11-synaptics.fdi

verwenden.

In der Wiki von ubuntuusers.de steht, dass dafür eine Konfiguration über HAL keine einzige Konfiguration in der xorg.conf sein darf http://wiki.ubuntuusers.de/Touchpad. Meiner Meinung ist das auch der Fall:???

Meine /etc/X11/xorg.conf :

Code: Alles auswählen

# /.../
# SaX generated X11 config file
# Created on: 2010-03-31T15:56:15+0200.
#
# Version: 8.1
# Contact: Marcus Schaefer <sax@suse.de>, 2005
# Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
#
# Automatically generated by [ISaX] (8.1)
# PLEASE DO NOT EDIT THIS FILE!
#

Section "Files"
  FontPath     "/usr/share/fonts/misc:unscaled"
  FontPath     "/usr/share/fonts/local"
  FontPath     "/usr/share/fonts/75dpi:unscaled"
  FontPath     "/usr/share/fonts/100dpi:unscaled"
  FontPath     "/usr/share/fonts/Type1"
  FontPath     "/usr/share/fonts/URW"
  FontPath     "/usr/share/fonts/Speedo"
  FontPath     "/usr/share/fonts/PEX"
  FontPath     "/usr/share/fonts/cyrillic"
  FontPath     "/usr/share/fonts/latin2/misc:unscaled"
  FontPath     "/usr/share/fonts/latin2/75dpi:unscaled"
  FontPath     "/usr/share/fonts/latin2/100dpi:unscaled"
  FontPath     "/usr/share/fonts/latin2/Type1"
  FontPath     "/usr/share/fonts/latin7/75dpi:unscaled"
  FontPath     "/usr/share/fonts/baekmuk:unscaled"
  FontPath     "/usr/share/fonts/japanese:unscaled"
  FontPath     "/usr/share/fonts/kwintv"
  FontPath     "/usr/share/fonts/truetype"
  FontPath     "/usr/share/fonts/uni:unscaled"
  FontPath     "/usr/share/fonts/CID"
  FontPath     "/usr/share/fonts/ucs/misc:unscaled"
  FontPath     "/usr/share/fonts/ucs/75dpi:unscaled"
  FontPath     "/usr/share/fonts/ucs/100dpi:unscaled"
  FontPath     "/usr/share/fonts/hellas/misc:unscaled"
  FontPath     "/usr/share/fonts/hellas/75dpi:unscaled"
  FontPath     "/usr/share/fonts/hellas/100dpi:unscaled"
  FontPath     "/usr/share/fonts/hellas/Type1"
  FontPath     "/usr/share/fonts/misc/sgi:unscaled"
  FontPath     "/usr/share/fonts/xtest"
  FontPath     "/opt/kde3/share/fonts"
  InputDevices "/dev/gpmdata"
  InputDevices "/dev/input/mice"
EndSection

Section "ServerFlags"
  Option       "AIGLX" "on"
  Option       "AllowMouseOpenFail" "on"
  Option       "IgnoreABI" "on"
  Option       "ZapWarning" "on"
EndSection

Section "Module"
  Load         "dbe"
  Load         "extmod"
  Load         "glx"
  Load         "dri"
EndSection

Section "InputDevice"
  # Driver "kbd" will be disabled unless 'Option "AutoAddDevices" "off"' 
  # is set in "ServerFlags" section. 
  Driver       "kbd"
  Identifier   "Keyboard[0]"
  Option       "Protocol" "Standard"
  Option       "XkbLayout" "de"
  Option       "XkbModel" "microsoftpro"
  Option       "XkbRules" "xfree86"
  Option       "XkbVariant" "nodeadkeys"
EndSection


Section "InputDevice"
  # Driver "mouse" will be disabled unless 'Option "AutoAddDevices" "off"' 
  # is set in "ServerFlags" section. 
  Driver       "mouse"
  Identifier   "Mouse[1]"
  Option       "Buttons" "12"
  Option       "Device" "/dev/input/mice"
  Option       "Name" "Logitech USB-PS/2 Optical Mouse"
  Option       "Protocol" "explorerps/2"
  Option       "Vendor" "Sysp"
  Option       "ZAxisMapping" "4 5"
  Option        "SHMConfig" "on"
EndSection


Section "Monitor"
  Option       "CalcAlgorithm" "XServerPool"
  DisplaySize  344 193
  HorizSync    30-66
  Identifier   "Monitor[0]"
  ModelName    "N156B6-L06 LCD MONITOR"
  Option       "DPMS"
  Option       "PreferredMode" "1366x768"
  VendorName   "CMO"
  VertRefresh  43-60
  UseModes     "Modes[0]"
EndSection


Section "Modes"
  Identifier   "Modes[0]"
EndSection


Section "Screen"
  DefaultDepth 24
  SubSection "Display"
    Depth      15
    Modes      "1366x768" "1360x768" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480" 
  EndSubSection
  SubSection "Display"
    Depth      16
    Modes      "1366x768" "1360x768" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480" 
  EndSubSection
  SubSection "Display"
    Depth      24
    Modes      "1366x768" "1360x768" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480" 
  EndSubSection
  SubSection "Display"
    Depth      8
    Modes      "1366x768" "1360x768" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480" 
  EndSubSection
  Device       "Device[0]"
  Identifier   "Screen[0]"
  Monitor      "Monitor[0]"
EndSection


Section "Device"
  BoardName    "ATI Radeon HD 3200 Graphics"
  Driver       "fglrx"
  Identifier   "Device[0]"
  Option       "XAANoOffscreenPixmaps" "true"
  Option       "Capabilities" "0x00000000"
  Option       "OpenGLOverlay" "off"
  Option       "FSAAScale" "0"
  Option       "FSAAEnable" "off"
  Option       "VideoOverlay" "on"
  VendorName   "ATI"
EndSection



Section "ServerLayout"
  Identifier   "Layout[all]"
  InputDevice  "Keyboard[0]" "CoreKeyboard"
  InputDevice  "Mouse[1]" "CorePointer"
  Option       "Clone" "off"
  Option       "Xinerama" "off"
  Screen       "Screen[0]"
EndSection


Section "DRI"
    Group      "video"
    Mode       0660
EndSection

Section "Extensions"
  Option       "Composite" "on"
EndSection
Könnt Ihr mir bitte helfen?

Benutzeravatar
misiu
Moderator
Moderator
Beiträge: 3995
Registriert: 8. Mär 2004, 11:27
Wohnort: bei Schweinfurt

Re: Touchpad konfigurieren

Beitrag von misiu » 11. Aug 2010, 06:29

So, wie ich das sehe , hast du überhaupt kein Abschnitt für dein Touchpad in der xorg.conf drin.
Bei meinem FS Amilo sieht das so aus:

Code: Alles auswählen

Section "InputDevice"
    Identifier     "Mouse[3]"
    Driver         "synaptics"
    Option         "Buttons" "5"
    Option         "Device" "/dev/input/mice"
    Option         "Emulate3Buttons" "on"
    Option         "HorizScrollDelta" "0"
    Option         "InputFashion" "Mouse"
    Option         "Name" "Synaptics;Touchpad"
    Option         "Protocol" "explorerps/2"
    Option         "SHMConfig" "on"
    Option         "Vendor" "Sysp"
    Option         "ZAxisMapping" "4 5"
EndSection
Diese Konfiguration funktionierte bei 11.2 tadellos.
Bei 11.3 ist es sogar einfacher, da das Touchpad direkt in den KDE-Systemeinstellungen
abgestimmt werden kann.

Zu den Funktionstasten:
es kann sein, dass einfach nur eine andere kompatible Tastatur in den KDE/Gnome-Systemeinstellungen
zugeschaltet werden muss (Tastatus-Model: Asus-Laptop), bei mir war das FS-Amilo: "fscaa1667g"

Code: Alles auswählen

Section "InputDevice"
    Identifier     "Keyboard[0]"
    Driver         "kbd"
    Option         "Protocol" "Standard"
    Option         "XkbLayout" "de"
    Option         "XkbModel" "fscaa1667g"
    Option         "XkbRules" "xfree86"
    Option         "XkbVariant" "nodeadkeys"
EndSection
MfG
misiu

Henne78
Newbie
Newbie
Beiträge: 25
Registriert: 4. Feb 2005, 00:14

Re: Touchpad konfigurieren

Beitrag von Henne78 » 20. Aug 2010, 01:38

Moin, moin.

Vielleicht hilft Dir dieser Forumsbeitrag.

http://www.opensuse-forum.de/gel%C3%B6s ... t3606-f11/

Konnte selbst noch nicht überprüfen ob es wirklich funktioniert. Aber ein Versuch ist es wert.

Gute Nacht
Henne
Kaffee Junge! Schöner, schwarzer, heißer Kaffee!

ASUS UX305F Notebook, OpenSUSE Tumbleweed, Gnome 3.20.2

Antworten