Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Optisches Laufwerk unter neuer Opensuse nicht erkannt.

Alles rund um Hardware, die unter Linux läuft oder zum Laufen gebracht werden soll

Moderator: Moderatoren

Antworten
Mumie
Hacker
Hacker
Beiträge: 274
Registriert: 4. Jan 2005, 18:50
Wohnort: bei Hannover

Optisches Laufwerk unter neuer Opensuse nicht erkannt.

Beitrag von Mumie » 15. Nov 2009, 19:01

Ich kann keine Version von Opensuse ab 11.1 starten. Auch die neueste Version von Mandriva, Ubuntu und Linux-Mint kann ich nicht starten. Ich erhalte eine Fehlermeldung. "Failed to detect CD/DVD or USB drive". Wenn ich die Opensuse Installations-DVD starte, dann kommt nach einer Weile die Aufforderung, ich solle CD1 einlegen. - Es läuft insbesondere auch keine Live-Version von den genannten Distributionen.

Opensuse11.0 kann ich als Live-Version starten. Opensuse11.0 lief auch bis vor ein paar Tagen problemlos auf meinem Computer. Auch Knoppix6.1 läuft problemlos. Ich kann es starten, ich kann es auf einen USB-Stick installieren und vom USB-Stick starten. Dann kann ich sogar den DVD-Brenner nutzen. Kubuntu8.10 kann ich auch starten.

Ich habe jetzt doch Opensuse11.2 per NET-Installer installiert. Läuft! Aber leider weiß Opensuse11.2 nichts von meinem optischen Laufwerk. Es existiert einfach nicht.

Wenn ich die Live-CD von Opensuse11.0 starte, dann kann ich zusehen, wie die CD mehrere Module ausprobiert.
Probing ....dies
Probing.....das
Probing....jenes
Probing.....OHCI-Hcd
und dann startet Opensuse11.0 völlig problemlos.

Die Live-CD von Opensuse11.1 testet auch OHCI-Hcd. Aber leider startet sie dann nicht, sondern sucht weiter. Und findet kein optisches Laufwerk.

Meine Hardware: Asus P5N-E SLI. Ich habe eine Sata-II Festplatte.
Und einen IDE DVD-Brenner TSSTcorpCD/DVDW SH-S182D von Samsung.

Wie kann ich eine neuere Linuxversion dazu bringen, mein optisches Laufwerk zu erkennen?
Zuletzt geändert von Mumie am 17. Nov 2009, 18:48, insgesamt 1-mal geändert.

Werbung:
Benutzeravatar
Jägerschlürfer
Moderator
Moderator
Beiträge: 4494
Registriert: 1. Jul 2005, 12:22
Wohnort: nahe Würzburg

Re: Optisches Laufwerk unter neuer Opensuse nicht erkannt.

Beitrag von Jägerschlürfer » 15. Nov 2009, 21:36

hast du schonmal die md5 Summe der CDs/DVDs geprüft, nachdem du diese gebrannt hast? Evtl haben die eine Macke und du bekommst die Meldung, dass die CD/DVD plötzlich nicht mehr gefunden werden kann. Auch würde ich ein Defekt deines Laufwerkes nicht ausschließen, wenn es bei so vielen Distris zu Problemen kommt.
>Linux-Club Foren FAQ< >LC-Wiki<

Know your enemy and know yourself Sun Tzu

Benutzeravatar
whois
Administrator
Administrator
Beiträge: 16608
Registriert: 11. Okt 2004, 08:50
Wohnort: Aachen
Kontaktdaten:

Re: Optisches Laufwerk unter neuer Opensuse nicht erkannt.

Beitrag von whois » 16. Nov 2009, 07:05

Jägerschlürfer hat geschrieben:Auch würde ich ein Defekt deines Laufwerkes nicht ausschließen, wenn es bei so vielen Distris zu Problemen kommt.
Das halte ich ehrlich gesagt für am Wahrscheinlichsten. ;)

Code: Alles auswählen

hwinfo --cd

Mumie
Hacker
Hacker
Beiträge: 274
Registriert: 4. Jan 2005, 18:50
Wohnort: bei Hannover

Re: Optisches Laufwerk unter neuer Opensuse nicht erkannt.

Beitrag von Mumie » 16. Nov 2009, 18:39

Meine Konsoleneingabe:
su
passwort
hwinfo --cd

Ich erhalte garnichts. Wie auch. Opensuse11.2 weiß offenbar nichts von dem Laufwerk.

Benutzeravatar
Jägerschlürfer
Moderator
Moderator
Beiträge: 4494
Registriert: 1. Jul 2005, 12:22
Wohnort: nahe Würzburg

Re: Optisches Laufwerk unter neuer Opensuse nicht erkannt.

Beitrag von Jägerschlürfer » 16. Nov 2009, 18:45

hast du zu Testzwecken ein anderen Laufwerk irgendwo rumliegen?
>Linux-Club Foren FAQ< >LC-Wiki<

Know your enemy and know yourself Sun Tzu

Mumie
Hacker
Hacker
Beiträge: 274
Registriert: 4. Jan 2005, 18:50
Wohnort: bei Hannover

Re: Optisches Laufwerk unter neuer Opensuse nicht erkannt.

Beitrag von Mumie » 16. Nov 2009, 19:07

Hier mal die Ausgabe unter Knoppix:

Code: Alles auswählen

knoppix@Microknoppix:~$ hwinfo --cd
42: IDE 00.0: 10602 CD-ROM (DVD)                                
  [Created at block.247]
  UDI: /org/freedesktop/Hal/devices/storage_model_TSSTcorpCD/DVDW_SH_S182D
  Unique ID: Fffu.Lal+4yQVKQ3
  Parent ID: qnJ_.kOf6HnwGAe2
  SysFS ID: /block/hda
  SysFS BusID: 0.0
  SysFS Device Link: /devices/pci0000:00/0000:00:0d.0/ide0/0.0
  Hardware Class: cdrom
  Model: "TSSTcorpCD/DVDW SH-S182D"
  Vendor: "TSSTcorpCD/DVDW"
  Device: "SH-S182D"
  Driver: "AMD_IDE", "ide-cdrom"
  Device File: /dev/hda
  Device Number: block 3:0
  Features: CD-R, CD-RW, DVD, DVD-R, DVD-RW, DVD+R, DVD+RW, DVD+DL, DVDRAM
  Size: 6036564 sectors a 512 bytes
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #9 (IDE interface)
  Drive Speed: 126
  Volume ID: "KNOPPIX"
  Application: "KNOPPIX"
  Creation date: "2009021003314800"
  El Torito info: platform 0, bootable
    Boot Catalog: at sector 0x02f8
    Media: none starting at sector 0x02fd
    Load: 2048 bytes
knoppix@Microknoppix:~$ 
Ja, ich habe noch einen alten Computer mit DVD-Brenner. Ich werde den mal ausbauen, und hier einbauen. Wird aber ein paar Tage dauern. Das wäre ja schön, wenn das der Grund wäre. Ich fürchte aber, dass es nicht am Laufwerk liegt.

Benutzeravatar
whois
Administrator
Administrator
Beiträge: 16608
Registriert: 11. Okt 2004, 08:50
Wohnort: Aachen
Kontaktdaten:

Re: Optisches Laufwerk unter neuer Opensuse nicht erkannt.

Beitrag von whois » 17. Nov 2009, 06:56

Na wenn das laufwerk überhaupt nicht erkannt wird unter Suse hast du ein generelles Problem.
Ich würde mal versuchen die Reparaturfunktion anzuwerfen und zu hoffen das es danach läuft.

Mumie
Hacker
Hacker
Beiträge: 274
Registriert: 4. Jan 2005, 18:50
Wohnort: bei Hannover

Re: Optisches Laufwerk unter neuer Opensuse nicht erkannt.

Beitrag von Mumie » 17. Nov 2009, 18:47

whois hat geschrieben:Ich würde mal versuchen die Reparaturfunktion anzuwerfen und zu hoffen das es danach läuft.
Funktioniert leider nicht. Die DVD startet, ich wähle "Reparatur" aus, und nach einer Weile werde ich gebeten, CD1 einzulegen.

Ich sehe das so:
Wenn ich den Computer mit der DVD im Laufwerk anschalte, dann wird das Laufwerk ja erstmal vom Bios gestartet. Dann wird der Linux-Kernel geladen. Und irgendwann übernimmt dann Opensuse11.2 die Kontrolle über den Computer. Und leider hat Opensuse11.2 keinen Treiber von dem Laufwerk. Opensuse11.0 hat offenbar noch den Treiber. Zwischen Opensuse11.0 und Opensuse11.1 ist der Treiber offenbar entfernt worden. Oder er wurde verändert.

Ich werde mal probieren, ein anderes Laufwerk einzubauen

Mumie
Hacker
Hacker
Beiträge: 274
Registriert: 4. Jan 2005, 18:50
Wohnort: bei Hannover

Re: Optisches Laufwerk unter neuer Opensuse nicht erkannt.

Beitrag von Mumie » 17. Nov 2009, 21:04

So, jetzt habe ich es getan. Das DVD-Laufwerk ist getauscht. Leider sieht Opensuse11.2 das Laufwerk immer noch nicht. Beim Versuch, es neu zu installieren, erhalte ich wieder die Meldung, ich solle sicherstellen, dass CD1 im Laufwerk ist. Hier mal die neue hwinfo --cd unter Knoppix:

Code: Alles auswählen

 knoppix@Microknoppix:~$ hwinfo --cd
43: IDE 01.0: 10602 CD-ROM (DVD)                                
  [Created at block.247]
  UDI: /org/freedesktop/Hal/devices/storage_model_HL_DT_ST_DVDRAM_GSA_4167B
  Unique ID: iqvy.rTMaySzN+L5
  Parent ID: qnJ_.kOf6HnwGAe2
  SysFS ID: /block/hdb
  SysFS BusID: 0.1
  SysFS Device Link: /devices/pci0000:00/0000:00:0d.0/ide0/0.1
  Hardware Class: cdrom
  Model: "HL-DT-ST DVDRAM GSA-4167B"
  Vendor: "HL-DT-ST"
  Device: "DVDRAM GSA-4167B"
  Driver: "AMD_IDE", "ide-cdrom"
  Device File: /dev/hdb
  Device Number: block 3:64
  Features: CD-R, CD-RW, DVD, DVD-R, DVD-RW, DVD+R, DVD+RW, DVD+DL, DVDRAM
  Size: 0 sectors a 512 bytes
  Drive status: no medium
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #9 (IDE interface)
  Drive Speed: 48
knoppix@Microknoppix:~$  
Warum können Opensuse11.2 und Opensuse11.1 das Laufwerk nicht sehen?
Knoppix kann es. Und Opensuse11.0 kann es! Was ist da passiert?
Ob es etwas mit dem Zusammenspiel zwischen Sata-Festplatte und IDE-DVD-Laufwerk zu tun hat?
Hat Opensuse11.1 vielleicht ein ganz neues HAL? Kann es das sein?

Benutzeravatar
misiu
Moderator
Moderator
Beiträge: 3995
Registriert: 8. Mär 2004, 11:27
Wohnort: bei Schweinfurt

Re: Optisches Laufwerk unter neuer Opensuse nicht erkannt.

Beitrag von misiu » 17. Nov 2009, 22:40

Driver: "AMD_IDE", "ide-cdrom"
Den Driver gibt es bei 11.2 nicht mehr.
Könnte mit einen anderen laufen:

Code: Alles auswählen

cdrom
:
linux-opm6:/home # modinfo cdrom
filename: /lib/modules/2.6.31.5-0.1-desktop/kernel/drivers/cdrom/cdrom.ko
license: GPL
srcversion: 47F42FD8DE1D54619126851
depends:
vermagic: 2.6.31.5-0.1-desktop SMP preempt mod_unload modversions 686
parm: debug:bool
parm: autoclose:bool
parm: autoeject:bool
parm: lockdoor:bool
parm: check_media_type:bool
parm: mrw_format_restart:bool

oder

Code: Alles auswählen

ide-cd_mod
linux-opm6:/home # modinfo ide-cd_mod
filename: /lib/modules/2.6.31.5-0.1-desktop/kernel/drivers/ide/ide-cd_mod.ko
license: GPL
alias: ide-cd
alias: ide:*m-cdrom*
description: ATAPI CD-ROM Driver
srcversion: DD9318CD458ECE20E38F2E5
depends: ide-core,cdrom
vermagic: 2.6.31.5-0.1-desktop SMP preempt mod_unload modversions 686
parm: debug_mask:ulong

Code: Alles auswählen

ata_generic
:
linux-opm6:/home # modinfo ata_generic
filename: /lib/modules/2.6.31.5-0.1-desktop/kernel/drivers/ata/ata_generic.ko
version: 0.2.15
license: GPL
description: low-level driver for generic ATA
author: Alan Cox
srcversion: 2265C355A6F6854497AA407
alias: pci:v*d*sv*sd*bc01sc01i*
alias: pci:v00001179d00000105sv*sd*bc*sc*i*
alias: pci:v00001179d00000103sv*sd*bc*sc*i*
alias: pci:v00001179d00000102sv*sd*bc*sc*i*
alias: pci:v000016CAd00000001sv*sd*bc*sc*i*
alias: pci:v00001045d0000C558sv*sd*bc*sc*i*
alias: pci:v00001106d00000561sv*sd*bc*sc*i*
alias: pci:v00003388d00008013sv*sd*bc*sc*i*
alias: pci:v00001060d0000673Asv*sd*bc*sc*i*
alias: pci:v00001060d0000886Asv*sd*bc*sc*i*
alias: pci:v00001060d00000101sv*sd*bc*sc*i*
alias: pci:v00009412d00006565sv*sd*bc*sc*i*
alias: pci:v00001042d00003020sv*sd*bc*sc*i*
depends:
vermagic: 2.6.31.5-0.1-desktop SMP preempt mod_unload modversions 686
parm: all_generic_ide:int



laufen .

MfG
misiu

Antworten