OBS - Gradle/maven dependencies download schlägt fehl

Alles rund um die verschiedenen Konsolen und shells sowie die Programmierung unter Linux

Moderator: Moderatoren

Antworten
Benutzeravatar
DaBossDaChef
Advanced Hacker
Advanced Hacker
Beiträge: 909
Registriert: 14. Feb 2008, 15:25

OBS - Gradle/maven dependencies download schlägt fehl

Beitrag von DaBossDaChef » 10. Jul 2017, 09:37

Hallo zusammen,

ich bin gerade dabei, ein java-openjfx-Paket zu basteln, jedoch scheitert es beim Download von Abhängigkeiten aus dem Maven-Repo:

Paket:
https://build.opensuse.org/package/show ... va-openjfx

Fehler:

Code: Alles auswählen

FAILURE: Build failed with an exception.
 
 * What went wrong:
 Failed to notify model configuration listener.
 > Could not resolve all dependencies for configuration ':runtime'.
    > Could not resolve org.antlr:antlr:3.1.3.
      Required by:
          :buildSrc:unspecified
       > Could not GET 'http://repo1.maven.org/maven2/org/antlr/antlr/3.1.3/antlr-3.1.3.pom'.
          > repo1.maven.org: unknown error
Irgendwie kann gradle das Maven-Repo nicht erreichen.

Hat da jemand vllt. eine Idee? Das Spec-File habe ich hier geklaut und ein wenig angepasst:
https://github.com/gferon/openjfx-fedora

Ich bekomme einen ähnlichen Fehler auch bei MediathekView:
https://build.opensuse.org/package/show ... iathekView

Code: Alles auswählen

 * What went wrong:
A problem occurred evaluating root project 'MediathekView-13.0.2'.
 > Could not resolve all files for configuration ':runtime'.
 > Could not resolve de.mediathekview:MSearch:2.1.1.
     Required by:
          project :
       > Could not resolve de.mediathekview:MSearch:2.1.1.
          > Could not get resource 'https://repo.mediathekview.de/repository/maven-public/de/mediathekview/MSearch/2.1.1/MSearch-2.1.1.pom'.
             > Could not GET 'https://repo.mediathekview.de/repository/maven-public/de/mediathekview/MSearch/2.1.1/MSearch-2.1.1.pom'.
                > repo.mediathekview.de
s]    > Could not resolve org.swinglabs.swingx:swingx-action:1.6.6-SNAPSHOT.
      Required by:
          project :
       > Could not resolve org.swinglabs.swingx:swingx-action:1.6.6-SNAPSHOT.
       > Unable to load Maven meta-data from https://repo.mediathekview.de/repository/maven-public/org/swinglabs/swingx/swingx-action/1.6.6-SNAPSHOT/maven-metadata.xml.
      > Could not get resource 'https://repo.mediathekview.de/repository/maven-public/org/swinglabs/swingx/swingx-action/1.6.6-SNAPSHOT/maven-metadata.xml'.
                > Could not GET 'https://repo.mediathekview.de/repository/maven-public/org/swinglabs/swingx/swingx-action/1.6.6-SNAPSHOT/maven-metadata.xml'.
Mache ich hier etwas falsch? Ich kenne mich jetzt mit gradle/ maven nicht wirklich aus...

Werbung:
Benutzeravatar
DaBossDaChef
Advanced Hacker
Advanced Hacker
Beiträge: 909
Registriert: 14. Feb 2008, 15:25

[Gelöst] OBS - Gradle/maven dependencies download schlägt fehl

Beitrag von DaBossDaChef » 10. Jul 2017, 15:14

Ich habe das gradle.build-File jetzt umgebaut, so dass lokale Libraries benutzt werden. So habe ich das Problem umgangen.

Von daher [Gelöst].

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste