Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Vista verloren nach Suse11 Default-Installation

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
JS2000
Newbie
Newbie
Beiträge: 6
Registriert: 19. Dez 2008, 12:40

Vista verloren nach Suse11 Default-Installation

Beitrag von JS2000 » 19. Dez 2008, 13:15

Hallo, ich möchte endlich mal Linux lernen und habe mir Suse11 installiert, dabei alle Default-Vorschläge akzeptiert. Suse startet prima, aber Vista startet nicht mehr, es gab sogar drei Einträge dafür.
Da ich aktuell aber das vista dringend brauche und möglichst nicht über eine Vista-Reparatur Linux wieder verlieren will, hoffe ich auf einen Rat, mit dem ich erstmal Vista wieder wählen kann.


Zwei davon habe ich nach etwas Suche erster Basics gelöscht und habe aktuell:

fdisk -l :
Platte /dev/sda: 500.1 GByte, 500107862016 Byte
255 Köpfe, 63 Sektoren/Spuren, 60801 Zylinder
Einheiten = Zylinder von 16065 × 512 = 8225280 Bytes
Disk identifier: 0x04a554ec

Gerät boot. Anfang Ende Blöcke Id System
/dev/sda1 * 1 35306 283586560 7 HPFS/NTFS
/dev/sda2 35306 60802 204797952 7 HPFS/NTFS

Platte /dev/sdb: 500.1 GByte, 500107862016 Byte
255 Köpfe, 63 Sektoren/Spuren, 60801 Zylinder
Einheiten = Zylinder von 16065 × 512 = 8225280 Bytes
Disk identifier: 0x04a554eb

Gerät boot. Anfang Ende Blöcke Id System
/dev/sdb1 1 41286 331621762 7 HPFS/NTFS
/dev/sdb2 41286 60801 156761246+ f W95 Erw. (LBA)
/dev/sdb5 41286 41548 2103491+ 82 Linux Swap / Solaris
/dev/sdb6 41548 44159 20980858+ 83 Linux
/dev/sdb7 44160 60801 133676833+ 83 Linux

cat devicemap gibt:
cat /boot/grup/device.map

(hd0) /dev/sda
(hd1) /dev/sdb

Vermutlich muss ich da mit Yast am Bootloader etwas ändern (womit ich auch die zwei überzähligen Einträge entfernt habe). Dort Steht unter Windows jetzt:
Offset für Chainloading blockieren: 1
Anderes System: /dev/sda1

Kann mir jemand einen Tip geben, wie ich vorgehen sollte ?

Vielen Dank - Jürgen

Werbung:
admine
Administrator
Administrator
Beiträge: 8757
Registriert: 15. Feb 2004, 21:13
Kontaktdaten:

Re: Vista verloren nach Suse11 Default-Installation

Beitrag von admine » 19. Dez 2008, 14:58

Der Eintrag für das Windows müsste bei dir so aussehen:

Code: Alles auswählen

title Windows
  rootnoverify (hd0,0)
  makeactive
  chainloader +1
Teste es mal.
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------

JS2000
Newbie
Newbie
Beiträge: 6
Registriert: 19. Dez 2008, 12:40

Re: Vista verloren nach Suse11 Default-Installation

Beitrag von JS2000 » 19. Dez 2008, 19:15

Danke für den Tipp. Ich musste ersteinmal herausfinden, womit ich editieren kann und habe schließlich nach einigen Fehlversuchen die Änderumg mit joe in menu.lst vorgenommen (nach su).
Jetzt kommt auch die Auswahl beim Starten, aber statt Windows startet dort anscheinend die Linux-Installation wieder. Sieht irgendwie so aus, als sei da noch etwas von der Installation übrig, obwohl die doch geklappt hat.
Aus der Schleife komme ich anscheinend nicht raus.

admine
Administrator
Administrator
Beiträge: 8757
Registriert: 15. Feb 2004, 21:13
Kontaktdaten:

Re: Vista verloren nach Suse11 Default-Installation

Beitrag von admine » 19. Dez 2008, 19:30

Wo genau liegt denn dein Windows?
Auf /dev/sda1 oder /dev/sdb1?
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------

JS2000
Newbie
Newbie
Beiträge: 6
Registriert: 19. Dez 2008, 12:40

Re: Vista verloren nach Suse11 Default-Installation

Beitrag von JS2000 » 20. Dez 2008, 10:07

Ehrlich gesagt, ich weiss es nicht. Ich habe den Rechner vor nicht langer Zeit so bekommen, das System war aber nie stabil und stürzt regelmäßig ab. Das hatte ich auf das mir unbekannte Vista geschoben, was ich auch über den Einsatz von Linux verifizieren will. Ich nehme einfach mal an, dass man ein neues System auf der ersten Platte aufsetzt.
Ich werde es aber nun einfach mal mit (hd1,0) versuchen.

JS2000
Newbie
Newbie
Beiträge: 6
Registriert: 19. Dez 2008, 12:40

Re: Vista verloren nach Suse11 Default-Installation

Beitrag von JS2000 » 20. Dez 2008, 10:53

Also, nur bei hd0,0 führt der Klick auf die WINDOWS-Startoption weiter. Danach aber scheint noch einmal so etwas wie ein Bootmanager zu kommen. Ich muss mich entscheiden, ob ich
1. MS Windows Vista
2. opensuse 11.0 installer(local) möchte.

klicke ich auf das erste, kommt aber dennoch der Installer, der aber zu nichts führt, da ich die DVD nicht eingelegt habe (und nicht noch einmal Suse installieren will).
klicke ich auf das zweite, ist das Ergebnis gleich.

Diese zweite Auswahl ist ja wohl falsch, da die Entscheidung für das System doch schon getroffen wurde.

Kann es da etwas wie einen zweiten ungewollten Bootmanager geben, den ich da statt des Windows-Systems ungewollt bekomme ?
Ansonsten werde ich später doch einmal die Windows-Recovery einlegen und schauen, was mir damit an Optionen geboten wird.

Schlafmuetze
Member
Member
Beiträge: 92
Registriert: 19. Dez 2008, 10:07

Re: Vista verloren nach Suse11 Default-Installation

Beitrag von Schlafmuetze » 20. Dez 2008, 11:04

Ich nehme mal an das Du die Installation von Windows aus gestartet hat, daraufhin wurde der Suse-Installer installiert und nach einem Neustart wurde die Suse-Installation gestartet. Klickst du nun auf "2. opensuse 11.0 installer(local)" wird die Installation neu gestartet. Klickst Du allerdings auf "1. MS Windows Vista" wird Vista gestartet, wie Du selbst schon sagtest. Ich hatte mein Suse auch auf diesen Weg installiert, ich hatte allerdings die DVD im Laufwerk gelassen als ich danach Windows startete, daraufhin startet die Deinstallationsroutine des Suse-Installers und der Installer wurde deinstalliert. Nun erscheint bei einem Neustart "2. opensuse 11.0 installer(local)" nicht mehr. Von daher solltest Du die DVD einfach noch mal einlegen und Windows starten. Passieren dürfte eigentlich nichts negatives, denn sollte widererwartend doch wieder der Installationsbildschirm von Suse kommen, so kannst Du dort ja einfach auf abbrechen klicken.
Suse 11.1
KDE 4.3

JS2000
Newbie
Newbie
Beiträge: 6
Registriert: 19. Dez 2008, 12:40

Re: Vista verloren nach Suse11 Default-Installation

Beitrag von JS2000 » 20. Dez 2008, 15:38

wäre zu schön gewesen, klappt aber nicht, d.h. ich komme immer wieder nur in die Installationsroutine, die - trotz eingelegter DVD - erstmal ein Stück läuft, bis sie nach Vorbereitung von USB-Devices dann auf die DVD zugreift und vier mal Install-Teile lädt.
Wenn ich diese Installation abbreche und Install/System wähle, dort dann installisierte Systeme starten wähle und die Windows-Partition wähle (sda1 VISTA), kommt die Meldung "ungültige Root partition".

JS2000
Newbie
Newbie
Beiträge: 6
Registriert: 19. Dez 2008, 12:40

Re: Vista verloren nach Suse11 Default-Installation

Beitrag von JS2000 » 20. Dez 2008, 19:27

Ich habe inzwischen mit der Vista-Installations-DVD einen Reparaturversuch bei Startproblemen durchgeführt, dort wurde aber nichts gefunden. Daraufhin habe ich einen Speichercheck vorgemerkt, damit Vista "eine andere Aufgabe" zur Erledigung nach dem nächsten Start bekam. Dieser Check wurde dann auch statt der Fortsetzung der Linux-Installation durchgeführt, danach ging es aber leider doch wieder in die Linux-Routine.
Dann habe ich auf C:, also unter /windows/c eine Datei menu.lst gefunden, die folgenden Inhalt hatte:
hiddenmenu
timeout 0
title openSUSE 11.0 installer (LOCAL)
find --set-root /openSUSE_hitme.txt
kernel /openSUSE/linux devfs=mount,dall ramdisk_size=65536 lang=de splash=silent vga=0x31A
initrd /openSUSE/initrd
Diese Datei habe ich einfach mal umbenannt. Die Startroutine kommt nun auch nicht mehr, stattdessen aber:
booting grldr
Turning on gate A20
success
Starting cmain()..

Da bleibt es hängen.

Ist das vielleicht noch ein Hinweis, der etwas bringt ?
Wenn denn alles nicht hilft, wird wohl eine Neuinstallation von Vista erforderlich, um wieder arbeiten zu können ?

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast