Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[gelöst] "rhytmische" Schreib/Lesevorgänge auf Festplatte

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
waker
Newbie
Newbie
Beiträge: 2
Registriert: 25. Feb 2006, 12:30

[gelöst] "rhytmische" Schreib/Lesevorgänge auf Festplatte

Beitrag von waker » 2. Dez 2008, 11:31

Hallo,
ich hatte das Problem schon einmal bei einer Suse 10.0 Distri und habe es einfach durch Neuintallation behoben (meiner Erinnerung nach trat das Problem nach Änderung im KPowersafe in Yast auf.

Nun habe ich es bei Suse 11.0 wieder geschafft.

Symptom: "ryhtmische Schreibvorgänge auf Festplattes"
Ich habe "/" auf einem raid1
Die Festplatte(n) führen ca alle 1,5 secunden einen ca. 1/10 sec dauernden Zugriff auf der Festplatte durch. (Im leerlauf, wenn ich nichts mit dem Rechner mache) Das klingt wie ein Metronom.

Da es enorm stört möcht ich es abstellen.

Ich weiss, dass ich damals als ich es bei Suse 10.0 hatte lange rumgesucht hatte (logs) welcher prozess das wohl macht und nichts finden konnte. Im Hinterkopf hatte ich nur, dass es nach einer yast/powerverwaltung änderung war. Muss aber nicht damit zu tun haben.

Hat jemand einen Tip wie man dem Festplattenmetronom schnell auf die Schliche kommen kann?

Danke und Gruss
Manfred

Werbung:
waker
Newbie
Newbie
Beiträge: 2
Registriert: 25. Feb 2006, 12:30

Re: [gelöst] "rhytmische" Schreib/Lesevorgänge auf Festplatte

Beitrag von waker » 2. Dez 2008, 11:39

Ich habe den "Fehler" gerade selbst gefunden...

Nach deaktivierung des Dienstes "Kerry Beagle" ist das Festplatten-Metronom weg...

Nach erneuter aktivierung des Dienstes dauert es ca zwei Minuten bis das Metronom sich wieder einschaltet..

Was da im Detail dann die Ursache ist wäre noch zu klären, aber Verzicht auf diesen Daemon ist solange mal meine Lösung :-)

Benutzeravatar
ing0
Member
Member
Beiträge: 173
Registriert: 1. Sep 2006, 16:37
Kontaktdaten:

Re: [gelöst] "rhytmische" Schreib/Lesevorgänge auf Festplatte

Beitrag von ing0 » 2. Dez 2008, 11:47

Mir kommt das Metronom ebenfalls bekannt vor, allerdings mit einer anderen Lösung.
Die Beschreibung der Erscheinung ist ziemlich ähnlich, jedoch war das nicht auf einen Prozess zurückzuführen.

Ich hab eine ganze Weile gebraucht um herauszu finden woran es liegt.
Das Ende vom Lied jedoch, das die Festplatte eine "park" Funktion hat wobei der Lesekopf, wenn die Festplatte nicht benötigt wird, mehr oder weniger fixiert wird um einen sicheren Transport zu gewährleisten. Diese Funktion sollte eigentlich nur dann in Kraft treten wenn der Laptop im Tiefschlaf oder Ruhezustand ist.

Bei mir trat eben dieses "Metronom" auf, und die Festplatte parkte etwa 30 mal pro sekunde...
Parken schön und gut, aber diese Funktion kann unter Umständen, und nach einigen Tausend Vorgängen schäden an Mechanik verursachen.

Lange Rede kleiner Befehl.

mit

Code: Alles auswählen

hdparm -B254 /dev/sdX
wird das selbsständige Parken im Leerlauf abgeschaltet, hdparm ist standartmäßig installiert und der Befehl sollte, sofern er hilft, in den Autostart wandern.

Viel Glück
openSuse Freischwimmer-Screencast
Loading. . .
██________]
20%

wowa
Newbie
Newbie
Beiträge: 1
Registriert: 29. Dez 2008, 23:51
Wohnort: Friedrichshafen
Kontaktdaten:

Re: [gelöst] "rhytmische" Schreib/Lesevorgänge auf Festplatte

Beitrag von wowa » 30. Dez 2008, 23:11

Hi,

habe das gleiche Problem. Deaktivieren von Beagle hat nichts gebracht, also habe ich es mit hdparm versucht, leider kamm dann folgende Meldgung:

Code: Alles auswählen

linux-desktop:/home/wolfgang # hdparm -B254 /dev/sda

/dev/sda:
 setting Advanced Power Management level to 0xfe (254)
 HDIO_DRIVE_CMD failed: Input/output error
Laut der Ausgabe von hdparm /dev/sda wird das Power-Management von der Platte aber unterstützt, es handelt sich um eine ca. 4 Monate alte 500GB-IDE-Platte von Western Digital.

Habe das jetzt zum ersten Mal unter openSUSE 11.1, unter Arch und (K)Ubuntu trat das noch nie auf.

Hat jemand noch eine Idee, wie man dieses lästige "Rattern" abschalten könnte?

Gruß
Wolfgang

psiko
Newbie
Newbie
Beiträge: 36
Registriert: 2. Apr 2007, 23:37

Re: [gelöst] "rhytmische" Schreib/Lesevorgänge auf Festplatte

Beitrag von psiko » 5. Jan 2009, 20:33

ein neues Problem unter einem als "gelöst" markierten Thread aufzumachen ist keine gute Idee.
Am besten einen neuen Thread aufmachen.

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste