Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[gelöst] auf Festplatte zugreifen, wo Win98 drauf ist

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
Baxbanni

[gelöst] auf Festplatte zugreifen, wo Win98 drauf ist

Beitrag von Baxbanni » 23. Nov 2008, 09:24

Hi /root,

Bei einem meiner PCs war Win98 drauf und hab aber keine Inst-CD mehr. Möchts aber noch behalten.
Jedenfalls hab ich Debian im LMZ der TU-Wien gekauft (war eine DVD für je einen Prozessortyp dabei) und auf eine zweite Festplatte draufgespielt. Funktioniert alles soweit. Zwar manchmal doch ein wenig ruckelig und langsam (obwohl ich extra viel RAM zugekauft hab) ... aber was solls. Ich kann etwa cool Sachen uploaden, wärend ich am Laptop andere Dinge erledige.

Leider bekomm ich nun beim debianeigenen Bootloader auch automatisch Win98 als Möglichkeit präsentiert. Das hat auch glaub ich anfangs funktioniert. (Ich kann mich nicht mehr erinnern). Doch letztens bekam ich beim Startversuch von Win98 eine Fehlermeldung, dass der Speicher voll ist und ich die Autoexec.bat editieren muß ... vielleicht sind da zuviel Programme drinnen? Hab nix dazugeschrieben selber.

Jedenfalls woll ich nun die autoexec.bat öffnen in Debian und bekam die Message [0] "Unable to mount the selected volume". Was soll ich tun? :???:

[0]
libhal-storage.c 1401 : info: called libhal_free_dbus_error but dbuserror was not set.

process 3371: applications must not close shared connections - see dbus_connection_close() docs. this is a bug in the application.

error: device /dev/hda1 is not removable

error: could not execute pmount
Zuletzt geändert von Baxbanni am 23. Nov 2008, 15:49, insgesamt 1-mal geändert.

Werbung:
Benutzeravatar
blacklips
Hacker
Hacker
Beiträge: 448
Registriert: 28. Nov 2006, 19:33
Wohnort: gießen, frankfurt

Re: auf Festplatte zugreifen unter Debian, wo Win98 drauf ist

Beitrag von blacklips » 23. Nov 2008, 10:45

Mal davon abgesehen, wie alt dieser Rechner mittlerweile schon sein muss ;).

Solltest du das Ergebnis folgender Befehle posten:

Code: Alles auswählen

su
Passwort eingeben
fdisk -l
cat /etc/fstab
Der Buchstabe hinter fdisk ist ein kleines L!
Mit diesen Infos sollte sich die Festplatte einbinden lassen.
Linux: Xfce 4.6

Baxbanni

Re: auf Festplatte zugreifen unter Debian, wo Win98 drauf ist

Beitrag von Baxbanni » 23. Nov 2008, 13:18

Gut... dann poste ich mal das Ergebnis:

Code: Alles auswählen

Disk /dev/hda: 30.0 GB, 30020272128 bytes
255 heads, 63 sectors/track, 3649 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hda1   *           1        3649    29310561    c  W95 FAT32 (LBA)

Disk /dev/hdb: 20.4 GB, 20411080704 bytes
255 heads, 63 sectors/track, 2481 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hdb1   *           1        2372    19053058+  83  Linux
/dev/hdb2            2373        2481      875542+   5  Extended
/dev/hdb5            2373        2481      875511   82  Linux swap / Solaris
debian:/home/web# cat /etc/fstab
# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
/dev/hdb1       /               ext3    defaults,errors=remount-ro 0       1
/dev/hdb5       none            swap    sw              0       0
/dev/hdc        /media/cdrom0   udf,iso9660 user,noauto     0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto  0       0
:|

Benutzeravatar
blacklips
Hacker
Hacker
Beiträge: 448
Registriert: 28. Nov 2006, 19:33
Wohnort: gießen, frankfurt

Re: auf Festplatte zugreifen unter Debian, wo Win98 drauf ist

Beitrag von blacklips » 23. Nov 2008, 15:17

Alles klar, dann sollte das so funktionieren:

Code: Alles auswählen

su
Passwort eingeben
mkdir /home/DEINUSER/windows/C
Alt+F2

Code: Alles auswählen

kdesu kwrite /etc/fstab
und dort dann folgende Zeile einfügen:
/dev/hda1 /home/DEINUSER/windows/C vfat users,gid=users,umask=0002,utf8=true 00
DEINUSER sollte durch deinen Benutzernamen ersetzt werden.
Solltest du Debian mit gnome verwenden so solltest du alternativ den Befehl

Code: Alles auswählen

gksu gedit /etc/fstab
benutzen.
Dann noch speichern klicken und einmal neustarten, dann sollte alles funktionieren. Ansonsten einfach nochmal fragen.
Linux: Xfce 4.6

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast