Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

(gelöst)Kein Zugriff auf USB-Festplatte

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Benutzeravatar
revo
Member
Member
Beiträge: 126
Registriert: 23. Mär 2006, 18:20
Wohnort: Berlin

Re: (gelöst)Kein Zugriff auf USB-Festplatte

Beitrag von revo » 28. Okt 2008, 12:21

Habe für alle noch eine kleine Info zum Schluss gefunden:

Code: Alles auswählen

Automatisches Einbinden externer Festplatten mit NTFS Schreibunterstützung

Wenn man eine NTFS-formatierte USB-Platte automatisch mit Schreibzugriff eingebunden haben will, so kann man folgendermaßen vorgehen:

   1. Platte anstecken und dann mittels ntfs-config alle externen Platten auf Schreibzugriff setzen
   2. Platte wieder abziehen
   3. die durch ntfs-config geänderte /etc/fstab wieder durch die ursprüngliche ersetzen. (Einfach die neu hinzugekommene Zeile wieder löschen). ntfs-config legt einen Eintrag für die externe Platte an, der das automatische mounten über hal verhindert.
   4. beim erneuten Einstöpseln sollte hal sich nun mit der Fehlermeldung

      hal-storage-mount-removable-extra-options auth_self_keep_always <-- (action, result)

      oder einer ähnlichen dem mounten verweigern
   5. /etc/PolicyKit/PolicyKit.conf editieren damit es ausschaut wie folgt:

      <?xml version="1.0" encoding="UTF-8"?> <!-- -*- XML -*- -->
      <!DOCTYPE pkconfig PUBLIC "-//freedesktop//DTD PolicyKit Configuration 1.0//EN" "http://hal.freedesktop.org/releases/PolicyKit/1.0/config.dtd">
      <!-- See the manual page PolicyKit.conf(5) for file format -->
      <config version="0.1">
      <match action="hal-storage-mount-removable-*">
        <match user="1000|1001">
         <return result="yes"/>
        </match>
      </match>
      </config>

      bei match user= werden dabei alle user id's aufgeführt, die mounten dürfen sollen.
   6. hal restarten (mit rchal restart) oder neu starten
   7. in /sbin/ eine neue datei mount.ntfs-3g.sh anlegen mit folgendem inhalt:

      #!/bin/bash
      /bin/ntfs-3g $1 "$2" -o locale=de_DE.UTF-8,$4

   8. dann das original mount.ntfs-3g sichern und mit dem neuen .sh script verlinken:

      cd /sbin
      chmod +x mount.ntfs-3g.sh
      mv mount.ntfs-3g mount.ntfs-3g.orig
      ln -s mount.ntfs-3g.sh mount.ntfs-3g

   9. Fertig. Ab jetzt sollte jede externe NTFS-USB-Platte automatisch mit Schreibzugriff eingebunden werden. 
hier die komplette Seite:
http://de.opensuse.org/NTFS
Meiner Meinung nach, könnte das Suse auch gleich für die "Benutzer" einfacher lösen. Denn bei den normalen USB geht das Automounten ja auch.
Gruß revo
Acer Aspire 7738G-744G32MN *TV Gigant II*
NVIDIA GeForce GT240M 1024 MB VRAM
Windows® 7 Home Premium (64-Bit)
openSUSE 13.2 (Harlequin) (x86_64)
Linux 3.16.7-21-desktop
KDE 4.14.6

Werbung:
Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast