Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Debian "Lenny" - Verschlüsseltes Laufwerk LVM / Soft RAID

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
philius

Debian "Lenny" - Verschlüsseltes Laufwerk LVM / Soft RAID

Beitrag von philius » 26. Sep 2008, 12:27

Hallo ihr Lieben!


Ich habe mir schon die letzten paar Wochen die Zähne daran ausgebissen, zu versuchen ein Debian mit einer verschlüsselten Soft RAID Partition auf zu setzen.

Damals bin ich folgendermaßen vorgegangen:

Debian "Lenny" Testing i386 heruntergeladen, graphische Installationsroutine gestartet und dann folgendermaßen partitioniert: 1. Soft RAID erstellt 2. im Soft RAID MD ein verschlüsseltes Volume erstellt. 3. Verschlüsseltes Volume konfiguriert 4. Installiert...

Allerdings ließen sich diese Paritionen nach dem auf die Installationsroutine folgenden Reboot und ersten Systemstart nicht vernünftig mounten.


Nun versuche ich es seit gestern folgendermaßen:

1. LVM aufsetzen, Gruppen, Volumes erstellen etc. ...
2. In den erstellten Laufwerken die verschlüsselten Partitionen erstellen.
3. Installation beenden, erster Systemstart...


Nun scheint das auch alles geklappt zu haben. Ich kann jedenfalls booten, zumindest als Superuser.
Soweit geht alles... aber Lenny möchte, das ich die konfiguration der erstellten Laufwerke manuell beende.
Außerdem kommt direkt beim Systemstart, eine Meldung daß die verschlüsselte SWAP partition nicht gemountet werden konnte. Lenny sucht standardmäßig in /dev/mapper/hda2_crypt ... ich weiß nicht genau, was ich da nun alternativ angeben könnte.

Die Systemkonfiguration und Partitionierung sieht folgendermaßen aus:

AMD Sempron 3400+, 2 GB DDR RAM, GeForce 8600 GT 256MB, Mini ATX Asus Mainboard (mit 2 x SATA), 3Com LAN PCI, SATA PCI Adapter (2 x SATA intern, 1 x SATA extern, 1 x IDE - Linux kompatibel)...


1 x 80GB IDE Primary Master, 1 x 40 GB IDE Primary Slave... Am Secondary Channel liegen die DVD LWs an.
2 x 400GB SATA HDs vom gleichen Typ an onboard SATA Ports...
2 x 500GB SATA HDs an PCI SATA Adapterkarte, ebenfalls gleichen Typs...


Partitionsschema:

72GB /root auf hda1
8GB verschlüsseltes Volume mit SWAP Partition auf hda2
---
40GB hdb1 /srv, 40GB sda1 /srv, 40GB sdb1 /srv, 40GB sdc1 /srv, 40GB sdd1 /srv... in LVM, unverschlüsselt.
---
200GB sda2, 200 GB sdb2, 200GB sdc2, 200GB sdd2 als /save in verschlüsseltem LVM
---
ca. 160GB sda3, 160GB sdb3, 300GB sdc3, 300GB sdd3 als /home in verschlüsseltem LVM


Jo, ich denke das wäre es grob zusammengefasst.

Ich kann euch später genauere Fehlermeldungen nachreichen per Knoppix, wenn ich wieder daheim bin.
Bin gerade in der Mittagspause, daher werde ich nun erstmal etwas essen und danach nochmal an die Arbeit.


Bis dahin! :???:

Liebe Grüße

philius

Werbung:
Benutzeravatar
whois
Administrator
Administrator
Beiträge: 16599
Registriert: 11. Okt 2004, 08:50
Wohnort: Aachen
Kontaktdaten:

Re: Debian "Lenny" - Verschlüsseltes Laufwerk LVM / Soft RAID

Beitrag von whois » 26. Sep 2008, 12:41

Hi

Bitte mal diese und eventuelle Fehler Meldung im Wortlaut reinstellen.

Code: Alles auswählen

Außerdem kommt direkt beim Systemstart, eine Meldung daß die verschlüsselte SWAP partition nicht gemountet werden konnte. 
Ich kann zumindest im Moment keinen groben Fehler erkennen.

cu

philius

Re: Debian "Lenny" - Verschlüsseltes Laufwerk LVM / Soft RAID

Beitrag von philius » 26. Sep 2008, 16:04

So! Re!

Hatte grad Probleme die Knoppix DVD zu starten... die war in der CD Tasche, als bei einem Wochenendbetrinkniss vor ein paar Wochen mal ne Flasche Bier drübergelaufen ist. :schockiert:
Nun hab ich mal ne Knoppix CD genommen und es funktioniert astrein... :D

Also, hab mal grob die Fehlermeldungen von Lenny abgeschrieben und werde sie hier jetzt mal reinhämmern:


PCI Not using MMCONFIG
usb1-1: device not accepting address 2, error -62
hub1-0:1.0: unable to enumerate USB device on port 1
cryptsetup: source device /dev/hda2 not found
resume: libgcrypt version: 1.4.1
resume: Could not stat the resume device file '/dev/mapper/hda2_crypt' Please type in the full path name to try again or press ENTER to boot the system: :roll:


Zu jedem einzelnen mount von /srv, /home und /save wird angegeben:

fsck.ext3: No such file or directory while trying to open /dev/mapper/volhome-home_crypt
/dev/mapper/volhome-home_crypt: The superblock could not be read or does not describe a correct ext2 filesystem. (...)

---

Warum soll es ein ext2 FS sein? (Habe ein verschlüsseltes ext3 angelegt, soweit ich mich erinnere...)
/volhome-home_crypt genau wie die restlichen mounts, auch der unverschlüsselte /srv produzieren diese Meldung!


LG

philius

philius

Re: Debian "Lenny" - Verschlüsseltes Laufwerk LVM / Soft RAID

Beitrag von philius » 27. Sep 2008, 15:56

> Vermutlich < Habe ich per Zufall herausgefunden, das es mit Soft RAID wohl doch nicht möglich ist, auch 4 Partitionen auf unterschiedlichen Festplatten in ein RAID zu legen....

Hab es zuletzt mit Open SUSE 11 probiert... da hat sich der Rechner dann alle Nase lang aufgehängt... als ich 4 Platten mit jeweils 1 Partition im RAID (nicht!) hatte...

Nun rennt alles einwandfrei mit 2 x 500GB HD und 2 x 400GB HD jeweils in einem RAID und mount...
'/' liegt auf seperaten EIDE Platten... und weil ich nicht wirklich etwas mit der zweiten 40GB EIDE anzufangen wußte, hab ich einfach mal ne 40GB SWAP kreiert :irre:


LG

philius

p.s.: Sagt mir wenn ich mich irre und 4 Platten in einem RAID doch möglich sind!

philius

Re: Debian "Lenny" - Verschlüsseltes Laufwerk LVM / Soft RAID

Beitrag von philius » 14. Feb 2009, 13:48

Vermutlich lag es an der Hardware, speziell dem PCI SATA Adapter das es nicht so richtig hinhaute... denn ich hab jetzt die Festplatten in meinen anderen Rechner verpflanzt, wo sie alle an nativen SATA Ports hängen. Nun geht das alles einwandfrei... hab die HD's im Softraid, worin wiederum ein verschlüsseltes Laufwerk ist. - Ohne LVM

Wäre es eigentlich möglich: Auf 4 einzelnen HD's erst zwei Soft RAID MD's anzulegen, in diesen zwei Soft RAID MD's dann jeweils ein LVM Volume zu erstellen und diese dann in einer LVM Gruppe/Volume zusammenzuführen in der wiederum eine verschlüsselte Partition steckt?

Liebe Grüße

philius

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste