Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[Gelöst] Bootvorgang bleibt manchmal vor GRUB stehen

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

pekabe
Hacker
Hacker
Beiträge: 279
Registriert: 4. Apr 2004, 09:14
Wohnort: Allgäu

Re: Bootvorgang bleibt manchmal vor GRUB stehen

Beitrag von pekabe » 1. Okt 2008, 20:27

Bin wieder ein Stück weiter gekommen.
Durch genaueres Einlesen bin ich darauf gekommen, dass bei SATA-Festplatten smartctl mit der Option "-d ata" aufgerufen werden muss, das funktioniert dann auch!

Folgendes liefern nun die Aufrufe:

smartctl -Hc -d ata /dev/sda

Code: Alles auswählen

smartctl version 5.37 [x86_64-suse-linux-gnu] Copyright (C) 2002-6 Bruce Allen
Home page is http://smartmontools.sourceforge.net/

=== START OF READ SMART DATA SECTION ===
SMART overall-health self-assessment test result: PASSED

General SMART Values:
Offline data collection status:  (0x82) Offline data collection activity
                                        was completed without error.
                                        Auto Offline Data Collection: Enabled.
Self-test execution status:      (   0) The previous self-test routine completed
                                        without error or no self-test has ever
                                        been run.
Total time to complete Offline
data collection:                 ( 430) seconds.
Offline data collection
capabilities:                    (0x5b) SMART execute Offline immediate.
                                        Auto Offline data collection on/off support.
                                        Suspend Offline collection upon new
                                        command.
                                        Offline surface scan supported.
                                        Self-test supported.
                                        No Conveyance Self-test supported.
                                        Selective Self-test supported.
SMART capabilities:            (0x0003) Saves SMART data before entering
                                        power-saving mode.
                                        Supports SMART auto save timer.
Error logging capability:        (0x01) Error logging supported.
                                        General Purpose Logging supported.
Short self-test routine
recommended polling time:        (   1) minutes.
Extended self-test routine
recommended polling time:        (  92) minutes.
smartctl -i -d ata /dev/sda

Code: Alles auswählen

smartctl version 5.37 [x86_64-suse-linux-gnu] Copyright (C) 2002-6 Bruce Allen
Home page is http://smartmontools.sourceforge.net/

=== START OF INFORMATION SECTION ===
Device Model:     MAXTOR STM3250310AS
Serial Number:    6RY25NAT
Firmware Version: 3.AAC
User Capacity:    250.059.350.016 bytes
Device is:        Not in smartctl database [for details use: -P showall]
ATA Version is:   7
ATA Standard is:  Exact ATA specification draft version not indicated
Local Time is:    Wed Oct  1 20:11:21 2008 CEST
SMART support is: Available - device has SMART capability.
SMART support is: Enabled
smartctl -A -d ata /dev/sda

Code: Alles auswählen

smartctl version 5.37 [x86_64-suse-linux-gnu] Copyright (C) 2002-6 Bruce Allen
Home page is http://smartmontools.sourceforge.net/

=== START OF READ SMART DATA SECTION ===
SMART Attributes Data Structure revision number: 10
Vendor Specific SMART Attributes with Thresholds:
ID# ATTRIBUTE_NAME          FLAG     VALUE WORST THRESH TYPE      UPDATED  WHEN_FAILED RAW_VALUE
  1 Raw_Read_Error_Rate     0x000f   119   099   006    Pre-fail  Always       -       224238525
  3 Spin_Up_Time            0x0003   097   097   000    Pre-fail  Always       -       0
  4 Start_Stop_Count        0x0032   100   100   020    Old_age   Always       -       418
  5 Reallocated_Sector_Ct   0x0033   100   100   036    Pre-fail  Always       -       0
  7 Seek_Error_Rate         0x000f   071   060   030    Pre-fail  Always       -       14652738
  9 Power_On_Hours          0x0032   100   100   000    Old_age   Always       -       366
 10 Spin_Retry_Count        0x0013   100   100   097    Pre-fail  Always       -       0
 12 Power_Cycle_Count       0x0032   100   100   020    Old_age   Always       -       414
187 Unknown_Attribute       0x0032   100   100   000    Old_age   Always       -       0
189 Unknown_Attribute       0x003a   100   100   000    Old_age   Always       -       0
190 Temperature_Celsius     0x0022   063   054   045    Old_age   Always       -       622854181
194 Temperature_Celsius     0x0022   037   046   000    Old_age   Always       -       37 (Lifetime Min/Max 0/18)
195 Hardware_ECC_Recovered  0x001a   091   061   000    Old_age   Always       -       72358067
197 Current_Pending_Sector  0x0012   100   100   000    Old_age   Always       -       0
198 Offline_Uncorrectable   0x0010   100   100   000    Old_age   Offline      -       0
199 UDMA_CRC_Error_Count    0x003e   200   200   000    Old_age   Always       -       0
200 Multi_Zone_Error_Rate   0x0000   100   253   000    Old_age   Offline      -       0
202 TA_Increase_Count       0x0032   100   253   000    Old_age   Always       -       0
Jetzt muß ich mich noch genauer in smart einlesen und mich "durchwurschteln"... Oder ist aus diesen Angaben schon etwas ersichtlic

Ein weiterer Punkt ist mir allerdings noch aufgefallen: im BIOS habe ich in der Bootreihenfolge zuerst das DVD-Laufwerk und erst als zweites die Festplatte eingestellt. Beim Booten mit einer Knoppix-Live-CD hatte ich nun öfters das Problem, dass der Bootvorgang auch beim berühmten Cursor hängenblieb. Also habe ich mal die Bootreihenfolge im BIOS so geändert, dass sofort von der Festplatte gestartet wird, vielleicht hat ja das DVD-Laufwerk einen Schuss?!

Gruß,
pekabe
SUSE Linux 10-3 64Bit
Asus M2N-X Plus
AMD Athlon 64 X2 4800+
(Windows XP)

Werbung:
pekabe
Hacker
Hacker
Beiträge: 279
Registriert: 4. Apr 2004, 09:14
Wohnort: Allgäu

Re: Bootvorgang bleibt manchmal vor GRUB stehen

Beitrag von pekabe » 3. Okt 2008, 10:46

Das war's wohl, seitdem ich in der Bootreihenfolge die Festplatte als erstes stehen habe, blieb der Bootvorgang nicht mehr hängen. Ganz offensichtlich liegt es also am DVD-Laufwerk, obwohl ich im normalen Betrieb (es handelt sich um einen DVD-Brenner von Samsung) noch nie Probleme damit hatte.

Jedenfalls ist das Problem gelöst und ich habe außerdem etwas über SMART gelernt ;)

Vielen Dank für Eure Unterstützung!

Gruß,
pekabe
SUSE Linux 10-3 64Bit
Asus M2N-X Plus
AMD Athlon 64 X2 4800+
(Windows XP)

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast