Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[Gelöst] VBOX 2 Upgrade Problem!

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Benutzeravatar
revealed
Guru
Guru
Beiträge: 3016
Registriert: 15. Sep 2006, 12:50

[Gelöst] VBOX 2 Upgrade Problem!

Beitrag von revealed » 14. Sep 2008, 19:14

Hallo!

Ich habe das VBOX Repo und gerade eben das Update gemacht auf die zweier Version. Meine VM lief vorher noch!

Nach der Installation kam mir folgender Fehler entgegen:
X Eine neue Sitzung konnte nicht angelegt werden.

Code: Alles auswählen

Callee RC: NS_ERROR_FACTORY_NOT_REGISTERED (0x80040154)
So dann dachte ich mir hm, ja ok. Mal alle VBOX Pakete Löschen und neu drauf! (Habe ich gemacht!)
Im FAQ dort steht: ( http://www.virtualbox.org/wiki/User_FAQ ) Man solle beim Deinstallieren dieses Verzeichnis töten:

Code: Alles auswählen

rm -rf /var/lib/dkms/vboxdrv
Wenn das RPM deinstalliert ist und ich glaube so oder so, existiert dieses nicht?

Jedenfalls -- Wieder probiert und selber Fehler. :(

Dann dachte ich mir hm ok gut könnte auch an der bestehenden VM im Homeverzeichnis liegen?
Also habe ich das bestehende
/home/user/.VirtualBox umbenannt und zum Test das Programm gestartet, worauf mir dieser Fehler begegnete:

Code: Alles auswählen

Assertion failed at '/usr/src/packages/BUILD/VirtualBox-2.0.0/src/VBox/Main/VirtualBoxImpl.cpp' (1915) in virtual nsresult VirtualBox::GetExtraData(const PRUnichar*, PRUnichar**).
Unexpected exception 'N8settings12EIPRTFailureE' (<NULL>)
.
Please contact the product vendor!.
Das Programm liess sich nicht starten! Ein erneutes Starten brachte die GUI hoch! Jedenfalls -- habe eine neue VM zum Test angelegt und beim Starten kommt wieder:

Code: Alles auswählen

Callee RC: NS_ERROR_FACTORY_NOT_REGISTERED (0x80040154)
Also liegt es weder am Home Verzeichnis noch an mir bekannten Methoden zur Neuinstallation der VirtualBox.

HILFE!

Gruß,

R

PS.: Was ich noch feststellen konnte:

Code: Alles auswählen

modprobe vboxdrv force_async_tsc=1
FATAL: Error inserting vboxdrv (/lib/modules/2.6.22.18-0.2-default/updates/vboxdrv.ko): Unknown symbol in module, or unknown parameter (see dmesg)
Ausgabe von dmesg:

Code: Alles auswählen

vboxdrv: Unknown symbol __udivdi3
Zuletzt geändert von revealed am 3. Okt 2008, 07:47, insgesamt 1-mal geändert.
|Nb: T60 2008 43G @oS Leap 42.1 | Pc: @oS TW Core i5 4670k; 8 GB RAM; MSI Z87 G43 Gaming | MSI TF 770 GTX | 840 EVO; SX900 |The reason computer chips are so small is computers don't eat much. | systemd | Mini Tuning guide für openSUSE 13.2 |

Werbung:
Benutzeravatar
revealed
Guru
Guru
Beiträge: 3016
Registriert: 15. Sep 2006, 12:50

Re: VBOX 2 Upgrade Problem!

Beitrag von revealed » 14. Sep 2008, 19:42

Ich schau nochmal YasT durch und deinstallier es nochmals...

Dann werd ich mal ein updatedb machen und alle Files suchen die eventuell noch rumliegen.

Hat daweil jemand eine Idee woran das liegen könnte?

Gruß,

R

Ich bin am Ende ich finde es leider nicht. Es kommt unter Anderem zu folgenden Fehlern:

Code: Alles auswählen

wild-thing:/home/disk # modprobe vboxadd
FATAL: Error inserting vboxadd (/lib/modules/2.6.22.18-0.2-default/updates/vboxadd.ko): No such device

Code: Alles auswählen

wild-thing:/home/disk # modprobe vboxvfs
WARNING: Error inserting vboxadd (/lib/modules/2.6.22.18-0.2-default/updates/vboxadd.ko): No such device
FATAL: Error inserting vboxvfs (/lib/modules/2.6.22.18-0.2-default/updates/vboxvfs.ko): Unknown symbol in module, or unknown parameter (see dmesg)
|Nb: T60 2008 43G @oS Leap 42.1 | Pc: @oS TW Core i5 4670k; 8 GB RAM; MSI Z87 G43 Gaming | MSI TF 770 GTX | 840 EVO; SX900 |The reason computer chips are so small is computers don't eat much. | systemd | Mini Tuning guide für openSUSE 13.2 |

Benutzeravatar
revo
Member
Member
Beiträge: 126
Registriert: 23. Mär 2006, 18:20
Wohnort: Berlin

Re: VBOX 2 Upgrade Problem!

Beitrag von revo » 14. Sep 2008, 21:33

Hey R,
Habe genau das selbe Problem :skeptisch: Denke da muss Sun noch etwas nachbessern. Hatte auch den heutigen Tag damit verbracht VBox wieder zum laufen zu bringen. Mit dem selben Erfolg :???:
Bin dabei noch auf eine Aktualisierung von Sun gestoßen. http://download.virtualbox.org/virtualb ... nload.html Lies sich aber nicht installieren.
Gruss revo
Acer Aspire 7738G-744G32MN *TV Gigant II*
NVIDIA GeForce GT240M 1024 MB VRAM
Windows® 7 Home Premium (64-Bit)
openSUSE 13.2 (Harlequin) (x86_64)
Linux 3.16.7-21-desktop
KDE 4.14.6

Benutzeravatar
revealed
Guru
Guru
Beiträge: 3016
Registriert: 15. Sep 2006, 12:50

Re: VBOX 2 Upgrade Problem!

Beitrag von revealed » 14. Sep 2008, 21:47

Aha. ;)

Immerhin, dann bin ich wieder nicht alleine das erbaut mich dann schon wieder!

Danke dir für die Information. Ich hab es jetzt erstmal deinstalliert und das disk img mit ISPCONFIG aufgehoben. Mal schaun, was da nächste woche passiert.

Wenn du oder jemand anderes was mitbekommt wegen Bugfix, währe es toll das hier zu posten, damit ich weiter testen kann mit der VM.

Gruß,

R
|Nb: T60 2008 43G @oS Leap 42.1 | Pc: @oS TW Core i5 4670k; 8 GB RAM; MSI Z87 G43 Gaming | MSI TF 770 GTX | 840 EVO; SX900 |The reason computer chips are so small is computers don't eat much. | systemd | Mini Tuning guide für openSUSE 13.2 |

balta
Newbie
Newbie
Beiträge: 12
Registriert: 26. Mär 2006, 21:48

Re: VBOX 2 Upgrade Problem!

Beitrag von balta » 14. Sep 2008, 23:40

Hi,

ich weiß zwar nicht ob es dieses Problem ist, aber ich fand bei der Lösungssuche folgendes:
http://www.mail-archive.com/vbox-dev@vi ... 00737.html

und siehe da: als root läuft VirtualBox 2.0 ohne diesen Fehler. Ein

Code: Alles auswählen

ln -s /home/xyz/.VirtualBox /root/.VirtualBox
und man hat seine VMs... ich weiß, keine schöne Lösung, aber immrhin läuft es.

Grüße,
balta

Benutzeravatar
revealed
Guru
Guru
Beiträge: 3016
Registriert: 15. Sep 2006, 12:50

Re: VBOX 2 Upgrade Problem!

Beitrag von revealed » 14. Sep 2008, 23:43

Hi!

Danke - Aber das ist für mich definitiv keine Lösung!

Gruß,

R
|Nb: T60 2008 43G @oS Leap 42.1 | Pc: @oS TW Core i5 4670k; 8 GB RAM; MSI Z87 G43 Gaming | MSI TF 770 GTX | 840 EVO; SX900 |The reason computer chips are so small is computers don't eat much. | systemd | Mini Tuning guide für openSUSE 13.2 |

stefan.becker
Advanced Hacker
Advanced Hacker
Beiträge: 1140
Registriert: 12. Mär 2006, 17:23

Re: VBOX 2 Upgrade Problem!

Beitrag von stefan.becker » 15. Sep 2008, 07:29

Löscht mal per Dateimanager im Verzeichnis "/tmp" die Unterverzeichnisse "/tmp/.vbox-*".

Das andere sollte wirklich nicht notwendig sein.

Bezgl. unbekannter Symbole: Was sagt "rpm -qa | grep kernel"?

Benutzeravatar
revealed
Guru
Guru
Beiträge: 3016
Registriert: 15. Sep 2006, 12:50

Re: VBOX 2 Upgrade Problem!

Beitrag von revealed » 15. Sep 2008, 07:34

Hi!

Vielen Dank für den Tipp!
Das Verzeichnis existiert bei mir scheinbar nicht? Ich muss schnell los jetz, sorry. Trotzdem die Ausgabe:

Code: Alles auswählen

wild-thing:/home/disk # rpm -qa | grep kernel && ls -al /tmp/.vbo*
kernel-default-2.6.22.18-0.2
linux-kernel-headers-2.6.22-19
kernel-syms-2.6.22.18-0.2
kernel-source-2.6.22.18-0.2
ls: Zugriff auf /tmp/.vbo* nicht möglich: Datei oder Verzeichnis nicht gefunden
Gruß,

R

PS.: Vbox is bei mir momentan nicht mehr installiert. Deswegen kein passendes Kernelmodul in der Ausgabe. Ich werd es heut Abend bei Zeit nochmal installieren. Ich glaub aber die Kernel auswahl is in Ordnung. Die läuft seit 2007 so.
|Nb: T60 2008 43G @oS Leap 42.1 | Pc: @oS TW Core i5 4670k; 8 GB RAM; MSI Z87 G43 Gaming | MSI TF 770 GTX | 840 EVO; SX900 |The reason computer chips are so small is computers don't eat much. | systemd | Mini Tuning guide für openSUSE 13.2 |

stefan.becker
Advanced Hacker
Advanced Hacker
Beiträge: 1140
Registriert: 12. Mär 2006, 17:23

Re: VBOX 2 Upgrade Problem!

Beitrag von stefan.becker » 15. Sep 2008, 07:45

Sieht soweit gut aus. Ist das 10.3 mit allen Updates oder kommt der Kernel woanders her?

Ansonsten auf jeden Fall mal ein Online Update machen.

Benutzeravatar
revealed
Guru
Guru
Beiträge: 3016
Registriert: 15. Sep 2006, 12:50

Re: VBOX 2 Upgrade Problem!

Beitrag von revealed » 15. Sep 2008, 08:05

Das is 10.3 mit allen Updates :)

Ich werds glaube ich vielleicht doch erst am Montag nochmal probieren, wenn ein Patch erschienen ist. Ist klingt optimistisch aber vielleicht bissl wie ne Forderung. Ich wollte nur nicht pessimistisch wirken.

Immerhin sei laut einem Popup des Frontend bereits die VirtualBox 2.2 verfügbar?

Gruß,

R
|Nb: T60 2008 43G @oS Leap 42.1 | Pc: @oS TW Core i5 4670k; 8 GB RAM; MSI Z87 G43 Gaming | MSI TF 770 GTX | 840 EVO; SX900 |The reason computer chips are so small is computers don't eat much. | systemd | Mini Tuning guide für openSUSE 13.2 |

Benutzeravatar
Rainer Juhser
Moderator
Moderator
Beiträge: 3892
Registriert: 14. Aug 2006, 17:03
Wohnort: 04711 Münchhausen

Re: VBOX 2 Upgrade Problem!

Beitrag von Rainer Juhser » 15. Sep 2008, 09:18

revealed hat geschrieben:Immerhin sei laut einem Popup des Frontend bereits die VirtualBox 2.2 verfügbar?
Ganz so weit ist es noch nicht - die neue Version trägt die Nummer 2.0.2 :roll:
Changelog: http://www.virtualbox.org/wiki/Changelog
Salü vom Rainer Juhser
_________________________
Bist du neu - guckst du hier:
Neu im Linux-Club?...Bitte LESEN! == Bedienungsanleitung Forum == Hilfe zu Antworten aus dem Forum
== WISSEN PUR: Linupedia - das Linux-Club WIKI!

Benutzeravatar
revealed
Guru
Guru
Beiträge: 3016
Registriert: 15. Sep 2006, 12:50

Re: VBOX 2 Upgrade Problem!

Beitrag von revealed » 15. Sep 2008, 18:18

jo da hab ich mich eindeutig vertan!

Gruß,

R
|Nb: T60 2008 43G @oS Leap 42.1 | Pc: @oS TW Core i5 4670k; 8 GB RAM; MSI Z87 G43 Gaming | MSI TF 770 GTX | 840 EVO; SX900 |The reason computer chips are so small is computers don't eat much. | systemd | Mini Tuning guide für openSUSE 13.2 |

open_suser
Newbie
Newbie
Beiträge: 1
Registriert: 15. Sep 2008, 19:59

Re: VBOX 2 Upgrade Problem!

Beitrag von open_suser » 15. Sep 2008, 23:25

Hallo Revealed

Ich hatte gestern mit Virtualbox 2.02 genau die gleiche Fehlermeldung und konnte das Programm Virtualbox nicht starten. Allerdings betraf der Fehler nur mein normales Benutzerkonto, während andere Benutzerkonten auf dem selben Rechner mit Virtualbox und den VDI-Dateien problemlos arbeiten konnten.

Nach vielen nutzlosen Maßnahmen inklusive eines (wirkungslosen) Downgrades auf Version 1.66 kam ich über ein Fehlerticket (http://www.virtualbox.org/ticket/1727) auf folgende (für mich funktionierende) Lösung:

Ich setzte die Rechte auf "meinen" Virtualbox-Ordner "/tmp/.vbox-*" (und seine Inhalte), die (fehlerhafterweise) auf Benutzer/Gruppe "root" gesetzt waren, so um, dass mein Benutzerkonto Besitzer mit vollen Zugriffsrechten wurde und seitdem funktioniert Virtualbox wieder korrekt.

Weil das Problem aber mit Version 2.02 ins Rollen kam, werde ich nun erstmal bei Version 1.66 bleiben (da Version 1.66 die Definitionen für die virtuellen Maschinen nicht lesen konnte, habe ich sie neu definiert; die VDI-Dateien von Version 2.02 konnte ich dabei problemlos weiterbenutzen).

Benutzeravatar
FordPrefect
Member
Member
Beiträge: 247
Registriert: 24. Feb 2007, 14:56
Wohnort: Stuttgart

Re: VBOX 2 Upgrade Problem!

Beitrag von FordPrefect » 15. Sep 2008, 23:49

Also ich kann nicht nachvollziehen was ihr schreibt. Ich habe VBox allerdings nicht vom Repo bezogen sondern das rpm von deren Homepage runter geladen und dann installiert. Ging bei beiden Updates (2.0 und 2.02) absolut problemlos.

Im Gegenteil, bei früheren Updates musste ich jeweils meine shared folders neu anlegen. Die haben dieses mal auf Anhieb funktioniert. Wie gesagt, nicht exakt die Voegehensweise von euch, aber bei mir hat das tadellos geklappt. Wenn ihr natürlich speziell auf die open source Variante scharf seid, dann hilft das natürlich nicht weiter.
Bild

Benutzeravatar
revealed
Guru
Guru
Beiträge: 3016
Registriert: 15. Sep 2006, 12:50

Re: VBOX 2 Upgrade Problem!

Beitrag von revealed » 17. Sep 2008, 21:32

Ja :)

Ich möchte auf die Vorteile einer OpenSource Software nicht verzichten müssen! Und obendrein noch ein einfaches RPM verwenden.

Gibts schon neuigkeiten zum RPM?

Gruß,

R
|Nb: T60 2008 43G @oS Leap 42.1 | Pc: @oS TW Core i5 4670k; 8 GB RAM; MSI Z87 G43 Gaming | MSI TF 770 GTX | 840 EVO; SX900 |The reason computer chips are so small is computers don't eat much. | systemd | Mini Tuning guide für openSUSE 13.2 |

}-Tux-{
Moderator
Moderator
Beiträge: 698
Registriert: 12. Dez 2004, 19:54
Kontaktdaten:

Re: VBOX 2 Upgrade Problem!

Beitrag von }-Tux-{ » 18. Sep 2008, 19:03

revealed hat geschrieben:Gibts schon neuigkeiten zum RPM?
Ja habs gerade gefixed. Die neue Version ist hier zu finden http://download.opensuse.org/repositori ... irtualBox/
Sorry für die Probleme.


}-Tux-{

Benutzeravatar
revealed
Guru
Guru
Beiträge: 3016
Registriert: 15. Sep 2006, 12:50

Re: VBOX 2 Upgrade Problem!

Beitrag von revealed » 18. Sep 2008, 20:13

Sehr genial!

Danke dir für die Information! Ich werds gleich ausprobieren.

Danke!

Gruß,

R
|Nb: T60 2008 43G @oS Leap 42.1 | Pc: @oS TW Core i5 4670k; 8 GB RAM; MSI Z87 G43 Gaming | MSI TF 770 GTX | 840 EVO; SX900 |The reason computer chips are so small is computers don't eat much. | systemd | Mini Tuning guide für openSUSE 13.2 |

eknem

Re: VBOX 2 Upgrade Problem!

Beitrag von eknem » 18. Sep 2008, 20:45

jetzt geht's wieder!

Danke

Benutzeravatar
revealed
Guru
Guru
Beiträge: 3016
Registriert: 15. Sep 2006, 12:50

Re: VBOX 2 Upgrade Problem!

Beitrag von revealed » 18. Sep 2008, 21:07

Hallo!

Ein Problem habe ich noch! Die VM startet zwar wieder allerdings kommt folgendes beim Boot:

Code: Alles auswählen

wild-thing:/home/disk # grep failed /var/log/boot.msg
<4>rtc_cmos: probe of 00:03 failed with error -16
doneStarting VirtualBox Additions failed
(modprobe vboxadd failed)
Starting VirtualBox Additions shared folder support failed
(modprobe vboxvfs failed)
wild-thing:/home/disk # modprobe vboxadd
FATAL: Error inserting vboxadd (/lib/modules/2.6.22.18-0.2-default/updates/vboxadd.ko): No such device
wild-thing:/home/disk # modprobe -l vbox
wild-thing:/home/disk # modprobe -l vboxadd
/lib/modules/2.6.22.18-0.2-default/updates/vboxadd.ko
wild-thing:/home/disk # modprobe vboxadd
FATAL: Error inserting vboxadd (/lib/modules/2.6.22.18-0.2-default/updates/vboxadd.ko): No such device
wild-thing:/home/disk #    
hat jemand Rat?

Code: Alles auswählen

wild-thing:/home/disk # rpm -qa |grep virtual
virtualbox-ose-guest-tools-2.0.2-6.1
virtualbox-ose-2.0.2-6.1
virtualbox-ose-kmp-default-2.0.2_2.6.22.18_0.2-6.1
xorg-x11-driver-virtualbox-ose-2.0.2-6.1
Gruß,

R
Zuletzt geändert von revealed am 18. Sep 2008, 21:43, insgesamt 2-mal geändert.
|Nb: T60 2008 43G @oS Leap 42.1 | Pc: @oS TW Core i5 4670k; 8 GB RAM; MSI Z87 G43 Gaming | MSI TF 770 GTX | 840 EVO; SX900 |The reason computer chips are so small is computers don't eat much. | systemd | Mini Tuning guide für openSUSE 13.2 |

}-Tux-{
Moderator
Moderator
Beiträge: 698
Registriert: 12. Dez 2004, 19:54
Kontaktdaten:

Re: VBOX 2 Upgrade Problem!

Beitrag von }-Tux-{ » 18. Sep 2008, 21:16

Was sagt dmesg beim Laden des vboxadd Modules? Dieses Module muss in der VM selbst geladen werden - nicht auf dem Hostsystem.


}-Tux-{

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast