Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[gelöst?] Virtualbox und 11.0: "not installed"

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
Thurisaz
Member
Member
Beiträge: 69
Registriert: 16. Nov 2004, 13:40
Kontaktdaten:

[gelöst?] Virtualbox und 11.0: "not installed"

Beitrag von Thurisaz » 22. Aug 2008, 15:04

Moins,

ich hab da ein Problem, das auf den ersten Blick aussieht wie http://www.linux-club.de/viewtopic.php?f=43&t=95945... aber der Sachverhalt ist etwas anders.

Yast2 zeigt mir das VirtualBox-Kernel Module als installiert an, beim Versuch die Box zu starten aber:
VirtualBox kernel driver not installed. The vboxdrv kernel module was either not loaded or /dev/vboxdrv was not created for some reason. Re-setup the kernel module by executing '/etc/init.d/vboxdrv setup' as root.
VBox status code: -1908 (VERR_VM_DRIVER_NOT_INSTALLED).


Fehlercode:
0x80004005
Komponente:
Console
Interface:
IConsole {1dea5c4b-0753-4193-b909-22330f64ec45}
Hab ich dann schön das Setupskript gestartet... und:
Stopping VirtualBox kernel module done
Recompiling VirtualBox kernel module, NOT. It has been packaged. done
Starting VirtualBox kernel module failed
(Kernel module not found)
(Kursiv = hier ist der Unterschied zum oben gelinkten Thread)

Wie jetzt? Das Skript kann das Modul stoppen (ach ja, der Runlevel-Editor zeigt es auch als aktiviert an), aber beim Starten ist es auf einmal nicht da? :schockiert:

Das Device ist im übrigen in der Tat nicht in /dev vorhanden... macht es Sinn, es irgendwie von Hand anzulegen? Wie?

(EDIT)

Einen Moment nach dem Abschicken des Postings (wann auch sonst... :zensur: ) fiel mir ein, mal ein "modprobe vboxdrv" abzusetzen. Jetzt kommt die Maschine zumindest noch... bleibt nur noch was drauf zu installieren. Mal sehen... :irre:
Zuletzt geändert von Thurisaz am 24. Aug 2008, 09:53, insgesamt 1-mal geändert.
M$ is not the answer, it is the question.

The answer is NO.

Werbung:
Thurisaz
Member
Member
Beiträge: 69
Registriert: 16. Nov 2004, 13:40
Kontaktdaten:

Re: Virtualbox und 11.0: Kernel Module (nicht) installiert?!

Beitrag von Thurisaz » 22. Aug 2008, 16:59

Oookay, das einzige was hier schiefläuft ist daß ich das vboxdrv-Modul erst mit modprobe in den Kernel schießen muß. Danach läuft alles wunderbar.

Wie war das doch, um das automatisch erledigen zu lassen... "install vboxdrv" in /etc/modules.conf.local? Das hab ich schon so ewig lang nicht mehr machen müssen... :???:
M$ is not the answer, it is the question.

The answer is NO.

jengelh
Guru
Guru
Beiträge: 4039
Registriert: 20. Nov 2004, 17:42
Kontaktdaten:

Re: Virtualbox und 11.0: Kernel Module (nicht) installiert?!

Beitrag von jengelh » 23. Aug 2008, 00:56

`insserv vboxdrv` als root auf der Shell.

Thurisaz
Member
Member
Beiträge: 69
Registriert: 16. Nov 2004, 13:40
Kontaktdaten:

Re: Virtualbox und 11.0: Kernel Module (nicht) installiert?!

Beitrag von Thurisaz » 23. Aug 2008, 09:13

Gerade gemacht, bringt's leider nicht?! :???:
M$ is not the answer, it is the question.

The answer is NO.

stefan.becker
Advanced Hacker
Advanced Hacker
Beiträge: 1140
Registriert: 12. Mär 2006, 17:23

Re: Virtualbox und 11.0: Kernel Module (nicht) installiert?!

Beitrag von stefan.becker » 23. Aug 2008, 14:09

Was sagen

rpm -qa | grep gcc
rpm -qa | grep kernel
rpm -qa | grep irtual

?


Was sagt der Befehl, den du getestet hast?

jengelh
Guru
Guru
Beiträge: 4039
Registriert: 20. Nov 2004, 17:42
Kontaktdaten:

Re: Virtualbox und 11.0: Kernel Module (nicht) installiert?!

Beitrag von jengelh » 23. Aug 2008, 17:06

Thurisaz hat geschrieben:Gerade gemacht, bringt's leider nicht?! :???:
Na insserv ist ja auch nur für die Bootphase. Wenn du dein Rechner noch an hast, musst du diesmal noch manuell starten, /etc/init.d/vboxdrv start .

Thurisaz
Member
Member
Beiträge: 69
Registriert: 16. Nov 2004, 13:40
Kontaktdaten:

Re: Virtualbox und 11.0: Kernel Module (nicht) installiert?!

Beitrag von Thurisaz » 23. Aug 2008, 19:15

stefan.becker hat geschrieben:Was sagen

rpm -qa | grep gcc
rpm -qa | grep kernel
rpm -qa | grep irtual

?


Was sagt der Befehl, den du getestet hast?
Die ersten drei:
rpm -qa | grep gcc
libgcc43-32bit-4.3.1_20080507-6.1
libgcc43-4.3.1_20080507-6.1

rpm -qa | grep kernel
kernel-xen-2.6.25.11-0.1
kernel-default-2.6.25.11-0.1

rpm -qa | grep irtual
xorg-x11-driver-virtualbox-ose-1.5.6-33.1
virtualbox-ose-1.5.6-33.1
virtualbox-ose-kmp-default-1.5.6_2.6.25.5_1.1-33.1
virtualbox-ose-guest-tools-1.5.6-33.1
Der insserv sagt gar nichts (für gewöhnlich ja ein gutes Zeichen :) )
M$ is not the answer, it is the question.

The answer is NO.

Thurisaz
Member
Member
Beiträge: 69
Registriert: 16. Nov 2004, 13:40
Kontaktdaten:

Re: Virtualbox und 11.0: Kernel Module (nicht) installiert?!

Beitrag von Thurisaz » 23. Aug 2008, 19:16

jengelh hat geschrieben:
Thurisaz hat geschrieben:Gerade gemacht, bringt's leider nicht?! :???:
Na insserv ist ja auch nur für die Bootphase. Wenn du dein Rechner noch an hast, musst du diesmal noch manuell starten, /etc/init.d/vboxdrv start .
Leider will das Biest auch nach Reboot noch manuell gestartet werden... gerade extra nochmal getestet :zensur:
M$ is not the answer, it is the question.

The answer is NO.

stefan.becker
Advanced Hacker
Advanced Hacker
Beiträge: 1140
Registriert: 12. Mär 2006, 17:23

Re: Virtualbox und 11.0: Kernel Module (nicht) installiert?!

Beitrag von stefan.becker » 23. Aug 2008, 20:03

OK. Ich würde die OSE 1.56 herunterwerfen und Version 1.64 von der VBOS Homepage installieren (die Version für Suse 10.3 läuft gut).

Allerdings muss noch was zusätzlich installiert werden

=> zypper install make automake autoconf gcc kernel-source

Thurisaz
Member
Member
Beiträge: 69
Registriert: 16. Nov 2004, 13:40
Kontaktdaten:

Re: Virtualbox und 11.0: Kernel Module (nicht) installiert?!

Beitrag von Thurisaz » 24. Aug 2008, 09:52

Hmmm. Okay. Da der Kram grundsätzlich erstmal läuft werde ich das wohl irgendwann demnächst ausprobieren. Bis dahin bin ich mal optimistisch und markiere diesen Thread als "gelöst" :)
M$ is not the answer, it is the question.

The answer is NO.

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste