Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

WinXP startet nicht mehr

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
Jeanquirit
Newbie
Newbie
Beiträge: 26
Registriert: 8. Feb 2008, 15:00

WinXP startet nicht mehr

Beitrag von Jeanquirit » 24. Jul 2008, 09:56

Hallo Leute,
nach dem ich mehrmals testweise openSUSE11 installiert und dabei fleißig Partitionen angelegt und gelöscht habe, läßt sich Windows nicht mehr starten. Ich schwöre, daß ich die Win-Partition nicht angerührt habe! Sie scheint an sich auch intakt zu sein (ich kann von Knoppix aus darauf zugreifen).

Ich glaube, daß die Reihenfolge der Partitionen irgendwie durcheinander geraten war (C und D waren in der Repairkonsole vertauscht), deshalb habe ich mit testdisk die Partitionstabelle neu geschrieben. Es gibt jetzt nur noch die leeren 8MB ganz am Anfang, die Windows-System-Partition, einen freien Bereich, meine Daten-Partition und noch einen freien Bereich. In der Wiederherstellungskonsole wird die Installation gefunden. FIXMBR, FIXBOOT und BOOTCFG bringen aber nichts: Der Rechner bleibt hängen in dem Moment, wenn das BIOS von der Platte booten soll - ohne Fehlermeldung.

Kann ich noch irgendwas versuchen, um eine Neuinstallation zu vermeiden?

Danke.

Werbung:
Benutzeravatar
lOtz1009
Moderator
Moderator
Beiträge: 7147
Registriert: 23. Jan 2008, 09:51
Wohnort: Sulzbach/Ts.

Re: WinXP startet nicht mehr

Beitrag von lOtz1009 » 24. Jul 2008, 09:59

Ich weiß nicht, ob das eher in ein Windows-Forum gehört, aber poste doch bitte mal die Ausgabe von

Code: Alles auswählen

fdisk -l (kleines L)
(von Knoppix oder Suse aus). Und welche Betriebssysteme sind nun auf deinem Rechner installiert?
::: openSUSE Member :::
::: LXDE-Team :::
Linux-Club Wiki
vi is an editor with two modes: one which destroys your input and the other which beeps at you.
Für meine Beiträge gilt:
Bild

Benutzeravatar
SUSEDJAlex
Advanced Hacker
Advanced Hacker
Beiträge: 863
Registriert: 18. Apr 2008, 22:09
Wohnort: Heimatplanet Abydos

Re: WinXP startet nicht mehr

Beitrag von SUSEDJAlex » 24. Jul 2008, 10:10

@Jeanquirit:

wenn du von Knoppix aus zugreifen kannst.....dann müsstest du auch sehen warum die 8mb vorne hängen.....ist nach m. E. nicht richtig.....

Die ganzen Partitionstabelle ist ziemlich durchgewirbelt worden.....LW C: muss ganz am Anfang der Partitionstabelle sein da darf nix davor sein......

LG SUSE_DJAlex
openSUSE LEAP 42.3 mit Plasma 5.11 / arch linux mit Kernel 4.9.70-1-lts und XFCE4

Jeanquirit
Newbie
Newbie
Beiträge: 26
Registriert: 8. Feb 2008, 15:00

Re: WinXP startet nicht mehr

Beitrag von Jeanquirit » 24. Jul 2008, 10:15

Code: Alles auswählen

root@Knoppix:/ramdisk/home/knoppix# fdisk -l

Platte /dev/sda: 750.1 GByte, 750155292160 Byte
255 Köpfe, 63 Sektoren/Spuren, 91201 Zylinder
Einheiten = Zylinder von 16065 × 512 = 8225280 Bytes
Disk identifier: 0x16ae16ad

    Gerät  boot.     Anfang        Ende     Blöcke   Id  System
/dev/sda1   *           2        6528    52428096    7  HPFS/NTFS
/dev/sda2           13055       78325   524289307+   7  HPFS/NTFS

Jeanquirit
Newbie
Newbie
Beiträge: 26
Registriert: 8. Feb 2008, 15:00

Re: WinXP startet nicht mehr

Beitrag von Jeanquirit » 24. Jul 2008, 10:26

Suse_DJAlex:
da darf nix davor sein......
Würde das heißen, dass die nachträglich dahingekommen sind? Dann müßten sie ja von der Win-Partition abgezwackt worden sein, ... ohne sie zu beschädigen?

Jeanquirit
Newbie
Newbie
Beiträge: 26
Registriert: 8. Feb 2008, 15:00

Re: WinXP startet nicht mehr

Beitrag von Jeanquirit » 24. Jul 2008, 10:38

Kann ich die Partition mit gparted gefahrlos um 8MB an den Anfang verschieben und würde das helfen?

Benutzeravatar
SUSEDJAlex
Advanced Hacker
Advanced Hacker
Beiträge: 863
Registriert: 18. Apr 2008, 22:09
Wohnort: Heimatplanet Abydos

Re: WinXP startet nicht mehr

Beitrag von SUSEDJAlex » 24. Jul 2008, 10:39

@jeanquirit:

Nein die 8MB-Größe muss nach hinten.....

LG SUSE_DJAlex
openSUSE LEAP 42.3 mit Plasma 5.11 / arch linux mit Kernel 4.9.70-1-lts und XFCE4

Jeanquirit
Newbie
Newbie
Beiträge: 26
Registriert: 8. Feb 2008, 15:00

Re: WinXP startet nicht mehr

Beitrag von Jeanquirit » 24. Jul 2008, 10:43

ich meinte die Windows-Partition (die 8MB sind ja gar keine Partition, sondern freier Bereich)

Benutzeravatar
lOtz1009
Moderator
Moderator
Beiträge: 7147
Registriert: 23. Jan 2008, 09:51
Wohnort: Sulzbach/Ts.

Re: WinXP startet nicht mehr

Beitrag von lOtz1009 » 24. Jul 2008, 10:46

Also deine Windows-Start(boot)partition sollte als primäre bootfähige Paritition an den Anfang. Dass vorher ein unpartitionierter Bereich ist, sollte eigentlich nichts ausmachen... :???:
::: openSUSE Member :::
::: LXDE-Team :::
Linux-Club Wiki
vi is an editor with two modes: one which destroys your input and the other which beeps at you.
Für meine Beiträge gilt:
Bild

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast