Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Suse11 und fcpci treiber

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Hewal
Newbie
Newbie
Beiträge: 27
Registriert: 27. Jan 2007, 09:58

Suse11 und fcpci treiber

Beitrag von Hewal » 10. Jul 2008, 11:03

Hallo liebe Gemeinde,

ich habe ein - für mich - Grossprojekt gestartet. Und zwar die Inbetriebnahme meiner Fritzcard PCI2.0 als Fax. Aber leider kommen da für mich als Linuxneuling dramatische Probleme zu :-) :

Zuallererst galt es für mich, den entsprechenden fcpci Treiber der Fritzcard zu installieren. Leider gibt es auf der foert-it Seite noch keinen für Suse 11. Daher habe ich mir die fcpci-0.1-0.src.rpm runtergeladen und mittels

Code: Alles auswählen

rpmbuild --rebuild fcpci-0.1-0.src.rpm
ein (hoffentlich) passendes packet "gebaut". Dieses lag dann unter /usr/src/packages/RPMS/i586. Mittels

Code: Alles auswählen

linux-25oy:/usr/src/packages/RPMS/i586 # uname -r
2.6.25.9-0.2-pae
erhielt ich info über meinen kernel. Daraus ergab sich, folgende code auszuführen:

Code: Alles auswählen

rpm -Uhv fcpci-kmp-pae-0.1_2.6.25.9_0.2-0.i586.rpm
und jetzt das Problem: wenn ich nun über Yast meine ISDN-Karte konfigurieren möchte, kommt nach bestätigung der Angaben die Meldung, dass der Treiber keinen Quellcode besitze. Wenn ich das ganze mit "ok" bestätige erscheint im Fenster, dass meine Fritzcard nicht konfiguriert sei.

Meine zweite Frage wäre auch, ob das senden von Faxen ähnlich wie bei windows läuft, und zwar über einen "Drucker" oder wie das ganze läuft? Und... wohin kommen meine empfangenen Faxe?

Grüße
Hewal

Werbung:
Benutzeravatar
whois
Administrator
Administrator
Beiträge: 16603
Registriert: 11. Okt 2004, 08:50
Wohnort: Aachen
Kontaktdaten:

Re: Suse11 und fcpci treiber

Beitrag von whois » 10. Jul 2008, 11:13

Hi

Kannst du uns mal bitte die Original Fehlermeldung zukommen lassen?

Dazu bitte noch folgende Angaben.

Code: Alles auswählen

uname -a

Code: Alles auswählen

lsmod |grep fcpci
Faxen über Linux gestaltet sich etwas anders sieh dir bitte mal die Links an.

http://wiki.linux-club.de/opensuse/Faxe ... lefonieren
http://www.hylafax.org/
http://www.capisuite.de/de-manual/

..und einige andere Links hier im Forum und der Wiki.

cu

Hewal
Newbie
Newbie
Beiträge: 27
Registriert: 27. Jan 2007, 09:58

Re: Suse11 und fcpci treiber

Beitrag von Hewal » 10. Jul 2008, 11:32

Hallo whois,

Code: Alles auswählen

Linux linux-25oy 2.6.25.9-0.2-pae #1 SMP 2008-06-28 00:00:07 +0200 i686 athlon i386 GNU/Linux
und

Code: Alles auswählen

lsmod |grep fcpci
fcpci                 614620  2
kernelcapi             56916  3 capidrv,fcpci,capi
Die Originale Fehlermeldung lautet (yast --> ISDN):
"Sie haben einen Treiber ohne Quellcode ausgewählt. Dieser Treiber ist nicht Teil unserer Distribution. Sie können diesen Treiber erst nach der Installationi weiterer Software-Packete von AVM verwenden. Gehen Sie gemäß den Release Notes vor und lesen Sie die zustäzlichen Hinweise auf der folgenden Web-Seite: http://en.opensuse.org........./_Linux_10.1
Fortfahren? ja - nein"

nach klick auf ja steht unter "Gerät Nicht konfigurier"

Danke für die Links, werde ich mir gleich mal anschauen.

Grüße Hewal

Benutzeravatar
whois
Administrator
Administrator
Beiträge: 16603
Registriert: 11. Okt 2004, 08:50
Wohnort: Aachen
Kontaktdaten:

Re: Suse11 und fcpci treiber

Beitrag von whois » 10. Jul 2008, 11:48

Hi

Die Fritz Capis sind doch schon im Kernel geladen. :?: :|
Was soll die Meldung denn?

cu

Hewal
Newbie
Newbie
Beiträge: 27
Registriert: 27. Jan 2007, 09:58

Re: Suse11 und fcpci treiber

Beitrag von Hewal » 10. Jul 2008, 11:55

welche Meldung meinst du? Die von yast? Ich hab keine Ahnung. Wie kann ich denn nun testen, ob meine Fritzcard geht? gibts da ne Möglichkeit?

Benutzeravatar
whois
Administrator
Administrator
Beiträge: 16603
Registriert: 11. Okt 2004, 08:50
Wohnort: Aachen
Kontaktdaten:

Re: Suse11 und fcpci treiber

Beitrag von whois » 10. Jul 2008, 12:26

Hewal hat geschrieben:Wie kann ich denn nun testen, ob meine Fritzcard geht? gibts da ne Möglichkeit?
Richte dir Hylafax oder Capisuite ein, dann siehst du ob sie läuft. :)

Hewal
Newbie
Newbie
Beiträge: 27
Registriert: 27. Jan 2007, 09:58

Re: Suse11 und fcpci treiber

Beitrag von Hewal » 10. Jul 2008, 13:38

da scheint noch etwas nicht zu passen. bei der Capisuite howto steht, man müßte etwas unter Yast - Netzwerkgeräte - FAX einstellen... aber das Netzwerkgerät fax ist bei mir nicht vorhanden. Hatte mal vor geraumer zeit mit Suse 10.1 rumexperementiert und damals das gnaze zum laufen bekommen und da war meineswissens Voice und Fax noch zu finden....

Benutzeravatar
whois
Administrator
Administrator
Beiträge: 16603
Registriert: 11. Okt 2004, 08:50
Wohnort: Aachen
Kontaktdaten:

Re: Suse11 und fcpci treiber

Beitrag von whois » 10. Jul 2008, 13:50

Hi

Um ehrlich zu sein bei mir werkelt fast nur noch Debian und Derivate.
Ich habe zwar vor einiger Zeit auf meinem Notebook Hylafax und Suse 11 eingerichtet aber mit Modem.
Mit fehlt die Zeit um beständig zu experementieren und Fehler wie diese zu reproduzieren.

Der Capi wird auf jeden Fall in den Kernel geladen von da her müsste es funktionieren.

cu

Hewal
Newbie
Newbie
Beiträge: 27
Registriert: 27. Jan 2007, 09:58

Re: Suse11 und fcpci treiber

Beitrag von Hewal » 10. Jul 2008, 17:11

hm.... das hlift mir jetzt grad aber ziemlich wenig :lol:

Benutzeravatar
Pyrdracon
Member
Member
Beiträge: 52
Registriert: 6. Okt 2005, 18:23
Wohnort: Aachen
Kontaktdaten:

Re: Suse11 und fcpci treiber

Beitrag von Pyrdracon » 10. Jul 2008, 17:28

Stimmt, früher gab es ein Modul, dass die Einstellung von Fax und Anrufbeantworter über Yast möglich machte. Anscheinend gibt es das nicht mehr, jedenfalls finde ich es ebenfalls nicht. Aber die Konfiguration ist auch nicht sonderlich schwer.

Wenn Capisuite installiert ist, kann man Fax und Anrufbeantworter recht leicht über die Dateien fax.conf und answering_machine.conf im Verzeichnis /etc/capisuite konfigurieren.

Eine Anleitung findet sich immer noch hier: Capisuite-Handbuch. Alternativ befindet sich nach der Installation unter /usr/share/doc/packages/capisuite/ die Dokumentation der Software, wahlweise als PDF oder in Form von HTML-Dateien.

Gruß
Michael

Hewal
Newbie
Newbie
Beiträge: 27
Registriert: 27. Jan 2007, 09:58

Re: Suse11 und fcpci treiber

Beitrag von Hewal » 10. Jul 2008, 17:43

na die datei fax.conf habe ich bereits nach anleitung editiert. Jedoch leider tut sich nichts beim faxempfang. bei meiner ganzen suche im internet hab ich einen befehl gefunden, der wohl anzeigt ob capi läuft und bei mir kam statt "running" "unused". Und irgendwie habe ich den eindruck, dass es da hängt. Es tut mir leid, aber für mich als Linux Neuling ist es schwer, mir die verwendeten Befehle auch alle im Kopf zu behalten...

Gruß

Benutzeravatar
Pyrdracon
Member
Member
Beiträge: 52
Registriert: 6. Okt 2005, 18:23
Wohnort: Aachen
Kontaktdaten:

Re: Suse11 und fcpci treiber

Beitrag von Pyrdracon » 10. Jul 2008, 18:17

Hast du die ISDN-Karte mit Yast eingerichtet? Da du ja jetzt den CAPI-Treiber installiert hast, kannst du nochmal bei Yast unter Netzwerkgeräte->ISDN nachschauen. Dort kannst du unter ISDN-Geräte ein CAPI-Gerät hinzufügen, wenn nicht schon geschehen. Als Treiber sollte da CAPI 2.0 driver stehen, Protokoll höchstwahrscheinlich Euro-ISDN (EDSS1). Nicht vergessen, das Land und die Ortskennziffer (ohne führende 0) anzugeben. ISDN-Prokollierung kann aktiviert werden und bei Geräte-Aktivierung Beim Systemstart auswählen.

Das ist allerdings noch der Dialog von openSUSE 10.2, aber ich denke, dass sich da für die 11.0er Version nicht so viel getan haben wird.

Gruß
Michael

P.S.: Lesen sollte man schon den ganzen Thread... blöd, wenn man immer nur überfliegt. Die Einrichtung unter Yast ist ja schon geschehen oder wurde wenigstens versucht. Sorry erstmal, ich suche mal weiter nach einer Lösung.

Nachtrag:
Sobald diese Fehlermeldung erscheint (ich habe das jetzt mal unter openSUSE 11.0 nachgestellt), sollte sich ein weiterer Konfigurationsdialog öffnen. Wenn keine Einwahl über ISDN ins Internet erforderlich ist, kann dieser Dialog auch übersprungen werden. Ich nutze meine ISDN-Karte nur noch mittels Capisuite als Anrufbeantworter und Faxgerät. Unter ISDN-Geräte sollte aber definitiv ein Gerät contr0 stehen, als Typ ISDN und bei Hardware AVM Fritz!Card PCI v2.0.

Hewal
Newbie
Newbie
Beiträge: 27
Registriert: 27. Jan 2007, 09:58

Re: Suse11 und fcpci treiber

Beitrag von Hewal » 10. Jul 2008, 18:35

Pyrdracon hat geschrieben: Nachtrag:
Sobald diese Fehlermeldung erscheint (ich habe das jetzt mal unter openSUSE 11.0 nachgestellt), sollte sich ein weiterer Konfigurationsdialog öffnen. Wenn keine Einwahl über ISDN ins Internet erforderlich ist, kann dieser Dialog auch übersprungen werden. Ich nutze meine ISDN-Karte nur noch mittels Capisuite als Anrufbeantworter und Faxgerät. Unter ISDN-Geräte sollte aber definitiv ein Gerät contr0 stehen, als Typ ISDN und bei Hardware AVM Fritz!Card PCI v2.0.
ja und genau hier liegt wohl der hund begraben, denn anstatt contr0 steht immer noch "nicht konfiguriert" dran...

Benutzeravatar
Pyrdracon
Member
Member
Beiträge: 52
Registriert: 6. Okt 2005, 18:23
Wohnort: Aachen
Kontaktdaten:

Re: Suse11 und fcpci treiber

Beitrag von Pyrdracon » 10. Jul 2008, 19:12

Was sagt denn

Code: Alles auswählen

hwinfo --isdn
und

Code: Alles auswählen

capiinfo
Vermutlich steht nicht viel in /etc/capi.conf, da die Karte ja noch nicht konfiguriert wurde, aber den Inhalt kannst du ja auch mal posten. Bei der Fritzcard sollte dort in etwa soetwas stehen:

Code: Alles auswählen

# card  file    proto   io      irq     mem     cardnr  options
fcpci   -       -       -       -       -       1
Welche ISDN Pakete sind sonst noch installiert?

Ansonsten vielleicht nochmal diesen Thread lesen: http://www.linux-club.de/viewtopic.php? ... 9&p=526114

Hewal
Newbie
Newbie
Beiträge: 27
Registriert: 27. Jan 2007, 09:58

Re: Suse11 und fcpci treiber

Beitrag von Hewal » 10. Jul 2008, 20:37

Code: Alles auswählen

linux-25oy:/home/hewal/Documents/fax # hwinfo --isdn
18: PCI 0c.0: 10300 ISDN Adapter
  [Created at pci.310]
  UDI: /org/freedesktop/Hal/devices/pci_1244_e00
  Unique ID: lgGW.GGXqL9GEYV1
  SysFS ID: /devices/pci0000:00/0000:00:0c.0
  SysFS BusID: 0000:00:0c.0
  Hardware Class: isdn adapter
  Model: "AVM FRITZ!Card PCI v2.0"
  Vendor: pci 0x1244 "AVM Audiovisuelles MKTG & Computer System GmbH"
  Device: pci 0x0e00 "Fritz!PCI v2.0 ISDN"
  SubVendor: pci 0x1244 "AVM Audiovisuelles MKTG & Computer System GmbH"
  SubDevice: pci 0x0e00
  Revision: 0x02
  Memory Range: 0xdfffffe0-0xdfffffff (rw,non-prefetchable)
  I/O Ports: 0xe400-0xe41f (rw)
  IRQ: 16 (no events)
  Requires: capi4linux, i4l-base, i4l-isdnlog
  Module Alias: "pci:v00001244d00000E00sv00001244sd00000E00bc02sc80i00"
  Driver Info #0:
    I4L Type: 8002/2 [AVM FRITZ!Card PCI v2.0]
  Driver Info #1:
    I4L Type: 1000/0 [AVM FRITZ!Card PCI v2.0]
  Config Status: cfg=no, avail=yes, need=no, active=unknown
und

Code: Alles auswählen

linux-25oy:/home/hewal/Documents/fax # capiinfo
capi not installed - No such device or address (6)
in der capi.conf steht in der tat nicht viel drinnen:

#SuSEconfig.isdn generated
# card file proto io irq mem cardnr options
fcpci - - - - - 1
fcpci - - - - - 2
fcpci - - - - - 3
fcpci - - - - - 4
fcpci - - - - - 5
fcpci - - - - - 6
fcpci - - - - - 7
fcpci - - - - - 8

Isdn-Packete sind bei mir folgende installiert:
capisuite, i4l-base, i4l-isdnlog, kisdnwatch

Der andere Thread bringt mich nicht weiter. auf der foeht-it seite gibts ja noch keinen fertigen openSuse11 treiber, daher hab ich die source von 10.3 genommen und mir per rpmbuild --rebuild die srpm zu einem rpm gebaut.

Aber es scheint ja anscheinend der Capi Treiber doch NICHT installiert zu sein?!

Edit:

Code: Alles auswählen

linux-25oy:/home/hewal/Documents/fax # uname -a
Linux linux-25oy 2.6.25.9-0.2-pae #1 SMP 2008-06-28 00:00:07 +0200 i686 athlon i386 GNU/Linux
was soll denn das pae am Ende von der Kernel Version? sollte da nicht "default" stehen?

Benutzeravatar
Pyrdracon
Member
Member
Beiträge: 52
Registriert: 6. Okt 2005, 18:23
Wohnort: Aachen
Kontaktdaten:

Re: Suse11 und fcpci treiber

Beitrag von Pyrdracon » 10. Jul 2008, 21:14

Also was mich irritiert, sind die vielen Einträge in der Datei /etc/capi.conf. Da sollte bei einer CAPI-fähigen ISDN-Karte maximal ein Eintrag stehen.

Benenn diese Datei mal um (als root)

Code: Alles auswählen

mv /etc/capi.conf /etc/capi.conf.backup
und starte danach nochmal einen Versuch mit Yast.

Edit: Da war ja noch jemand schneller. Das PAE steht für einen Kernel, der mit mehr als 4 GB Speicher umgehen kann. (http://de.wikipedia.org/wiki/Physical_Address_Extension). Solange das Kernelmodul für die Fritzcard ebenfalls für den PAE-Kernel gebaut wurde, ist ja alles in Ordnung.

Hewal
Newbie
Newbie
Beiträge: 27
Registriert: 27. Jan 2007, 09:58

Re: Suse11 und fcpci treiber

Beitrag von Hewal » 11. Jul 2008, 09:02

seltsam. Die neue /etc/capi.config sieht wie folgt aus:

#SuSEconfig.isdn generated
# card file proto io irq mem cardnr options
fcpci - - - - - 1
fcpci - - - - - 2
fcpci - - - - - 3
fcpci - - - - - 4
fcpci - - - - - 5
fcpci - - - - - 6
fcpci - - - - - 7
fcpci - - - - - 8
fcpci - - - - - 9

also ist jetzt irgendwie die letzte zeile (warum auch immer) hinzugekommen

Benutzeravatar
Pyrdracon
Member
Member
Beiträge: 52
Registriert: 6. Okt 2005, 18:23
Wohnort: Aachen
Kontaktdaten:

Re: Suse11 und fcpci treiber

Beitrag von Pyrdracon » 11. Jul 2008, 09:39

Versuch es nochmal, allerdings in folgender Reihenfolge:
  1. rm /etc/capi.conf
  2. in Yast alle konfigurierten ISDN-Adapter löschen
  3. Konfiguration speichern und Yast beenden
  4. Yast-ISDN-Konfiguration noch einmal starten
  5. Falls es jetzt ein nicht-konfiguriertes Gerät geben sollte, dieses einrichten und eventuell das richtige (Fritz!Card PCI v2.0) auswählen
  6. Speichern
  7. Zur Probe nochmal /etc/capi.conf überprüfen
  8. Neu booten (nur zur Sicherheit, damit keine alten Treiber mehr geladen sind)
Kannst du mal die Ausgabe von

Code: Alles auswählen

ls -l /dev/capi*
posten?

fritz99
Newbie
Newbie
Beiträge: 2
Registriert: 10. Jun 2004, 21:19
Wohnort: Menden

Re: Suse11 und fcpci treiber

Beitrag von fritz99 » 22. Jul 2008, 17:33

Hallo,

einen Hinweis hätte ich noch:

Um bei Suse 11 oder auch 10.3 unter Netzwerkgeräte die Module Fax und Anrufbeantworter zu finden muß das Yastmodul : yast2-phone-services installiert werden.
Das gab es bei früheren Versionen nicht. Da waren diese Module immer vorhanden.

gruss
fritz99
Microsoft(Blue Screen) ist Vergangenheit !

chudacku
Newbie
Newbie
Beiträge: 14
Registriert: 4. Apr 2007, 15:05

Re: Suse11 und fcpci treiber

Beitrag von chudacku » 27. Jul 2008, 15:23

Ich hatte auch Probleme mit dem Einrichten von CapiSuite und meiner 7 Jahre alten Fritz!Card A1 - allerdings läuft nun CapiSuite nach etlichen Versuchen und dem Neukauf einer aktuellen Fritz!Card v2.0 bestens.

Die alte Fritz!Card habe ich weggeschmissen, allerdings werden jetzt beim Booten zu viele, auch die alten ISDN-Devices aktiviert.

Der Befehl rcisdn restart ergibt folgendes:

Code: Alles auswählen

rcisdn restart
Stopping ISDN                                                         done
Unloading ISDN driver  capi fcpci fcpci fcpci fcpci fcpci             done
Setting up ISDN card contr0 AVM FRITZ!Card PCI                        done
                     contr1 AVM FRITZ!Card PCI                        done
                     contr2 AVM FRITZ!Card PCI                        done
                     contr3 AVM FRITZ!Card PCI v2.0                   done
                     contr4 AVM FRITZ!Card PCI v2.0                   done
Loading Driver contr0 1 kcapi capi                                    done
Initializing capi for contr0 (1)                                      done
Loading Driver contr1 2                                               done
Initializing capi for contr1 (2)                                      done
Loading Driver contr2 3                                               done
Initializing capi for contr2 (3)                                      done
Loading Driver contr3 4                                               done
Initializing capi for contr3 (4)                                      done
Loading Driver contr4 5                                               done
Initializing capi for contr4 (5)                                      done

Nun meine Frage:

Wie kann ich die 4 unnötigen contr*-Devices deaktivieren und löschen?

Unter Yast geht es leider nicht, da meine Fritz!Card als nicht konfiguriert eingetragen ist. Auch wenn ich die Dateien /etc/capi.conf und /etc/capi.conf.SuSEconfig.saved bearbeite und alle Zeilen bis auf die erste lösche, werden diese nach dem Booten wieder automatisch gefüllt:

Code: Alles auswählen

#SuSEconfig.isdn generated
# card	file	proto	io	irq	mem	cardnr	options
fcpci	-	-	-	-	-	1
fcpci	-	-	-	-	-	2
fcpci	-	-	-	-	-	3
fcpci	-	-	-	-	-	4
fcpci	-	-	-	-	-	5
Auch ein komplettes Löschen der beiden capi.conf brachte kein besseres Resultat.

Ich benutze openSUSE 11.0 (i586) unter Kernel 2.6.25.11-0.1-pae i686 mit KDE 3.5.9 "release 49.1!

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste