Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Nach Opensuse 11 installation kein XP boot mehr [gelöst]

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
jay-jey
Member
Member
Beiträge: 79
Registriert: 16. Jan 2008, 10:32

Nach Opensuse 11 installation kein XP boot mehr [gelöst]

Beitrag von jay-jey » 22. Jun 2008, 14:02

Hallo,

ich hab gerade mal OpenSuse 11 installiert jetzt aber das Problem, dass Grub bzw LiLO XP nicht mehr bootet immer wenn ich den Punkt anwähle kommt nur

rootnoverify (hd0,5)
chainloader (hd1,0)+1

und dann hängt er fest. Ich hab auch schon versucht per yast den Bootmanager neu zu installieren aber nichts passiert.
Zuletzt geändert von jay-jey am 9. Jul 2008, 12:13, insgesamt 1-mal geändert.

Werbung:
Alf72
Member
Member
Beiträge: 180
Registriert: 30. Dez 2007, 21:00

Re: Nach Opensuse 11 installation kein XP boot mehr

Beitrag von Alf72 » 22. Jun 2008, 15:27

Hi Jay-Jey,

wie sieht denn Deine /boot/grub/menu.lst aus?
Und auf welchen Platten hast Du welche Partitionen/Systeme installiert?

Gruß Alf

Anxiety
Newbie
Newbie
Beiträge: 7
Registriert: 22. Jun 2008, 14:31

Re: Nach Opensuse 11 installation kein XP boot mehr

Beitrag von Anxiety » 22. Jun 2008, 15:43

Ich hab das selbe problem, wie kann ich denn die menu.lst öffnen, bzw, da was ändern.

Gruß Boris

Alf72
Member
Member
Beiträge: 180
Registriert: 30. Dez 2007, 21:00

Re: Nach Opensuse 11 installation kein XP boot mehr

Beitrag von Alf72 » 22. Jun 2008, 15:57

Hi Boris,

diese Datei kann nur als "root" angezeigt/editiert werden... aber VORSICHT beim Editieren!

Gruß Alf

jay-jey
Member
Member
Beiträge: 79
Registriert: 16. Jan 2008, 10:32

Re: Nach Opensuse 11 installation kein XP boot mehr

Beitrag von jay-jey » 22. Jun 2008, 15:59

Hi meine menu.lst sieht so aus:
die Einträge scheinen richtig zu sein aber mit dem rootnoverfiy bin ich mir nicht ganz so sicher.
Also auf der sdb1 ist Windows und auf der sda5 ist linux weiß auch grad nicht warum auf 5 aber egal.

# Modified by YaST2. Last modification on So Jun 22 12:25:23 UTC 2008
default 0
timeout 8
gfxmenu (hd0,5)/boot/message

###Don't change this comment - YaST2 identifier: Original name: linux###
title openSUSE 11.0 - 2.6.25.5-1.1
root (hd0,5)
kernel /boot/vmlinuz-2.6.25.5-1.1-pae root=/dev/disk/by-id/scsi-SATA_SAMSUNG_SP1614NS016J10Y611846-part6 resume=/dev/sda5 splash=silent showopts vga=0x317
initrd /boot/initrd-2.6.25.5-1.1-pae

###Don't change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe -- openSUSE 11.0 - 2.6.25.5-1.1
root (hd0,5)
kernel /boot/vmlinuz-2.6.25.5-1.1-pae root=/dev/disk/by-id/scsi-SATA_SAMSUNG_SP1614NS016J10Y611846-part6 showopts ide=nodma apm=off acpi=off noresume nosmp noapic maxcpus=0 edd=off x11failsafe vga=0x317
initrd /boot/initrd-2.6.25.5-1.1-pae

###Don't change this comment - YaST2 identifier: Original name: windows 1###
title windows1
rootnoverify (hd0,5)
chainloader (hd1,0)+1

###Don't change this comment - YaST2 identifier: Original name: windows 2###
title windows 2
rootnoverify (hd0,5)
chainloader (hd1,1)+1

###Don't change this comment - YaST2 identifier: Original name: windows 3###
title windows 3
rootnoverify (hd0,5)
chainloader (hd1,2)+1

Anxiety
Newbie
Newbie
Beiträge: 7
Registriert: 22. Jun 2008, 14:31

Re: Nach Opensuse 11 installation kein XP boot mehr

Beitrag von Anxiety » 22. Jun 2008, 16:21

Und wie genau kann ich sie ändern. Ich glaub nämlich dass ich die Lösung habe. Kann es aber bisher nur während des booten ändern und würde es gerne für längerfristig machen ^^

Gruß Boris

Alf72
Member
Member
Beiträge: 180
Registriert: 30. Dez 2007, 21:00

Re: Nach Opensuse 11 installation kein XP boot mehr

Beitrag von Alf72 » 22. Jun 2008, 16:29

@Boris:
Nehme einfach einen Texteditor Deiner Wahl (z.B. vi, emacs, ...) :)

@jay-jey:
Ich kann auch nichts besonderes sehen... hast Du wirklich 3 Win Installationen da drauf? Funktionieren denn die anderen? Mit Windows auf einer 2. Platte kenne ich mich leider auch nicht aus... vielleicht ist das ein Problem :(

Alf72
Member
Member
Beiträge: 180
Registriert: 30. Dez 2007, 21:00

Re: Nach Opensuse 11 installation kein XP boot mehr

Beitrag von Alf72 » 22. Jun 2008, 16:31

@jay-jey:

Ergänzung:
Soviel ich weiß kann man die Platten "tauschen"... ich glaube das geht mit...

map (hd0) (hd1)
map (hd1) (hd0)

Es könnte sein, dass Windows das braucht ;)

Anxiety
Newbie
Newbie
Beiträge: 7
Registriert: 22. Jun 2008, 14:31

Re: Nach Opensuse 11 installation kein XP boot mehr

Beitrag von Anxiety » 22. Jun 2008, 16:41

Ok Thx

jay-jey
Member
Member
Beiträge: 79
Registriert: 16. Jan 2008, 10:32

Re: Nach Opensuse 11 installation kein XP boot mehr

Beitrag von jay-jey » 22. Jun 2008, 16:55

nee ich hab keine 3 windows installationen grub hat einfach nur alle Partionen auf meiner zweiten paltte als windows eingebunden das wirkliche XP ist nur auf der ersten.

Das mit dem Map soll ich das in die menu.list eintrage oder wo mach ich das?

Also
Sda5 ist das /root Verzeichniss
Sdb1 ist c:\ unter win xp

spoensche
Moderator
Moderator
Beiträge: 7376
Registriert: 30. Okt 2004, 23:53
Wohnort: Siegen

Re: Nach Opensuse 11 installation kein XP boot mehr

Beitrag von spoensche » 22. Jun 2008, 17:00

Melde dich mal als root per Konsole an und poste mal die Ausgabe von

Code: Alles auswählen

fdisk -l (kleines L)

jay-jey
Member
Member
Beiträge: 79
Registriert: 16. Jan 2008, 10:32

Re: Nach Opensuse 11 installation kein XP boot mehr

Beitrag von jay-jey » 22. Jun 2008, 17:13

Stimmt wäre wahrscheinlich von schon am Anfang der schnellste weg gewesen also:

Platte /dev/sda: 160.0 GByte, 160041885696 Byte
255 Köpfe, 63 Sektoren/Spuren, 19457 Zylinder
Einheiten = Zylinder von 16065 × 512 = 8225280 Bytes
Disk identifier: 0x000ec8d2

Gerät boot. Anfang Ende Blöcke Id System
/dev/sda1 * 6921 12142 41945715 c W95 FAT32 (LBA)
/dev/sda2 1 6920 55584868+ f W95 Erw. (LBA)
/dev/sda3 12143 19457 58757737+ 83 Linux
/dev/sda5 1 262 2104452 82 Linux Swap / Solaris
/dev/sda6 263 2839 20699721 83 Linux
/dev/sda7 2840 6920 32780601 83 Linux

Partitionstabelleneinträge sind nicht in Platten-Reihenfolge

Platte /dev/sdb: 500.1 GByte, 500107862016 Byte
255 Köpfe, 63 Sektoren/Spuren, 60801 Zylinder
Einheiten = Zylinder von 16065 × 512 = 8225280 Bytes
Disk identifier: 0x6bdcd890

Gerät boot. Anfang Ende Blöcke Id System
/dev/sdb1 * 1 7649 61440561 7 HPFS/NTFS
/dev/sdb2 7650 17210 76798732+ 7 HPFS/NTFS
/dev/sdb3 17211 55455 307202962+ 7 HPFS/NTFS
/dev/sdb4 55456 60801 42941745 f W95 Erw. (LBA)
/dev/sdb5 55456 60801 42941713+ 7 HPFS/NTFS

jay-jey
Member
Member
Beiträge: 79
Registriert: 16. Jan 2008, 10:32

Re: Nach Opensuse 11 installation kein XP boot mehr

Beitrag von jay-jey » 22. Jun 2008, 18:13

Hallo also ich hab jetzt mal die menu.lst ein wenig geändert zu

# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/sda1
title Microsoft Windows XP Professional
map (hd1) (hd0)
map (hd0) (hd1)
rootnoverify (hd1,0)
savedefault
chainloader +1

aber das hat nichts gebracht außer das jetzt kommt:

Error 15

jay-jey
Member
Member
Beiträge: 79
Registriert: 16. Jan 2008, 10:32

Re: Nach Opensuse 11 installation kein XP boot mehr

Beitrag von jay-jey » 22. Jun 2008, 18:56

So ich hab es jetzt irgendwie geschafft das XP doch bootet also meine Vorgehensweise war: Try and error :) also vielleicht kann mir ja jemand mal erklären was jetzt genau der punkt war der geholfen hat:

1. die menu-lst nach meinem letzten Eintrag ändern aber savedefault weglassen (produziert wohl den Error 15)
2. yast unter bootmanager bootmanger-installation
alle kästchen ankreuzen
3. booten und hoffentlich freuen

Ich übernehme keinerlei Verantwortung für dies da ich keine Ahnung hab woran es liegt und wie es eigentlich geht. Werde auch, solange nichts mehr passiert, es unterlassen etwas zu ändern.

Hoffe es hilft dir auch Boris

Alf72
Member
Member
Beiträge: 180
Registriert: 30. Dez 2007, 21:00

Re: Nach Opensuse 11 installation kein XP boot mehr

Beitrag von Alf72 » 22. Jun 2008, 20:31

Ich vermute Du müsstest statt "chainloader +1" "chainloader (hd0,0)+1" verwenden, da Du die Platten ja vorher virtuell getauscht hast... bin mir da aber nicht sicher. Das könnte auch den Fehler "15" erklären... der bedeutet "File not found"... der "File" ist im Prinzip die chainloader Angabe... aber dazu sollte sich lieber ein Experte äußern :?:

Der Eintrag "savedefault" bewirkt, dass beim nächsten Booten dieser Eintrag - wenn er verwendet wurde - als default verwendet wird. Sollte also nichts mit Deinem Fehler "15" zu tun haben ;)

spoensche
Moderator
Moderator
Beiträge: 7376
Registriert: 30. Okt 2004, 23:53
Wohnort: Siegen

Re: Nach Opensuse 11 installation kein XP boot mehr

Beitrag von spoensche » 22. Jun 2008, 21:34

Öffne mal als root die Datei /boot/grub/menu.lst. Dort editierst du dann den ersten Windows Eintrag.

Alt:

Code: Alles auswählen

chainloader (hd1,0)+1
Neu:

Code: Alles auswählen

chainloader (hd0,0)+1

jay-jey
Member
Member
Beiträge: 79
Registriert: 16. Jan 2008, 10:32

Re: Nach Opensuse 11 installation kein XP boot mehr

Beitrag von jay-jey » 23. Jun 2008, 17:39

Hi, sorry hab gestern nichts mehr gemacht und bin erst jetzt wieder dazu gekommen.

mit chainloader (hd0,0)+1
funzt es nicht aber
mit chainloader (hd1,0)+1

wie gesagt keine Ahnung woran es jetzt liegt hab hier nochmal meine menu.lst und meine Fstab gepostet

http://phpfi.com/326382

wenn ihr nen sicheren weg kennt könnt ihr den ja hier posten, weil ich denke, dass ich nicht der einzige mit dem Problem ist (siehe Boris). Aber ansonsten ist mein Problem (dank euch) gelöst. Also nochmal Danke.

spoensche
Moderator
Moderator
Beiträge: 7376
Registriert: 30. Okt 2004, 23:53
Wohnort: Siegen

Re: Nach Opensuse 11 installation kein XP boot mehr

Beitrag von spoensche » 23. Jun 2008, 18:13

Sorry, war mein Fehler. Weil du Windows ja auf der 2. Platte hast muss es auch

Code: Alles auswählen

chainloader(1,0)+1
sein.

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast