Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[gelöst]VirtualBox 1.6.2 und USB

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
Benutzeravatar
prinzunix
Hacker
Hacker
Beiträge: 520
Registriert: 19. Sep 2005, 11:05
Wohnort: Pulheim
Kontaktdaten:

[gelöst]VirtualBox 1.6.2 und USB

Beitrag von prinzunix » 12. Jun 2008, 10:53

Hallo zusammen,

also, was muss man tun, damit USB mit Virtual Box funktioniert?
  • VirtualBox läuft und das Symbol für USB erscheint auch unten rechts
    in der Statusbar.

    Das Gerät wurde erkannt und in den USB-Gerätefilter der virtuellen Maschine
    von mir eingetragen.

    Das USB-Dateisystem ist gemountet über die fstab mit dem Eintrag:

    Code: Alles auswählen

    usbfs	/proc/bus/usb	usbfs	auto,mode=666,gid=85 0 0
    Eine Gruppe USB mit gid=85 angelegt und die user zugeordnet.
Habe ich was übersehen oder vergessen?
Im Handbuch ist das sehr dürftig ausgeführt. Das Gerät
wird auch unter Geräte, USB ausgegraut angezeigt im
Menü der VirtualBox. Ich tippe mal auf ein Rechteproblem.

Viele Grüße, Prinzunix.

Ergänzung:

Es ist ein Rechteproblem.
Mit

Code: Alles auswählen

pc-vm222:~ # chmod -R go+w /dev/bus/usb/
pc-vm222:~ # chmod -R go+w /proc/bus/usb/
kriegt man das Teil ans Laufen. Also bleibt im Prinzip nur das Problem,
wie man das hinbekommt, dass die Rechte automatisch korrekt gesetzt werden.

Für Tipps wäre ich sehr dankbar, denn das ist doch recht unbequem so.

Lösung:

Code: Alles auswählen

usbfs   /proc/bus/usb   usbfs   auto,devgid=1000,devmode=664 0 0
Kaum gibt man die richtige Zeile in die fstab ein, dann geht es.
Unter troubleshooting in den Tiefen des Handbuches war es doch zu finden.
Der Trend geht klar zum Siebtrechner. 64 Bit für alle!
Greets to linux-club.de powercrunchers!

Werbung:
Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast