Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

groups Problem

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
chakaa
Member
Member
Beiträge: 86
Registriert: 23. Mai 2004, 21:44

groups Problem

Beitrag von chakaa » 19. Mai 2008, 12:38

Hallo,

(bin nicht ganz sicher ob dies die richtige Rubrik ist für Fragen zum Thema Benutzerrechte?)


Ich habe immer wieder das Problem, dass eine Änderung der Gruppenzugehörigkeit erst nach einem Neustart gültig wird.

Wenn ich also einen Benutzer "Chef" einer Gruppe "VIP" zuordne, kann dieser erst nach einem Reboot auf die Ordner der Gruppe VIP zugreifen.

Seltsam ist doch dies hier:

Code: Alles auswählen

Chef@rechner1:~> whoami
Chef
Chef@rechner1:~> groups
users dialout video
Chef@rechner1:~> id
uid=1000(Chef) gid=100(users) Gruppen=16(dialout),33(video),100(users)
Chef@rechner1:~> id Chef
uid=1000(Chef) gid=100(users) Gruppen=100(users),16(dialout),14(VIP),33(video)
bei "id Chef" wird die Gruppe also angezeigt :wtf:

Ist das ein genereller Linux-Bug oder habe ich die Logik nur mal wieder nicht verstanden?
Martin
openSuSE 11.4

Werbung:
Grothesk
Ultimate Guru
Ultimate Guru
Beiträge: 14662
Registriert: 26. Okt 2003, 11:52
Wohnort: Köln

Beitrag von Grothesk » 19. Mai 2008, 12:41

Normal.
Die Sitzung für den User muss komplett geschlossen werden. Ein Reboot ist allerdings nicht notwendig, einmal komplet abmelden und wieder anmelden reicht aus.
"Die Rechtschreibung ist Freeware, du darfst sie kostenlos nutzen. Allerdings ist sie nicht OpenSource, d.h. du sollst sie nicht verändern oder in veränderter Form veröffentlichen."

chakaa
Member
Member
Beiträge: 86
Registriert: 23. Mai 2004, 21:44

Beitrag von chakaa » 19. Mai 2008, 13:12

Grothesk hat geschrieben:Normal.
Die Sitzung für den User muss komplett geschlossen werden. Ein Reboot ist allerdings nicht notwendig, einmal komplet abmelden und wieder anmelden reicht aus.
hatte ich versucht.
Ich war per SSH (PuTTY) angemeldet und hatte mich damit zwischendurch abgemeldet. Außerdem Samba restart.
Danach wieder per PuTTY rein und die obigen Ausgaben erhalten.

Aber jetzt (nach 2 Stunden) geht es plötzlich (ohne reboot) :?:

Wird das irgendwie zeitversetzt aktualisiert?

Ich brauche halt eine zuverlässige Methode, wann ich dem Benutzer sagen kann: jetzt klappt's. Möglichst auch ohne Samba Unterbrechung.

Geht das bzw. was genau muss ich tun?
Martin
openSuSE 11.4

jengelh
Guru
Guru
Beiträge: 4039
Registriert: 20. Nov 2004, 17:42
Kontaktdaten:

Re: groups Problem

Beitrag von jengelh » 20. Mai 2008, 17:31

chakaa hat geschrieben:bei "id Chef" wird die Gruppe also angezeigt :wtf:
`id` ohne Benutzernamen zeigt den Status des aktuellen Prozesses an, während `id name` den allgemeinen Status anzeigt. Ausloggen ist nicht nötig, aber eine Reinitialisierung mittels newgrp—startet übrigens eine neue Shell, also beim Ausloggen mehrmals ausloggen ;-)

chakaa
Member
Member
Beiträge: 86
Registriert: 23. Mai 2004, 21:44

Re: groups Problem

Beitrag von chakaa » 20. Mai 2008, 20:39

jengelh hat geschrieben:`id` ohne Benutzernamen zeigt den Status des aktuellen Prozesses an, während `id name` den allgemeinen Status anzeigt.
was man alles wissen muss.. :wink:
chakaa hat geschrieben:ch war per SSH (PuTTY) angemeldet und hatte mich damit zwischendurch abgemeldet. Außerdem Samba restart.
ich denke gerade: vielleicht ist das "Samba restart" eher kontraproduktiv. Samba wird den Benutzer vielleicht automatisch wieder anmelden. Muss ich mal erforschen..
Martin
openSuSE 11.4

Antworten