Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Probleme mit VM-Player

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
R2-D2
Newbie
Newbie
Beiträge: 15
Registriert: 22. Mär 2007, 17:44

Probleme mit VM-Player

Beitrag von R2-D2 » 10. Mai 2008, 15:06

Habe da ein (kleines?) technisches Problem. Benutze den VMWare Player, und wollte mir WinXP als Guest einrichten. Komme damit aber weder ins Internet, noch kann ich den seriellen und parallen Port nutzen (beide in der VMX vorhanden).

Habe NAT als Ethernet Einstellung gewählt; geht aber trotzdem nicht :cry:

WinXP zeigt mir auch ständig an, dass kein Ethernet-Controller installiert wurde, aber wie komme ich daran???


Hoffe jemand kann mir helfen...

(nutze Suse 10.3)

Werbung:
stefan.becker
Advanced Hacker
Advanced Hacker
Beiträge: 1140
Registriert: 12. Mär 2006, 17:23

Beitrag von stefan.becker » 10. Mai 2008, 15:28

Sorry, meine Glaskugel ist in Reparatur.

Ohne Infos kann man nichts sagen: => Poste die vmx-Datei!

R2-D2
Newbie
Newbie
Beiträge: 15
Registriert: 22. Mär 2007, 17:44

Beitrag von R2-D2 » 10. Mai 2008, 15:37

hier ist sie:

Code: Alles auswählen

#!/usr/bin/vmplayer

# Filename: WinXP.vmx
# Generated 2008-04-19;15:37:54 by EasyVMX! 2.0 (beta)
# http://www.easyvmx.com

# This is a Workstation 6 config file
# It can be used with Player
config.version = "8"
virtualHW.version = "6"

# Selected operating system for your virtual machine
guestOS = "winxppro"

# displayName is your own name for the virtual machine
displayName = "WinXP"

# These fields are free text description fields
guestinfo.vmware.product.url = "http://www.easyvmx.com/"
guestinfo.vmware.product.class = "virtual machine"

# Number of virtual CPUs. Your virtual machine will not
# work if this number is higher than the number of your physical CPUs
numvcpus = "1"

# Memory size and other memory settings
memsize = "320"
MemAllowAutoScaleDown = "FALSE"
MemTrimRate = "-1"

# PowerOn/Off options
gui.powerOnAtStartup = "FALSE"
gui.fullScreenAtPowerOn = "FALSE"
gui.exitAtPowerOff = "FALSE"

# Unique ID for the virtual machine will be created
uuid.action = "create"

# Settings for VMware Tools
tools.remindInstall = "TRUE"
tools.upgrade.policy = "upgradeAtPowerCycle"

# Startup hints interfers with automatic startup of a virtual machine
# This setting has no effect in VMware Player
hints.hideAll = "TRUE"

# Enable time synchronization between computer
# and virtual machine
tools.syncTime = "TRUE"

# USB settings
# This config activates USB
usb.present = "TRUE"
usb.generic.autoconnect = "TRUE"

# First serial port, physical COM1 is available
serial0.present = "TRUE"
serial0.fileName = "Auto Detect"
serial0.autodetect = "TRUE"
serial0.hardwareFlowControl = "TRUE"

# Optional second serial port, physical COM2 is not available
serial1.present = "FALSE"

# First parallell port, physical LPT1 is available
parallel0.present = "TRUE"
parallel0.fileName = "Auto Detect"
parallel0.autodetect = "TRUE"
parallel0.bidirectional = "TRUE"

# Sound settings
sound.present = "TRUE"
sound.fileName = "-1"
sound.autodetect = "TRUE"

# Logging
# This config activates logging, and keeps last log
logging = "TRUE"
log.fileName = "WinXP.log"
log.append = "TRUE"
log.keepOld = "3"

# These settings decides interaction between your
# computer and the virtual machine
isolation.tools.hgfs.disable = "FALSE"
isolation.tools.dnd.disable = "FALSE"
isolation.tools.copy.enable = "TRUE"
isolation.tools.paste.enabled = "TRUE"

# Other default settings
svga.autodetect = "TRUE"
mks.keyboardFilter = "allow"
snapshot.action = "autoCommit"

# First network interface card
ethernet0.present = "TRUE"
ethernet0.virtualDev = "e1000"
ethernet0.connectionType = "nat"
ethernet0.addressType = "generated"
ethernet0.generatedAddressOffset = "0"

# Settings for physical floppy drive
floppy0.present = "TRUE"
floppy0.startConnected = "TRUE"
floppy0.autodetect = "TRUE"

# Settings for physical CDROM drive
ide1:0.present = "TRUE"
ide1:0.deviceType = "cdrom-raw"
ide1:0.startConnected = "TRUE"
ide1:0.fileName = "auto detect"
ide1:0.autodetect = "TRUE"

# First IDE disk, size 4800Mb
ide0:0.present = "TRUE"
ide0:0.fileName = "WinXP.vmdk"
ide0:0.mode = "persistent"
ide0:0.startConnected = "TRUE"
ide0:0.writeThrough = "TRUE"

# END OF EasyVMX! CONFIG

floppy0.fileName = "/dev/fd0"
extendedConfigFile = "WinXP.vmxf"
virtualHW.productCompatibility = "hosted"

ethernet0.generatedAddress = "00:0c:29:f3:00:b3"
uuid.location = "56 4d 6d 37 d5 3f 8c ef-25 a8 3f 05 4b f3 00 b3"
uuid.bios = "56 4d 6d 37 d5 3f 8c ef-25 a8 3f 05 4b f3 00 b3"
ide0:0.redo = ""
checkpoint.vmState = "WinXP.vmss"
ethernet0.pciSlotNumber = "16"
sound.pciSlotNumber = "17"

stefan.becker
Advanced Hacker
Advanced Hacker
Beiträge: 1140
Registriert: 12. Mär 2006, 17:23

Beitrag von stefan.becker » 10. Mai 2008, 16:55

Du hast die Intel e1000 eingestellt. Dafür wird ein Treiber benötigt. Ist erst ab Vista serienmäßig => www.intel.com

Parallel / seriell: Gib mal die echten Devices (/dev/ttyS0, /dev/parport0) an statt autodetect.

Allerdings funktioniert das eh nie zu 100 %. Um was für Geräte geht es denn?

Drucker nutzt immer besser über das Netzwerk, sofern der Host sie unterstützt.

R2-D2
Newbie
Newbie
Beiträge: 15
Registriert: 22. Mär 2007, 17:44

Beitrag von R2-D2 » 10. Mai 2008, 17:21

Hab jetzt mal die .vmx geändert; ohne Erfolg. Bekomme immer noch die Fehlermeldung "can not connect virtual device parallel0"; bei seriell das gleiche... (wird wirklich für nen alten Drucker benötigt)

Den Treiber für die NIC hab ich zwar gefunden, kann ihn aber nicht einbinden, da usb ja noch nicht funktioniert...

Benutzeravatar
Martin Breidenbach
Ultimate Guru
Ultimate Guru
Beiträge: 5632
Registriert: 26. Mai 2004, 21:33
Wohnort: N 50.17599° E 8.73367°

Beitrag von Martin Breidenbach » 10. Mai 2008, 18:17

Dann nimm doch AMD PCNET als Nic.

Paralelle und serielle Schnittstellen habe ich unter VMware noch nie zu benutzen versucht.
Nicht Böse sein ! Der Onkel macht doch nur Spaß !

stefan.becker
Advanced Hacker
Advanced Hacker
Beiträge: 1140
Registriert: 12. Mär 2006, 17:23

Beitrag von stefan.becker » 10. Mai 2008, 18:26

Seriell brauchst du also nicht? Dann lass es einfach weg.

Den Parallelport greift sich aufgrund des Druckers der Host. Entweder Druckdienst stoppen/Modul entladen (Blödsinn) oder einbinden als Netzwerkdrucker (beste Lösung).

stefan.becker
Advanced Hacker
Advanced Hacker
Beiträge: 1140
Registriert: 12. Mär 2006, 17:23

Beitrag von stefan.becker » 10. Mai 2008, 18:28

Anhang aus einem VirtualBox Howto:

Auch ohne Netzwerkkonfiguration und Shared Folders kann man im Gast auf externe Daten zugreifen:

- Die im Gast benötigten Dateien in ein Verzeichnis kopieren (z. B. /tmp/daten).
- Aus diesen Daten ein ISO-Image erstellen:
Code:

mkisofs -o /tmp/daten.iso /tmp/daten

- Das ISO-Image in VirtualBox als CDROM einbinden (Geräte / CD einbinden / Abbild)

Dies ermöglicht z. B. das Kopieren eines Intel e1000 Treibers zum Gast auch ohne Netzwerk.


Bei VMWARE natürlich das ISO entsprechend als CD-Laufwerk in die vmx-Datei eintragen.

R2-D2
Newbie
Newbie
Beiträge: 15
Registriert: 22. Mär 2007, 17:44

Beitrag von R2-D2 » 10. Mai 2008, 19:37

besten dank

läuft jetzt (fast) alles :P :P

Antworten