Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Apache kann nicht installiert werden

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
sirD
Newbie
Newbie
Beiträge: 5
Registriert: 23. Apr 2008, 15:55

Apache kann nicht installiert werden

Beitrag von sirD » 23. Apr 2008, 16:15

Hallo.
ich habe ein suse system 10.3 auf meinem vmWare laufen!!
ich will diesen als webserver benutzen und habe Apache2 zu installiert!!
wenn ich nun den dienst im system service starte dann klappt das nicht. apache kann nicht gestartet werden !!
wenn ich den dienst in der konsole starte bekomme ich folgende fehlermeldung:

Starting httpd2 (prefork) /usr/sbin/httpd2-prefork: error while loading shared libraries: libaprutil-1.so.0: cannot open shared object file: No such file or directory

The command line was:
/usr/sbin/httpd2-prefork -f /etc/apache2/httpd.conf

kann jemand helfen ??

Werbung:
Benutzeravatar
whois
Administrator
Administrator
Beiträge: 16599
Registriert: 11. Okt 2004, 08:50
Wohnort: Aachen
Kontaktdaten:

Beitrag von whois » 23. Apr 2008, 16:27

Hi

Reinstallier dir das Paket libapr-util1 noch mal.
Vielleicht ist das nicht sauber installiert worden.
Das gehört zu Apache Portable Runtime (APR) Library.

cu

sirD
Newbie
Newbie
Beiträge: 5
Registriert: 23. Apr 2008, 15:55

Beitrag von sirD » 23. Apr 2008, 16:36

das problem ist dass ich das nciht mal installieren kann !!!!
ich wähle im software manager libaprutil an und es wird auch anscheinend installiert... wenn ich aber nach der "installation" wieder in den software manager gehe dann wird libaprutil als nciht vorhanden angezeigt !!!!!
nur woran kanns liegen ??

Benutzeravatar
whois
Administrator
Administrator
Beiträge: 16599
Registriert: 11. Okt 2004, 08:50
Wohnort: Aachen
Kontaktdaten:

Beitrag von whois » 23. Apr 2008, 16:42

sirD hat geschrieben:nur woran kanns liegen ??
Puh, du scheints ein grösseres Problem zu haben als das Apache.

Keine Ahnung wo es da genau klemmt.
Hast du in letzter Zeit ein update gefahren?

Welchen Kernel hast du jetzt drauf?
Fährst du ein 64 Bit System?

Bitte mal folgende Ausgabe ins Forum stellen.

Code: Alles auswählen

rpm -qa| grep yast

Code: Alles auswählen

rpm -qa| grep kernel

Code: Alles auswählen

rpm -qa| grep apache

Darf ich dich bitten in allgemein üblicher deutscher Rechtschreibung deine Postings zu verfassen(auch Gross und Kleinschreibung)

Danke. :wink:

sirD
Newbie
Newbie
Beiträge: 5
Registriert: 23. Apr 2008, 15:55

Beitrag von sirD » 23. Apr 2008, 16:53

nach der neuinstalltion habe ich es versucht. da ich merkte dass es nicht geht hab ich erstmal ein online update durchgeführt mit der hoffnung dass i-welche patches dabei sind die das problem lösen...

ich benutzte ein 32-bit system !!!!

hier unten die eingaben:

EM2008:~ # rpm -qa| grep yast
yast2-schema-2.15.0-123
yast2-xml-2.15.0-55
yast2-perl-bindings-2.15.3-29
yast2-ldap-2.15.1-83
yast2-apparmor-2.1-26
yast2-nfs-client-2.15.0-25
yast2-support-2.15.3-14
yast2-network-2.15.81-2
yast2-ntp-client-2.15.12-7
yast2-packager-2.15.81-4
yast2-inetd-2.15.1-41
autoyast2-installation-2.15.17-17
autoyast2-2.15.17-17
yast2-restore-2.15.4-22
yast2-theme-openSUSE-2.15.14-4
yast2-ncurses-2.15.27-16
yast2-country-2.15.20-7
yast2-sound-2.15.11-18
yast2-irda-2.15.1-94
yast2-scanner-2.15.5-42
yast2-fingerprint-reader-2.15.2-27
yast2-kerberos-client-2.15.7-32
yast2-samba-client-2.15.11-33
yast2-update-2.15.23-21
yast2-metapackage-handler-0.7.1-9
yast2-sudo-2.15.3-86
yast2-bootloader-2.15.29-2
yast2-backup-2.15.6-0.1
yast2-trans-stats-2.15.0-32
yast2-storage-lib-2.15.27-4
yast2-slp-2.15.0-31
yast2-control-center-qt-2.15.4-12
yast2-hardware-detection-2.15.8-36
yast2-qt-2.15.16-19
yast2-2.15.58-12
yast2-control-center-2.15.4-12
yast2-printer-2.15.6-4
yast2-firewall-2.15.8-8
yast2-runlevel-2.15.3-19
yast2-x11-2.15.11-22
yast2-tv-2.15.7-23
yast2-ldap-client-2.15.12-37
yast2-samba-server-2.15.7-57
yast2-storage-2.15.27-4
yast2-tune-2.15.7-20
yast2-online-update-2.15.24-0.1
yast2-core-2.15.13-0.1
yast2-repair-2.15.8-0.1
yast2-trans-de-2.15.30-0.1
yast2-transfer-2.14.0-107
yast2-pkg-bindings-2.15.51-4
yast2-mouse-2.15.1-81
yast2-bluetooth-2.15.4-17
yast2-pam-2.14.0-128
yast2-sysconfig-2.15.3-58
yast2-nis-client-2.15.3-21
yast2-security-2.15.1-23
yast2-installation-2.15.54-4
yast2-users-2.15.38-7
yast2-iscsi-client-2.15.2-39
yast2-registration-2.15.3-15
yast2-add-on-2.15.17-4
yast2-online-update-frontend-2.15.24-0.1
yast2-mail-2.15.23-2.1
yast2-profile-manager-2.15.1-0.1

EM2008:~ # rpm -qa| grep kernel
kernel-default-2.6.22.17-0.1

EM2008:~ # rpm -qa| grep apache
apache2-prefork-2.2.4-70.4
apache2-utils-2.2.4-70.4
apache2-worker-2.2.4-70.4
apache2-2.2.4-70.4

sirD
Newbie
Newbie
Beiträge: 5
Registriert: 23. Apr 2008, 15:55

Beitrag von sirD » 23. Apr 2008, 16:54

Äm sorry... Ich habe im letzten Beitrag nicht auf meine Rechtschreibung und meine Groß- und Kleinschreibung geachtet !!! Ich versuche es zu ändern ;-)

Benutzeravatar
whois
Administrator
Administrator
Beiträge: 16599
Registriert: 11. Okt 2004, 08:50
Wohnort: Aachen
Kontaktdaten:

Beitrag von whois » 23. Apr 2008, 17:27

Hi

Ich habe im Moment keine Suse 10.3 im Betrieb, aber IMHO müsste bei Yast alles dabei sein.
Beim Kernel fehlen die Kernelsources.

Hmm, sorry da muss ich selber mal nachforschen.

cu

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste