Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[Benutzerrechte, allgemein unklare Thematik] gelöst

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
Benutzeravatar
tommy tulpe
Hacker
Hacker
Beiträge: 355
Registriert: 28. Mär 2006, 16:28

[Benutzerrechte, allgemein unklare Thematik] gelöst

Beitrag von tommy tulpe » 20. Apr 2008, 12:41

Hallo!

Ich weiß nicht, in welchem Forum ich mich am Besten melde, ich hoffe, es ist hier richtig. Es geht um mehrere, meiner Meinung nach zusammenhängende Dinge, mit denen ich nicht weiter komme. Meine Benuterverwaltung/Rechtevergabe scheint allgemein irgendwie durcheinander zu sein und ich weiß nicht woran es hapert. Grund für meine Annahme sind folgende schon mal an anderer Stelle gepostete (aber nicht beantwortete) Probleme:

1. Wenn ich mich mit ALT/F2 "kdesu konqueror " als root anmelde, müsste ich doch Allmacht als root haben. Meine Möglichkeiten sind aber anders, als wenn ich mich komplett neu als root anmelde. Selbst in der Konsole bekomme ich manchmal den Hinweis für dies und das keine Berechtigung zu haben.
2. Ich habe z.B. VirtualBox installiert und kann es auf einmal nur noch als root starten. Habe aber nichts geändert gehabt. Habe Handbuch zu Rechtevergabe gelesen, und alle in den Foren erhältlichen Tips befolgt und nichts hat sich geändert.
3. In den letzten Tagen hängt der Rechner öfter

Besteht die Möglichkeit von Viren / rootkits / Trojanern oder ähnlichem ?
Wie kann ich das zuverlässig prüfen? Habe KlamAv und Chkrootkit laufen lassen und nichts gefunden.
Wo finde ich Auskünfte, in welche Gruppen ich mich als Benutzer regulär eintragen muss ohne Sicherheitsrisiken einzugehen?

Alles etwas durcheinander aber ich weiss nicht so recht weiter. Irgendwas scheint grundlegend nicht zu stimmen...

tommy
Zuletzt geändert von tommy tulpe am 25. Apr 2008, 17:57, insgesamt 1-mal geändert.
Kernel 2.6.34.7-0.3-desktop x86_64, openSUSE 11.3 (x86_64), KDE: 4.4.4 (KDE 4.4.4) "release 3", Grafikkarte nVidia GeForce 8200, 3D-Treiber: NVIDIA 256.53, AMD Phenom(tm) 9650 Quad-Core Processor 1150,00 MHz, RAM 8 GB, Swap 2GB

Werbung:
spoensche
Moderator
Moderator
Beiträge: 7340
Registriert: 30. Okt 2004, 23:53
Wohnort: Siegen

Beitrag von spoensche » 20. Apr 2008, 12:58

Zu 1.:
Du hast aber dann nur die "Allmacht" in dem Programm Konqueror.

Zu 2:
Ist dein normaler User Mitglied der Gruppe vboxusers? Das muss er nämlich sein.

Zu 3:
Was sagen denn die Logfiles? (/var/log/messages)

Benutzeravatar
tommy tulpe
Hacker
Hacker
Beiträge: 355
Registriert: 28. Mär 2006, 16:28

Benutzerrechte, allgemein unklare Thematik

Beitrag von tommy tulpe » 20. Apr 2008, 14:11

Danke für die schnelle Antwort:
1. Allmacht im Konqueror heisst doch aber, dass ich zB. auch alle Dateien/ordner im home Bereich eines Benutzers löschen können muss
2. Dass mit der Gruppe vboxusers ist -entschuldige- ein bekannter Fehler
,der immer zuerst geklärt wird. Das ist ja gerade meine Crux: Benutze das Programm schon länger und habe auf einmal diese Probleme. Habe schon die Benutzerrechte für etc/init.d/vboxdrv und vboxnet geändert. Habe in dev/vboxdrv alles erlaubt und nichts ändert sich. Aber auch an anderen Stellen habe ich wie gesagt Rechteprobleme und ist deswegen eher ein generelles Problem ....
3.
Apr 20 08:16:09 Multi3 syslog-ng[2543]: new configuration initialized
Apr 19 08:16:56 Multi3 isdnlog: Apr 19 08:16:56 tei 73 calling ? with ? HANGUP ( 0:01:53)
Apr 19 08:17:33 Multi3 su: (to nobody) root on none
Apr 19 08:18:11 Multi3 syslog-ng[2543]: last message repeated 2 times
Apr 19 08:23:16 Multi3 isdnlog: Apr 19 08:23:16 * Call to tei 127 from ? on +49 xxxxxx RING (3.1 kHz audio)
Apr 19 08:23:16 Multi3 kernel: capidrv-1: incoming call ,1,2,xxxx
Apr 19 08:23:16 Multi3 kernel: capidrv-1: patching si2=2 to 0 for VBOX
Apr 19 08:23:16 Multi3 kernel: isdn_net: Incoming call without OAD, assuming '0'
Apr 19 08:23:16 Multi3 kernel: isdn_net: call from 0 -> 0 xxxx ignored
Apr 19 08:23:16 Multi3 kernel: isdn_tty: Incoming call without OAD, assuming '0'
Apr 19 08:23:16 Multi3 kernel: isdn_tty: call from 0 -> xxxx ignored
Apr 19 08:23:16 Multi3 kernel: capidrv-1: incoming call ,1,0,xxxx ignored
Apr 19 08:23:16 Multi3 kernel: klogd 1.4.1, ---------- state change ----------
Apr 19 08:23:24 Multi3 isdnlog: Apr 19 08:23:24 Call to tei 123 from ? on +49 xxxxxx CONNECT (3.1 kHz audio)
Apr 19 08:23:51 Multi3 isdnlog: Apr 19 08:23:51 Call to tei 123 from ? on +49 5xxxxx, Lxxxx HANGUP ( 0:00:27)
Apr 19 08:30:09 Multi3 smartd[3955]: Device: /dev/sdb, SMART Usage Attribute: 190 Temperature_Celsius changed from 76 to 61
Apr 19 08:30:09 Multi3 smartd[3955]: Device: /dev/sdb, SMART Usage Attribute: 194 Temperature_Celsius changed from 24 to 39
Apr 19 08:30:09 Multi3 smartd[3955]: Device: /dev/sdb, SMART Usage Attribute: 195 Hardware_ECC_Recovered changed from 85 to 74
Apr 19 08:38:57 Multi3 isdnlog: Apr 19 08:38:57 * Call to tei 127 from +49 xxxx, Lxxxx on +49 xxxxxx, Lxxxxxx RING (3.1 kHz audio)
Apr 19 08:38:57 Multi3 kernel: capidrv-1: incoming call 5xxxxx0,1,2,2286
Apr 19 08:38:57 Multi3 kernel: capidrv-1: patching si2=2 to 0 for VBOX
Apr 19 08:38:57 Multi3 kernel: isdn_net: call from xxxxxx -> 0 xxxx ignored
Apr 19 08:38:57 Multi3 kernel: isdn_tty: call from xxxxxxxx -> xxxx ignored
Apr 19 08:38:57 Multi3 kernel: capidrv-1: incoming call xxxxxx,1,0,xxxxignored
Apr 19 08:39:02 Multi3 isdnlog: Apr 19 08:39:02 * Call to tei 123 from +49 xxxxxxx, Lxxxxx on +49 xxxxx, Lxxxxx HANGUP
Apr 19 08:39:48 Multi3 isdnlog: Apr 19 08:39:48 * Call to tei 127 from +49 xxxxx, Lxxxxx on +49 xxxxx6, Lxxxxx RING (3.1 kHz audio)
Apr 19 08:39:48 Multi3 kernel: capidrv-1: incoming call xxxxxxx,1,2,xxxxx
Apr 19 08:39:48 Multi3 kernel: capidrv-1: patching si2=2 to 0 for VBOX
Apr 19 08:39:48 Multi3 kernel: isdn_net: call from xxxxx -> 0 xxxxignored
Apr 19 08:39:48 Multi3 kernel: isdn_tty: call from xxxxxx -> xxxxx ignored
Apr 19 08:39:48 Multi3 kernel: capidrv-1: incoming call xxxxx,1,0,xxxxxignored
Apr 19 08:39:54 Multi3 isdnlog: Apr 19 08:39:54 Call to tei 123 from +49 xxxx, Lxxxxx on +49 xxxxx, Lxxxxx CONNECT (3.1 kHz audio)
Apr 19 08:41:51 Multi3 isdnlog: Apr 19 08:41:51 Call to tei 123 from +49 xxxxx, Lxxxxxon +49 xxxx, Lxxxxx HANGUP ( 0:01:57)
Ax
Apr 19 08:43:09 Multi3 kernel: capidrv-1: incoming call ,1,2,2286
Apr 19 08:43:09 Multi3 kernel: capidrv-1: patching si2=2 to 0 for VBOX
Apr 19 08:43:09 Multi3 kernel: isdn_net: Incoming call without OAD, assuming '0'
Apr 19 08:43:09 Multi3 kernel: isdn_net: call from 0 -> 0 2286 ignored
Apr 19 08:43:09 Multi3 kernel: isdn_tty: Incoming call without OAD, assuming '0'
Apr 19 08:43:09 Multi3 kernel: isdn_tty: call from 0 -> 2286 ignored
Apr 19 08:43:09 Multi3 kernel: capidrv-1: incoming call ,1,0,2286 ignored
Apr 19 08:43:31 Multi3 isdnlog: Apr 19 08:43:31 Call to tei 123 from ? on +49 xxxxxx CONNECT (3.1 kHz audio)
Apr 19 08:43:54 Multi3 isdnlog: Apr 19 08:43:54 Call to tei 123 from ? on +49 xxxxxxxx HANGUP ( 0:00:23)
Apr 19 09:00:03 Multi3 isdnlog: Apr 19 09:00:03 tei 73 calling ? with ? Time:Sat Apr 19 09:00:00 2008
Apr 19 09:00:03 Multi3 isdnlog: Apr 19 09:00:03 tei 73 calling ? with ? COLP *INVALID* -- ignored!
Apr 19 09:00:03 Multi3 isdnlog: Apr 19 09:00:03 tei 73 calling ? with ? CONNECT
Apr 19 09:00:08 Multi3 smartd[3955]: Device: /dev/sdb, SMART Usage Attribute: 190 Temperature_Celsius changed from 61 to 56
Apr 19 09:00:08 Multi3 smartd[3955]: Device: /dev/sdb, SMART Usage Attribute: 194 Temperature_Celsius changed from 39 to 44
Apr 19 09:00:08 Multi3 smartd[3955]: Device: /dev/sdb, SMART Usage Attribute: 195 Hardware_ECC_Recovered changed from 74 to 71
Apr 19 09:00:23 Multi3 isdnlog: Apr 19 09:00:23 tei 73 calling ? with ? HANGUP ( 0:00:20)
Apr 19 09:00:45 Multi3 isdnlog: Apr 19 09:00:45 * Call to tei 127 from ? on +49 xxxxxxx RING (3.1 kHz audio)
Apr 19 09:00:45 Multi3 kernel: capidrv-1: incoming call ,1,2,xxxx
Apr 19 09:00:45 Multi3 kernel: capidrv-1: patching si2=2 to 0 for VBOX
Apr 19 09:00:45 Multi3 kernel: isdn_net: Incoming call without OAD, assuming '0'
Apr 19 09:00:45 Multi3 kernel: isdn_net: call from 0 -> 0 2286 ignored
Apr 19 09:00:45 Multi3 kernel: isdn_tty: Incoming call without OAD, assuming '0'

Sagt mir alles nichts, ausser Spinnerei mit Capi oder Anrufbeantworter?!
Habe keinen AB eingerichtet. Nur Fax über Kmail mit Capisuite

Gruss

tommy
Kernel 2.6.34.7-0.3-desktop x86_64, openSUSE 11.3 (x86_64), KDE: 4.4.4 (KDE 4.4.4) "release 3", Grafikkarte nVidia GeForce 8200, 3D-Treiber: NVIDIA 256.53, AMD Phenom(tm) 9650 Quad-Core Processor 1150,00 MHz, RAM 8 GB, Swap 2GB

spoensche
Moderator
Moderator
Beiträge: 7340
Registriert: 30. Okt 2004, 23:53
Wohnort: Siegen

Beitrag von spoensche » 20. Apr 2008, 16:05

Code: Alles auswählen

Apr 19 08:39:48 Multi3 kernel: capidrv-1: patching si2=2 to 0 for VBOX 
Könnte das Problem mit Virtual Box sein. Bei dem Rest bin ich noch am überlegen. Wenn du den Konqueror als root geöffnet hast, kannst du alle Dateien löschen.

Code: Alles auswählen

Apr 19 08:30:09 Multi3 smartd[3955]: Device: /dev/sdb, SMART Usage Attribute: 190 Temperature_Celsius changed from 76 to 61
Apr 19 08:30:09 Multi3 smartd[3955]: Device: /dev/sdb, SMART Usage Attribute: 194 Temperature_Celsius changed from 24 to 39
Apr 19 08:30:09 Multi3 smartd[3955]: Device: /dev/sdb, SMART Usage Attribute: 195 Hardware_ECC_Recovered changed from 85 to 74 
Also laut deiner Meldung (smartd) ist deine Festplatte wohl ein bisschen zu heiss geworden., das könnte mit dein Problem sein. Hast du keinen Gehäuselüfter oder dein System getunet?

Benutzeravatar
tommy tulpe
Hacker
Hacker
Beiträge: 355
Registriert: 28. Mär 2006, 16:28

Benutzerrechte, allgemein unklare Thematik

Beitrag von tommy tulpe » 20. Apr 2008, 16:24

Hallo !

Das ist ja prima, dass wenigstens mal was in Sicht ist.
Kein Gehäuselüfter, nur CPU, nichts getuntes, alles Standard.
Kann aber eben nicht alles als kdesu konqueror löschen, wenn ich als root eingelogt bin.
VBox hat was mit der Capi zu tun?

tommy
Kernel 2.6.34.7-0.3-desktop x86_64, openSUSE 11.3 (x86_64), KDE: 4.4.4 (KDE 4.4.4) "release 3", Grafikkarte nVidia GeForce 8200, 3D-Treiber: NVIDIA 256.53, AMD Phenom(tm) 9650 Quad-Core Processor 1150,00 MHz, RAM 8 GB, Swap 2GB

spoensche
Moderator
Moderator
Beiträge: 7340
Registriert: 30. Okt 2004, 23:53
Wohnort: Siegen

Beitrag von spoensche » 21. Apr 2008, 16:09

Wenn du als root den Konqueror gestartet hast und eine Datei löschen möchtest, was bekommst du da denn genau für eine Fehlermeldung?

Benutzeravatar
tommy tulpe
Hacker
Hacker
Beiträge: 355
Registriert: 28. Mär 2006, 16:28

Benutzerrechte, allgemein unklare Thematik

Beitrag von tommy tulpe » 21. Apr 2008, 18:12

Hallo! Kann es gar nicht genau erklären, würde gern mal screenshot schicken, weiss aber nicht wie ich ihn Dir zukommen lassen kann.
Im Konqueror werden teilweise gar nicht die gewohnten Menüs gezeigt, so kann ich z.B. in meinem home Verzeichnis als root Sachen teils gar nicht löschen, da die Option im Menü grau hinterlegt ist.Bild
Kernel 2.6.34.7-0.3-desktop x86_64, openSUSE 11.3 (x86_64), KDE: 4.4.4 (KDE 4.4.4) "release 3", Grafikkarte nVidia GeForce 8200, 3D-Treiber: NVIDIA 256.53, AMD Phenom(tm) 9650 Quad-Core Processor 1150,00 MHz, RAM 8 GB, Swap 2GB

Benutzeravatar
TomcatMJ
Guru
Guru
Beiträge: 2480
Registriert: 1. Apr 2004, 00:29
Wohnort: Köln
Kontaktdaten:

Beitrag von TomcatMJ » 21. Apr 2008, 18:51

Du kannst im Konqueror im root-Modus auch nicht Dateien löschen auf die niemand, also auch root nicht, Schreibrechte hat. Ebensowenig darf root in ein Verzeichnis wechsel auf das ihm der Zugriff gesperrt wurde. Der Unterschied zu einem normalen User ist dann eben nur der, daß root sich selbst die passenden Dateirechte/Zugriffsrechte setzen kann um solche Dateien dann auch zu löschen bzw. in solche Verzeichnisse dann zu wechseln.
Voreinsteungen für Zugriffsrechte können ja durchaus per umask gesetzt werden (siehe dazu auch unter http://wiki.linux-club.de/opensuse/Zugriffsrechte )
Das wird vermutlich der Knackpunt bei deinen misslungen Dateilöschversuchen dann gewesen sein ;)

Bis denne,
Tom

Benutzeravatar
tommy tulpe
Hacker
Hacker
Beiträge: 355
Registriert: 28. Mär 2006, 16:28

Benutzerrechte, allgemein unklare Thematik

Beitrag von tommy tulpe » 25. Apr 2008, 17:37

Da fress ich doch nen Besen! Da bin ich in Yast/System/Sicherungskopie der Systembereiche gegangen, da ich vorsichtshalber das System sichern wollte, bevor ich rumbastle. Zum Glück war das gewählte Speicherziel zu klein...
Denn nachdem ich auf abbrechen gedrückt habe, passierte dies:
- VirtualBox hatte ich vorher komplett deinstalliert gehabt und keinerlei Dateien mehr in home und temp Verzeichnis. Nach der oben beschriebenen Aktion hatte ich es auf einmal wieder drauf und zwar als normaler User zu nutzen ! Leider funktioniert jetzt USB nicht mehr....
- Goggle Earth hatte vorher auch plötzlich den Dienst versagt, jetzt lies es sich wieder ganz normal installieren, was vorher fehlgschlagen war.

Interessant? Manche Problem lösen sich (fast) von selbst. Man muss nur was richtig verkehrt machen.

Was bleibt ist jetzt zum wiederholten Mal ein VBox Problem mit USB.

tommy
Kernel 2.6.34.7-0.3-desktop x86_64, openSUSE 11.3 (x86_64), KDE: 4.4.4 (KDE 4.4.4) "release 3", Grafikkarte nVidia GeForce 8200, 3D-Treiber: NVIDIA 256.53, AMD Phenom(tm) 9650 Quad-Core Processor 1150,00 MHz, RAM 8 GB, Swap 2GB

spoensche
Moderator
Moderator
Beiträge: 7340
Registriert: 30. Okt 2004, 23:53
Wohnort: Siegen

Beitrag von spoensche » 25. Apr 2008, 17:47

Wenn du die USB Unterstützung meinst, glaub ich das das nicht geht, bin mir aber nicht sicher. Sieh einfach mal in den Einstellungen nach.

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast