SuSe 9.1 (2.6.5-7.54) VMWARE 4.5.2 - bei vmware-config Fehle

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

datensurfer
Newbie
Newbie
Beiträge: 48
Registriert: 22. Feb 2004, 14:19
Wohnort: hannover
Kontaktdaten:

Beitrag von datensurfer » 21. Jun 2004, 20:35

hmm... und wie ohne router? Weil eigentlich habe ich ja nur die ip von meiner i-net verbindung und diese wechselt! *grübel* Oder muss ich dazu ein proxy aufsetzen?

Hat mal jemand durch die vmware auf seine linux-i-net-verbindung zugegriffen OHNE Router?

Werbung:
Lietzi
Newbie
Newbie
Beiträge: 2
Registriert: 20. Jun 2004, 19:23

VMWare 4.5.1 Key nicht für 4.5.2

Beitrag von Lietzi » 22. Jun 2004, 10:46

Hallo Leute!

Bin ein Neuling.. also nicht schlagen für die doofe Frage:

Hatte das gleiche Problem wie hier beschrieben und hab dabei von vmware 4.5.1 auf 4.5.2 geupdatet.. vmware läuft scheinbar vorerstmal einwandfrei.. zumindest bis hin zur Eingabe der Serial.. mein 4.5.1 Key wird nicht akzeptiert mit der Meldung "Error: no match".

Ungültig scheint sie nicht zu sein.. denn ändere ich sie ein wenig kommt der provozierte Fehler "Error: invalid".

Was mach ich falsch? Ist das Update doch nicht kostenlos? Muss ich ne neue Serial "anfordern".

Meine 4.5.1 Version tut es seit Kernel 2.6 nicht mehr.. auch nach gutem zureden und neukompilieren des Kernels.. muss ich da vielleicht anders vorgehen als hier im Thread beschrieben?

Bin für Hilfe dankbar!

robertthronhill
Newbie
Newbie
Beiträge: 20
Registriert: 4. Jun 2004, 22:07

Beitrag von robertthronhill » 22. Jun 2004, 15:45

Ich hatte nach dem Update kein Problem.
Geh in das Verzeichnis ~/.vmware und schau, ob da die Dateien license.ws.3.0 und license.ws.4.0 drin sind. Wenn du VMware schon mal registiert hattest sollten die beiden Dateien da sein.

Benutzeravatar
Martin Breidenbach
Ultimate Guru
Ultimate Guru
Beiträge: 5632
Registriert: 26. Mai 2004, 21:33
Wohnort: N 50.17599° E 8.73367°

Beitrag von Martin Breidenbach » 22. Jun 2004, 15:49

VMware 4.5.2 sollte mit VMware 4.x Keys laufen. Wenn's das nicht tut - als registrierter Kunde mit legal gekaufter Lizenz kann man sich ja an VMware wenden.

datensurfer
Newbie
Newbie
Beiträge: 48
Registriert: 22. Feb 2004, 14:19
Wohnort: hannover
Kontaktdaten:

Beitrag von datensurfer » 22. Jun 2004, 16:26

Martin Breidenbach hat geschrieben:VMware 4.5.2 sollte mit VMware 4.x Keys laufen. Wenn's das nicht tut - als registrierter Kunde mit legal gekaufter Lizenz kann man sich ja an VMware wenden.
Sehe ich auch so! Gerade im Linux Bereich sollte man KEINE User von illegalen Lizenzen unterstützen.
Schon alleine aus dem Grund nicht, weil es viel Open Source Software gibt welche den Support viel mehr verdient!

Lietzi
Newbie
Newbie
Beiträge: 2
Registriert: 20. Jun 2004, 19:23

Beitrag von Lietzi » 22. Jun 2004, 17:05

Das ich da wohl anrufen kann ist klar.. nur bevor ich mich da zum Affen mache wollte ich das kurz hier im kleinen Kreis mit euch abklären..

Also eigentlich sollte es laufen..

und der Fehler "No Match" muss also andere Gründe haben die Ihr nicht kennt..

na dann freu ich mich mal auf den Support von vmware.. *schonmaleinkissenzumwartensuch*

Bis dann dann

P.S. Die Dateien die angesprochen worden sind habe ich natürlich nicht mehr drin, da ich Suse 9.1 wie es sich gehört komplett neu installiert habe. Und da das kompilieren von 4.5.1 nicht funzte habe ich es unter 9.1 nicht zum Laufen gebracht. 4.5.2 läuft, quittiert aber meine Serial-Eingabe mit "No Match". Ich dachte in einem VMWare-Bereich eines Forums kriegt man da mal schnell eine Lösung (im Gegensatz zu dem Hersteller-Support), wenn das Problem allgemein bekannt ist. Ich dachte immer für sowas gibt es Foren.. naja geirrt.. offensichtlich.. dennoch danke für die nette Hilfe!

Benutzeravatar
Martin Breidenbach
Ultimate Guru
Ultimate Guru
Beiträge: 5632
Registriert: 26. Mai 2004, 21:33
Wohnort: N 50.17599° E 8.73367°

Beitrag von Martin Breidenbach » 22. Jun 2004, 18:08

Bei mir gabs dieses Problem nicht und ich habe bisher auch keine Nachricht gelesen wo jemand anders das Problem gehabt hätte :(

datensurfer
Newbie
Newbie
Beiträge: 48
Registriert: 22. Feb 2004, 14:19
Wohnort: hannover
Kontaktdaten:

Beitrag von datensurfer » 22. Jun 2004, 19:27

Martin Breidenbach hat geschrieben:Bei mir gabs dieses Problem nicht und ich habe bisher auch keine Nachricht gelesen wo jemand anders das Problem gehabt hätte :(
geht mir genauso!
Übrigens muss keine Datei in irgend ein Verzeichnis liegen, es reicht wenn bei der Install die RICHTIGE Serial eingegeben wird.
Könnte natürlich auch ein serial-eingabe-bug der vmware sein...

Back2topic: hat jemand mal Netzwerk Zugriff aus der vmware auf die linux-i-net-dsl-verbindung gemacht? Wenn ja tipps?

Benutzeravatar
Martin Breidenbach
Ultimate Guru
Ultimate Guru
Beiträge: 5632
Registriert: 26. Mai 2004, 21:33
Wohnort: N 50.17599° E 8.73367°

Beitrag von Martin Breidenbach » 22. Jun 2004, 19:46

Ich denke die Frage ist ob der zwischen Host-only und Internet routen kann. Kann ich so leider nicht testen.

Falls Du hier keine Hilfe kriegst kannst Du's ja mal hier

http://vmware.itst.org/

oder hier

http://www.vmware.com/community

probieren.

datensurfer
Newbie
Newbie
Beiträge: 48
Registriert: 22. Feb 2004, 14:19
Wohnort: hannover
Kontaktdaten:

Beitrag von datensurfer » 22. Jun 2004, 19:57

cool thx, werde mich da bei gelegenheit mal durchwühlen!

banshee
Newbie
Newbie
Beiträge: 2
Registriert: 23. Mai 2004, 18:03
Wohnort: Aachen / NRW
Kontaktdaten:

Besten Dank !!

Beitrag von banshee » 26. Jun 2004, 14:27

Hallo,
habe den halben gestrigen Abend mit dem Problem vmware-config.pl und dem Kernel 2.6.5-7.75 auf SUSE 9.1 verbracht. Dank Deiner super Anleitung hat es dann gerade auch endlich (!) funktioniert.
Super Hinweis, vielen Dank !!

Gruß
Stefan
:lol:

Benutzeravatar
Phantom
Newbie
Newbie
Beiträge: 5
Registriert: 23. Jun 2004, 18:44
Wohnort: Bremen

Beitrag von Phantom » 18. Jul 2004, 10:45

Ich hab mich jetzt schon durch einiges durchgeforstet, bin aber noch keinen Schritt weiter.

Beim Versuch VmWare 4.5.2 zu installieren komme ich einfach nicht weiter:

Code: Alles auswählen

andreas@as:~> su
Password:
as:/home/andreas # vmware-config.pl
Making sure services for VMware Workstation are stopped.

Stopping VMware services:
   Virtual machine monitor                                             done

Trying to find a suitable vmmon module for your running kernel.

None of the pre-built vmmon modules for VMware Workstation is suitable for your
running kernel.  Do you want this program to try to build the vmmon module for
your system (you need to have a C compiler installed on your system)? [yes]

Using compiler "/usr/bin/gcc". Use environment variable CC to override.

What is the location of the directory of C header files that match your running
kernel? [/usr/src/linux/include]

The path "/usr/src/linux/include" is a kernel header file directory, but it does
not contain the file "asm/page.h" as expected.

What is the location of the directory of C header files that match your running
kernel? [/usr/src/linux/include]
Was muss ich noch alles machen um es endlich zum laufen zu bringen?
[/quote]

Benutzeravatar
Martin Breidenbach
Ultimate Guru
Ultimate Guru
Beiträge: 5632
Registriert: 26. Mai 2004, 21:33
Wohnort: N 50.17599° E 8.73367°

Beitrag von Martin Breidenbach » 18. Jul 2004, 11:16

Hmmm.... wenn /usr/src/linux/include existiert dann sollten die Kernel-Quellen ja drauf sein.

Ich würde mir das /usr/src/linux/include mal ansehen was da so drin ist.

Ggf Kernel-Quellen nochmal neu installieren und dann danach ein Online Update damit die installierten Kernel-Quellen zum installierten Kernel passen.

Benutzeravatar
Phantom
Newbie
Newbie
Beiträge: 5
Registriert: 23. Jun 2004, 18:44
Wohnort: Bremen

Beitrag von Phantom » 18. Jul 2004, 12:26

file:/usr/src/linux/include habe ich selbst angelegt. Inzwischen befinden sich dort folgende Dateien/Ordner drin:
  • file:/usr/src/linux/include/asm/asm (leerer Ordner)
    file:/usr/src/linux/include/linux/autoconf.h
    file:/usr/src/linux/include/linux/version.h
    file:/usr/src/linux/include/net (leerer Ordner)

Benutzeravatar
Martin Breidenbach
Ultimate Guru
Ultimate Guru
Beiträge: 5632
Registriert: 26. Mai 2004, 21:33
Wohnort: N 50.17599° E 8.73367°

Beitrag von Martin Breidenbach » 18. Jul 2004, 12:56

Aua.

Die Verzeichnisse werden beim Installieren der Kernel-Quellen automatisch angelegt. Das heißt also daß Du die Kernel-Quellen nicht installiert hast. Die werden aber zur Installation von VMware benötigt.

Also:
Selbstangelegtes Zeugs löschen.
Kernelquellen installieren.
ggf YaST Online Update machen

und dann VMware installieren/konfigurieren.

Benutzeravatar
T2111w2
Newbie
Newbie
Beiträge: 5
Registriert: 19. Jul 2004, 22:09

Danke

Beitrag von T2111w2 » 19. Jul 2004, 22:13

Danke für die umfangreiche Hilfe die hier geboten wird.
Ich bin neu hier und jetzt schon hochzufrieden mit dem Bord.
:wink:
mfg
T2111w

moonman
Newbie
Newbie
Beiträge: 2
Registriert: 20. Jul 2004, 10:43

Beitrag von moonman » 20. Jul 2004, 11:37

Hallo habe die install so verfolgt wie oben beschrieben doch ich bekomme dieses ergebnis

Bergwerk:/usr/src/linux # /usr/bin/vmware-config.pl
Making sure services for VMware Workstation are stopped.

Stopping VMware services:
Virtual machine monitor done

Trying to find a suitable vmmon module for your running kernel.

None of the pre-built vmmon modules for VMware Workstation is suitable for your
running kernel. Do you want this program to try to build the vmmon module for
your system (you need to have a C compiler installed on your system)? [yes] yes

Using compiler "/usr/bin/gcc". Use environment variable CC to override.

What is the location of the directory of C header files that match your running
kernel? [/usr/src/linux-2.6.5-7.95] /usr/src/linux

The path "/usr/src/linux" is an existing directory, but it does not contain at
least one of these directories "linux", "asm", "net" as expected.

What is the location of the directory of C header files that match your running
kernel? [/usr/src/linux-2.6.5-7.95] /usr/src/linux/include

The directory of kernel headers (version 2.6.4-52-default) does not match your
running kernel (version 2.6.5-7.95-default). Even if the module were to compile
successfully, it would not load into the running kernel.

What is the location of the directory of C header files that match your running
kernel? [/usr/src/linux-2.6.5-7.95]

Extracting the sources of the vmmon module.

Building the vmmon module.

Using standalone build system.
make: Entering directory `/tmp/vmware-config5/vmmon-only'
make[1]: Entering directory `/tmp/vmware-config5/vmmon-only'
make[2]: Entering directory `/tmp/vmware-config5/vmmon-only/driver-2.6.5-7.95-default'
make[2]: Leaving directory `/tmp/vmware-config5/vmmon-only/driver-2.6.5-7.95-default'
make[2]: Entering directory `/tmp/vmware-config5/vmmon-only/driver-2.6.5-7.95-default'
In file included from ../linux/driver.h:18,
from ../linux/driver.c:38:
../include/compat_wait.h:60: error: conflicting types for `poll_initwait'
/usr/include/linux/poll.h:44: error: previous declaration of `poll_initwait'
../linux/driver.c:131: warning: initialization from incompatible pointer type
../linux/driver.c:135: warning: initialization from incompatible pointer type
make[2]: *** [driver.o] Error 1
make[2]: Leaving directory `/tmp/vmware-config5/vmmon-only/driver-2.6.5-7.95-default'
make[1]: *** [driver] Error 2
make[1]: Leaving directory `/tmp/vmware-config5/vmmon-only'
make: *** [auto-build] Error 2
make: Leaving directory `/tmp/vmware-config5/vmmon-only'
Unable to build the vmmon module.

For more information on how to troubleshoot module-related problems, please
visit our Web site at "http://www.vmware.com/download/modules/modules.html" and
"http://www.vmware.com/support/reference ... linux.html".

Execution aborted.

Bergwerk:/usr/src/linux #


wer kann mir weiter helfen
was soll ich tun

danke
byby

Benutzeravatar
Martin Breidenbach
Ultimate Guru
Ultimate Guru
Beiträge: 5632
Registriert: 26. Mai 2004, 21:33
Wohnort: N 50.17599° E 8.73367°

Beitrag von Martin Breidenbach » 20. Jul 2004, 18:12

moonman hat geschrieben:The directory of kernel headers (version 2.6.4-52-default) does not match your running kernel (version 2.6.5-7.95-default). Even if the module were to compile successfully, it would not load into the running kernel.
Wenn Du die Kernel-Quellen erst nach einem YaST Online Update installiert hast dann ist es sehr wahrscheinlich daß der YOU einen neueren Kernel installiert hat der nun nicht zu den Quellen paßt.

Lösung: nochmal YOU laufen lassen damit er auch die Quellen aktualisiert (das dauert auch über DSL ein wenig)

steffenza
Newbie
Newbie
Beiträge: 4
Registriert: 30. Jul 2004, 19:14
Wohnort: Berlin

Hallo

Beitrag von steffenza » 30. Jul 2004, 19:25

Sie können VMware nur auf einem selbst kompilierten Kernel laufen lassen.
Wenn sie den Kernel selbst kompilieren müsste es funktionieren.

ViennaAustria
Newbie
Newbie
Beiträge: 1
Registriert: 4. Aug 2004, 21:18
Wohnort: Wien

Beitrag von ViennaAustria » 4. Aug 2004, 21:39

Hallo Martin!

Danke für Deinen Tipp - hat auch bei mir bestens funktioniert. Um unerfahrenen Usern "Compilier-Experimente" zu ersparen, sammle ich die Binaries auf

http://schallar.at/thomas/vmware/

Diese nach der Installation vom VMware RPM nach /usr/lib/vmware/modules/binary/ entpacken und schon findet vmware-config.pl die richtigen Module.

Derzeit ist auf der angegebenen Adresse leider nur das Modul von mir für den aktuellen SMP-Kernel für SuSE 9.1 verfügbar (2.6.5-7.95-smp). Ich hoffe darauf, dass mir Gleichgesinnte Ihre Moule zuschicken, damit ich sie reinstellen kann - mit genauer Kernelversion (Ausgabe von `uname -r´) und Bezeichnung der Linux-Distribution (SuSE 9.1, RedHat 9.0, etc.) bitte!

Antworten

Wer ist online?

Mitglieder in diesem Forum: Bing [Bot], Yahoo [Bot] und 2 Gäste