Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Grub startet WinXP nicht

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
Rainere
Newbie
Newbie
Beiträge: 7
Registriert: 4. Apr 2008, 19:21

Grub startet WinXP nicht

Beitrag von Rainere » 4. Apr 2008, 19:58

Hallo,

hab folgendes Problem:
Grub starte mein WinXP nicht. Habe 2 Festplatten, als 1. Samsung-SP1654N und als 2. Samsung-HD250HJ
Hab OpenSuse 10.3 auf /dev/sdb6 und WinXP auf /dev/sdb1. Die erst Festplatte sda (Samsung-SP1654N) ist nur für Daten.

Suse starten ganz normal. Wenn ich Win im Grubmenü auswähle bleibt Grub dann stehen und gibt die Meldung:
Booting command-list
rootnoverify (hd1,0)
chainloader (hd1,0)+1

Dann geht nur noch strg+alt+entf.

Meine Einstellungen:

Code: Alles auswählen

fdisk -l:
Platte /dev/sda: 160.0 GByte, 160041885696 Byte
255 heads, 63 sectors/track, 19457 cylinders
Units = Zylinder of 16065 * 512 = 8225280 bytes
Disk identifier: 0x00000001

   Gerät  boot.     Anfang        Ende     Blöcke   Id  System
/dev/sda1               1       19457   156288321   83  Linux

Platte /dev/sdb: 250.0 GByte, 250059350016 Byte
255 heads, 63 sectors/track, 30401 cylinders
Units = Zylinder of 16065 * 512 = 8225280 bytes
Disk identifier: 0x0cb9ad1f

   Gerät  boot.     Anfang        Ende     Blöcke   Id  System
/dev/sdb1   *           1        4448    35728528+   7  HPFS/NTFS
/dev/sdb2            4449       30401   208467472+   f  W95 Erw. (LBA)
/dev/sdb5            4449        4710     2104452   82  Linux Swap / Solaris
/dev/sdb6            4711        7321    20972826   83  Linux
/dev/sdb7            7322       30401   185390068+  83  Linux

Code: Alles auswählen

cat /etc/fstab
/dev/disk/by-id/scsi-SATA_SAMSUNG_HD250HJS0URJDRP808309-part7 /home                                ext3       acl,user_xattr        1 2
/dev/disk/by-id/scsi-SATA_SAMSUNG_HD250HJS0URJDRP808309-part6 /                                    ext3       acl,user_xattr        1 1
/dev/disk/by-id/scsi-SATA_SAMSUNG_HD250HJS0URJDRP808309-part5 swap                                 swap       defaults              0 0
proc                 /proc                proc       defaults              0 0
sysfs                /sys                 sysfs      noauto                0 0
debugfs              /sys/kernel/debug    debugfs    noauto                0 0
usbfs                /proc/bus/usb        usbfs      devgid=1000,devmode=0664 0                 0
devpts               /dev/pts             devpts     mode=0620,gid=5       0 0
/dev/disk/by-id/scsi-SATA_SAMSUNG_HD250HJS0URJDRP808309-part1 /windows                             ntfs-3g    users,gid=users,fmask=133,dmask=022,locale=de_DE.UTF-8 0 0
/dev/disk/by-id/scsi-SATA_SAMSUNG_SP1654NS0GEJ1EL401362-part1 /mnt/disk                            ext3       defaults              1 2

Code: Alles auswählen

cat /boot/grub/menu.lst
# Modified by YaST2. Last modification on Fr Apr  4 17:58:37 CEST 2008
default 0
timeout 8
gfxmenu (hd1,5)/boot/message
##YaST - activate

###Don't change this comment - YaST2 identifier: Original name: linux###
title openSUSE 10.3 - 2.6.22.17-0.1
    root (hd1,5)
    kernel /boot/vmlinuz-2.6.22.17-0.1-default root=/dev/disk/by-id/scsi-SATA_SAMSUNG_HD250HJS0URJDRP808309-part6 vga=0x31a resume=/dev/sdb5 splash=silent  showopts
    initrd /boot/initrd-2.6.22.17-0.1-default

###Don't change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe -- openSUSE 10.3 - 2.6.22.17-0.1
    root (hd1,5)
    kernel /boot/vmlinuz-2.6.22.17-0.1-default root=/dev/disk/by-id/scsi-SATA_SAMSUNG_HD250HJS0URJDRP808309-part6 vga=normal showopts ide=nodma apm=off acpi=off noresume nosmp noapic maxcpus=0 edd=off 3
    initrd /boot/initrd-2.6.22.17-0.1-default

###Don't change this comment - YaST2 identifier: Original name: linux-2.6.22.17-0.1-bigsmp###
title openSUSE 10.3
    root (hd1,5)
    kernel /boot/vmlinuz-2.6.22.17-0.1-bigsmp root=/dev/disk/by-id/scsi-SATA_SAMSUNG_HD250HJS0URJDRP808309-part6 vga=0x31a resume=/dev/sdb5 splash=silent  showopts
    initrd /boot/initrd-2.6.22.17-0.1-bigsmp

###Don't change this comment - YaST2 identifier: Original name: failsafe-2.6.22.17-0.1-bigsmp###
title Failsafe -- openSUSE 10.3
    root (hd1,5)
    kernel /boot/vmlinuz-2.6.22.17-0.1-bigsmp root=/dev/disk/by-id/scsi-SATA_SAMSUNG_HD250HJS0URJDRP808309-part6 vga=normal showopts ide=nodma apm=off acpi=off noresume nosmp noapic maxcpus=0 edd=off 3
    initrd /boot/initrd-2.6.22.17-0.1-bigsmp

###Don't change this comment - YaST2 identifier: Original name: Kernel-2.6.22.17-0.1-default###
title Kernel-2.6.22.17-0.1-default
    root (hd1,5)
    configfile /boot/grub/menu.lst
    configfile /boot/grub/menu.lst
    configfile /boot/grub/menu.lst
    configfile /boot/grub/menu.lst

###Don't change this comment - YaST2 identifier: Original name: windows###
title Windows
    rootnoverify (hd1,0)
    chainloader (hd1,0)+1


###Don't change this comment - YaST2 identifier: Original name: xen###
title XEN
    root (hd1,5)
    kernel /boot/xen.gz
    module /boot/vmlinuz-xen root=/dev/disk/by-id/scsi-SATA_SAMSUNG_HD250HJS0URJDRP808309-part6 vga=0x31a resume=/dev/sdb5 splash=silent showopts
    module /boot/initrd-xen

Code: Alles auswählen

cat /boot/grub/device.map
(hd0)   /dev/sda
(hd2)   /dev/sdg
(hd1)   /dev/sdb
Hab schon alle möglichen Einstellungen bei rootnoverify und chainloader probiert, hat aber noch nichts geklappt.

Es ging aber schon mal. Vielleicht ist da mal ne Einstellung ausversehen verstellt wurden?

Wenn mir jemand helfen könnte, das wäre klasse.

Danke

Gruß
Rainer

Werbung:
scummos
Hacker
Hacker
Beiträge: 275
Registriert: 27. Jan 2007, 09:36
Kontaktdaten:

Beitrag von scummos » 4. Apr 2008, 20:36

Das ist komisch... normalerweise sollte das funktioniern (bzw. ich kenne es so):

Code: Alles auswählen

title windows
rootnoverify (hd0,1)
chainloader +1
boot
Meine Homepage: http://scummos.sc.funpic.de/show.php
Und mein Browserspiel, schaut doch mal vorbei, wir suchen noch Tester!
Bild

Rainere
Newbie
Newbie
Beiträge: 7
Registriert: 4. Apr 2008, 19:21

Beitrag von Rainere » 4. Apr 2008, 20:54

scummos hat geschrieben:Das ist komisch... normalerweise sollte das funktioniern (bzw. ich kenne es so):

Code: Alles auswählen

title windows
rootnoverify (hd0,1)
chainloader +1
boot


Hat auch nicht geklappt. Hab verschiedene Einstellungen probiert....

towo
Moderator
Moderator
Beiträge: 3710
Registriert: 15. Feb 2004, 16:42
Wohnort: Nimritz
Kontaktdaten:

Beitrag von towo » 4. Apr 2008, 21:15

Code: Alles auswählen

title windows
map (hd0) (hd1)
map (hd1) (hd0)
rootnoverify (hd1,0)
makeactive
chainloader +1
So sollte das schon gehen.
Signatur nach Diktat spazieren gegangen

Bild

Rainere
Newbie
Newbie
Beiträge: 7
Registriert: 4. Apr 2008, 19:21

Beitrag von Rainere » 4. Apr 2008, 21:28

towo hat geschrieben:

Code: Alles auswählen

title windows
map (hd0) (hd1)
map (hd1) (hd0)
rootnoverify (hd1,0)
makeactive
chainloader +1
So sollte das schon gehen.

Hat geklappt, Vielen Dank
Woran lags denn? Was bedeutet
map (hd0) (hd1)
map (hd1) (hd0)?

admine
Administrator
Administrator
Beiträge: 8782
Registriert: 15. Feb 2004, 21:13
Kontaktdaten:

Beitrag von admine » 4. Apr 2008, 21:33

Rainere hat geschrieben: Hat geklappt, Vielen Dank
Woran lags denn? Was bedeutet
map (hd0) (hd1)
map (hd1) (hd0)?
Windows will immer von 1. Platte und 1. Partition starten ;)
Wenn man von der 2.Platte ein Windows starten will, vertauscht man virtuell Platte 2 und 1. Dadurch wird Windows eine erste Platte vorgegauckelt.
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------

Rainere
Newbie
Newbie
Beiträge: 7
Registriert: 4. Apr 2008, 19:21

Beitrag von Rainere » 4. Apr 2008, 21:41

Alles klar.... :lol:

Antworten