Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

SuSE 10.2,LIRC Senden klappt nicht-irsend:[gelöst]

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
fritzbee21
Hacker
Hacker
Beiträge: 279
Registriert: 12. Aug 2004, 14:16

SuSE 10.2,LIRC Senden klappt nicht-irsend:[gelöst]

Beitrag von fritzbee21 » 12. Mär 2008, 23:29

Ich habe mir einen IR Sender gebaut um damit per serieller Schnittstelle IR Kommandos zu senden.

LIRC habe ich die 0.8.3 installiert, yast zeigt mir aber ne 0.8.0 an.



wenn ich den Treiber lade
modprobe lirc_serial

bekomme ich

Mar 12 19:49:06 lupo kernel: lirc_dev: IR Remote Control driver registered, at major 61
Mar 12 19:49:07 lupo kernel: lirc_serial: auto-detected active high receiver
Mar 12 19:49:07 lupo kernel: lirc_dev: lirc_register_plugin: sample_rate: 0


möchte ich ein Kommando mit IRSEND senden:

lupo:# irsend -d /dev/lircd SEND_ONCE D-BOX off 00000000000000cf
irsend: command failed: SEND_ONCE D-BOX off
irsend: hardware does not support sending


d.h. mein LIRC meint ich wäre nicht sendefähig.


Hier auf der Webseite habe ich dazu folgendes gefunden:

http://iguanaworks.net/faq.psp

LIRC will complain that the "hardware does not support sending" if "With transmitter diode" is not selected. We get this question most commonly from SuSE users because the version of lirc_serial that comes installed with SuSE does not have the transmitter diode configured.

Per Yast habe ich die Möglichkeit ein LIRC 0.8.0 zu installieren, dies habe ich mal deinstalliert und anschliessend meine Version 0.8.3 (habe bei der ersten Installation ein RPM Packet gebaut) installiert.
Nun zeigt mir zwar yast an ich hab die 0.8.3 drin, aber unter /etc/init.d habe ich keine Möglichkeit das rclirc start auszuführen, da das rclirc nicht vorhanden ist. Wenn ich dagegen das 0.8.0 installiere, hab ich zwar das rclirc aber ich kann nicht senden.


Wer kann mir denn weiterhelfen ? Wie bekomme ich mein LIRC verwendet und nicht das von yast/SUSE?


Lirc habe ich installiert und zwar so:

lupo:/usr/local/src/lirc-0.8.3pre1 # ./setup.sh
1. Driver Config
1. Homebrew
1 Com 1
1 With transmitter Diode MARKIERT
2. Software generated carrier MARKIERT
OK
3. save config and run configure


You will have to use the lirc_serial kernel module.

Now enter 'make' and 'make install' to compile and install the package.


make

make install


NACHTRAG:

ich habe jetzt eben nochmal versucht das LIRC aus dem CVS zu installieren, also LIRC ausgecheckt, dann
./autogen.sh

anschliessend

./configure

und die Sachen eingestellt, dann wie oben
3. save config and run configure

allerdings läuft hier jetzt nichts mehr durch und so kann ich auch kein make ausführen ???
Zuletzt geändert von fritzbee21 am 14. Mär 2008, 01:04, insgesamt 1-mal geändert.

Werbung:
Benutzeravatar
whois
Administrator
Administrator
Beiträge: 16599
Registriert: 11. Okt 2004, 08:50
Wohnort: Aachen
Kontaktdaten:

Beitrag von whois » 13. Mär 2008, 06:55

Hi

Stell bitte mal folgendes Ergebnis ins Forum.

Code: Alles auswählen

rpm -qa| grep lirc
Was für einen Kernel beutzt du?
Spiel dir über einen Paketmanager doch zuerst mal die Version von diesem Repo ein.

Webpin

cu

fritzbee21
Hacker
Hacker
Beiträge: 279
Registriert: 12. Aug 2004, 14:16

Beitrag von fritzbee21 » 13. Mär 2008, 18:04

lupo:/home/wolfgang # rpm -qa| grep lirc
lirc-kmp-default-0.8.0_2.6.18.2_34-10
lirc-0.8.3pre1-1

lupo:/home/wolfgang # uname -r
2.6.18.2-34-default
lupo:/home/wolfgang #

HIer gibt es ein WIKI:
http://wiki.linux-club.de/opensuse/LIRC

passt denn in meinem Fall das Kernel Packet (0.8.0) zu meinem LIRC (0.8.3)?

ich kann über yast das lIRC 0.8.0 installieren, dann funzt LIRC aber nur als Empfänger.
Wenn ich das 0.8.3er Packet anschliessend installiere, taucht das aber nicht auf (habs ja als Sender kompiliert)


NACHTRAG:

in dem oben genannten Wiki zu Beginn folgendes:

Solltet ihr kein zu eurem installierten Kernel passendes Paket mit Kernel-Modulen finden, müsst ihr es euch selbst bauen.

d.h. ich habe jetzt mal mit yast mein lirc-kmp-default-0.8.0_2.6.18.2_34-10 deinstalliert, da ich meine Kernel sourcen ja selbst bauen möchte (mit TransmitterDiode enabled).

meine LIRC Konfig durchlaufen und anschliessend mit checkinstall ein RPM gebaut.
das RPM umgenannt:

rename lirc-0.8.3pre1-1.i386.rpm lirc-kmp.rpm lirc-0.8.3pre1-1.i386.rpm

und anschliessend mit
rpm -i lirc-kmp.rpm
installiert.

Wenn ich alles richtig verstanden habe, müsste das ja so klappen (laut WIKI).
Nur ich kann den lirc_serial Treiber nicht laden, weil irgendwas nicht passt

lupo:/home/wolfgang # modprobe lirc_serial
WARNING: Could not open '/lib/modules/2.6.18.2-34-default/updates/lirc_dev/lirc_dev.ko': No such file or directory
FATAL: Could not open '/lib/modules/2.6.18.2-34-default/updates/lirc_serial/lirc_serial.ko': No such file or directory

lupo:/home/wolfgang # rpm -qa| grep lirc
lirc-0.8.0-41
lirc-0.8.3pre1-1



Irgdnwie steig ich nicht mehr durch ...???

fritzbee21
Hacker
Hacker
Beiträge: 279
Registriert: 12. Aug 2004, 14:16

Beitrag von fritzbee21 » 14. Mär 2008, 01:02

so nachdem ich nochmal das Web gequält habe, kann ich mir die Antwort gleich selbst geben.
Also man braucht tatsächlich erstmal das Packet lirc, will man senden darf man das Suse Packet per Yast NICHT installieren, sondern muss per WIKI sich das selbst bauen.
Am Ende nach dem make, NICHT make install sondern checkinstall und dann beim RPM Bauen das Packet umbenennen in
lirc-kmp-default
dann das rpm mit
rpm -i
installieren


Ich hab zwar noch ein anderes Problem mit LIRC,
siehe hier:

http://www.linux-club.de/ftopic91301.html

ich kann auf dem Rechner, an dem der Sender mal hängen soll das lirc-kmp nicht bauen

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste