Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Externe Festplatte verhindert boot / Selber Schuld

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
Benutzeravatar
Bushard
Newbie
Newbie
Beiträge: 8
Registriert: 28. Feb 2008, 09:03

Externe Festplatte verhindert boot / Selber Schuld

Beitrag von Bushard » 11. Mär 2008, 16:28

Hi erstmal,habe seit einigen Tagen ein ernstes Problem derzeit Open Suse 10.3 (10.26).
Nun habe ich trotz besseren Wissens folgenden Fehler begangen, da eine externe zeitweise eingesetzt (geliehen) USB- Platte , wieder auf das ursprünglich System angesetzt werde sollte, wurde diese in FAT formatiert und läuft seitdem wie sie soll!

Was ich vergaß war das ich diese USB – Platte mit YAST gemountet hatte, ohne die Partition zu löschen. Nun hab ich natürlich das Problem, und bekomme folgende Meldung.

Skript Auszug:

+Error on stat () /dev/disk/byid/usb-Maxtor_S_TM3160212A-0:0-part1: No such file directory
+Fsck.ext3 /dev/disk/byid/usb-Maxtor_S_TM3160212A-0:0-part1 failed (status 0*8). Run failedly
+Blogd : no message logging because /var filesystem is not accessible
+Ehci-hcd ohci-hcd uhci-hcd usb-ohci usb-uhci
+Fsck failed for at least one filesystem (not/).
+Please repair manually and reboot.
+The root file system is is already mounted read-wirte.
+Attention : only CONTROL-D will reboot
+…….
+……
+Give root password for login:……….
(repair filesystem) #

Jetzt dachte ich ok kann ja nicht so schwer sein und habe erst mal versucht den gegebenen Anweisungen zu folgen, doch ohne Erfolg. Zu dem mit einem unguten Gefühl in der Magengegend. Daher hab ich mich dann entschieden folgendes zu versuchen;

# unmount /dev/disk/byid/usb-Maxtor_S_TM3160212A-0:0-part1
# fdisk /dev/disk/byid/usb-Maxtor_S_TM3160212A-0:0-part1
# find | xargs run fstab
# del /dev/disk/byid/usb-Maxtor_S_TM3160212A-0:0-part1

Aber soweit kam ich ja gar nicht den Abbruch in Zeile 1 wegen unbekannten Befehl!! ??? Ja nun bin ich ziemlich unsicher was ich tun kann. Weil irgendwie kommt mir die shell komisch! MG

Werbung:
rolle
Guru
Guru
Beiträge: 3721
Registriert: 4. Mai 2004, 21:50
Kontaktdaten:

Beitrag von rolle » 11. Mär 2008, 16:35

Daas Kind heißt umount, ohne 'n'. Du kannst auch einfach den vi starten und von Hand die entsprechende Zeile in der fstab auskommentieren. Oder Du machst das von einer LiveCD aus. Oder...
Horrido, Roland

Für meine Postings gilt außer bei Zitaten hier im Linux-Club die Creative Commons.

Benutzeravatar
Bushard
Newbie
Newbie
Beiträge: 8
Registriert: 28. Feb 2008, 09:03

Beitrag von Bushard » 11. Mär 2008, 19:33

Hi;
Öhh ja genau! Was echt gut war, war der Tip mit G-Parted, nur leider klappt das nicht.
Mit Umount bin ich einen tacken weiter nur sagt er mir jetzt das er das ganze nicht kennt!! Also das device !! Was ich als erfolg verbuche, da ich mich mit dem vi nicht gut auskenne werde ich jetzt noch brauchen!

Hoffe halt ich bau keinen Murgs!

Freddie62
Guru
Guru
Beiträge: 1526
Registriert: 24. Jan 2006, 14:21
Wohnort: Bielefeld

Beitrag von Freddie62 » 11. Mär 2008, 21:03

Zum Thema vi:

Code: Alles auswählen

man vi
geht auch in der Konsole! :wink:

CU Freddie
Leap 42.3, Kernel: 4.4, LXDE. Schleppi: Dell Latitude 5520 mit Win7 Prof./Leap42.3-X64, Kernel: 4.14.15-5.g9a6fca5-default, LXDE

Benutzeravatar
Bushard
Newbie
Newbie
Beiträge: 8
Registriert: 28. Feb 2008, 09:03

Beitrag von Bushard » 12. Mär 2008, 18:32

Juhu besten Dank, melde mich wieder mit dem Tux !

rolle
Guru
Guru
Beiträge: 3721
Registriert: 4. Mai 2004, 21:50
Kontaktdaten:

Beitrag von rolle » 12. Mär 2008, 19:14

Feini. Kannst Du bitte noch Deinen ersten Post editieren und in den Titel ein [gelöst] setzen?
Horrido, Roland

Für meine Postings gilt außer bei Zitaten hier im Linux-Club die Creative Commons.

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste