Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[gelöst] FreeNX mit LDAP-Usern?

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
magic_halli
Hacker
Hacker
Beiträge: 369
Registriert: 10. Jul 2006, 08:44

[gelöst] FreeNX mit LDAP-Usern?

Beitrag von magic_halli » 7. Mär 2008, 14:32

Hi,

ich habe auf einem Suse10.1 Rechner freenx (per Yast) und "NX Free Edition" von www.nomachine.com installiert. Ich kann jetzt auf diesen Rechner von einem anderen Rechner im lokalen Netzwerk mittels des NX-Client zugreifen. Das klappt schonmap prima. Bei der Clientanmeldung benutze ich einen User, der lokal auf dem NX-Server angelegt ist.
Jetzt soll/wird der NX-Server mit LDAP-Useranmeldung laufen. Nur kann sich jetzt leider der NX-Client mit LDAP-Usern nicht mehr authentifizieren!!!

Geht das zu machen, dass ich mich von einem NX-Client auf einem NX-Server anmelde, der mit LDAP-Anmeldung funktioniert?
Das würde ja dann bedeuten, dass auf dem NX-Server keine lokal angelegten Nutzer mehr existieren!

Wie bekomme ich dieses Szenario trotzdem zum laufen? Muß ich irgendwas an der /etc/ssh/sshd_config hierfür ändern?
Meine sshd_config sieht derzeit so aus:

Code: Alles auswählen

#	$OpenBSD: sshd_config,v 1.72 2005/07/25 11:59:40 markus Exp $

# This is the sshd server system-wide configuration file.  See
# sshd_config(5) for more information.

# This sshd was compiled with PATH=/usr/bin:/bin:/usr/sbin:/sbin

# The strategy used for options in the default sshd_config shipped with
# OpenSSH is to specify options with their default value where
# possible, but leave them commented.  Uncommented options change a
# default value.

#Port 22
#Protocol 2,1
#AddressFamily any
#ListenAddress 0.0.0.0
#ListenAddress ::

# HostKey for protocol version 1
#HostKey /etc/ssh/ssh_host_key
# HostKeys for protocol version 2
#HostKey /etc/ssh/ssh_host_rsa_key
#HostKey /etc/ssh/ssh_host_dsa_key

# Lifetime and size of ephemeral version 1 server key
#KeyRegenerationInterval 1h
#ServerKeyBits 768

# Logging
# obsoletes QuietMode and FascistLogging
#SyslogFacility AUTH
#LogLevel INFO

# Authentication:

#LoginGraceTime 2m
#PermitRootLogin yes
#StrictModes yes
#MaxAuthTries 6

#RSAAuthentication yes
#PubkeyAuthentication yes
#AuthorizedKeysFile	.ssh/authorized_keys

# For this to work you will also need host keys in /etc/ssh/ssh_known_hosts
#RhostsRSAAuthentication no
# similar for protocol version 2
#HostbasedAuthentication no
# Change to yes if you don't trust ~/.ssh/known_hosts for
# RhostsRSAAuthentication and HostbasedAuthentication
#IgnoreUserKnownHosts no
# Don't read the user's ~/.rhosts and ~/.shosts files
#IgnoreRhosts yes

# To disable tunneled clear text passwords, change to no here!
PasswordAuthentication no
#PermitEmptyPasswords no

# Change to no to disable s/key passwords
#ChallengeResponseAuthentication yes

# Kerberos options
#KerberosAuthentication no
#KerberosOrLocalPasswd yes
#KerberosTicketCleanup yes
#KerberosGetAFSToken no

# GSSAPI options
#GSSAPIAuthentication no
#GSSAPICleanupCredentials yes

# Set this to 'yes' to enable support for the deprecated 'gssapi' authentication
# mechanism to OpenSSH 3.8p1. The newer 'gssapi-with-mic' mechanism is included
# in this release. The use of 'gssapi' is deprecated due to the presence of 
# potential man-in-the-middle attacks, which 'gssapi-with-mic' is not susceptible to.
#GSSAPIEnableMITMAttack no
 

# Set this to 'yes' to enable PAM authentication, account processing, 
# and session processing. If this is enabled, PAM authentication will 
# be allowed through the ChallengeResponseAuthentication mechanism. 
# Depending on your PAM configuration, this may bypass the setting of 
# PasswordAuthentication, PermitEmptyPasswords, and 
# "PermitRootLogin without-password". If you just want the PAM account and 
# session checks to run without PAM authentication, then enable this but set 
# ChallengeResponseAuthentication=no

UsePAM yes
#User hallbauer ist derzeit noch ein lokal angelegter User
AllowUsers nx hallbauer
RSAAuthentication no
PubkeyAuthentication yes
PermitRootLogin no

#AllowTcpForwarding yes
#GatewayPorts no
X11Forwarding yes 
#X11DisplayOffset 10
#X11UseLocalhost yes
#PrintMotd yes
#PrintLastLog yes
#TCPKeepAlive yes
#UseLogin no
#UsePrivilegeSeparation yes
#PermitUserEnvironment no
#Compression delayed
#ClientAliveInterval 0
#ClientAliveCountMax 3
#UseDNS yes
#PidFile /var/run/sshd.pid
#MaxStartups 10

# no default banner path
#Banner /some/path

# override default of no subsystems
Subsystem	sftp	/usr/lib/ssh/sftp-server

# This enables accepting locale enviroment variables LC_* LANG, see sshd_config(5).
AcceptEnv LANG LC_CTYPE LC_NUMERIC LC_TIME LC_COLLATE LC_MONETARY LC_MESSAGES 
AcceptEnv LC_PAPER LC_NAME LC_ADDRESS LC_TELEPHONE LC_MEASUREMENT 
AcceptEnv LC_IDENTIFICATION LC_ALL
Danke und Gruß
Zuletzt geändert von magic_halli am 10. Mär 2008, 10:28, insgesamt 1-mal geändert.
Suse10.1
AMD X2 DualCore 4400+
2GB RAM

Werbung:
rolle
Guru
Guru
Beiträge: 3724
Registriert: 4. Mai 2004, 21:50
Kontaktdaten:

Beitrag von rolle » 7. Mär 2008, 15:11

Wenn die LDAP-Anmeldung sauber integriert ist, müßte das über PAM problemlos und transparent funktionieren. Natürlich nur, wenn Du dem SSH-Server auch andere als die beiden explizit erlaubten Nutzerinnen erlaubst.
Horrido, Roland

Für meine Postings gilt außer bei Zitaten hier im Linux-Club die Creative Commons.

magic_halli
Hacker
Hacker
Beiträge: 369
Registriert: 10. Jul 2006, 08:44

Beitrag von magic_halli » 10. Mär 2008, 09:51

rolle hat geschrieben:Wenn die LDAP-Anmeldung sauber integriert ist, müßte das über PAM problemlos und transparent funktionieren. Natürlich nur, wenn Du dem SSH-Server auch andere als die beiden explizit erlaubten Nutzerinnen erlaubst.
Die LDAP-Anmeldung ist sauber integriert und funktioniert auf dem Rechner.
Soll das dann heißen, ich muß bei 'AllowUsers' in der /etc/ssh/sshd_config auch noch zulässige LDAP-User eintragen? ...wenn dem so ist - ziemlich doof eigentlich.
:?
Suse10.1
AMD X2 DualCore 4400+
2GB RAM

magic_halli
Hacker
Hacker
Beiträge: 369
Registriert: 10. Jul 2006, 08:44

Beitrag von magic_halli » 10. Mär 2008, 10:19

Jo, es funktioniert. Jedoch muss ich expliziet jeden LDAP-User auch unter 'AllowUsers' angeben! Das is echt mies... :cry:
Suse10.1
AMD X2 DualCore 4400+
2GB RAM

rolle
Guru
Guru
Beiträge: 3724
Registriert: 4. Mai 2004, 21:50
Kontaktdaten:

Beitrag von rolle » 10. Mär 2008, 13:20

Dann streiche die komplette AllowUsers-Zeile, dann darf sich jeder anmelden. Oder Setze das Ganze auf eine Gruppe auf und erlaube diese in der sshd_config.
Horrido, Roland

Für meine Postings gilt außer bei Zitaten hier im Linux-Club die Creative Commons.

Antworten