Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Beim Installieren von GRUB ist ein Fehler aufgetreten.

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
atlantis
Newbie
Newbie
Beiträge: 3
Registriert: 27. Feb 2008, 23:51

Beim Installieren von GRUB ist ein Fehler aufgetreten.

Beitrag von atlantis » 28. Feb 2008, 00:11

Hallo

Ich versuche OpenSuSe 10.2 auf einer IBM X360 Maschine zu installieren, die ein Raid1 am originalen ServeRAID 4LX Controller hat mit 2 18G SCSI HDs und ein weiteres Raid1 an einem Promise TX2300 SATA Controller mit 2 500G HDs.

Am Ende der Installation, wenn der Bootloader installiert werden soll, erscheint der Fehler
  • Beim Installieren von GRUB ist ein Fehler aufgetreten.

    (...)

    Error 23: Error while parsing number
    grub> quit
Es wird ja angeboten, die Bootloader-Konfiguration zu ändern, aber nichts was ich versucht habe hat was geändert. Ich bin zwar kein Linux-Neuling aber auch kein Crack, und mit GRUB hatte ich bisher nie direkt zu tun.

Es gibt zwar viele Referenzen zu diesem oder dazu ähnlichen Problemen, aber eine Lösung habe ich nicht gefunden.

Kann mir jemand erklären, was die Ursache des Problems ist, oder vielleicht sogar eine Lösung?

Grüsse
Martin

Werbung:
Saedelaere
Member
Member
Beiträge: 207
Registriert: 1. Feb 2007, 23:45

Beitrag von Saedelaere » 28. Feb 2008, 01:03

Ich kann dir jetzt zwar nicht direkt helfen, was dein Problem betrifft. Prinzipiell würde ich es aber mit der neuesten Version von OpenSuse versuchen.

Grüßle
TV-Viewer 0.8.x
GUI für Hauppauge PVR und andere ivtv basierenden TV-Karten
sourceforge.net Projekseite
Homepage
Ankündigungs, und Diskussionsthread

atlantis
Newbie
Newbie
Beiträge: 3
Registriert: 27. Feb 2008, 23:51

Beitrag von atlantis » 28. Feb 2008, 10:00

Ich stimme dir natürlich im Prinzip auch zu, da es von 10.3 aber kein komplettes CD-Set mehr gibt geht das vorderhand nicht, weil:

- Die Installation mit der Single-CD (wo dann die Repositories online geladen werden) hat nicht funktioniert (nach dem Neustart während der Installation erscheint nachher der Loginscreen statt dass die Installation fortgesetzt wird).

- Die Maschine hat nur ein Slim-CD-Rom (wie ein Notebook). Ich habe ein entsprechendes DVD-Rom aber das läuft scheinbar nicht 100% in dieser Maschine (bei Slimdrives gibt es das, hatte ich auch schon bei einem Notebook).

Aber vielleicht weiss ja jemand eine Quelle für den CD-Satz von 10.3, eigentlich ist es ja möglich diesen aus den Daten der DVD zu erstellen, vielleicht hat das ja jemand getan.

Gruss
Martin

pft
Advanced Hacker
Advanced Hacker
Beiträge: 843
Registriert: 22. Dez 2004, 13:01

Beitrag von pft » 28. Feb 2008, 10:52

Ein Ausweg wäre, von irgendeiner Live-CD zu booten und die DVD-Daten direkt auf der lokalen Platte abzulegen.

Aber, ich kann mir nicht vorstellen, dass die Grub Probleme damit gelöst sind, auch wenn Deine HW etwas ungewöhnlich ist.
Sagt der Porsche bei 250 km/h zu seinem Fahrer: "Ich kann noch mehr - Du auch?"
... Ich hab zwar keinen Porsche aber dafür Linux

atlantis
Newbie
Newbie
Beiträge: 3
Registriert: 27. Feb 2008, 23:51

Beitrag von atlantis » 28. Feb 2008, 12:16

Du hast schon recht, die HW ist eher ungewöhnlich, bisher habe ich meist mehr oder weniger normale PCs als Server verwendet, das gab auch weniger Probleme bei der Installation, diesmal sind aber die Anforderungen höher, so dass ich mich für eine professionelle Maschine entschied.

Gruss
Martin

Antworten