Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

nfs mit qemu

Alles rund um die Systemverwaltung, die Administration und Konfiguration Eures Linuxsystems

Moderator: Moderatoren

Antworten
GetIT
Newbie
Newbie
Beiträge: 13
Registriert: 28. Apr 2006, 16:41
Wohnort: Schweinfurt

nfs mit qemu

Beitrag von GetIT » 14. Feb 2008, 23:51

Ich habe unter openSUSE10.2 qemu (Version:0.9.0) installiert.
Hostname: virtual-test

Desweiteren habe ich unter dem Host (openSUSE) einen NFS-Server installiert und das Verzeichnis /nfs freigegeben

Code: Alles auswählen

/nfs  (ro)
Inhalt der Datei /etc/exports

Ich habe auch mit exportfs -ra die exports neu eingelesen.

Jetzt starte ich mit qemu-Image mit folgender Befehlszeile:

Code: Alles auswählen

qemu -M pc -boot c -hda ~david/qemu/images/eigene/neu5.img -net nic,model=ne2k_pci,macaddr=52:54:00:12:34:57 -net tap,script=no
Als Host habe ich sowohl eine openSUSE10.2 als auch ein Slackware9 probiert.
Bei beiden habe ich natürlich die Pakete nfs-utils und portmap installiert.

Jetzt habe ich versucht im Gast (openSUSE oder Slackware) die NFS-Freigabe zu mounten

Code: Alles auswählen

mount -t nfs virtual-test:/nfs /mnt/nfs
Nach betätigen von Enter bleibt das System "hängen" (sowohl SUSE als Gast als auch Slackware).

Aus dem Server heraus kann ich den Client erreichen und umgekehrt.
D.h. ein ping funktioniert von beiden Seiten.


Bin langsam mit meiner Weisheit am Ende.
Internet hilft nicht und in Büchern habe ich auch keine Lösung gefunden.
Hoffentlich kann hier jemand helfen?!

Werbung:
Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste